6. Setting up a rate table

When a trip has been matched with a rate index, the rate header to which that index is attached determines the calculation method to be used when the rate schedule is applied. The rate header may contain a single unit rate, or it may be linked to a rate table, which is a matrix of per unit settlement rates.

When setting up rate tables, your selection in the **Rows** field and the **Col's** field in the rate header section define what the rows and/or columns in the table mean.

- The table may consist of rows only, columns only, or both rows and columns.
- Only one table may be defined for a pay rate.

In the rate header shown below, rows are defined as *Origin City* and columns as *Dest City*. The corresponding rate table is shown below the header:

When the system finds a row/column match, the pay amount is calculated by multiplying the pay amount in the intersecting cell of the matrix by the number of pay units. The pay type selected in the rate header determines pay units. For example, in the rate header shown above, the pay type is *Flat Pay Rate*. For a trip with an origin city of Cleveland, OH, and a destination state of Erie, PA, a resource will be paid a flat rate of $300.00.

These subsections provide general rate table setup instructions.

- Definitions of row/column selections .................................................................6.2
- Quantity-based options that affect how table rates are applied........................6.10
- Default behavior for application of quantity-based rates ...............................6.11
- Rounding up to the next quantity ......................................................................6.12
- Incremental rating based on quantity ranges ....................................................6.14
- Making entries in rows and columns .................................................................6.15
- Using a versions prior to 2012.11_07.0783 .........................................................6.15
- Using version 2012.11_07.0783 or greater .......................................................6.16
Setting up a rate table

- Entering table values manually ................................................................. 6.16
- Generating table values automatically ...................................................... 6.16
- Completing the generation of rates in a table defined by both rows and columns ........................................ 6.23
- Expanding an existing table ........................................................................ 6.26
- Understanding the % Range option to generate rates .................................. 6.29
- Ignoring zero dollar rate cells ..................................................................... 6.31
- Entering multiple values for a row or column heading .................................. 6.32
- Removing multiple values for a row or column heading .............................. 6.33
- Deleting rows ............................................................................................ 6.34
- Deleting columns ...................................................................................... 6.34
- Deleting an entire table .............................................................................. 6.34
- Sorting rows and columns alphanumerically .............................................. 6.35
- Switching rows to columns and columns to rows ...................................... 6.35

**Definitions of row/column selections**

By default, the **Rows** and **Col's** fields in a rate header are set to **Not Used**. To set up a table of multiple rates for a rate schedule, select the desired value in the **Rows** and/or **Col's** fields. Selections are listed here in alphabetical order.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg Fuel Price</td>
<td>Allows you to set up a fuel surcharge pay rate that is based on an Average Fuel Price table. An Average Fuel Price table consists of a list of effective dates and the corresponding average fuel prices in effect for those dates. These tables are set up in File Maintenance. For details on setting up Average Fuel Price rates, see <a href="AverageFuelPriceForPay_V.2012andEarlier.doc">Basing fuel surcharge pay on an Average Fuel Price table</a> in the Pay Rate Examples documentation.</td>
</tr>
<tr>
<td>Axle Count</td>
<td>Allows you to base pay on the combined number of axles recorded for the assigned resources (tractor, trailer 1, and trailer 2). For details see, <a href="AxleCountRating_V.2012andEarlier.doc">Setting up rates based on axle count</a> in the Pay Rate Examples documentation.</td>
</tr>
<tr>
<td>Bill To</td>
<td>Customer being billed; this selection corresponds to the company ID in the <strong>Bill To</strong> field on the order.</td>
</tr>
</tbody>
</table>
| BillTo OtherTypes1-2 | Classifications recorded in the **Other Type 1** and **Other Type 2** fields in the profile of the Bill To company recorded on the order.  
**Note:** Your company defines the names and options for these fields in the **OtherType1** and **OtherType2** labels in the System Administration application. |
| Commodity        | Commodity transported on the order.  
**Note:** If there are multiple commodities on the order, the system only looks at the first one. |
| Commodity Class  | Classification code of the commodity transported on the order.  
**Note:** If there are multiple commodities on the order, the system only looks at the first one. |
<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Count</td>
<td>Freight count of an order.</td>
</tr>
<tr>
<td>Day Of Week</td>
<td>As of TMWSuite V.2009.08.1049, define pay rate tables based on the <em>Arrival</em> date for the first stop.</td>
</tr>
<tr>
<td></td>
<td><strong>Notes:</strong></td>
</tr>
<tr>
<td></td>
<td>1. You must have [Tariff]Use_DayOfWeek=N in your TTS50.</td>
</tr>
<tr>
<td></td>
<td>2. For details, see Creating pay rates based on day of week or time of day (DayOfWeekPay_V.2013andLater.doc) in the Pay Rate Examples documentation.</td>
</tr>
<tr>
<td>DayOfWeek(Early Arv)</td>
<td>As of TMWSuite V.2015.14_07.0357, define pay rate tables based on the <em>Earliest</em> date for the first billable stop</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> For details, see Creating pay rates based on day of week or time of day (DayOfWeekPay_V.2013andLater.doc) in the Pay Rate Examples documentation.</td>
</tr>
<tr>
<td>Dest Co (Order)</td>
<td>This option is designed for split trips. The rate will pull if the order’s last billable stop is on any trip segment that is part of the move associated with the segment being settled.</td>
</tr>
<tr>
<td></td>
<td>For details, see Restricting pay based on origin/destination (RestrictPayBasedOnOrigDest_V.2012andEarlier.doc) in the Advanced Pay Rate Features documentation.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The rate will be applied even if the resource being paid was assigned to a segment that did not include the order’s last billable stop.</td>
</tr>
</tbody>
</table>

**Note regarding the following Destination options:** On a pay rate table, the Destination options relate to the final delivery location on the segment. If the trip segment does not have any billable stops, the destination is the stop at the end of the empty move.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dest. City</td>
<td>City where the last stop took place.</td>
</tr>
<tr>
<td>Dest. Company</td>
<td>ID of the company where the last stop took place.</td>
</tr>
<tr>
<td>Dest. State</td>
<td>State/province where the last stop took place.</td>
</tr>
<tr>
<td>Dest. Zip (3-digit)</td>
<td>First three characters of the ZIP/postal code of the location where the last stop took place.</td>
</tr>
</tbody>
</table>
### Setting up a rate table

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| Dest Zip (Full)| When you select this option, the rating engine will apply the rate only when the ZIP Code used to define the rate is an exact match to the ZIP Code recorded in the profile of the company where the last stop occurred. If the company’s ZIP code has:  
- Five-digits, then any full ZIP Code rate tables for this company must also have five-digits.  
- Nine-digits, then any full ZIP Code rate tables for this company must also have nine-digits.  
  **Note:** When setting up full ZIP Code rate tables for nine-digits ZIP codes, the format used in the rate table **must** match the format used in the company’s profile. For example, if the nine-digit ZIP Code is hyphenated in the company’s profile, it must also be hyphenated in the rate table, e.g., 44060-1234 is not the same as 440601234 or 44060 1234. |
| Dist (Hub)     | Allows you to set up rates for mile ranges based on the tractor’s odometer readings. To use this option, you must:  
- Use a pay type that is based on hub miles.  
- Have `UseHubMiles=N` in the [Settlement] section of your TTS50.ini file.  
  **Note:** `UseHubMiles=Y` is used when you **always** want all mileage-based rates to be based on hub miles.  
For details on paying by hub mile, see [Paying based on hub miles](HubMiles_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| Dist (RoundTrip*Adj) | Allows you to set up rates based on round trip miles. For details, see [Basing pay rates on round trip miles](RoundTripPay_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| Dist (Actual) Total | Custom                                                                                                                                                                                                 |
| Distance (Actual) | This option works in conjunction with the **Loaded** field on the rate’s index to set up rate tables based on just loaded miles or just empty miles.  
For example, suppose a trip has 10 empty miles and 100 loaded miles. If you define the table using:  
- **Distance (Actual)** and the **Loaded** field is set to **Loaded**  
The system uses only the loaded miles (100) to select a rate from the table.  
- **Distance (Actual)** and the **Loaded** field is set to **Empty**  
The system uses only the empty miles (10) to select a rate from the table.  
- **Distance (Route)**  
The system uses all miles (110) to determine where the trip’s mileage quantity falls in the mileage ranges recorded in the rate table.  
For details, see [Calculating pay based on loaded or empty mileage ranges](DistanceActual_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
## Setting up a rate table

### Distance (Billed)
This option allows you to set up a table for mileage ranges based billable miles. The system determines the rate by looking at the quantity of billing miles, and then applies that rate to the number of Settlement miles. It is intended to be used when the mileage quantity used for billing is not the same as the mileage that Settlements uses.

During the rating process, the rating engine does the following:
1. Looks at the total number of billed miles on the order.
2. Determines where that quantity falls in the mileage-based table to find the rate associated with that quantity.
3. Multiples the rate times the Settlement miles to create a pay detail.

### Distance (O-D)
Origin to destination miles.

**Note:** When this option is used, miles between interim stops are not considered.

### Distance (Empty)
Total

### Distance (Loaded)
Total

### Distance (Route)
Total miles (loaded and empty) on a trip for which the driver is being paid.

### Distance (Route) Total
Custom

### Driver Company
The company with which the driver is associated in his/her profile.

**Note:** The Company options are user-defined in the Company label, accessed in the System Administration application.

### Driver Division
The division to which the driver belongs, as identified in his/her profile.

**Note:** The Division options are user-defined in the Division label, accessed in the System Administration application.

### Driver Domicile
The home location for the driver, as identified in his/her profile.

**Note:** The Domicile options are user-defined in the Domicile label, accessed in the System Administration application.

### Driver Fleet
The fleet to which the driver is assigned in his/her profile.

**Note:** The Fleet options are user-defined in the Fleet label, accessed in the System Administration application.

### Driver ID
Allows you to set up a rate for a specific driver or co-driver.

### Driver TeamLeader
The driver’s team leader, as identified in his/her profile.

**Note:** The Team Leader options are user-defined in the TeamLeader label, accessed in the System Administration application.

### Driver Terminal
Terminal to which the driver is assigned in the driver profile.

**Note:** The options for this field are defined in the Terminal label in the System Administration application.
### Setting up a rate table

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver Type 1-4</td>
<td>Driver classifications to which the driver is assigned in the driver profile. <strong>Note:</strong> The names and options for these fields are defined in the DrvType1 - DrvType4 labels in the System Administration application.</td>
</tr>
<tr>
<td>Drop Stops</td>
<td>Used to define secondary pay rate tables that will calculate pay based on the number of drop stops recorded on a trip. You can specify whether pay is created for all stops, or only for stops that are more than a user-defined number. <strong>Note:</strong> This option (along with the Pickup Stops option) allows you to create separate pay rates for pickup stops and for drop stops. In addition, you can use the existing incremental rating feature to specify a different number of free stops for each rate. For details, see <a href="PickupAndDropStopPayRates_V.2012andEarlier.doc">Setting up separate stop pay rates for pickups and drops</a> in the Pay Rate Examples documentation.</td>
</tr>
</tbody>
</table>
| Event            | Allows you to create a rate schedule that is based on events assigned to stops that occurred during a trip. It is applicable when:  
  - The rate schedule is for a particular event type; and  
  - Rates differ based on the number of times the specified event is recorded on a trip.  
  For details, see [Basing pay rates on event types](EventbasedPayRates_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| Event Type       | Allows you to set up a rate schedule that is based on events assigned to stops that occurred during a trip. It is applicable when:  
  - The rate schedule is for multiple event types; and  
  - Each event type has a specific rate.  
  For details, see [Basing pay rates on event types](EventbasedPayRates_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| Factor           | Supported only for billing rates.                                                                                                                                                                         |
| Height           | Supported only for billing rates.                                                                                                                                                                         |
| Length           | Supported only for billing rates.                                                                                                                                                                         |
| LHRate           | Custom.                                                                                                                                                                                                   |
| Orig Co (Order)  | This option is designed for split trips. The rate will pull if the order’s first billable stop is on any trip segment that is part of the move associated with the segment being settled. For details, see [Restricting pay based on origin/destination](RestrictPayBasedOnOrigDest_V.2012andEarlier.doc) in the Advanced Pay Rate Features documentation. **Note:** The rate will be applied even if the resource being paid was assigned to a segment that did not include the order’s first billable stop. |
Note regarding the following **Origin options**: On a pay rate table, the **Origin** options relate to the initial pickup location on a trip segment. If the trip segment does not have any billable stops, the origin is the stop at the start of the empty move.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Origin City</td>
<td>City where the first stop took place.</td>
</tr>
<tr>
<td>Origin Company</td>
<td>ID of the company where the first stop took place.</td>
</tr>
<tr>
<td>Origin State</td>
<td>State/province where the first stop took place.</td>
</tr>
<tr>
<td>Origin Zip (3-digit)</td>
<td>First three characters of the ZIP/postal code of the location where the first stop took place.</td>
</tr>
</tbody>
</table>
| Origin Zip (Full)| When you select this option, the rating engine will apply the rate only when the ZIP Code used to define the rate is an **exact** match to the ZIP Code recorded in the profile of the company where the first stop occurred. If the company's ZIP code has:  
  - Five-digits, then any full ZIP Code rate tables for this company must also have five-digits.  
  - Nine-digits, then any full ZIP Code rate tables for this company must also have nine-digits.  
  **Note**: When setting up full ZIP Code rate tables for nine-digits ZIP codes, the format used in the rate table **must** match the format used in the company's profile. For example, if the nine-digit ZIP Code is hyphenated in the company's profile, it must also be hyphenated in the rate table, e.g., 44060-1234 is not the same as 440601234 or 44060 234. |
| Other Type 1 - 2 | Classifications recorded in the **Other Type 1** and **Other Type 2** fields in the profile of the Order By company recorded on the order.  
  **Note**: The names and options for these fields are defined in the **OtherType1** and **OtherType2** labels in the System Administration application. |
| Out of Route      | Supported only for billing rates.                                                                                                                                                                  |
| PassThruStateProv| Allows you to set up secondary pay rates that will calculate add-on pay based on the number of miles traveled through specified states or provinces. When the rate is applied to a trip, the system creates a separate pay detail for the miles traveled in each state on the trip.  
  For details, see [Creating secondary mileage pay based on the states or provinces the trip passes through](MileagePayBasedOnStateProvPassThru_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
### Setting up a rate table

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
</table>
| Pickup Stops           | Used to define secondary pay rate tables that will calculate pay based on the number of pickup stops recorded on a trip. You can specify whether pay is created for all stops, or only for stops that are more than a user-defined number.  
**Note:** This option (along with the Drop Stops option) allows you to create separate pay rates for pickup stops and for drop stops. In addition, you can use the existing incremental rating feature to specify a different number of free stops for each rate. For details, see [Setting up separate stop pay rates for pickups and drops](PickupAndDropStopPayRates_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| RevType1–RevType4      | Revenue classification on the order header for the order for which the driver is being paid. If multiple orders exist on the trip, the system looks only at the first one.  
**Note:** Your company defines the names and options for these fields in the RevTypes1–4 labels in the System Administration application. |
| Seniority (months)     | Number of months a driver has been employed. To determine the driver’s seniority level, the system checks the entry in the Seniority Date field in the driver’s profile in File Maintenance. If a Seniority Date is not specified, the system uses the entry in the Hire Date field. For details, see [Setting up a line haul rate that is based on driver seniority](SeniorityRates_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| State Passed Through   | Custom                                                                                                                                                                                                       |
| Stop Other 1-2         | These options are used in conjunction with the options selected in the existing Event field to set up secondary rates that will be applied only when the specified event occurs at the specified stop.  
**Notes:**  
1. The Stop Other Type 1-2 options:  
   - Are supported only for secondary pay rates.  
   - Are supported only on rates that also have an event defined.  
   - Are associated with the Other Type 1 and Other Type 2 fields in the company profile of the stop company.  
2. For details, see [Calculating pay for events that occur at specific stops](StopOtherType1-2_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
| Stops                  | Applicable for secondary stop pay rates. Pay is based on the number of loaded stops on an order. For details on setting up accessorial rates for stop pay, see [Setting up basic stop pay rates](SettingUpBasicStopPayRates_V.2012andEarlier.doc) in the Pay Rate Examples documentation. |
### Setting up a rate table

<table>
<thead>
<tr>
<th><strong>Value</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Time of Day</td>
<td>Allows you to create <em>flat</em> pay based on when a trip starts. You can use it to set up a matrix of flat pay amounts to accommodate different rates for shift pay. For details, see <a href="DayOfWeekPay_V.2012andEarlier.doc">Creating flat pay rates based on when a trip starts</a> in the Pay Rate Examples documentation.</td>
</tr>
<tr>
<td>Tractor Company</td>
<td>The company that owns the tractor, as identified in the tractor's profile. This field is most commonly used for multi-company organizations. <strong>Note:</strong> The options are defined in the Company label, accessed in the System Administration application.</td>
</tr>
<tr>
<td>Tractor Division</td>
<td>The division to which the tractor belongs, as identified in the tractor's profile. <strong>Note:</strong> The options are defined in the Division label file, accessed in the System Administration application.</td>
</tr>
<tr>
<td>Tractor Fleet</td>
<td>The fleet to which the tractor belongs, as identified in the tractor's profile. <strong>Note:</strong> The options are defined in the Fleet label file, accessed in the System Administration application.</td>
</tr>
<tr>
<td>Tractor Terminal</td>
<td>Terminal to which the tractor is assigned in the tractor profile. <strong>Note:</strong> The options for this field are defined in the Terminal label in the System Administration application.</td>
</tr>
<tr>
<td>Tractor Type1–4</td>
<td>Tractor classifications to which the tractor is assigned. <strong>Note:</strong> The names and options for these fields are defined in the TrcType1 – TrcType4 labels in the System Administration application.</td>
</tr>
<tr>
<td>Trailer Company</td>
<td>The company to which the trailer is associated, as identified in the trailer's profile. Most commonly used for multi-company organizations. <strong>Note:</strong> The options are defined in the Company label, accessed in the System Administration application.</td>
</tr>
<tr>
<td>Trailer Division</td>
<td>The division with which the trailer is associated, as identified in the trailer's profile. <strong>Note:</strong> The options are defined in the Division label, accessed in the System Administration application.</td>
</tr>
<tr>
<td>Trailer Fleet</td>
<td>The fleet to which the trailer belongs, as identified in the trailer's profile. <strong>Note:</strong> The options are defined in the Fleet label, accessed in the System Administration application.</td>
</tr>
<tr>
<td>Trailer Terminal</td>
<td>Terminal to which the trailer is assigned in the trailer profile. <strong>Note:</strong> The options for this field are defined in the Terminal label in the System Administration application.</td>
</tr>
<tr>
<td>Trailer Type1–4</td>
<td>Trailer classifications to which the primary trailer is assigned. <strong>Note:</strong> The names and options for these fields are defined in the TrlType1 – TrlType4 labels in the System Administration application.</td>
</tr>
</tbody>
</table>
Setting up a rate table

Pay Rate Basics

Revised: 7/2015

Copyright TMW Systems, Inc.

<table>
<thead>
<tr>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trip Type</td>
<td>Allows you to set up a rate table that is based on the LghType1 classification assigned to the trip segment.</td>
</tr>
<tr>
<td></td>
<td><strong>Notes:</strong></td>
</tr>
<tr>
<td></td>
<td>1. This option can be used with consolidated orders and split trips.</td>
</tr>
<tr>
<td></td>
<td>2. When orders on separate trip segments are consolidated onto one trip segment, the system resets the LghType1-4 values to the values associated with the order that is listed first in the stop sequence.</td>
</tr>
<tr>
<td></td>
<td>3. Use of this option is not supported for cross docked orders.</td>
</tr>
<tr>
<td></td>
<td>4. LghType1 classifications are assigned in the Assign Driver/ Equipment window in Order Entry, or the Asset Assignment window in Dispatch.</td>
</tr>
<tr>
<td></td>
<td>5. The LghType1 options are defined in the LghType1 label in the System Administration application.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Volume</th>
<th>Freight volume of an order for which the resource is being paid.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weight</td>
<td>Freight weight of an order for which the resource is being paid.</td>
</tr>
<tr>
<td>Width</td>
<td>Supported only for billing rates.</td>
</tr>
</tbody>
</table>

### Quantity-based options that affect how table rates are applied

By default, when the system applies a rate from a table that is defined by a quantity (such as pieces), it applies the exact quantity recorded on the trip. For example, if 630 pieces were delivered, the system would create a single pay detail for 630 pieces.

However, you can use the **Rating Options** field and the **Option Applies To** field on the rate’s header to set up an alternate calculation method for quantity-based table rates.

Three rating options are available in the **Rating Options** field:

- **None** (default)
  - The system will apply the quantity exactly as it was recorded for the trip.
  - **Note:** You *must* use this option for mileage-based rates.

- **Use Next** (use range Qty)
  - When the trip’s quantity falls between the quantities recorded for two rows/columns, the system will round up the pay detail’s quantity to the amount recorded in the next row/column.
• **Incremental**

  The system will treat the quantity recorded in each row/column as a tier. If the trip’s quantity spans multiple tiers, the system will create a separate pay detail (with a separate rate) for each tier.

When you select an option other than *None* in the **Rating Option** field, you **must** select either **Rows** or **Columns** in the **Option Applies To** field. This determines whether the **Rating Option** selection applies to the table’s rows or columns.

**Note:** The **Rating Option** and **Option Applies To** fields display only when an option is selected in the **Rows** and/or the **Col’s** field.

When no selection is made in the **Rows** or the **Col’s** fields, the **Rate** field is displayed instead.

---

**Default behavior for application of quantity-based rates**

By default, the system does the following when applying the correct rate:

1. Determines the total commodity quantity (for rates based on count, weight, or volume).
2. Determines where the total falls in the quantity breaks listed in the rate table.
3. Identifies the rate associated with the applicable quantity break.
4. Multiplies the rate by the total quantity to get the total pay amount.

Order #3532, shown here, will be used to illustrate how the default selections for the **Rating Option** and **Option Applies To** fields affect creation of pay details.

A count of 630 pieces has been recorded for the order.
Rate #777, shown below, is the best match for this trip. Note that:

- The pay type is $/Piece.
- Rows field is set to Count.
- The Rating Option and Option Applies To fields are set to the defaults of None and N/A respectively.

Because the Rating Option and Option Applies To fields were left at None and N/A respectively, the system applies a per-piece rate of $0.65 to a count of 630 pieces, as shown here:

The resource is paid using the exact quantity that was recorded on the order with a single per-piece rate applied to the total quantity.

**Rounding up to the next quantity**

The Use Next (use range Qty) option in the Rating Option field allows you to specify how the system should round up a settlement quantity when it falls between two rows/columns. The Rating Option field works in combination with the Option Applies To field, which specifies
whether the system should look at quantities defined by rows, or quantities defined by columns.

Shown below is a rate schedule based on count. Note the following:

- The **Rows** field is set to *Count*.
- The pay type is */Piece*.
- The **Rating Option** field is set to *Use Next (use range Qty)*. The **Option Applies To** field is set to *Row*.

The rate matches Order #3532, shown here. Note that the quantity is 630 pieces.

When the rate is applied to the trip, the system multiplies the per-piece rate by 700 pieces. This is because 630 falls between 500 and 700 in the table. The *Use Next (use range Qty)* setting on the rate indicates that the system should round to the next highest quantity in the table, which is 700. The per-piece rate is not affected by the change in quantity, because the per-piece rate of $0.65 is applicable to both quantities.
Incremental rating based on quantity ranges

For some rate schedules involving rate tables, you may need the system to break down the pay quantity into increments according to the limits set by the rows/columns. Each increment (i.e., quantity break) is associated with a specific rate. When an incremental rate is applied to an order, a single pay detail is created for each increment.

This example shows an incremental rate in which the rows in the rate table are defined as Count. Note that the Rating Option field is set to Incremental and the Option Applies To field is set to Row.

When the system applies this rate, it will break down the settlement quantity according to the limits set by the rows. The pay is calculated in this way:

- The first 300 of the quantity is calculated at the rate for 1-300 pieces. That rate is $0.50.
- The next 200 of the quantity is calculated at the rate for 301-500 pieces. That rate is $0.60.
- The last 130 of the quantity is calculated at the rate for 501-700 pieces. That rate is $0.65.

A separate pay detail is created for each increment, as shown here:
Making entries in rows and columns

The Add Table Rows and Add Table Columns windows are used to add Rows and/or columns to rate tables. The windows' functionality was expanded in V.2012.11_07.0783.

Using a versions prior to 2012.11_07.0783

In versions of TMWSuite prior to V.2012.11_07.0783, the window could be used to create only blank rows and/or columns. After adding the blank rows and/or columns, you had to manually add the lookup quantities and rates.

The Add Table Rows and Add Table Columns windows that were available prior to V.2012.11_07.0783

For information on how to set up rows and/or columns in versions prior to V.2012.11_07.0783, see the Entering table values manually section below.
Using version 2012.11_07.0783 or greater

Starting in version V.2012.11_07.0783, there are two methods you can use to add rows and columns in the windows.

- **Manual method**
  First, you enter the number of blank rows or columns to add. Then you must manually add quantities and rates (this is the functionality that was available prior to V.2012.11_07.0783).
  For details, see the **Entering table values manually** section below.

- **Auto-generation method**
  The system auto-generates the table based on limits you specify (no manual entry of table data is required).
  For details, see the **Generating table values automatically** section below.

The Add Table Rows and Add Table Columns windows that are available starting in V.2012.11_07.0783

**Entering table values manually**

Follow these steps to set up a rate table manually:

1. If you have not already set up your rate header, make the appropriate selection in the Rows and/or Col's fields.
   
   **Note:** For details, see the section **Required entries for a rate table** in the chapter 04.SettingUpPayRateHeader_V.2012andEarlier.doc.

2. If the table portion of the Edit Settlement Rate Schedule Folder is not already in view, click the **Table** tab (located under the rate header).

3. If the table is set up to use rows and requires more than one row:
   
   a. Click **Add Row** in the sheet toolbar, or select **Edit > Add > Row(s)/Index**.
      
      The system displays the Add Table Rows window in which you indicate the number of rows to be added.
b. In the **How many rows would you like to add?** field, enter the number of additional rows to be added.

**Note:** Do not make an entry in any other field.

![Add Table Rows](image)

- **Add Table Rows**

How many rows would you like to add?

<table>
<thead>
<tr>
<th>(</th>
<th>)</th>
<th>OK</th>
<th>Cancel</th>
</tr>
</thead>
<tbody>
<tr>
<td>(</td>
<td>)</td>
<td>(</td>
<td>)</td>
</tr>
</tbody>
</table>

**LOOKUP VALUES**

<table>
<thead>
<tr>
<th>Base Lookup</th>
<th>00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increment</td>
<td>0</td>
</tr>
</tbody>
</table>

b. Click **OK**.

4. If the table is set up to use columns and requires more than one column:

a. Click **Add Col** in the sheet toolbar, or select **Edit > Add > Column(s)**.

   The system displays the Add Table Columns window in which you indicate the number of columns to be added.

b. In the **How many columns would you like to add?** field, enter the number of columns to be added.

   **Note:** Do not make an entry in any other field.

![Add Table Columns](image)

   **Add Table Columns**

   How many columns would you like to add?

<table>
<thead>
<tr>
<th>(</th>
<th>)</th>
<th>OK</th>
<th>Cancel</th>
</tr>
</thead>
<tbody>
<tr>
<td>(</td>
<td>)</td>
<td>(</td>
<td>)</td>
</tr>
</tbody>
</table>

   **LOOKUP VALUES**

<table>
<thead>
<tr>
<th>Base Lookup</th>
<th>00</th>
</tr>
</thead>
<tbody>
<tr>
<td>Increment</td>
<td>0</td>
</tr>
</tbody>
</table>

c. Click **OK**.

The table is displayed with the specified number of blank rows and/or columns.

![Table](image)

<table>
<thead>
<tr>
<th>Index</th>
<th>Index City</th>
<th>Index Asset</th>
<th>Index Trip</th>
<th>Index Settings</th>
<th>Double-click for multiple entries</th>
<th>(</th>
<th>)</th>
<th>MAX</th>
<th>MAX</th>
<th>MAX</th>
<th>MAX</th>
</tr>
</thead>
<tbody>
<tr>
<td>(</td>
<td>)</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(</td>
<td>)</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(</td>
<td>)</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(</td>
<td>)</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>(</td>
<td>)</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
5. If using rows, record the appropriate entry in each row heading. Use the ENTER key, the TAB key, or the mouse to move from one row to the next.
   **Note:** You can use CTRL+END to go from the current row heading to the last row heading. To go from the current row heading to the first row heading, use CTRL+HOME.

6. If using columns, record the appropriate entry in each column heading. Use the TAB key or the mouse to move from one column to the next.
   **Note:** You can use CTRL+HOME to go from the current column heading to the first one.

7. Click ![Save](image) in the sheet toolbar, or select **File > Save** to save your work.
   **Note:** If duplicate row or column headings are found, or if the numeric value of a row or column heading is out of sequence, a warning message will be shown and you will have the opportunity to make corrections before saving the rate table.

### Generating table values automatically

*First available in TMWSuite: 2012.11_07.0783*

You can use the Add Table Rows or Add Table Columns windows to automatically generate a rate table based on criteria you set. The table's lookup values must correspond to a range type of lookup, such as distance, weight, volume, average fuel price, etc.

Follow these steps to generate a rate table automatically:

1. If you have not already set up your rate header, make the appropriate selection in the **Rows** and/or **Col's** fields.
   **Note:** For details, see the section **Required entries for a rate table** in the chapter 04.SettingUpPayRateHeader_V.2012andEarlier.doc.

2. If the table portion of the Edit Settlement Rate Schedule Folder is not already in view, click the **Table** tab (located under the rate header).
3. If the table is set up to use rows and requires more than one row:
   
a. Click **Add Row** in the sheet toolbar, or select **Edit > Add > Row(s)/Index**. The system displays a window.

   ![Add Table Rows Window]

   - b. Select the **...or generate** check box.
   - c. Make entries in the **LOOKUP VALUES** section:

     **Base Lookup**

     The starting value from which the system will generate lookup values.

     **Increment**

     The value used by the system to generate lookup values between the Base Lookup value and the Max Lookup value and/or the Min Lookup value.

     **Note**: Lookup values can be set up to increment by a flat amount or by a percentage. When increments are set up as percentages, ten percent is entered as 10.0000. See the description for the (increment type) field.
(increment type) Select either:

- **Flat**
  The value in the Increment field will be used as a flat amount to generate lookup values.

- **%**
  The value in the Increment field will be used as a percentage to generate lookup values.

**Round**
Select the number of decimal places to which the system will round its calculations for percentage type of increments.

The options are 0-4.

**Note:** The Round field displays only when % is selected as the increment type.

**Max Lookup**
The table's highest lookup value.

When the system generates the table, it will add the increment value to the Base Lookup value to create the next lookup value. Then it will add the increment value to that value to create the next lookup value, and so on until it reaches the Max Lookup value.

**Min Lookup**
The table's lowest lookup value.

When the system generates the table, it will subtract the increment value from the Base Lookup value to create the next lookup value. Then it will subtract the increment value from that value to create the next lookup value, and so on until it reaches the Min Lookup value.

d. Make entries in the RATE VALUES fields:

**Base Rate**
The rate that will correspond to the Base Lookup value.

**Increment**
The value by which the system will increment the rates it generates for this table. The value entered can be positive or negative.

**Note:** Rates can be set up to increment by a flat amount or by a percentage. When increments are set up as percentages, ten percent is entered as 10.0000. See the description for the (increment type) field.
(increment type)  Select either:

- **Flat**
  The rates generated by the system will increment by the *flat* value recorded in the **Increment** field.
  For example, when 10 is recorded in the **Increment** field, each rate will increment by 10 from the previous rate. So if 100.00 is the base rate, the system will create the following rates: 110.00, 120.00, and 130.00, and so on up to the maximum lookup.

- **%**
  The rates generated by the system will increment by the *percentage* recorded in the **Increment** field.
  For example when 10 is recorded in the **Increment** field, each rate will increment by 10 percent from the previous rate. So if 100.00 is the base rate, the system will create the following rates: 110.00, 121.00, and 133.10, and so on to the maximum lookup.

- **% Range**
  The system generates the rates by multiplying the lookup amount times the percentage recorded in the **Increment** field. For more information, see the **Understanding the % Range option to generate rates** section.

**Round**  Select the number of decimal places to which the system will round its calculations for percentage type of increments.

The options are 0-4.

**Note:** The **Round** field displays only when % or % Range is selected as the increment type.
For example:

- Click OK.
  The system closes the window and generates the table based on your entries.
f. If the table is set up to use columns and requires more than one column, click Add Col in the sheet toolbar, or select Edit > Add > Column(s).

g. In the Add Table Columns window, repeat steps b thru e.

h. Click OK.

4. Click Save in the sheet toolbar, or select File > Save to save your work.

5. If your table is defined by both rows and columns, some of the cells will probably still be displaying 0.0000 rates. To create rates for those cells, continue with the instructions in the Completing the generation of rates in a table defined by both rows and columns section.

Completing the generation of rates in a table defined by both rows and columns

When you have a table that is defined by both rows and columns, extra steps are required to generate rates in all cells. This is true because when you use the Add Table Rows window (or the Add Table Columns window), the system generates the row (or column) lookup values in the header column (or row), and the corresponding rates in first column (or row). For example:

When you use both the Add Table Rows window and the Add Table Columns window to generate rows and columns, the system generates rates only the first column and for the first row. All the other cells are display 0.0000.
You use the **Generate Rates** command to complete the task of generating rates. You access the command by right clicking on either the column header or the row header. The instruction below uses the command from the column header. To access the command from the row header, simply substitute row for column in the instructions below.

To generate rates for the rest of the cells, follow these steps:

1. Right-click the column header of the first column.

2. Select **Generate Rates** from the shortcut menu.
   The Generate Rates window displays.

3. Make entries in these fields:

   **Base Rate**  
   Enter the base rate that will correspond to the first lookup value.

   **Increment**  
   The value by which the system will increment the rates it generates for the column or row being edited. The value entered can be positive or negative.

   **Note:** Rates can be set up to increment by a flat amount or by a percentage. When increments are set up as percentages, ten percent is entered as 10.0000. See the description for the (increment type) field.
Setting up a rate table

Pay Rate Basics

6.25

Revised: 7/2015

Copyright TMW Systems, Inc.

(increment type) Select either:

- **Flat**
  The rates generated by the system will increment by the *flat* value recorded in the **Increment** field.
  For example, when 10 is recorded in the **Increment** field, each rate will increment by 10 from the previous rate. So if 100.00 is the base rate, the system will create the following rates: 110.00, 120.00, and 130.00, and so on up to the maximum lookup.

- **%**
  The rates generated by the system will increment by the *percentage* recorded in the **Increment** field.
  For example when 10 is recorded in the **Increment** field, each rate will increment by 10 percent from the previous rate. So if 100.00 is the base rate, the system will create the following rates: 110.00, 121, and 133.10, and so on to the maximum lookup.

- **% Range**
  The system generates the rates by multiplying the lookup amount times the percentage recorded in the **Increment** field.
  For more information, see the **Understanding the % Range option to generate rates** section.

**Round** Select the number of decimal places to which the system should round its calculations for percentage type of increments.

The options are 0-4.

**Note:** The **Round** field displays only when % or % Range is selected as the increment type.

4. Click **OK**.
The system generates the rates and displays the table.

<table>
<thead>
<tr>
<th>Index</th>
<th>Index Qty</th>
<th>Index Asset</th>
<th>Index Trip</th>
<th>Index Settings</th>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Doubleclick for multiple entries</td>
<td>20,000.00</td>
<td>30,000.00</td>
<td>40,000.00</td>
<td>50,000.00</td>
</tr>
<tr>
<td></td>
<td>25,000</td>
<td>0.1000</td>
<td>0.1100</td>
<td>0.1200</td>
<td>0.1300</td>
</tr>
<tr>
<td></td>
<td>50,000</td>
<td>0.1500</td>
<td>0.1600</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>75,000</td>
<td>0.2000</td>
<td>0.2100</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>100,000</td>
<td>0.2500</td>
<td>0.2600</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>125,000</td>
<td>0.3000</td>
<td>0.3100</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>150,000</td>
<td>0.3500</td>
<td>0.3600</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>175,000</td>
<td>0.4000</td>
<td>0.4100</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>200,000</td>
<td>0.4500</td>
<td>0.4600</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td></td>
<td>MAX</td>
<td>0.5000</td>
<td>0.5100</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
</tbody>
</table>

Notice in our example above, the system generated rates for the second column.

5. Manually enter the rate for the MAX row.
6. Repeat Steps 1-5 for each column.
7. Click **Save** in the sheet toolbar, or select File > Save to save your work.

**Expanding an existing table**

You can use the Add Table Rows or Add Table Columns window to generate additional rates in an existing table.

1. Retrieve the rate in the Edit Settlement Rate Schedule Folder window.
2. Select the Table tab.
3. Do one of the following:
   * Click **Add Row** or select Edit > Add > Row(s)/Index to add rows to the table.
   * Click **Add Col** or select Edit > Add > Column(s) to add columns to the table.
4. The window appropriate for your choice is displayed.
   a. Select the **or generate** check box.
   b. Make entries in the **LOOKUP VALUES** fields:
      - **Base Lookup**
        The starting value from which the system will generate new lookup values. The value must be greater than the current highest lookup value, other than Max.
### Increment
The value used by the system to generate lookup values between the new Base Lookup value and the Max Lookup value.

**Note:** Lookup values can be set up to increment by a flat amount or by a percentage. When increments are set up as percentages, ten percent is entered as 10.0000. See the description for the (increment type) field.

#### (increment type)
Select either:
- **Flat**
  The value in the **Increment** field will be used as a flat amount to generate lookup values.
- **%**
  The value in the **Increment** field will be used as a percentage to generate lookup values.

### Round
Select the number of decimal places to which the system should round its calculations for percentage type of increments.
The options are 0-4.

**Note:** The **Round** field displays only when % is selected as the increment type.

### Max Lookup
The table's highest lookup value.

When the system generates the table, it will add the increment value to the new Base Lookup value to create the next lookup value. Then it will add the increment value to that value to create the next lookup value, and so on until it reaches the Max Lookup value.

c. **Make entries in the RATE VALUES fields:**

#### Base Rate
The rate that will correspond to the new Base Lookup value.

#### Increment
The value by which the system will increment the rates it generates for this table. The value entered can be positive or negative.

**Note:** Rates can be set up to increment by a flat amount or by a percentage. When increments are set up as percentages, ten percent is entered as 10.0000. See the description for the (increment type) field.
(increment type) Select either:

- **Flat**
  The rates generated by the system will increment by the flat value recorded in the **Increment** field.

- **%**
  The rates generated by the system will increment by the percentage recorded in the **Increment** field.

- **% Range**
  The system generates the rates by multiplying the lookup amount times the percentage recorded in the **Increment** field. For more information, see the Understanding the % Range option to generate rates section.

**Round** Select the number of decimal places to which the system should round its calculations for percentage type of increments.

The options are 0-4.

**Note:** The Round field displays only when % is selected as the increment type.

![Increment field example](increment_field_example.png)

- Click OK.
  The system closes the window and generates the new rates based on your entries.

5. Click **Save** in the sheet toolbar, or select **File > Save** to save your work.
Understanding the % Range option to generate rates

When the % Range option is selected in the RATE VALUES section of the window, you can generate rates based on a percentage of the lookup value.

Notes:

1. When using the % Range option, lookup values are set up and generated the same way as with the other methods available in this window, i.e., Flat and %.

2. When the % Range option is selected, the Base Rate field is removed from view.
When the % Range option is selected, the system will generate rates by multiplying each lookup value times the percentage entered in the **Increment** field \((\text{lookup value} \times \text{increment} = \text{rate})\).

For example, we set 10 in the **Increment** field. So the system multiplies each of the lookup values times 10\% \((25 \times 10\% = 2.50, \text{and so on})\).

<table>
<thead>
<tr>
<th>Index</th>
<th>Index Qty</th>
<th>Index Asset</th>
<th>Index Tip</th>
<th>Index Settings</th>
<th>Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>25.000</td>
<td></td>
<td>2.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>75.000</td>
<td></td>
<td>7.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>125.000</td>
<td></td>
<td>12.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>175.000</td>
<td></td>
<td>17.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>225.000</td>
<td></td>
<td>22.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>275.000</td>
<td></td>
<td>27.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>325.000</td>
<td></td>
<td>32.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>375.000</td>
<td></td>
<td>37.5000</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>MAX</strong></td>
<td></td>
<td><strong>0.0000</strong></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
**Ignoring zero dollar rate cells**

*First available in TMWSuite: 2012.11_07.0783*

In some rate tables, a row and column may intersect at a cell for which no rate applies. For example, suppose you are setting up an origin state to destination state rate schedule. Because Illinois is the origin state for some rates and the destination state for other rates, Illinois must be both a row entry and a column entry in the rate table.

However, the rate schedule does not provide a rate for loads that begin and end in Illinois. Because the system does not accept a null (blank) value in a cell, you must enter 0.0000 in the Illinois-to-Illinois cell.

When setting up a pay rate table, you can select the **Ignore Zero Rates** check box to specify that 0.0000 entries are just placeholders and not valid rates. Any zero-dollar rates that exist in the rate table will not be applied.

**Note:** The **Ignore Zero Rates** check box is also available when you create rate tables in the Edit Billing Rate Schedule Folder.
Entering multiple values for a row or column heading

In some pay rate tables, the same rate amount may apply for multiple row entries or column entries. Although you can record the rate repeatedly for each entry to which it applies, you also have the option to enter multiple values in a row or column heading so that the rate can be entered just once.

You can enter multiple values only for these row/column selections:

- **Axle Count**
- **Dest. Zip (Full)**
- **PassThruState/Prov**
- **Bill To**
- **Driver ID**
- **Revenue Type 1-4**
- **Billto Othertypes 1-2**
- **Driver Terminal**
- **Seniority (months)**
- **Commodity**
- **Driver Type 1-4**
- **Stop Othertypes1-2**
- **Commodity Class**
- **Event**
- **Tractor Terminal**
- **Day of Week**
- **Event Type**
- **Trailer Terminal**
- **Dest. Co. (Order)**
- **Orig Co. (Order)**
- **Tractor Type 1-4**
- **Dest. Company**
- **Origin Company**
- **Trailer Type 1-4**
- **Dest. State**
- **Origin State**
- **Trip Type**
- **Dest. Zip (3-digit)**
- **Other Type 1-2**

To use this feature, do the following:

1. Define your rows and/or columns. (To do so, make the appropriate selection in the **Rows** field and/or **Col.’s** field in the rate header.)

2. Double-click the heading of the row or column in which multiple values are to be entered. The Multiple Selection window is displayed. It is shown here with sample data:

![Multiple Selection Window](image-url)
Note: Another way to access the Multiple Selection window is to right click the heading of the row or column. Then select *Multiple Selection*.

3. Enter the appropriate values. Use a semicolon to separate entries. Do not use spaces.

4. When your entries are complete, click **OK**. After the Multiple Selection window closes, note that the row or column heading now shows in teal to indicate that multiple values exist. In addition, an asterisk (*) is shown to the left of the first entry. Only the first few entries are visible. For example:

5. In the appropriate cell, enter the rate that applies to all the values you entered.

**Removing multiple values for a row or column heading**

To quickly remove multiple values from the heading of a row or column, right-click the heading; then choose **Single Selection** from the short cut menu. The system displays this warning:

Click **OK**. When the window closes, only the first value entered in the heading will be retained.
Deleting rows

If you set up a multi-row table of rate amounts for a rate schedule, but then decide that a particular row is not needed, you can delete the unnecessary row.

1. Position the cursor in one of the fields in the row you want to delete.

2. Click **Del Row** in the sheet toolbar, or select **Edit > Delete > Row(s)/Index**.

3. The system displays a message asking how many rows you wish to delete.

   Enter the appropriate number; click **OK**.

   If you enter a number greater than 1, the system deletes the currently selected row, as well as the appropriate number of rows beneath it.

Deleting columns

If you set up a multi-column table of rate amounts for a rate schedule, but then decide that a particular column is not needed, you can delete the unnecessary column.

1. Position the cursor in one of the fields in the column you want to delete.

2. Click **Del Col** in the sheet toolbar or select **Edit > Delete > Column(s)**.

3. The system displays a message asking how many columns you wish to delete.

   Enter the appropriate number; click **OK**.

   If you enter a number greater than 1, the system deletes the currently selected column, as well as the appropriate number of columns to the right of it.
Deleting an entire table

There may be times when you set up a table for a rate but later decide that you have not set up the table correctly. Although you could use the Delete Row and Delete Column commands to delete the table, the Clear Table feature is the fastest method. This feature:

- Deletes all rows.
- Deletes all columns.
- Sets the Rows and Col’s fields in the rate header to Not Used.

To clear a table, follow these steps:

1. With the rate table you want to clear displayed in the Edit Settlement Rate Schedule Folder, select Edit > Clear Table, or click Clear in the sheet toolbar.
   The system displays the following warning message to indicate that it is about to clear the table:

   ![Clear Rate Table](image)

   2. To clear the table, click OK.
      All rows and columns are removed, and the Rows and Col's fields in the header are reset to Not Used.

Sorting rows and columns alphanumerically

There may be times when you set up rows and columns for a table without first making sure that they are listed in alphanumeric order.

If you decide later that such order is needed, you can select Edit > Sort Table to have the system automatically arrange the rows and columns in alphanumeric order.

The system displays a message saying that you must save the table before it can be sorted.
Click **Yes** to continue the process.

Notice in the example shown here that the values of the table cells are maintained.

<table>
<thead>
<tr>
<th>MA</th>
<th>IN</th>
<th>OH</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>130.0000</td>
<td>145.0000</td>
</tr>
<tr>
<td>MI</td>
<td>140.0000</td>
<td>135.0000</td>
</tr>
<tr>
<td>OH</td>
<td>150.0000</td>
<td>125.0000</td>
</tr>
</tbody>
</table>

**Note:** If both rows and columns have been established for the table, all will be arranged in alphanumeric order. There is no way to sort only rows or only columns.

### Switching rows to columns and columns to rows

After you set up rows and columns for a table, you may decide that it would be better to have your rows display as columns and your columns display as rows. To switch them automatically, select **Edit > Transform Table**.

The system displays a message saying that you must save the table before it can be sorted.

To continue the process, click **Yes**.

Notice in the example shown here the values of the table cells are maintained.

<table>
<thead>
<tr>
<th>MA</th>
<th>IN</th>
<th>MI</th>
<th>OH</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>130.0000</td>
<td>140.0000</td>
<td>150.0000</td>
</tr>
<tr>
<td>OH</td>
<td>145.0000</td>
<td>135.0000</td>
<td>125.0000</td>
</tr>
</tbody>
</table>