How to Contact TMT Fleet Maintenance Support

**TMW Systems Client Center** - This is your one-stop source for self-service upgrades, installs and documentation for TMT Fleet Maintenance. A username and password is required and can be obtained from TMT Fleet Maintenance Support.

**NetSuite Customer Care Center** - The TMW Systems Customer Care Center allows you to create, edit, and monitor technical support cases. A username and password is required and can be obtained from TMT Fleet Maintenance Support.

**Phone** - Call 919.493.4700; option 6 then option 3 and talk directly to a Support Analyst. They are available Monday through Friday 8:00 AM to 6:00 PM EST.

After 15 minutes on hold, all calls automatically rollover to voicemail.

**Email** – Messages to **tmtsupport@tmwsystems.com** result in a technical support case being opened for you. By default, Email cases are assigned Medium priority and are addressed after NetSuite and Phone cases.
# Contents

## Chapter 1: General Information

- Introduction ................................................................................................................. 1
- Conventions Used In This Book .................................................................................. 1
- Security ........................................................................................................................ 1
- Database Login .......................................................................................................... 2
- Database Issues ......................................................................................................... 2
- Other Administrative Issues ....................................................................................... 2
- Defining Labor Cost, Shop Rate vs Burden Labor Rate ............................................. 2
- Shop Rate Method ...................................................................................................... 3
- Burden Labor Rate Method ....................................................................................... 3
- Online and Batch Modes of Repair Order Processing ............................................... 3

## Chapter 1: TMT Fleet Maintenance/SQL Menus

- TMT Fleet Maintenance Menus .................................................................................. 6
  - Masters Menu ........................................................................................................ 6
  - Activities Menu ..................................................................................................... 9
  - SysMgr Menu ....................................................................................................... 11
  - Window Menu ...................................................................................................... 12
- Forms ......................................................................................................................... 15
  - Grids and Grid Controls ....................................................................................... 16
  - Using the Grouping Feature .................................................................................. 17
  - Standard Controls ............................................................................................... 18
  - Data Navigator ...................................................................................................... 20
- Adding Images .......................................................................................................... 21
  - RTF and TXT ........................................................................................................ 22
  - PDF ...................................................................................................................... 22
  - JPEG .................................................................................................................. 22
  - BMP .................................................................................................................... 22
- The Main System Menu ............................................................................................. 22
- The TMT Fleet Maintenance Toolbar ......................................................................... 23
  - Toolbar Shortcut Icons .......................................................................................... 23
- Displaying Toolbar Panels ......................................................................................... 25
  - General Toolbar Panel .......................................................................................... 25
  - Masters Toolbar Panel .......................................................................................... 25
  - Orders Toolbar Panel ............................................................................................. 25
  - Reporting Toolbar Panel ........................................................................................ 25
- Adding Items to TMT Fleet Maintenance Menus ......................................................... 26
- TMT Fleet Maintenance Wallpaper Backgrounds ....................................................... 27

## Chapter 3: Building the Foundation

- ................................................................................................................................. 29
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>29</td>
</tr>
<tr>
<td>Preparing for Master Record Data Entry</td>
<td>32</td>
</tr>
<tr>
<td>System Setup</td>
<td>33</td>
</tr>
<tr>
<td>TMT Fleet Maintenance Options</td>
<td>34</td>
</tr>
<tr>
<td>Repairs - Jobcodes</td>
<td>39</td>
</tr>
<tr>
<td>Repairs - Overtime</td>
<td>40</td>
</tr>
<tr>
<td>Inventory</td>
<td>43</td>
</tr>
<tr>
<td>Invoicing - SysMgr &gt; Options &gt; Invoicing</td>
<td>47</td>
</tr>
<tr>
<td>User Interface</td>
<td>51</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>52</td>
</tr>
<tr>
<td>Modules</td>
<td>56</td>
</tr>
<tr>
<td>User Options</td>
<td>56</td>
</tr>
<tr>
<td>Transman INI</td>
<td>58</td>
</tr>
<tr>
<td>General Section</td>
<td>59</td>
</tr>
<tr>
<td>Additional Sections</td>
<td>59</td>
</tr>
<tr>
<td>Codekeys Setup</td>
<td>62</td>
</tr>
<tr>
<td>Units of Measure</td>
<td>64</td>
</tr>
<tr>
<td>Company Setup</td>
<td>65</td>
</tr>
<tr>
<td>Company Definition</td>
<td>65</td>
</tr>
<tr>
<td>Tools Catalog Setup</td>
<td>66</td>
</tr>
<tr>
<td>Auto Fleet Definitions</td>
<td>66</td>
</tr>
<tr>
<td>Repair Order System Setup</td>
<td>67</td>
</tr>
<tr>
<td>Complaint, Cause, and Correction Codes</td>
<td>67</td>
</tr>
<tr>
<td>Complaint Code</td>
<td>68</td>
</tr>
<tr>
<td>Cause Codes</td>
<td>69</td>
</tr>
<tr>
<td>Correction Codes</td>
<td>69</td>
</tr>
<tr>
<td>Position Codes</td>
<td>70</td>
</tr>
<tr>
<td>Meters, Fluids, PMs Setup</td>
<td>71</td>
</tr>
<tr>
<td>Meter Groups</td>
<td>72</td>
</tr>
<tr>
<td>Fluid Groups</td>
<td>75</td>
</tr>
<tr>
<td>PM Setup</td>
<td>75</td>
</tr>
<tr>
<td>Adding Component Specifications</td>
<td>76</td>
</tr>
<tr>
<td>Accounting Features</td>
<td>77</td>
</tr>
<tr>
<td>Tax Rates and Fees</td>
<td>77</td>
</tr>
<tr>
<td>Resolving Tax Rates</td>
<td>78</td>
</tr>
<tr>
<td>Pay Grades</td>
<td>79</td>
</tr>
<tr>
<td>Create a New Pay Grade</td>
<td>80</td>
</tr>
<tr>
<td>Edit a Pay Grade</td>
<td>80</td>
</tr>
<tr>
<td>Pay Grades and Labor Rates</td>
<td>80</td>
</tr>
<tr>
<td>Work Shifts</td>
<td>81</td>
</tr>
<tr>
<td>Defining Jobcodes</td>
<td>81</td>
</tr>
<tr>
<td>Chapter 4: Building the Structure of Your Business</td>
<td>83</td>
</tr>
<tr>
<td>Shop Master</td>
<td>83</td>
</tr>
<tr>
<td>Repairs - Jobcodes</td>
<td>94</td>
</tr>
<tr>
<td>Repairs - Overtime</td>
<td>96</td>
</tr>
<tr>
<td>Purchasing</td>
<td>97</td>
</tr>
<tr>
<td>Inventory</td>
<td>98</td>
</tr>
<tr>
<td>Invoicing</td>
<td>99</td>
</tr>
<tr>
<td>Printing</td>
<td>101</td>
</tr>
<tr>
<td>Miscellaneous</td>
<td>102</td>
</tr>
<tr>
<td>TINA (TMT Fleet Maintenance INterActive)</td>
<td>102</td>
</tr>
<tr>
<td>Mechanic Workstation</td>
<td>104</td>
</tr>
<tr>
<td>Parts Workstation</td>
<td>106</td>
</tr>
<tr>
<td>Drivers Master</td>
<td>106</td>
</tr>
<tr>
<td>Personal Information</td>
<td>107</td>
</tr>
<tr>
<td>Unit Assign- ments</td>
<td>108</td>
</tr>
<tr>
<td>Employee Master</td>
<td>109</td>
</tr>
</tbody>
</table>
Chapter 6: Management Reports

- Re-open a Closed Repair Order ................................................................. 181
- Repair Order Status .................................................................................. 181
- Repair Order Entry Options ...................................................................... 181
- Tracking Chronic Repairs ....................................................................... 183
- Repair Order Entry .................................................................................. 183
- Vendor Repair Orders ............................................................................. 185
- Sections Tab .......................................................................................... 187
- User Fields - Images ............................................................................... 188
- Add New Repair Order Section ............................................................... 188
- Viewing Line Items .................................................................................. 189
- Add New Lines to Repair Orders .............................................................. 190
- New Part Line ........................................................................................ 190
- New Labor Line ...................................................................................... 191
- New Service Line .................................................................................. 192
- New Comment Line ................................................................................ 192
- Tracking Warranty Information ............................................................... 193
- Repair Order Templates .......................................................................... 194
- Create New Repair Order Template ....................................................... 195
- Create Repair Orders from Templates - Single Unit ............................... 196
- Create Repair Orders from Templates - Multiple Units ......................... 197
- Create RO from Repair Order Query Using RO Templates ................. 198
- Create RO from Shop Planner Using RO Templates ............................. 198
- Repair Order Work Card ....................................................................... 198
- Re-Opening Closed Repair Orders ......................................................... 200
- Meter Readings ...................................................................................... 201
- Using Palm Devices to Enter Meter Readings ........................................ 203
- Indirect Charges ..................................................................................... 204
- Indirect Charge Order Query ................................................................. 204
- Indirect Order Entry ............................................................................... 205
- Purchasing and Inventory Management .................................................. 206
- Physical Inventory Process ..................................................................... 206
- Your First Physical Inventory Count ....................................................... 210
- Requesting Parts .................................................................................. 211
- Requisition List .................................................................................... 211
- Prices Used on Requisition Lists ........................................................... 213
- Using Palm Devices to Enter Parts Requisitions .................................... 213
- Searching Purchase Orders .................................................................... 214
- Purchase Order Options ........................................................................ 218
- Purchase Dollar Amount Limits ............................................................. 219
- Creating and Updating Purchase Orders ................................................ 219
- Changing Vendors on Purchase Orders .................................................. 224
- Receiving Purchase Orders .................................................................... 224
- Using Blanket Purchase Orders .............................................................. 227
- Printing Purchase Orders ....................................................................... 227
- Printing Bar Code Labels from a Purchase Order List ........................... 228
- Part Transfers ....................................................................................... 228
- Fuel System .......................................................................................... 231
- Fuel Ticket Entry .................................................................................... 233
- Using Palm Devices to Enter Fuel Tickets ............................................. 234
- ComData MC Fuel Import ..................................................................... 237
- Display a List of Trip Tickets ................................................................. 242
- Entering New Trip Tickets ..................................................................... 243
- Setting Trip Ticket Options .................................................................... 244
- Editing Trip Tickets ............................................................................... 244
- Closing Trip Tickets ............................................................................. 245
- Deleting Trip Tickets ............................................................................ 246

Chapter 6: Management Reports ................................................................... 249
Chapter 7: Advanced TMT Fleet Maintenance Features

Tracking Shop and Employee Tool Inventories ................................................................. 277
  Tools Catalog .................................................................................................................. 277
  Employee Tools .............................................................................................................. 278

Inspection Tickets.............................................................................................................. 279
  Inspection Tickets Setup .............................................................................................. 279
  Using Inspection Tickets .............................................................................................. 280

Accounting Export Module Setup .................................................................................... 282
  Set Up the Chart of Accounts ....................................................................................... 283
  Accounting Year ........................................................................................................... 284
  Period Close Process .................................................................................................... 285

Accounting Integration .................................................................................................... 286
  About the Accounting Export Program ........................................................................ 287
  Using Trans-man/SQL To Export Accounting Data ..................................................... 287
  Creating Export Configurations ................................................................................. 287
  Exporting Using TMT Fleet Maintenance/SQL ............................................................ 287
  Text File Export ........................................................................................................... 288

Requirements for Exporting Accounting Data ............................................................... 289
  Exporting to a Text File from TMT Fleet Maintenance/SQL ....................................... 289
  Requirements for Exporting to Great Plains .............................................................. 290

Customizing the Great Plains Interface .......................................................................... 290

Setting Up the Export Transaction Function .................................................................. 292
  1. Create the Chart of Accounts .................................................................................... 292
  2. Create Sub-Accounts ................................................................................................. 292
  3. Create Disbursement Rules ...................................................................................... 293
  4. Create a New Base Transaction Rule ...................................................................... 294
  5. Create Transaction Sub-rules ................................................................................... 295
  6. Turn On Accounting Transactions in SysMgr .......................................................... 296

Exporting Account Data .................................................................................................. 297

Exporting Data Using TMT Fleet Maintenance/SQL ...................................................... 297
Exporting Data Using the Accounting Export Program .............................................. 299
Exporting Data to Great Plains ...................................................................................... 304
Trouble-shooting Accounting Export ........................................................................... 305
Chapter 8: Importing and Exporting Data ................................................................. 345
Importing Data ........................................................................................................ 345
Additional Considerations ....................................................................................... 347
Setting Up Data Imports .......................................................................................... 347
Using the Data Import Wizard - Overview .............................................................. 348
Uploading Data from Handheld Devices ................................................................. 349
Importing Repair Invoices ...................................................................................... 351
Create a Repair Invoice Import ................................................................................ 352
Importing Units ......................................................................................................... 354
Importing Fuel Data .................................................................................................. 355
Import Considerations .............................................................................................. 356
Importing Fuel Tickets .............................................................................................. 359
Importing Parts Inventory ....................................................................................... 360
Importing Parts Requests ....................................................................................... 363
Importing Meter Readings ...................................................................................... 366
Importing Yard Check Data .................................................................................... 368
Importing FleetNet America Data ............................................................................ 371
Import Considerations .............................................................................................. 371
Setting Up the FleetNet America Import ............................................................... 371
Step 1 - Preliminary Setup ....................................................................................... 371
Step 2 - Data Import Wizard Setup ........................................................................ 371
Chapter 1: General Information

Introduction

The TMT Fleet Maintenance/SQL Workbook describes the basic commands of this Windows application.

It outlines the setup process required to effectively implement the TMT Fleet Maintenance/SQL maintenance management system. This process is key to the reporting capabilities of the system and deserves careful analysis. You can modify the setup; however, the initial setup determines the reporting capabilities of the application. Some steps must be completed in a particular order, so it is essential that you follow the procedures outlined here to complete your TMT Fleet Maintenance/SQL setup. The procedures in this book take you through this process in the order required to minimize redundant data entry.

The Workbook is a learning tool for the personnel involved with daily data-entry tasks. Each task and data entry screen is reviewed in detail. Exercises are provided to give you “hands-on” experience with these tasks.

TMT Fleet Maintenance/SQL provides many standard reports. The way you set up the database and how you perform data entry tasks affects the usefulness and accuracy of the information you store in the TMT Fleet Maintenance database.

Conventions Used In This Book

Information in this book is formatted to be easily recognizable. Conventions used in this book include:

<table>
<thead>
<tr>
<th>Convention</th>
<th>Use</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Bold</strong></td>
<td>Highlights items that you must type, or button names.</td>
</tr>
<tr>
<td><strong>Code</strong></td>
<td>Highlights coding used in macros and command lines.</td>
</tr>
<tr>
<td><em>Italic</em></td>
<td>Highlights screen names, book titles, field names, variables, and important items.</td>
</tr>
</tbody>
</table>

The arrow indicates the drill-down sequence for a menu choice.
For example, **SysMgr > Options** means “select SysMgr on the File menu, then select the Options choice from the drop-down menu.”

Security

TMT Fleet Maintenance/SQL incorporates two levels of security to protect your data from unauthorized access:

- Database security
- Application security
Because of the multiple security levels, users can be added or deleted using the Security Administration (SecAdmin) program that is located in the TMT Fleet Maintenance/SQL program folder.

For more information about security, see the TMT Fleet Maintenance/SQL Installation and Administration Guide.

Database Login

After the TMT Fleet Maintenance/SQL program starts, a password screen is displayed.

![Database Login Screen]

You must enter a valid User Name and Password that were created by the System Administrator in order to access the TMT Fleet Maintenance/SQL program functions.

If a valid user name and password are not entered after three attempts, the Transman main menu is displayed, but none of the program functions are enabled and no connection to a database is made.

While a password can be stored in the TRANSMAN.INI file, it is not recommended because it compromises security. Each user should enter a password at every login, and guard the password as confidential company information.

**NOTE:** The password is case-sensitive. For example, MyPassword is NOT the same as mypassword.

Database Issues

Recent updates to TMT Fleet Maintenance/SQL include database optimization, database constraints, and other updates designed to maintain data integrity and to improve functionality.

Other Administrative Issues

Defining Labor Cost, Shop Rate vs Burden Labor Rate

A decision must be made about how your company will determine labor cost. This is not an issue of right versus wrong, but an issue of determining the method that seems most appropriate to your business and reporting needs. In one sense, it makes little difference as long as the method that you choose is applied consistently. Even if you choose to charge all labor at $1 per hour, your reporting functions could still yield meaningful relative information about labor cost.

Select the method that best meets your needs. If you plan to export accounting data to your general ledger (GL) accounting system, labor cost should be defined in a way that is acceptable to your accounting department.
**Shop Rate Method**

The Shop Rate method considers labor cost as a function of the operating cost of your maintenance facility. The shop rate method is useful in evaluating your shop’s performance in comparison to other maintenance solutions, like outsourcing.

The basic method of arriving at your Shop Rate is to divide the operating costs of your facility by the potentially available labor hours for the same time period. The result expresses the cost of operating your facility in labor hours. Shop Rate includes all shop overhead, like supplies, utilities, paid overtime, and support staff salaries.

When using the Shop Rate method, similar labor operations performed by different individuals earning different wages have the same cost, because labor cost is not determined by the individual’s rate of pay.

**Burden Labor Rate Method**

The Burden Labor Rate method considers labor cost as a function of the cost to the company of an individual employee’s time. Burden Labor Rate is calculated by adding your individual employee’s gross wage, cost of benefits, and employment taxes to determine a cost to the company for each individual employee’s time (burden rate). Labor cost is then posted at the individual burden rate for each employee.

When using the Burden Labor Rate method, similar labor operations performed by employees with different levels of compensation have different labor costs, because the labor cost is determined by the burden rate assigned to each employee.

Once you have determined how you want to post your labor cost, use the appropriate process below to set your system up to use the method you have chosen.

- To use the Shop Rate method, create a labor rate for each shop for the shop rate hourly amount and assign the same labor rate to each employee.
- To use the Burden Labor Rate method, create a labor rate for each burden labor rate for each shop and assign the appropriate rate to each employee.

The process that you use to assign labor rates to your employees determines the meaning of your labor cost values.

**Online and Batch Modes of Repair Order Process**

The two modes of Repair Order (RO) process refer to data entry time sequence. The Online Repair Order is designed as a real-time process. The Batch Repair Order is designed to facilitate after-the-fact data entry.

The actual operations required are the same, but the sequence and timing of data entry events differ. In actual practice, even a shop that normally uses the online process might need to use the batch data entry process. The actual processes are covered in Chapters 6 through 12.

The main benefit of the online process is that it takes place in real time. When a job comes in to the shop, the Repair Order is opened. As work progresses, labor and parts are charged to the RO. When the work is complete, the RO is reviewed and closed.

This method has some inherent characteristics that can be of significant benefit:
• Warranty recovery is enhanced because your personnel are advised of potential warranty conditions during the Repair Order process, allowing them to save any parts that are removed. When the RO is opened, there is onscreen advice of a valid New Unit warranty condition. When a section is created, there is on-screen advice of a valid assembly warranty on the system involved. When the parts are charged to the RO, there is on-screen advice of a valid warranty condition on the part that was replaced.

• When the RO is opened, any work pending or due PMs are listed for selection to create sections on the RO.

• Inventory management can be improved when parts are charged to the RO as they leave the parts room. Inventory is relieved when parts are charged to RO’s, so the inventory system is updated as the parts are used. This allows you to use the Parts Requisition system to place frequent reorders of your inventory and to reduce the number of parts that must be kept on hand. Effective use of this method can significantly reduce your inventory capital requirements.

• Repair Order Diagnostics print with the Online Repair Order Work Card. Well designed diagnostics can help improve the efficiency of your preventive maintenance (PM) program and provide timely suggestions to your line technicians of manufacturer technical bulletins.

• PM Parts Pick Lists print with the Online Repair Order Work Card, saving time for your technicians and parts clerks when pulling parts for the work required.

The Batch Repair Order process is optimized for historical data entry. This is the easiest method to implement in a shop migrating from a paper system. Using this method, a data entry operator keys the Repair Order data into TMT Fleet Maintenance/SQL from the existing paper ROs. Shop process is undisturbed, and analysis of the data provided is almost as effective as in the Online method. The PM scheduler report is available to facilitate the scheduling of required maintenance. Warranty recovery can be enhanced by promoting an internal process to retain parts that were removed.

One tactic that can be employed to make a gradual transition from batch to online operation is to open repair orders as jobs come in to the shop. Use the Repair Order Work Card and its diagnostics and pick lists to document the work done, then have the data entry clerk enter the labor and part charges the next morning. If the data entry can be done the following day, you get most of the benefit of the online mode of operation. To use this technique, emphasize the following processes for data entry:

1. The first step each morning is to receive any parts that came in since parts were received the previous day. Parts must be received before they can be charged to ROs.

2. Next, post the previous day’s RO labor and part charges. This relieves inventory of any parts used in the previous day’s work.

3. Then, run the Requisition report, review it and modify it appropriately, then reorder the parts you need. This enables you to manage your inventory to within one day of parts usage.

Employing this technique can ease a transition from a paper-based system to online operation and its inherent advantages. It introduces your personnel to the online concept and facilitates making the next move toward full real-time function.
For more information on how to specify batch or on-line mode, see “Repair Order Entry Options” on page 181.
Chapter 1: TMT Fleet Maintenance/SQL Menus

This chapter describes using the TMT Fleet Maintenance/SQL functions that are accessed by the menu bar. It also describes display conventions used in TMT Fleet Maintenance.

Microsoft Windows® has several standard functions that you probably use every day. Most Windows applications follow these rules or conventions. TMT Fleet Maintenance/SQL allows you to do almost every type of operation from the computer keyboard. Mouse operations can also be performed by using a combination of keystrokes. For more information about Windows and menu conventions, see your Windows documentation.

TMT Fleet Maintenance Menus

To pull down a menu, click on the menu item, or press the ALT key plus the underlined letter from the menu name. For example, on the File menu, press ALT + F.

On any drop-down menu, you can use the arrow keys to navigate to the appropriate menu choice and then press the Enter key, or use the mouse to click the menu item.

You can also use hotkeys (also called shortcut keys) to select the menu option. In this book, the hotkey for a command is underlined. For example, press the v key for Print Preview while the menu is dropped down. You can also press a series of hot keys. For example, to select the Print Preview, press ALT + F + V.

To enable hotkeys on a Windows 2000 or Windows XP computer, you must press ALT when the TMT Fleet Maintenance application is opened. You must press and release ALT before the menu is expanded or Windows does not apply the hotkeys. When you complete navigating the path and close the TMT Fleet Maintenance form, the hotkeys are no longer applied and do not appear again until you press ALT.

NOTE: Not all menu options are available. Some options require other modules, such as the invoicing module, to be installed before they are displayed on the menu. These limitations are noted in the following charts.

File Menu

The File menu in TMT Fleet Maintenance/SQL contains Mail, Load Saved Report, Print, Print Setup, and Print Preview options. You can select the menu options with the mouse or with a hot key. Hot key: ALT + F
<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mail</td>
<td>Check Mail</td>
<td>Check for incoming e-mail</td>
</tr>
<tr>
<td></td>
<td>Send Mail</td>
<td>Send queued outgoing e-mail</td>
</tr>
<tr>
<td>Command</td>
<td>Sub-Command</td>
<td>Action</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Load Saved Report</td>
<td></td>
<td>Display a report that was created previously and stored. The report cannot be saved to a different format.</td>
</tr>
<tr>
<td>Print</td>
<td></td>
<td>Display the Windows print menu</td>
</tr>
<tr>
<td>Print Setup</td>
<td></td>
<td>Display the print setup menu</td>
</tr>
<tr>
<td>Print Preview</td>
<td></td>
<td>Display a formatted view of the data from the active form, shown as it will print</td>
</tr>
<tr>
<td>Exit</td>
<td></td>
<td>Exit TMT Fleet Maintenance</td>
</tr>
</tbody>
</table>

### Edit Menu

From the Edit menu, you can select the database-editing mode you need

**Hotkey: ALT + E**.

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Hot Keys</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td></td>
<td>CTRL + X</td>
<td>Deletes the highlighted text (and copies it to the Windows clipboard)</td>
</tr>
<tr>
<td>Copy</td>
<td></td>
<td>CTRL + C</td>
<td>Copy the highlighted text into the Windows clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td></td>
<td>CTRL + V</td>
<td>Insert copied text (or anything on the Windows clipboard) at the cursor position</td>
</tr>
<tr>
<td>Search</td>
<td></td>
<td>F4</td>
<td>Displays a standard search dialog box, then searches for a field’s value from a predetermined list.</td>
</tr>
<tr>
<td>Edit record</td>
<td></td>
<td>CTRL + E</td>
<td>Edit a database record</td>
</tr>
<tr>
<td>Insert record</td>
<td></td>
<td>CTRL + INS</td>
<td>Insert a new record into the database</td>
</tr>
<tr>
<td>Delete record</td>
<td></td>
<td>CTRL + DEL</td>
<td>Delete a record from the database</td>
</tr>
<tr>
<td>Post Changes</td>
<td></td>
<td>F6</td>
<td>Writes the data you entered to the database</td>
</tr>
<tr>
<td>Cancel Changes</td>
<td></td>
<td>ALT + BKSP</td>
<td>Cancel an operation in progress</td>
</tr>
<tr>
<td>Show Toolbar</td>
<td></td>
<td></td>
<td>If checked, displays the toolbar buttons at the top of the window</td>
</tr>
<tr>
<td>Show Status Bar</td>
<td></td>
<td></td>
<td>If checked, displays the status bar at the bottom of the window</td>
</tr>
<tr>
<td>Config Toolbar</td>
<td></td>
<td></td>
<td>Displays the Toolbar on the top of the window</td>
</tr>
<tr>
<td>Alignment Top</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Sub-Command</td>
<td>Hot Keys</td>
<td>Action</td>
</tr>
<tr>
<td>-----------</td>
<td>-------------</td>
<td>----------</td>
<td>---------------------------------------------</td>
</tr>
<tr>
<td>Alignment</td>
<td>Bottom</td>
<td></td>
<td>Displays the Toolbar on the bottom of the window</td>
</tr>
<tr>
<td>Alignment</td>
<td>Left</td>
<td></td>
<td>Displays the Toolbar on the left side of the window</td>
</tr>
<tr>
<td>Alignment</td>
<td>Right</td>
<td></td>
<td>Displays the Toolbar on the right side of the window</td>
</tr>
<tr>
<td>Panels</td>
<td>General</td>
<td></td>
<td>Display the General toolbar icon panel</td>
</tr>
<tr>
<td>Panels</td>
<td>Masters</td>
<td></td>
<td>Display the Masters toolbar icon panel</td>
</tr>
<tr>
<td>Panels</td>
<td>Orders</td>
<td></td>
<td>Display the Orders toolbar icon panel</td>
</tr>
<tr>
<td>Panels</td>
<td>Reporting</td>
<td></td>
<td>Display the Reports toolbar icon panel</td>
</tr>
<tr>
<td>Reset Form</td>
<td>States</td>
<td></td>
<td>Reset all custom form settings back to TMT Fleet Maintenance defaults</td>
</tr>
</tbody>
</table>

**Masters Menu**

From the Masters menu, you can access Master file functions.

**Hot key: ALT + M**

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shops</td>
<td>Displays the data associated with each shop in the Shops database</td>
</tr>
<tr>
<td>Drivers</td>
<td>Displays a list of drivers to be used on Trip Tickets and Road Calls. Units can be assigned to drivers. A Driver Only cannot charge labor against repair orders or charge labor in Mechanic Workstation.</td>
</tr>
<tr>
<td>Employees</td>
<td>Displays the data about employees associated with each shop</td>
</tr>
<tr>
<td>Units</td>
<td>Displays data about each unit in the units database</td>
</tr>
<tr>
<td>Parts Catalog</td>
<td>Set up parts catalog to ensure all shops use the same part ID for a part</td>
</tr>
<tr>
<td>Shop Inventory</td>
<td>Displays an inventory for each shop</td>
</tr>
<tr>
<td>Vendors</td>
<td>Displays data about each vendor in the database</td>
</tr>
<tr>
<td>Customers</td>
<td>Assign and update customer assignments to units to enable invoicing functions; available with installation of invoicing module</td>
</tr>
<tr>
<td>Vendor Parts</td>
<td>Create, delete, or maintain vendor-supplied parts.</td>
</tr>
</tbody>
</table>
### Orders Menu

Use the Orders menu to access Ordering functions and reports:

Hot key: **ALT + O**

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Repair Orders</td>
<td></td>
<td>Access information about repair orders</td>
</tr>
<tr>
<td>Purchase Orders</td>
<td></td>
<td>Access information about purchase orders</td>
</tr>
<tr>
<td>Fuel Tickets</td>
<td></td>
<td>Access information about fuel tickets</td>
</tr>
<tr>
<td>Trip Tickets</td>
<td></td>
<td>Access information about trip tickets</td>
</tr>
<tr>
<td>Indirect Charges</td>
<td></td>
<td>Access information about indirect charges</td>
</tr>
<tr>
<td>Inspection Tickets</td>
<td></td>
<td>Access information about inspection tickets; view, update or add inspection tickets</td>
</tr>
<tr>
<td>Invoices</td>
<td></td>
<td>Access information about invoices; view, update or add invoices; available with invoicing module</td>
</tr>
<tr>
<td>Warranty Claims</td>
<td></td>
<td>Access information about warranty claims</td>
</tr>
<tr>
<td>Campaigns</td>
<td></td>
<td>Creates a pending repair order to apply a specific action to a group of units</td>
</tr>
</tbody>
</table>
### Inven Menu

Use the Inven menu to access inventory functions and report.

Hot key: ALT + I

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Part Request Form</td>
<td></td>
<td>Enables mechanic to request a part</td>
</tr>
<tr>
<td>Requisition List</td>
<td></td>
<td>Access the requisition list</td>
</tr>
<tr>
<td>Part Fee / Tax Assignment</td>
<td></td>
<td>Enter part fee and tax definitions</td>
</tr>
<tr>
<td>Parts Transfer</td>
<td></td>
<td>Enables parts to be moved from one shop to another</td>
</tr>
<tr>
<td>Physical Inventory</td>
<td></td>
<td>Manage physical inventories; adjust inventory at shop level</td>
</tr>
<tr>
<td>Reports</td>
<td>Parts Usage Report</td>
<td>Create a parts usage report</td>
</tr>
<tr>
<td></td>
<td>Parts Inventory Reports</td>
<td>Create a parts inventory report - by bin, cost, kit, and reorder analysis, in addition to a general listing</td>
</tr>
<tr>
<td></td>
<td>Physical Inventory Reports</td>
<td>Create and print a report about physical inventory</td>
</tr>
<tr>
<td></td>
<td>Parts on Pending Orders Reports</td>
<td>Create and print a report about parts included on pending work orders.</td>
</tr>
</tbody>
</table>

### Activities Menu

Use the Activities menu to access meter reading and bar code label functions, and warranty reports.

Hot key: ALT + A

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Meter Readings</td>
<td></td>
<td>Display the posted meter readings log for each unit</td>
</tr>
</tbody>
</table>
## Data Imports

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Imports</td>
<td>Fuel Data Import</td>
<td>Enables import of fuel tickets to update fuel or meter readings; available with installation of data import/export module</td>
</tr>
<tr>
<td></td>
<td>Data Import Wizard</td>
<td>Enables you to set up file specifications for a flat ASCII file used to import information using a Wizard to set up the information; available with data import/export module</td>
</tr>
<tr>
<td>Data Export</td>
<td></td>
<td>Enables export of TMT Fleet Maintenance data for fuel tickets, trip tickets, trip ticket segments, meter readings, LTD meter values, PM due, parts list, customer masters, unit masters, and vendor masters. (Requires installation of data import/export module. Other available export modules include: ALK Batch Pro, ALK Company Fuel Purchase, ALK Road Fuel Purchase, Tire Audit Meter Data, Customer Invoices, and Employee Timecards.)</td>
</tr>
</tbody>
</table>

## Bar Code Labels

<table>
<thead>
<tr>
<th>Command</th>
<th></th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bar Code Labels</td>
<td></td>
<td>Create bar code labels</td>
</tr>
</tbody>
</table>

## Parts Price Update

<table>
<thead>
<tr>
<th>Command</th>
<th></th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts Price Update</td>
<td></td>
<td>Allows the parts prices on the shop master to be marked up (requires invoicing module)</td>
</tr>
</tbody>
</table>

## Period Close

<table>
<thead>
<tr>
<th>Command</th>
<th></th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Period Close</td>
<td></td>
<td>Closes a period so that additional transactions cannot be entered into that period; enables period close reports to be run for open and closed periods</td>
</tr>
</tbody>
</table>

## Parts Search by Shop

<table>
<thead>
<tr>
<th>Command</th>
<th></th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts Search by Shop</td>
<td></td>
<td>Search for a part across multiple shops</td>
</tr>
</tbody>
</table>

## Parts Vendor Bid Update

<table>
<thead>
<tr>
<th>Command</th>
<th></th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parts Vendor Bid Update</td>
<td></td>
<td>Enables you to search for a parts vendor and update a parts bid price.</td>
</tr>
</tbody>
</table>

## Fixed Cost

<table>
<thead>
<tr>
<th>Command</th>
<th></th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fixed Cost</td>
<td></td>
<td>Create a fixed cost record for a unit.</td>
</tr>
</tbody>
</table>

## Reports

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reports</td>
<td>Warranty Reports</td>
<td>Create a report for units covered by warranty</td>
</tr>
</tbody>
</table>

## SysMgr Menu

Use the SysMgr menu to access system management functions.

**Hot key:** ALT + G

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calendar Setup</td>
<td></td>
<td>Create a calendar that can be assigned to a work shift.</td>
</tr>
<tr>
<td>Company Setup</td>
<td></td>
<td>Access the company setup screens</td>
</tr>
<tr>
<td>Repair Order Setup</td>
<td>Cause Codes</td>
<td>Access or update the list of cause codes</td>
</tr>
<tr>
<td>Command</td>
<td>Sub-Command</td>
<td>Action</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Complaint Codes</td>
<td></td>
<td>Access or update the list of complaint codes</td>
</tr>
<tr>
<td>Correction Codes</td>
<td></td>
<td>Access or update the list of correction codes</td>
</tr>
<tr>
<td>Position Codes</td>
<td></td>
<td>Access or update the list of position codes</td>
</tr>
<tr>
<td>Diagnostic Definitions</td>
<td></td>
<td>Access or update the list of diagnostic definitions</td>
</tr>
<tr>
<td>Pick List Definitions</td>
<td></td>
<td>Access or update the list of definitions for the pick list</td>
</tr>
<tr>
<td>Inspection Tickets</td>
<td></td>
<td>Access or update the list of definitions for inspection tickets</td>
</tr>
<tr>
<td>Jobcodes Description</td>
<td></td>
<td>Access or update the list of definitions for job codes</td>
</tr>
<tr>
<td>Commodity Codes</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Invoice Price Tables</td>
<td></td>
<td>Create pricing structures to use for different sales situations; available with installation of invoicing module</td>
</tr>
<tr>
<td>Import/Export</td>
<td>Fuel Import Setup</td>
<td>Set up specifications for importing fuel data</td>
</tr>
<tr>
<td>Import Wizard Setup</td>
<td></td>
<td>Set up specifications to import tire audit data and VMRS codes</td>
</tr>
<tr>
<td>VMRS Part Import</td>
<td></td>
<td>Imports VMRS part codes for vendors into Transman</td>
</tr>
<tr>
<td>Scheduled Exports</td>
<td></td>
<td>Display a list of scheduled export jobs</td>
</tr>
<tr>
<td>Meters, Fluids, PM Setup</td>
<td>Meter Setup</td>
<td>Access or update the list of meters</td>
</tr>
<tr>
<td></td>
<td>Fluids Setup</td>
<td>Access or update the list of fluids</td>
</tr>
<tr>
<td></td>
<td>PM Setup</td>
<td>Access or update the list of preventive maintenance codes</td>
</tr>
<tr>
<td>Component Specifications</td>
<td></td>
<td>Set up custom fields that appear on unit specification forms when setting up specifications for a unit</td>
</tr>
<tr>
<td>User Defined Fields</td>
<td></td>
<td>Set fields to track information that TMT Fleet Maintenance does not track, located on all master records, repair orders, purchase orders and invoices</td>
</tr>
<tr>
<td>Tax Rates and Fees</td>
<td></td>
<td>Access or update the list of tax rates and fees</td>
</tr>
<tr>
<td>Pay Grades</td>
<td></td>
<td>Access or update the list of pay grades</td>
</tr>
<tr>
<td>Work Shifts</td>
<td></td>
<td>Access or update the list of work shifts</td>
</tr>
<tr>
<td>Command</td>
<td>Sub-Command</td>
<td>Action</td>
</tr>
<tr>
<td>------------------</td>
<td>----------------</td>
<td>-------------------------------------------------------------</td>
</tr>
<tr>
<td>System Setup</td>
<td>Codekeys</td>
<td>Access or update the Codekeys list</td>
</tr>
<tr>
<td>Tools Catalog</td>
<td></td>
<td>Work with the tools catalog</td>
</tr>
<tr>
<td>Units of Measure</td>
<td></td>
<td>Set the method for measurement</td>
</tr>
<tr>
<td>Auto Fleet Definitions</td>
<td></td>
<td>Define or update auto fleet definitions</td>
</tr>
<tr>
<td>eCommerce Setup</td>
<td></td>
<td>Define or update the e-commerce definitions</td>
</tr>
<tr>
<td></td>
<td>Standard</td>
<td>Set up free-form messages for invoices, warranty, and purchase orders</td>
</tr>
<tr>
<td></td>
<td>Messages</td>
<td></td>
</tr>
<tr>
<td>Re-Open</td>
<td>Closed RO</td>
<td>Reopen a closed repair order</td>
</tr>
<tr>
<td></td>
<td>Re-open</td>
<td>Reopen a closed invoice.</td>
</tr>
<tr>
<td></td>
<td>Closed Invoice</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Re-Open</td>
<td>Reopen a closed indirect labor charge</td>
</tr>
<tr>
<td></td>
<td>Closed Indirect</td>
<td></td>
</tr>
<tr>
<td>Claims Price</td>
<td></td>
<td>Create pricing structures to use for various warranty situations</td>
</tr>
<tr>
<td>Tables</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Accounts</td>
<td>Chart of</td>
<td>Define and maintain charts of accounts; available with installation of accounting feature</td>
</tr>
<tr>
<td></td>
<td>Accounts</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Account</td>
<td>Define and maintain information about disbursements; available with installation of accounting feature</td>
</tr>
<tr>
<td></td>
<td>Disbursements</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Export Preview</td>
<td>View accounting export data before the export is performed</td>
</tr>
<tr>
<td></td>
<td>Export</td>
<td>Export accounting data; available with installation of accounting feature</td>
</tr>
<tr>
<td></td>
<td>Transactions</td>
<td></td>
</tr>
<tr>
<td>Service Locator</td>
<td>Update</td>
<td>Used to update TMT Fleet Maintenance with the NATC Vendor information (the NATC Locator Service module must be purchased)</td>
</tr>
<tr>
<td>Options</td>
<td></td>
<td>Access a list of setup (or &quot;preferences&quot;) information for this installation of TMT Fleet Maintenance</td>
</tr>
<tr>
<td>User Options</td>
<td></td>
<td>Options are variables that can be changed in TMT Fleet Maintenance to modify how the system operates; based on name of the person who is logged into TMT Fleet Maintenance, so each user can have a separate set of user options</td>
</tr>
<tr>
<td>Reports</td>
<td>Codekeys</td>
<td>Create a report containing a list of codekeys</td>
</tr>
<tr>
<td></td>
<td>Diagnostics</td>
<td>Create a report containing a list of diagnostic codes</td>
</tr>
<tr>
<td></td>
<td>Tools</td>
<td>Create a report containing a list of tools</td>
</tr>
</tbody>
</table>
**User Menu**

The User menu enables you to access Crystal Report functions, set up a list of programs that can be added as menu items and called from within TMT Fleet Maintenance/SQL, and to access the Internet from TMT Fleet Maintenance/SQL. Hot key: ALT + U

<table>
<thead>
<tr>
<th>Command</th>
<th>Sub-Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Reports</td>
<td>TRANSMAN.INI</td>
<td>Creates a report listing the options saved in the TRANSMAN.INI file.</td>
</tr>
<tr>
<td></td>
<td>Setup</td>
<td>Setup for user report functions.</td>
</tr>
<tr>
<td>Crystal Viewer</td>
<td>Setup</td>
<td>Enables you to add Crystal Reports as menu items in TMT Fleet Maintenance/SQL.</td>
</tr>
<tr>
<td>Tools</td>
<td>SecAdmin</td>
<td>Enables you to access the SecAdmin program from within TMT Fleet Maintenance/SQL.</td>
</tr>
<tr>
<td></td>
<td>Setup</td>
<td>Setup for tools functions.</td>
</tr>
<tr>
<td>Internet</td>
<td>Setup</td>
<td>Setup for Internet connections.</td>
</tr>
</tbody>
</table>

**Window Menu**

Use this menu to access common Windows functions. Hot key: ALT + W

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tile</td>
<td>Display open windows side-by-side in a grid pattern across the Transman screen, with each window displayed the same size</td>
</tr>
<tr>
<td>Cascade</td>
<td>Display open windows one above another in a hierarchy across the screen, displaying only the title bar of windows which are obscured by the top window</td>
</tr>
<tr>
<td>Arrange All</td>
<td>Arrange all open windows neatly across the TMT Fleet Maintenance screen</td>
</tr>
<tr>
<td>Close All</td>
<td>Close all open windows</td>
</tr>
</tbody>
</table>

**NOTE:** there are no sub-command menus on the Window menu.

**Help Menu**

The Help menu enables you to understand and troubleshoot the TMT Fleet Maintenance system. Help menus in TMT Fleet Maintenance/SQL are similar to most Windows products. Hot key: ALT + H

<table>
<thead>
<tr>
<th>Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Display the table of contents of Transman's help system</td>
</tr>
<tr>
<td>Search for Help on</td>
<td>Displays a search screen. Enter a word for which you want to search; a list of topics that contain the search word is displayed. Double-click on a topic entry in the list to display the topic.</td>
</tr>
<tr>
<td>Command</td>
<td>Action</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>How to Use</td>
<td>Displays a short tutorial on how the help system works</td>
</tr>
<tr>
<td>Help</td>
<td></td>
</tr>
<tr>
<td>TMT Home Page</td>
<td>Opens a web browser and displays TMT Software’s home page:</td>
</tr>
<tr>
<td></td>
<td><a href="http://www.TMTSoftware.com">www.TMTSoftware.com</a></td>
</tr>
<tr>
<td>About</td>
<td>Displays a screen containing version and date information about your TMT Fleet Maintenance installation</td>
</tr>
</tbody>
</table>

**NOTE:** there are no sub-command menus on the Help menu.

**Forms**

There are several different types of forms in TMT Fleet Maintenance/SQL. A form is a window that contains objects. Several types of objects can be present on a particular form. Each has its own characteristics and hotkeys. A sample form that contains all of the objects is shown in this section. Each object type and the hotkey associated with that object are described in the following sections.

**Grids and Grid Controls**

TMT Fleet Maintenance/SQL uses two types of grid boxes:

**Standard Grid** - A standard grid contains lines of boxes around the data fields that you can edit. To insert a line, press CTRL + INS and a new line displays. Also, if you use the Tab key to move to the grid and on the last row and column, then you press Tab again, it rolls to the next row and starts a new line that you can edit. The Tab key and the arrow keys move you from cell to cell.

**List View Grid** - The box shown on the bottom is a view only list. However, most view only grids allow you to insert new items into the list by right-clicking the mouse and choosing Insert, or edit items by double-clicking on them. This will display an edit form so you can change the selected item.

The grids used for orders and order entry screens are slightly different. The columns in these grids can be sorted and resized. The setting remains as the first user of a computer sets them, until another user changes one or more of the...
column widths or how the columns are sorted. The most recent setting is always used. Changes made to column widths and other settings are machine specific, not user specific.

- To resize a grid, double-click on the right border of the column heading. The column automatically adjusts the smallest width. This is similar to what happens in Excel spreadsheets.
- You can use a mouse that has a wheel control. As you turn the wheel, the display scrolls down the grid.
- You can click on the column header on the order query grids to sort in ascending or descending order. You can easily determine the grid sort in the one column that currently displays the up or down arrow.
- You can right-click to view information about the current value in the search components field. You can also use wildcard searches using % and range searches using the ~ characters. Wildcard searches work in any free-form text field (a field that allows you to enter text using the keyboard or touchpad screen).
- Lookup and search components fields do not display or allow the entry of inactive codes.
- For many forms, ShopID is a required field as the first data entry point. You cannot enter data into other fields or open other tabs until the ShopID is entered. This enforces shop-level security.
- On many forms, if you enter incorrect data or leave a null value in a required field, an error message is returned.
- Some numeric form fields are enhanced to provide a more accurate value when the number is rounded; for example, this occurs with fuel transactions because of the long decimal values. You can also adjust these figures manually.
- Most forms provide the capability to change the grid so that columns can be resized, rearranged, added, removed, or grouped. The changes are retained when the form is closed and then re-opened.

### Using the Grouping Feature

On many forms, you can dynamically change the grouping criteria by clicking on and dragging a column header into the Group sort area.

In the example, *Status* was dragged to the Grouping area.
Standard Controls

**NOTE:** All of the available object types are shown in this example.

- **Edit Box** - The Edit Box is a standard data-entry box for typing in text. This usually is not a validated field because there is no lookup available.

- **Memo Box** - The Memo Box displays multiple lines of data and has a scroll bar where you can view the data that cannot be displayed all at the same time within the size of the box. These are normally view-only boxes.

- **List Box** - A list of items is displayed from which you can select an item. Click on the item to select it. You can use List boxes to select and move data to another list box.

- **Checklist Box** - This type of list has multiple items that you can select from a list. When you click an item in the list, it becomes *selected* and a check mark is displayed next to it in the list. Clicking on a selected item de-selects it.

- **Spin Edit** - The Spin Edit is an edit box that usually contains a list of numbers or other data that you can scroll up or down in a logical fashion.
**Combo Box** - A Combo Box is an edit box that contains data that is displayed drop-down list. This is normally a validated field since a list of preselected items is displayed. Use **ALT + 0** (zero) to drop-down the list box.

**Tab Control** - Most of the multi-level forms in TMT Fleet Maintenance/SQL use tab control. You can pull up a new sub-form that pertains to the main form. When a tab is high-lighted, press the left or right arrow key, or click the **Tab** key itself to change forms.

You can also press **F2** and select from the pop-up menu using the up and down arrow keys, and then press the Enter key when the tab title you want to select is highlighted.

**Radio Group** - A Radio Group is a group of radio buttons that you can use to select a single item from a list or group.

**Check Box** - A Check Box can be toggled on or off. Use the Tab key to move to the Check Box and click on the Check Box or press the space bar to change its state.

**Radio Button** - A Radio button can be toggled on or off. Use the Tab key to move to the Radio Button and click on the Radio Button or press the space bar to change its state.

**Date and Search Edit** - You can click on the small calendar or the small flashlight on the **Edit Box** to display a search dialog. The date search shows a small calendar where you can select a specific date and year. The search flashlight displays a standard search dialog box which allows you to search for a record.

**Tree View** - The tree view is a structured view of data or related topics. Press the + and the - signs to the left of the tree to expand and contract the tree.

**Command Button** - Command buttons perform a particular command when pressed. Click on the button to perform the desired action, or use the Tab key to move to the button and press the Enter key.

**Tool Bar Button** - The Tool Bar button is a short cut to a specific program.

Click the button to perform the desired action. If you move the mouse cursor over the button, a hint is displayed in the Status Bar that shows you the button’s function.

**OK, Cancel, Help** - The OK, Cancel, and Help keys are used on dialog boxes. A dialog box is an active window that does not allow any other window to become active until the current window dialog box is cleared. **OK** clears the dialog box by recording the data entered in the window. **Cancel** clears the dialog box by deleting any entry made in the window. **Help** displays the on-line help screen to give you additional information about the requirements for the dialog box.

In fields where typing is allowed, you can begin to type your selection, and if the term you are typing is in TMT Fleet Maintenance/SQL, the program can **auto-complete** the field. Each character entered in the field is used to locate and select the nearest match in the list. To use this function, go to **SysMgr User Options User Interface** and make sure the **Enable AutoComplete** check box is checked.
Data Navigator

The Data Navigator is used to navigate through master records. This provides a convenient way to scroll through master records, insert new records, post changes to a record, cancel changes to a record, delete records, and bookmark a record.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
<th>Keyboard Equivalent</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Navigates to the first record in the database.</td>
<td>CTRL + F7</td>
</tr>
<tr>
<td></td>
<td>Navigates to the previous record in the database from the currently-selected record.</td>
<td>F7</td>
</tr>
<tr>
<td></td>
<td>Navigates to the next record in the database from the currently-selected database.</td>
<td>F8</td>
</tr>
<tr>
<td>Button</td>
<td>Function</td>
<td>Keyboard Equivalent</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------------------------------------------------------------</td>
<td>---------------------</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Navigates to the last record in the database.</td>
<td>CTRL + F8</td>
</tr>
<tr>
<td><img src="image.png" alt="Button" /></td>
<td>Bookmarks the currently-selected record. This enables you to use the bookmark GO TO function to return to a specific record in the database. Bookmarks are saved until a new bookmark is assigned. Only one record can be bookmarked at a time. Returns to the record in the database that was bookmarked. A record must be bookmarked before this function can be used.</td>
<td></td>
</tr>
</tbody>
</table>

## Adding Images

Many TMT Fleet Maintenance/SQL forms enable you to add images. Images are added on master records by clicking on the Images button on the User Fields tab. Records with this capability include Employees, Drivers, Shops, Company, Vendors, Customers, Shop Inventory, units, Repair Orders, Purchase Orders, Part Transfers, Invoices, Trip Tickets, and Diagnostic Definitions.

Image types can include JPEG files, bitmap files, text files, rich text files, and PDF files.

A description can be added when the image file is added to the master record. Descriptions cannot be changed after the master record has been saved and exited.

The size of the file is limited by the Borland database engine (BDE). The default size is 32Kb.

To have TMT Fleet Maintenance/SQL determine if the size of the file being uploaded is too large, open the TRANSMAN.INI file and add the BLOB SIZE=#### parameter to the [Database] section (where #### is the file size). For example, you could set it to BLOB SIZE=1024. This would allow importing of all files 1 megabyte or less. If the file size is greater than the setting in the TRANSMAN.INI file, the message *Image is too large for your current “BLOB SIZE” is displayed.*

The setting in the TRANSMAN.INI file overrides the default BDE setting.

*NOTE:* *When printing a work card, the image prints on the last page.*

## File Type Specific Features

### JPEG

**Stretch Image** - Stretches the image to fill the screen space. If not checked, the picture will be displayed in its normal size.

**Percentage** - Displays the image at 100%, 50%, 25%, and 20%.

**Color Depth** - Displays the image at 24-bit color or 8-bit color.
Color/Grey - Displays the image in color (RGB) or greyscale.

Quality/Speed - Displays the image based on quality (slower to load, highest quality of image) or speed (faster to load, less quality in image).

BMP

Stretch Image - Stretches the image to fill the screen space. If not checked, the picture will be displayed in its normal size.

PDF

Adds the option to view a PDF document without Adobe’s Acrobat Reader software. This functionality is provided by the PDF Viewer and no longer requires the installation of the (free) Adobe Acrobat Reader software.

RTF and TXT

No special options are available.

The Main System Menu

The Main System Menu is displayed when the TMT Fleet Maintenance/SQL program is loaded. From this form, you can select the menu items to start the associated program.

NOTE: The example shows the optional background image.

You can change the color of the background, or add wallpaper (a background graphic, as shown in the example). See “TMT Fleet Maintenance Wallpaper Backgrounds” on page 27.
The TMT Fleet Maintenance Toolbar

The TMT Fleet Maintenance system has a Toolbar at the top of the Main System menu under the menu selection bar.

Notice that when you place the cursor over each button, information about its function is displayed in the status bar.

You can place the Toolbar on the left, right, or bottom of the Main System menu screen by using the Edit Configure Toolbar Alignment option. Use the Edit Configure Toolbar Panels option to select which groups of icons will be available on the toolbar.

Toolbar Shortcut Icons

TMT Fleet Maintenance/SQL provides a group of shortcut icons located on the toolbar, just under the menu bar. These icons enable quick access to commands on the menu bar.

For information on changing which icons are displayed, see “Displaying Toolbar Panels” on page 25.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Panel</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Print Icon]</td>
<td>General</td>
<td>Click the Print shortcut to print the current form or grid that has focus.</td>
</tr>
<tr>
<td>![E-mail Icon]</td>
<td>General</td>
<td>Click the e-mail shortcut to run the e-mail interface program established in SysMgr Options User Interface.</td>
</tr>
<tr>
<td>![Help Icon]</td>
<td>General</td>
<td>Click the Help shortcut to display the online help contents.</td>
</tr>
<tr>
<td>![Shop Inventory Icon]</td>
<td>Masters</td>
<td>The Shop Inventory definition tab shortcut is used to set up the most basic information about a part. If the part exists in the parts catalog when being created, all the fields except for Taxable and Bar Code Label will automatically be filled in with the parts catalog data.</td>
</tr>
<tr>
<td>![Parts Catalog Icon]</td>
<td>Masters</td>
<td>The Parts Catalog definition tab shortcut is used to set up the most basic information about a part. When a part is created in Shop Inventory with a part id that exists in the catalog, all this information will automatically be filled in on the Shop Inventory master for the part.</td>
</tr>
<tr>
<td>Icon</td>
<td>Panel</td>
<td>Shortcut</td>
</tr>
<tr>
<td>------</td>
<td>-------</td>
<td>----------</td>
</tr>
<tr>
<td><img src="image1.png" alt="Icon Panel Shortcut" /></td>
<td>Masters</td>
<td>The <strong>Vendor Part Information</strong> form is used to enter vendor parts into the TMT Fleet Maintenance system. When a vendor part is entered on a purchase order, this form will appear and is required to enter vendor parts. This form tracks the basic information about the part as well as warranty information. The warranty information allows vendor parts charged on repair orders from purchase orders to be tracked for warranty.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Icon Panel Shortcut" /></td>
<td>Masters</td>
<td>The <strong>Units</strong> definition tab shortcut is used to set up all the pertinent information about units to be tracked.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Icon Panel Shortcut" /></td>
<td>Masters</td>
<td>The <strong>Shop Master</strong> definition tab shortcut is used to define basic information about a Shop.</td>
</tr>
<tr>
<td><img src="image4.png" alt="Icon Panel Shortcut" /></td>
<td>Masters</td>
<td>The Employee Master shortcut is used to set up information about an employee. Also used to store Driver information.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Icon Panel Shortcut" /></td>
<td>Masters</td>
<td>The Customers shortcut is used to display information about a customer. The only required field is Customer ID.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Icon Panel Shortcut" /></td>
<td>Masters</td>
<td>The Vendors shortcut is used to display basic information about a vendor. The required fields are Currency and Vendor Type.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Icon Panel Shortcut" /></td>
<td>Orders</td>
<td>Click on this shortcut to open a new repair order.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Icon Panel Shortcut" /></td>
<td>Orders</td>
<td>Click on this shortcut to search a list of repair orders.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Icon Panel Shortcut" /></td>
<td>Orders</td>
<td>The <strong>New Warranty Claim</strong> shortcut displays the Potential Warranty form that is used to enter information about a new warranty claim. A claim can be created from a section by selecting the section and right-clicking and selecting Generate Claim or by selecting the section and clicking the Generate Claim button.</td>
</tr>
</tbody>
</table>
The **Search Warranty Claim** shortcut is used to view claim lists, open an existing claim to view the detail, and create new warranty claims. Entering additional data can narrow the listing contents. Additional information that can be entered includes: Claim Number, Vendor ID, Shop ID, Unit ID, Status, Claim Type, and Date Opened range. Any combination of these fields may be used.

Click on this shortcut to **open a new purchase order** header.

Click on this shortcut to **search a list of purchase orders**.

Click on the **New Fuel Ticket** shortcut to open the fuel ticket batch management screen.

Click on this shortcut to **search a list of fuel tickets**.

Click on the **Shop Reports** shortcut to display the dialog box that enables you to create Shop Reports.

Click on the **Unit Reports** shortcut to display the dialog box that enables you to create Unit Reports.

Click on the **Unit Repair Inquiry** shortcut to display a list of unit inquiries.

---

**Displaying Toolbar Panels**

Groups of useful toolbar icons (called *panels*) are provided in TMT Fleet Maintenance/SQL. You can display or not display a panel.

To toggle panel display on or off, go to *Edit Configure Toolbar Panels* and select the panel you want to work with.
General Toolbar Panel

If *General* is selected, the General toolbar panel is displayed.

Masters Toolbar Panel

If *Masters* is selected, the Masters toolbar panel is displayed.

Orders Toolbar Panel

If *Orders* is selected, the Orders toolbar panel is displayed.

Reporting Toolbar Panel

If *Reporting* is selected, the Reporting toolbar panel is displayed.

Adding Items to TMT Fleet Maintenance Menus

You can add to TMT Fleet Maintenance’s menus programs that you frequently use. You can also add reports other than those included with TMT Fleet Maintenance. The process is the same for Reports, Tools, and Internet setups.

To add an item, go to **User** **Tools** **Setup**.

The *Tool Properties* dialog box is displayed. This box contains a list of user tools that you added to TMT Fleet Maintenance/SQL.
To add a new program or report, click on Add. The Tool Properties screen is displayed.

In the Title field, type a name for the program or report; this name is displayed on TMT Fleet Maintenance's menu. In the Filename field, use the folder icon next to the field to navigate to the location of the program or report and select it. The path must be included in the file name specification. In the Working Directory field, you can specify a working directory; you can specify additional parameters, if necessary, in the Parameters field.

If the Enabled check box is checked, this type of tool is available in TMT Fleet Maintenance/ SQL. If the check box is not checked, you cannot use this type of tool.

After you enter the necessary specifications, click OK to add the program or report.

You can add the following types of reports:

- Program files (.EXE)
- Help files (.HLP)
- Text files (.TXT)

TMT Fleet Maintenance Wallpaper Backgrounds

You can use a bitmap (.BMP) file as TMT Fleet Maintenance’s desktop wallpaper. The wallpaper can be tiled or centered on the screen. This is specified in the TRANSMAN.INI file.
To edit this file, go to Start Run and type Transman.INI in the Open field, then press Enter.

To make it appear on the TMT Fleet Maintenance Desktop, add the following line to the [General] section of the TRANSMAN.INI file:

```
background=Drive: \Path \filename.bmp
```

(Where *filename* is the filename of the background graphic file. It must be a .BMP file format.

For example:

```
background=C:\Program Files\TMTSoftware\Transman\tmtlogo.bmp
```

To specify whether the background image is centered or tiled, add the following line to the TRANSMAN.INI file:

```
backgroundType=(center or tile)
```

If no background type is entered, the default is tile.

The background must be a file type of .BMP (bitmap). No other file type will work.

You can also change the color of the main TMT Fleet Maintenance background. Available color choices are black, white, and grey. To specify the background color, add the following line to the [General] section of the TRANSMAN.INI file:

```
backgroundcolor=(black, white, or grey)
```

If no background color is entered, the default is grey.

The example shows the Transman graphic on the main menu screen.
Chapter 3: Building the Foundation

This chapter reviews the preparation of the TMT Fleet Maintenance/SQL system. Before you can enter the actual Master files for your Shops, Employees, Units and Inventory, you must provide the system with information that defines the ways in which the output data can be reported.

You should complete the setup procedure in the order that is presented. Many of these steps are required before further actions can be performed and are indicated in the entry screen. Other steps are optional. This chapter describes the necessary setup and the sequential order that must be followed to use the system.

Overview

Here is a brief overview of the steps required to set up TMT Fleet Maintenance/SQL.

The process you use to enter information into TMT Fleet Maintenance can determine the ease or difficulty of maintaining or adding new information. Some fields and screens require information from other screens. Consequently, some of the data should be done sequentially. After initial setup it is possible to do most of these tasks "on the fly," creating or modifying the information as needed. Help is available by pressing F1 on each screen. Field definitions and examples are presented in the help topics.

1. Gather data about your business. Use the Data Collection Forms to gather the data that will be entered into TMT Fleet Maintenance/SQL. These forms are contained in “Data Collection Forms” on page 367.

2. (OPTIONAL) Set up the User Defined Fields. These fields are found in several entry screens throughout TMT Fleet Maintenance. Add or modify any additional fields in this area, or choose to modify the User Fields in the Tab areas of specific forms. There are no prerequisites for User Defined Fields.

3. Set up Options. In SysMgr Options, set up default parameters that affect program-wide options. If you are unsure about option selections, contact TMT Software Customer Support for assistance. There are no prerequisites for Options.

4. Set up Required Codekeys. Codekeys provide a database of codes (ATA, TMT, and user-defined) to assist your data entry. Most of the codes that you will need are in the default database; you can add additional codes as required.
Codekey Categories

REQUIRED CODEKEYS

PM codes (000 Maintenance codes)
Departments
Divisions
Cost Centers
Unit Activities
Unit Models
Regions

ADDITIONAL CODEKEYS

Unit Types
Unit Status Codes
Employee Classifications
Employee Status Codes
Shop Types
Vendor Types

If you forget to add all the codes that you need, codekeys can be created at any time by typing in the new code and then adding a description for that code. There are no prerequisites for Codekeys.

5 Set up Units of Measure. Review the list of units of measure codes in SysMgr System Setup Units of Measure to see if the units of measure that are commonly used at your shops are included. This section provides data to Meter Setup, Inventory, and other screens. If you use US standard units of measure, no changes are required; the default database should be adequate for these codes. There are no prerequisites for Units of Measure.

6 Set up the Company Master. Create a company name (and an accounting table, if you plan to use the Period Close Process) for your company. The company name prints in the heading of Reports. Prerequisites: State Codes (STATES) from SysMgr System Setup Codekeys; Currency (CURRENCY) from SysMgr System Setup Units of Measure. The default database might be adequate for some of these codes.

7 (OPTIONAL) Set up the Tools Catalog. In SysMgr System Setup Tools Catalog, create a database of tools that can be assigned to employees or to shops. You can also add these tools as needed. Prerequisites: Tool Category (TOOLTYPES) from SysMgr System Setup Codekeys.

8 Set up Fleet Definitions. In SysMgr System Setup Auto Fleet Definitions, select the items that will be used to create fleet information.

9 Set up Codes for Repair Orders. In SysMgr Repair Order Setup, create or modify codes that are used in Repair Orders as well as other sections in TMT Fleet Maintenance. The default database might be adequate for some of these codes.

• Complaint Codes. Create a database of the cause of problems that might initiate a repair order and associate these codes with specific components.
Prerequisites: Component Code (0031, 0032) from SysMgr  System Setup Codekeys.

- **Cause Codes.** Create a database of the correction that initiated the repair order and associate these codes with specific components.
Prerequisites: Component Code (0031, 0032) from SysMgr  System Setup Codekeys.

- **Correction Codes.** Create a database of what was done to correct the cause in the repair order and associate these codes with specific components.
Prerequisites: Component Code (0031, 0032) from SysMgr  System Setup Codekeys.

- **Position Codes.** Create Diagnostic Definitions (0033) to assist in troubleshooting a Unit Type or a Fleet. Diagnostic definitions print out on the repair order work card when a repair order is done that meets the diagnostics assignment.
Prerequisites: Unit ID from Masters  Units; Fleet Description from SysMgr  System Setup Auto Fleet Definitions; Unit Type (UNITTYPE), Component Code (0033) from SysMgr  System Setup Codekeys; Correction Codes from SysMgr  Repair Order Setup Correction Codes.

- **Pick List Definitions.** Create a “shopping list” of parts. Pick Lists print on the repair order work card when a repair is done that meets the pick list assignment.
Prerequisites: Shop ID from Masters  Shops; Part ID from Masters  Parts Catalog; Unit ID from Masters  Units; Fleet Description from SysMgr  System Setup Auto Fleet Definitions; Unit Type (UNITTYPE), Component Code (0031, 0032, 0033) from SysMgr  System Setup Codekeys; Correction Codes from SysMgr  Repair Order Setup Correction Codes.

- **Diagnostics.** Create a list of diagnostic codes for routine maintenance tasks.
Prerequisites: Unit ID from Masters  Units; Fleet Description from SysMgr  System Setup Auto Fleet Definitions; Unit Type (UNITTYPE), Component Code (0031, 0032, 0033) from SysMgr  System Setup Codekeys; Correction Codes from SysMgr  Repair Order Setup Correction Codes.

- **Inspection Tickets.** Type the inspection that was performed and used to create repair orders from the Inspection Form.
Prerequisites: Unit Type (UNITTYPE), Component Code (0031, 0032, 0033) from SysMgr  System Setup Codekeys.

10  **Set up Unit Meters, Fluids, and PMs.** In SysMgr  Meters  Fluids  PMs Setup, enter information about the types of meters, fluids, and preventive maintenance (PM) procedures you expect to use. This section supplies data for Fuel Tickets, Repair Orders, Units, and so forth. The default database might be adequate for some of these codes.

- **Meter Setup.** Set up a variety of meter parameters and assign Meter Groups to Unit Types.
Prerequisites: UOM from SysMgr  System Setup Units of Measure; Meter Type (METERTYPE), Component Code (0031, 0032, 0033) from SysMgr  System Setup Codekeys; Position Codes from SysMgr  Repair Order Setup Position Codes.
• **Fluid Setup.** Create a database of fluids and assign Fluid Groups to Unit Types for tracking consumption.

  **Prerequisites:** Unit Type (UNITTYPE), Fluid Type (FLUIDTYPES), and Additive Type (ADDITIVETYPE), Component Code (0031, 00332, 0033) from **SysMgr System Setup Codekeys**; UOM from **SysMgr System Setup Units of Measure.**

• **PMs Setup.** Create Preventive Maintenance (PM) programs for individual Units or a Unit Group and assign PM Groups to Unit Types.

  **Prerequisites:** Unit Type (UNITTYPE), Component Code (0031, 0032, 0033) from **SysMgr System Setup Codekeys.**

11 **Set up Component Specifications for Units.** In **SysMgr Component Specifications,** add additional information about any Components in your database. There are no prerequisites for Component Specifications.

12 **Set up Accounting Features.** In **SysMgr Accounting Setup,** set up your Chart of Accounts to assign charges and income to specific accounts.

13 **Set up Fees and Tax Rates.** In **SysMgr Tax Rates and Fees,** create a database of Fees and Tax Rates that can be assigned to Shops, Vendors, and Parts/Services. Before you can complete the Vendor Tax Assignment section of this form, you must first create a Vendor ID.

  **Prerequisites:** Charge Category (CHGCATEG) from **SysMgr System Setup Codekeys**; Shop ID from **Masters Shops**; Vendor ID from **Masters Vendors.** The default database might be adequate for some of these codes.

14 **Set up Pay Grades.** In **SysMgr Pay Grades,** create Pay Grades that can be assigned to employees. There are no prerequisites for pay grades.

15 **Set up Work Shifts.** In **SysMgr Work Shifts,** create Work Shifts that can be assigned to Employees and to Units. There are no prerequisites for work shifts.

16 **Set up Shops.** In **Masters Shops**, create individual shops within a company. Assign tools to a shop and generate expense reports for each shop.

  **Prerequisites:** State Codes (STATES), Shop Type (SHOPTYPE), Division (DIVISION), Cost Center (COSTCENTER), Department (DEPARTMENT), Region (REGION), and Tool Category (TOOLTYPES) from **SysMgr System Setup Codekeys**; Currency (CURRENCY) from **SysMgr System Setup Units of Measure.** The default database might be adequate for some of these codes.

17 **Set up Employees.** In **Masters Employees**, create a database of information about your employees. Assign Pay Grades, Work Shifts, and Tools to employees.

  **Prerequisites:** Shop ID from **Masters Shops**; Pay Grade from **SysMgr Pay Grades**; Work Shift from **SysMgr Work Shifts**; Tool Category (TOOLTYPES), State codes (STATES), Status (EMPSTATUS), Classification (EMPCLASS), and Skills (EMPSKILL) from **SysMgr System Setup Codekeys.** The default database might be adequate for some of these codes.

18 **Set up Units.** In **Masters Units**, create a database of units for your organization. Assign Units to a specific Shop or Work Shift. Assign Meter Groups, Fluid Groups, and PM Groups to Unit Types before creating Units. (See **Set up Unit Meters, Fluids, and PMs.**)

  **Prerequisites:** Shop ID from **Masters Shops**; Currency (CURRENCY), UOM from **SysMgr System Setup Units of Measure**; Shift ID from **SysMgr Work Shifts**; Meter Position from **SysMgr Repair Order Setup Position Codes**; Part ID from **Masters Shop Inventory**; Unit Type (UNITTYPE), Make (0034), Model (UNITMODEL), Activity (ACTIVITY), Status (UNITSTATUS), Division (DIVISION), Department (DEPARTMENT), Cost Center (COSTCENTER), Meter Type (METERTYPE), and Fluid Type (FLUIDTYPES) from **SysMgr System Setup Codekeys.** The default database might be adequate for some of these codes.

19 **Set up Vendors.** In **Masters Vendors**, create a database of Vendor information that can be assigned to Parts/Services and Accounts.

  **Prerequisites:** Shop ID from **Masters Shops**; Tax Code from **SysMgr Fees and**
Preparing for Master Record Data Entry

Before you can begin working with TMT Fleet Maintenance/SQL, you must gather the data that will be entered into the system.

Use the Data Collection forms to gather the data required for the Master records before you begin data entry. This makes the task of creating the Master records easier to accomplish quickly. Collecting the necessary information is the more challenging task, and this should be accomplished before data entry begins.

**NOTE:** Shop Options and System Manager Global Options are interdependent in many of the options’ settings. After a shop level option is set, it takes precedence over the same System Manager options setting.

TMT Software provides data collection forms that you can use to gather this information before entering it into TMT Fleet Maintenance/SQL. See “Data Collection Forms” on page 367.

The data you need to gather before you start working with TMT Fleet Maintenance varies, depending on how your company is set up and on the function in TMT Fleet Maintenance/SQL that you want to use.

Whenever you create a new master record, the Definition or Personal Information tab data must be completed and posted before proceeding to the other tabs of that master record. If you start a new master record on a tab other than the Definition or Personal Information tabs, the screen automatically switches to the Definition or Personal Information tab when you answer Yes to the Create New Master Record? prompt.

Depending on how you use TMT Fleet Maintenance, you might need to maintain information about:

- Customers
- Vendors
- Employees, including pay grades and shifts
- Shops
• Units (vehicles)
• Inventory (parts)
• Tools used in your shops

For more information about what needs to be done, contact the Sales Department at TMT Software, or contact Customer Support.

System Setup

Initial system setup includes basic procedures that are necessary for later configuration. Codekey setup, Units of Measure and Auto fleet definitions are required by many other areas of the program.

TMT Fleet Maintenance Options

The TMT Fleet Maintenance Options program sets up the default and other system parameters. Exercise caution when changing these values.

These options are set up in SysMgr.
Repaired Go to Sysmgr > Options > Repairs

Use burden labor rate - If checked, the Burden Labor Rate for an employee will be used rather than the employee base wage. Burden Labor Rate includes employment costs such as benefits and employment taxes, and therefore reflects the cost to the company of the employee's time. Choosing the Shop Rate method in the Shop Master record overrides the choice made here.

Print bar-coded RO number - If this selection is checked, the RO number on the RO work card prints in bar code format and text. If it is not checked, the RO number prints in text only.

Check for Open ROs when creating New RO - If this selection is checked, when you open an RO for a unit, TMT Fleet Maintenance checks for the existence of other Open ROs for that unit and advise you of their existence. You can then add sections to the existing RO if you want, or continue to create the new RO. If it is not checked, this check is not performed.

Require Vendor for Vendor Lines on RO - If this selection is checked, charge lines on RO sections cannot be checked as Vendor Supplied unless a valid Vendor ID is recorded on the RO section. If it is not checked, any line can be marked as Vendor Supplied, even if there is no Vendor reference on the RO section.

Require Cause and Correction if under warranty - If this selection is checked, any RO section that is a potential warranty will require both Cause and Correction codes on the labor charge lines. If it is not checked, these codes are not required. This option should only be checked if Cause and Correction codes are provided for any system or assembly codes that you are likely to use.

Prompt for Creating of Vendor Parts Records - If this option is checked, the system displays a prompt asking whether to create a Vendor Part master record when entering vendor parts on a repair order when the parts do not exist in the Vendor Parts master for the selected shop and vendor. If the option is not checked, no prompt is displayed and no opportunity is given to create a vendor parts master record for the vendor part entered.
Create Unit Cross Reference for Catalog Parts - If checked, when a part that resides in the parts catalog is charged to a repair order, the Fleet Definition will be used to automatically create the Unit Cross Reference. The following fields will be populated based on what is checked in SysMgr > System Setup > Auto Fleet Definitions: Year, Make, Model, Capacity, Unit Type, Engine, and Wheel Base. Note: The From Year and To Year will both be populated with the same year from the unit master.

Enable Warranty Processing - If this selection is checked, the Repair Order process detects potential warranty claims and provides the Repair Order data to the Warranty Claim processing function of TMT Fleet Maintenance. If it is not checked, this function is disabled.

Labor Entry via Start/End Times - If this selection is checked, labor charges are entered by the beginning and ending time of the operation. If it is not checked, labor times are entered by the total number of decimal hours.

Disable Ignore for Meter Readings - If checked, the Ignore button will be disabled on the meter reading warning preventing the user from entering bogus meter reading entries.

Require Meter on Opening of RO - If this option is checked, a meter reading must be entered when opening a new repair order. If it is not checked, a meter reading is optional. This option enables warranty determination by the meter reading when the repair order is opened.

Do not allow meters that exceed the Daily Max - If checked:
- When entering a meter reading and that meter reading exceeds the daily max the Accept button will be disabled on the unit meter exceeds daily max message.
- If an import has Ignore Invalid Meter Readings checked, meters that exceed the daily max will be marked ignored.

PO required for vendor lines on ROs - If checked, Vendor Lines cannot be added to a STANDARD repair order unless they are received directly to the repair order from a purchase order. The Vendor Supplied checkbox will be unchecked and disabled on the repair order line items and the vendor ID field will be disabled on the repair order section. If checked and a Vendor RO is created, the Vendor Supplied checkbox will be checked and disabled on Services, Comments, Tax, and Fee lines and checked and enabled on Parts and Labor. The Vendor field will be disabled on the section. Note: If this option is checked and a Vendor ID is entered on the header of a repair order, the repair order will be automatically changed to a VENDOR RO.

Allow for adding items to Requisition List - If this option is checked, when a part and quantity is entered on a repair order and there is not sufficient inventory on hand, the system will display a prompt that allows the difference between the amount entered and the amount on hand to be added to a manual part requisition for that repair order. If this option is not checked, a normal error message is displayed that there is not sufficient inventory on hand, and the quantity will have to be changed to the amount on hand or the part entry will have to be cancelled if there are no parts on hand.

Allow non-vendor service lines on Orders - If unchecked, service lines cannot be created on indirect charges and service lines will not be allowed on repair orders depending on the option PO Required for Vendor Lines on ROs:
- PO Required for Vendor Lines on ROs Unchecked - Service lines are not allowed on non-vendor sections.
- PO Required for Vendor Lines on ROs Checked - Service lines are not allowed on non-vendor and vendor sections.

Check for Open VROs when creating new RO - This option will allow you to see all the Vendor Repair Orders on a unit on the Open Repair Orders List form. Standard ROs will still look at the ShopID to
determine if they are visible, but the Vendor Repairs will not. All VROs for the Unit selected will be displayed. This will override the GLOBAL option set in SysMgr > Options > Repairs

**Custom Repair Order** - If checked, a crystal report file name and path can be entered. When printing a repair order work card, the OrderID will be passed to the report. The path to the Crystal Report including the Crystal Report name can be up to 254 characters.

**Repair - Default Repair Class** - Enables you to select a default repair class.

**Repair - Default Repair Site** - Enables you to select a default repair site.

**Vendor RO - Default Repair Class** - Enables you to select a default repair class for vendor repairs.

**Vendor RO - Default Repair Site** - Enables you to select a default repair site for vendor repairs.

**Note:** Selecting the default values for the last 4 fields is reasonable if most of the work done in your shop is similar in class or site, if not, providing a default value can result in users’ failure to select the appropriate code. This can lead to problems with accuracy in searching and reporting repair order data.

**Chronic Repair Interval (Days)** - When a value is entered for the number of days, the system will track a chronic repair as a repair that occurs more than once within the number of days selected for the repair shop, unit, and component code. When a new section is created on a repair order and the component code entered has been done on a previous repair order for the selected repair shop and unit, a yellow message is displayed in the section indicating how many repairs for the selected component code have occurred within the specified number of days. The message is also displayed when reviewing repair order sections in the repair order history.

**Chronic RO Check (Open, Complete, Closed)** - include Open, Complete, and Closed ROs in determining a chronic repair. This option will also use the Section Opened date to determine if it falls within the repair interval days. If the option is unchecked, Chronic Repairs are based off Closed ROs and the section completed date.

**Chronic Repair Level** - Added Controls at which level the system looks for matches on the Component code for chronic repairs. For System it looks at the first 3 characters of a component code, for Assembly the first 6 characters and for Part the first 9 characters. For example if the component code is 123-456-789 then System level looks at 123, Assembly level looks at 123 and 123-456 and Part level looks at 123, 123-456 and 123-456-789.

**Max RO Component Level** - This option determines the highest level of component code that can be entered on a repair order section. If System is selected, only a 3-digit code can be entered (for example, 013). If Assembly is selected, only a 3-digit or 6-digit code can be entered (for example, 013 or 013-001). If Part is selected, a 3-digit, 6-digit, or 9-digit code can be entered (for example, 013, 013001, or 013-001-001).

**Require RO Sign Off** - If the option Require RO Sign Off is checked, a checkbox with the Sign Off Open Prompt text will appear on the RO below the Status Time on the RO Header. If checked, the box will become disabled and cannot be unchecked. When the RO is closed, a Sign Off Required window will appear with the Sign Off Close Prompt text, a comment box, a Yes button and a No button. If the option Require RO Sign Off Comment is checked, a comment is required to click Yes and the comments can be up to 254 characters. If Yes is clicked the RO will close normally. If No is clicked, the RO will not be closed. As an example the Sign Off Open prompt could be Does repair require a wheel to be taken off? And the Sign Off Close Prompt could be Has re-torque been completed?
Select PMs Due to Create Sections - If this selection is checked and the RO Entry options is set to Y for Auto Create Sections, any PMs due for a unit when a repair order is created are displayed in a dialog box. You can then select the PMs to be done on that repair order. If it is not checked, the PM sections are automatically created on the Online Repair Order. (For more information about this option, see page 182.)

Section Component Code for PM Parts - If checked, the section component code is used for parts charged on the repair order instead of the part component code. This option works when the reason for repair code has been marked Update PM in codekeys. This option overrides the Component match function from the part record in Shop Inventory.

Dependent PM Detection % - selects the percent of the lowest level for the meter due that triggers the PM showing due on the PM schedule.

Independent PM Detection % - selects the percent of the scheduled interval that triggers the PM showing due on the PM schedule.

Validate Comp Code against PMs for that Unit - When this selection is checked, PM operations not defined for a unit cannot be posted on the RO. When it is not checked, this verification is not performed.

Default complaint code - Select the complaint code that will automatically be used when a PM repair order section is created. The default complaint code is PM.

Default reason for repair code - Select the Reason for Repair code that will automatically be used when a PM repair order section is created. The default reason for repair code is PM.

NOTE: Selecting default values for these fields is reasonable if most of the work done in your shop is similar in class or site, but if not, providing a default value can result in users’ failure to select the appropriate code. This can lead to problems with accuracy in searching and reporting repair order data.
Repairs - Jobcodes

Go to **SysMgr Options Repairs Jobcodes.**

**Employee and Jobcode Assignments** - If checked, enables job codes and displays the job codes section of the repair order section when the Sections tab of a repair order is clicked. Job codes are created based on the fleet ID if **Auto Create Job Codes Based on Fleet ID** is checked. Job codes default using the system component code and complaint code if **Auto default Job Code (Component Complaint)** is checked.

**Auto default Job Code (Component Complaint)** - If checked, the job code will default using the repair order section's component code and complaint code.

**Auto Create Job Codes Based on Fleet ID** - If checked, a job code will be automatically created based on repair shop and fleet for a component complaint code combination if a job codes does not already exist in the job code database for that component and complaint.

**Allow Employee Assignment without a Job Code** - If this option is checked, a mechanic can create a section without entering a job code. If this option is not checked, a job code must be entered on each section.
Repairs - Overtime

Go to SysMgr > Options > Repairs > Overtime.

Allow Paygrade selection - If checked, when a mechanic charges labor to a repair order, he can select the paygrade to be applied: Standard, Overtime, Weekend, or Holiday.

Auto selection of weekend paygrade - If checked, the weekend paygrade is automatically applied if the work is performed on a weekend.

Purchasing

Go to SysMgr > Options > Purchasing.

Print bar-coded receiving labels - If this selection is checked, bar coded labels for parts are printed when the part is received into inventory. If it is not checked, bar coded labels for parts are not printed when the part is received into inventory. If the part is associated with a repair order, the label does not print for those parts that are directly received to the repair order.
Expense supplies to indirect charges - If this selection is checked, a Part Type of Supplies goes through Inventory and is charged as an Indirect Part Charge when received. If it is not checked, a Part Type of Supplies remains in Inventory when received.

Use last cost for new vendor purchases - If this selection is checked, when you purchase a part from a vendor that you have not purchased that part from before, the PO system defaults to the last price you paid for the part. If it is not checked, the PO system defaults to $0.00 for the cost of the item. In either case, you can adjust the cost to what you expect to pay for the part from this vendor.

On-hand based re-order formula - If it is not checked, the requisition system uses the following formula:

If Quantity on Hand + Quantity on Order is less than or equal to the Trigger Point, then Re-Order Quantity is equal to the Target Point minus the Safety Point.

If this selection is checked, the requisition system uses the following formula:

If Quantity on Hand + Quantity on Order is less than or equal to the Trigger Point, and Safety Point = 0, then Re-Order Quantity is equal to the Target Point minus the sum of Quantity on Hand and Quantity on Order.

If Safety Point is greater than 0, then the standard formula above is applied.

Allow create vendor on the fly - If this selection is checked, entry of a non-existing Vendor ID on a Purchase Order displays a message that the vendor does not exist, and asks if you want to create it. If you select Yes, you can enter the required vendor information and save the new vendor record so that vendor can be used. If this selection is not checked, you must add new vendors in Masters, Vendor Masters before they can be used on a Purchase Order.

Require invoice amount to match PO receipt total - If this option is checked, the amount entered for invoices on a purchase order must equal the amount of the purchase order receipt. If they are not equal, the parts cannot be received for that receipt.

Use shop tax (instead of vendor tax) - If this option is checked, the tax amounts for purchase orders is based on the tax rates set up on the Shop Master for the shop for which the purchase order is being created. If it is not checked, the tax amounts is based on the tax rates set up on the Vendor Master for the vendor that will be used for the purchase order.

Use external PO system - If this option is checked, it disables the recalculation of the quantity on order for parts so that information can be imported from an external PO system.

Don’t Allow Vendor Parts on POs - If this option is checked, vendor parts cannot be entered from the Purchase Order system.

Do Not allow Duplicate Invoice Number by Vendor - If this option is checked, the same invoice number cannot be used twice for a vendor.

Prompt for PO Close at time of PO Receipt - If this option is checked, the purchase order system works based on the purchase order option Do not automatically close on Receive; if Do not automatically close on Receive is checked, the purchase order is changed to a received status and the system prompts the user to close the receipt at that time. If Do not automatically close on Receive is not
checked, the purchase order receipt is changed to a closed status when parts are received and the purchase order is changed to a closed status when all parts have been received.

If this option is not checked, the purchase order system always changes receipts to a received status and no option is presented to close the receipt when all parts are received. The purchase order option Do not automatically close on Receive will be checked and disabled. This option forces ALL purchase orders regardless of purchase order type to go through the three-step process of Open → Received → Closed. This allows user roles to be created so that one user role can only open purchase orders, one user role can only receive purchase orders, and another user role can only close purchase orders.

This option can be set globally from SysMgr → Options or at the user level. To set the option at the user level, run TMT Security Administrator. On the Users tab right-click on the user and select Set User Options. Uncheck Prompt for PO Close at PO Receipt Time and click OK. Only a TMT security administrator can set this option for a user.

**Use Bid Price for Vendor Price on PO** - If this option is checked, the bid price for the vendor is used as the price when a part is created on a purchase order for a vendor with a bid price.

**Can Not Override Bid Price** - If this option is checked and the Use Bid Price Instead of Vendor Price option is checked, the price field is disabled if the part has a bid price for the selected vendor and the user cannot change the price. The price can only be changed when the purchase order is received.

**Require Payment Method** - Requires a payment method to be entered when creating a purchase order or a vendor repair order. This option is used to determine whether a payment method on an invoice payment is required for repair invoices and direct sale invoices.

**Service Lines on POs require an Order** - If this option is checked, an order number and section are required before the service line can be created on the purchase order.

**Custom Purchase Order - Print Custom Purchase Order Report** - If this option is checked, the file name and path information for a Crystal Report can be entered. When printing a purchase order or purchase order receipt, the Order ID is passed to the report. If a single receipt is printed, the section ID is also passed; otherwise, a 0 is passed to indicate all receipts.
Inventory

Go to Sysmgr > Options > Inventory.

**Accounting Method** - Select from the following methods:

- **AVGCOST** - Average cost is the method where the average cost for the part is used when parts are charged out of inventory.

- **FIFO** - First In, First Out - the method where the earliest cost on record for a part is relieved from inventory first when parts are charged out of inventory.

- **LIFO** - Last in, First Out - the method where the last cost on record for a part is relieved from inventory first when parts are charged out of inventory.

**Include sales tax in inventory cost** - If this option is checked, the sales tax is calculated on purchase orders. The tax is included in the inventory costs and is charged on orders. This setting also applies tax to vendor parts on repair orders.

**Include sales tax in orders only** - If this option is checked, the sales tax is included on the order but is not reflected in the cost of inventory. This setting also applies tax to vendor parts on repair orders.

**Exclude sales tax in orders/inventory** - If this option is checked, sales tax is calculated on purchase orders, but is not carried in inventory or charged on orders when parts are charged out.
Default Inventory Account - If an account type is entered, anytime a part is created in parts catalog, shop inventory, or from a purchase order, this account type will be defaulted unless a different account type has been set at the shop level.

Notes: If a value is entered at the global level, the shop level will be equal to this value. The shop level value can be changed to a different account, however the shop level value cannot be null. A value entered here will overwrite the account type set on the parts catalog when a part in the parts catalog is created in a shop unless the shop level account has been changed to something different than the global. What value is shown in the drop down is controlled by the SysMgr > Options > Accounting > Account Type setting. The options are By Account Type, By Account ID, and By Account Description.

Parts Catalog Vendor Sync Options - Update Vendor - If this option is checked, the vendor for the parts catalog is updated at the shop level when a new vendor is added, an existing vendor is updated, or the part is created in the shop. If it is not checked, vendor information from the parts catalog is not used at the shop level. This option can be overwritten at the Shop Level options.

Parts Catalog Vendor Sync Options - Update Primary Vendor - If this option is checked and the Update Vendor from Parts Catalog option is active for the shop, when the primary vendor for a part is changed on the parts catalog, it will also be changed on that part in the shop inventory.

Parts Catalog Vendor Sync Options - Update Target Point - If this option is checked and the Update Vendor from Parts Catalog option is active for the shop, when the target point of a vendor for a part is changed in the parts catalog, it will also be changed on that part in the shop inventory.

Parts Catalog Vendor Sync Options - Update Price - If this option is checked and the Update Vendor from Parts Catalog option is active for the shop, when the price of a vendor for a part is changed on the parts catalog, it will also be changed on that part in the shop inventory.

Track fuel in inventory - If this selection is checked, it indicates that you maintain your company fuel inventory in TMT Fleet Maintenance/SQL. If it is not checked, it indicates that you do not maintain your company fuel inventory in TMT Fleet Maintenance.

Use last cost for consignment parts - If this selection is checked, the last cost is used as the cost for consignment parts. If it is not checked, consignment part cost is based on the accounting method selected.

Lookup VMRS codes for new parts - If this selection is checked, the VMRS database must be searched for this part. If it is not checked, the VMRS database is not required for this part. If the correct VMRS code is not assigned to your inventory records, TMT Fleet Maintenance/SQL is not able to track parts warranty effectively.

Allow Local Parts - If this selection is checked, any shop can purchase and maintain an inventory of parts that do not exist in the Part Catalog. If it is not checked, only parts that exist in the Parts Catalog can be purchased or added to the local shop Part Inventory records.

Enable Centralized Average Cost Calculation. The option can only be checked if the Accounting Method = AVGCOSt. Once the option is checked a centralized shop must be selected. This shop will act as a warehouse where parts are received via PO and distributed to other shops via Part Transfers. This shop will be the shop in which all POs are created and POs will not be allowed to be created in other shops. Other than POs, no other order types will be created in the centralized shop (no ROs, Indirects, etc.) This change will average the part cost upon receiving of inventory to the shop selected as the centralized shop and will use all parts in all shops in the calculation. This is the only time the average cost will be calculated.

For example: Shop 01 is our centralized shop. You have the following for a part when the option is turned on (This example assumes the Tax excluded option):
You now receive into Shop 01 this part with a quantity of 3 and an actual price of $20.75. This will increase the Cost total to $295.55 (233.30+62.25). The new average cost will be calculated as $24.62916 ($295.55/12) and applied to all shops containing this part. The new values will appear as follows:

<table>
<thead>
<tr>
<th>Shop</th>
<th>On Hand</th>
<th>Average Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>01</td>
<td>5</td>
<td>24.629167</td>
</tr>
<tr>
<td>02</td>
<td>2</td>
<td>24.629167</td>
</tr>
<tr>
<td>03</td>
<td>0</td>
<td>24.629167</td>
</tr>
<tr>
<td>05</td>
<td>2</td>
<td>24.629167</td>
</tr>
<tr>
<td>22</td>
<td>2</td>
<td>24.629167</td>
</tr>
<tr>
<td>31</td>
<td>1</td>
<td>24.629167</td>
</tr>
<tr>
<td>Total</td>
<td>12</td>
<td>295.55</td>
</tr>
</tbody>
</table>

**Use VMRS Descriptions as Part Description** - If this option is checked, when a new part is created and a component code is typed into the component code field on the Parts Catalog, the description for the part is automatically populated with the description for the component code. For example, if 034-001 is typed in the component field, the description becomes Headlamps. This feature applies only to the parts catalog.
**Allow Parts Transfers from Part Requisition** - If this option is checked, when a part and quantity are entered on a repair order and there is insufficient inventory on hand, a prompt is displayed allowing the difference between the amount entered and the amount on hand to be added to a manual part requisition for that repair order. If it is not checked, a normal error message is displayed that there is insufficient inventory on hand, and the quantity must be changed to the amount on hand or the part entry must be cancelled if there are no parts on hand.

If a part in the source shop’s inventory is out of balance, the error Inventory is out of balance for this part, please contact support is issued when attempting to transfer the part to the selected shop’s inventory, and that part is highlighted in red on the requisition list for the receiving shop. A part is considered out of balance when the quantity on hand does not equal the quantity in the bins or does not equal the quantity on cost records.

When this option is checked, the additional right-click option Add to Manual Requisition List is available in the Automatic Requisitions grid for shops that have the Allow Parts Transfers option enabled.

**Use TMT Part Number for Manufacture Number** - If this option is checked, when a parts catalog part is added, the number typed in the Part ID field is automatically populated to the Mfg Part No. field.

**Auto Cross Options - Substitute Parts** - Parts that can be used in place of other parts. A part entered here must exist in the Parts Catalog.

**Auto Cross Options - Superseded Parts** - numbers are added to the Superseded Parts list when a part is renumbered and the option **Renumber and add to Superseded Parts** is used. Superseded part records cannot be entered manually.

**Auto Cross Options - Cross Reference** - Part numbers that cross-reference back to the part selected. A part number added to this tab can exist in the catalog or may be a number that does not exist in the system. A manufacturer is required for cross-reference part records.

**Auto Cross Options - Component Code** - checking this box allows you to look up parts by the component code. If you do not check this box and type a component code number in the Part No. box you will get a message saying part not found do you want to create it.

**Auto Cross Options - Manufacturer Part ID** - checking this box allows you to look up parts by the manufacturer part id. If you do not check this box and type a manufacturer part id in the Part No. box you will get a message saying part not found do you want to create it.
Invoicing - SysMgr > Options > Invoicing.

**Enforce Invoice Estimate** - If this option is checked, an estimate amount is required to create a repair order for a customer. If **Enforce Customer Limits** is checked and limits are established for a customer, the invoice estimate is automatically required for that customer when creating a new repair order.

**Show Running Invoice Prices on Repair Orders** - If this option is checked and the repair order has a customer, a Price field is displayed next to the Total field at the bottom left-hand corner of the repair order with a running total based on the customer's invoice price table. The running total does not include taxes and fees.

**Auto close RO from Invoice** - If checked and an invoice is Closed that is associated with a Complete RO, the RO will also be marked Closed and the Closed date of the invoice will be used as the Closed date of the RO. If you have this option turned on and **Require Invoice Amount to Match PO Receipt Total** turned on and you try to close an invoice created from a Complete Vendor Repair Order (VRO) and the PO side of the VRO does not have an invoice. You will receive the following message: "The Purchase Order associated with the Vendor RO must have an invoice before the order can be closed." This will prevent the invoice from being closed until a PO invoice is added to the VRO and will ensure that the PO side of the VRO is properly exported to accounting.

**Billable default to "Y"** - If checked, all customers will also have the option checked (unless changed at the customer level) and every section created on a repair order for those customers will have Billable checked. Sections marked billable are the only sections that can be invoiced, so un-checking this option at the Customer Level will require that a section be marked billable manually before it can be invoiced.

**Sum Labor for Invoice by Jobcode** - If checked, labor will be summed based on the Jobcode. A Jobcode can have the following type of time Flat Rate, SRT Time, User-Entered Estimated Time, and Estimated Time setup on the Jobcode master. When summing Jobcodes on the invoice, the program will check the Jobcode master and use Flat Rate unless there is no Flat Rate time. If there is no Flat Rate time, the program will use SRT Time. If there is no SRT Time, the program will use user-entered estimated time, which was entered when the assignment was created. If the user did not enter estimated time, the program will use the estimated time setup on the Jobcode master. If there is no estimated time...
for the Jobcode, the system will use the sum of the labor hours on the section and create a line with the description for the Jobcode. If a section does not have any Jobcodes, a single line for the total labor hours on the section will be created on the invoice. Summary for this rule: Use Flat Rate, if no Flat Rate, use SRT Time, if no SRT Time, use User-entered estimated time, if no user-entered estimated time, use estimated time, if no estimated time sum all labor lines on the section.

If two or more different Jobcodes exist on a section, the invoice will contain each Jobcode and the time for each Jobcode based upon the Flat Rate, SRT Time, or estimated time rules described above. If two or more of the same Jobcodes exist for a section, the invoice will contain a single labor line for that Jobcode and the time will be based upon the Flat Rate, SRT Time, or estimated time rules described above with the time being for a single job (not a sum of the time for the multiple Jobcodes).

Note: If the same Jobcode exists on two assignments on a repair section and the user has entered estimated time on one of the assignments containing that Jobcode but not the other assignment, the program will treat this as two different Jobcodes. Both assignments would have to have the same user-entered estimated time for the system to recognize this as the same Jobcode.

Note: If Actual cost for labor is used on the Invoice Price Table for the customer, the highest labor rate for each section will be used as the cost basis for all labor time on that section.

The default setting is unchecked and disabled. This option is unchecked and disabled if either Sum Labor by Paygrade Type or Make Minimum Labor Line a Separate Line is checked. This option is controlled at the Global, Shop, and Customer level.

**Sum Labor for Invoice by Task Times** - This option will be enabled if **Sum Labor for Invoice by Jobcode** is checked. With this option checked labor lines are created based on Task Times. For this option to work as designed Tasks must be assigned to Jobcodes and time must be associated with the tasks. The selection of Estimated Time, SRT Time, or Flat Rate Time is applied the same as when summing by Jobcode. The description for the labor line will be the same as the Task Description.

**Allow Invoicing by Fixed Price** - This option will be enabled if **Sum Labor for Invoice by Task Times** is checked. With this option checked, a service line is created for each fixed price task. If parts are associated with the task and they have been marked as fixed, they will appear on the invoice with a price of zero.

**Apply Service Line Markups to Flat Prices** - This option will be enabled if **Allow Invoice by Fixed Price** is checked. With this option checked, the service line for the fixed price task will be marked up based on the markup on the Services Tab of the invoice price table for the price table used.

**Sum Labor by Paygrade Type** - If checked the labor lines will be summed together by paygrade type of Standard, Overtime, and Weekend and a line will appear for each type and the Price will be based on the paygrade type. If unchecked, all labor lines will be rolled into a single line called Shop Labor and use the Base Rate to calculate the price. The default for this field is checked. This option is controlled at the Global, Shop, and Customer level.

**Make Minimum Labor Line a Separate Line** - If checked and a minimum labor line is required to achieve the minimum labor hours, the minimum labor amount will appear as a separate line. If unchecked, the amount will be rolled into the Shop Labor line. The default for this field is checked. This option is controlled at the Global, Shop, and Customer level.

**Min. Labor Line description:** - If the **Make Minimum Labor Line a Separate Line** is checked, the description for that line can be user-defined. The default value is **Labor Adjustment**. This option is controlled at the Global, Shop, and Customer level.
**Remit payment to:** This field determines what address is printed as the “remit to” address on an invoice. Select **Company** to print the Company master’s address, or select **Shop** to print the invoicing shop’s address.

**Print Custom Invoice Report** - this box is checked the invoicing function generates an invoice that you design in Crystal Report Writer. The path to your Invoice Report and filename must be provided in the filename box, and can be located by clicking on the Explorer **Browse** button next to the field.

**Print Custom Direct Sale Invoice** - When this box is checked, the invoicing function generates a Direct Sale invoice that you design in Crystal Report Writer. The path to your Direct Sale Invoice Report and filename must be provided in the filename box, and can be located by clicking on the Explorer **Browse** button next to the field.

**Use PARADOX Tables for Custom Invoice** - If checked the system will expect that Crystal Reports were created using paradox tables. If unchecked, the system will expect the Crystal Reports will link directly to TMT Fleet Maintenance database and the TMT Crystal Viewer must be installed on the machine that will be creating the invoices.

**Print Custom Fuel Invoice Report** - this box is checked the invoicing function generates a fuel invoice that you design in Crystal Report Writer. The path to your Fuel Invoice Report and filename must be provided in the filename box, and can be located by clicking on the Explorer **Browse** button next to the field. **Note:** Custom Fuel Invoices require that the Crystal Report use the OrderID.
Go to **SysMgr > Options >Accounting**.

**Enable Inter-company Account Assignments** - This global option is required to use the McLeod Interface.

**Account Type** - This global option determines how listings are sorted and displayed, and what is displayed in the Account Type columns in reports. (Only one of these options can be selected.)

- By Account Type
- By Account ID
- By Account Description

If Account Type is selected, Description appears in the second column. If Description is selected, Account ID is displayed in the second column.

**Enable Accounting Features** - When this selection is checked, TMT Fleet Maintenance/ SQL creates accounting transactions using information set up in Accounts Chart of Accounts and Accounts Account Disbursements and allow that information to be exported using Accounts Export Transactions. These records can be exported for use by a GL, AP, or AR accounting system. This feature cannot be checked until the Base Accounting Rule has two accounts set up in **SysMgr Accounts Account Disbursements**. This feature requires extensive setup that is not covered in this book. Contact TMT Software for assistance with implementing this feature.

**NOTES**: **DO NOT** enable accounting features until the required accounting setup has been completed. Before you make any changes to the options in this section, ensure that the change is correct; after options are checked, they cannot be unchecked.

**Ignore Inactive Disbursement Rules** - If this option is checked, the system does not create Accounting Transactions for those rules that are set to Inactive. If it is not checked, inactive rules go to the base rule’s accounts.

**NOTE**: After this option is checked, it cannot be unchecked.
Prompt for GL Accounts on PO Lines - If this option is checked, the system only creates accounting transactions for purchase orders and vendor ROs and will require entering G/L account numbers at the time purchase order lines and vendor RO lines are created. This disables the Accounting Close Process as well as all other accounting rules processing. Codes marked as Inactive Codes do not display in the Account drop-down list on Customer Master, Parts Catalog, or Shop Inventory records; these codes are also not displayed on PO lines and Vendor RO lines when the Prompt for GL Accounts on PO Lines is checked.

**NOTE:** After this option is checked, it cannot be unchecked.
Go to **SysMgr > Options > Printing.**

This tab is used only for bar code label printing setup.

---

**Print Shop Name in place of Company Name on POs and Invoices** - If this option is checked, the name of the shop is used on the purchase order and invoice printouts; otherwise the company name is printed.

**Bar Code Printer** - The name of the default bar code printer. **NOTE:** This is NOT the same as the Windows default printer.

**Bar Code Printer Fonts:**

- **Bar Code** - The selected font to use for bar code printing.

- **Leading/Trailing** - If checked, an asterisk is forced to print at the beginning and end of a barcode. This setting should only be used if the printer driver for the bar code printer that you are using does not do this automatically.

- **Small Text** - The default font to use for printing small text. The default is 8 points.

- **Medium Text** - The default font to use for printing medium text. The default is 12 points.

- **Large Text** - The default font to use for printing large text. The default is 20 points.

- **Extended ASCII support for barcode printing** - If checked, this feature adds a Tab character to the end of bar codes printed on reports and labels. This enables you to scan in an order number and have the focus automatically move to the next field.
Go to **SysMgr → Options → User Interface.**

### Maximized Windows
- If this selection is checked, when a sizeable window is opened it will be maximized. This is useful for displays using 800 x 600 resolutions so fields are not hidden from view when opened. This is a global selection, which means that all forms on all workstations will open maximized. If this is not checked, all forms open in the window mode, which can cause some fields to be hidden from view on low-resolution workstations.

### Confirm dialog Cancel
- If this selection is checked, when you cancel a dialog box, a confirmation window pops up to let you know that you will lose changes. If it is not checked, the dialog box closes without warning you that you will lose changes.

### Treat Enter key as Tab
- If this selection is checked, the Enter key responds like the Tab key to move to the next field. If this is not checked, when you press the Enter key, the dialog box closes instead of moving to the next field.

### Sound With Error Messages
- If this selection is checked, pop-up error messages are accompanied by a tone or beep from the computer system speaker. If it is not checked, pop-up error messages are silent.

### Auto Cross VIN to Unit ID
- If this option is checked, a serial number can be entered in the Unit ID field and the system will automatically cross-reference the Unit ID.

### Max number of rows returned
- This number indicates the maximum number of matches shown for a search. A higher number results in longer search times, but can be useful if you have a large number of records to be viewed. A smaller number results in a faster search, but might omit the data you need.

### E-mail Interface Type
- Links your current e-mail system to TMT Fleet Maintenance/SQL so you can send and receive e-mail without leaving the application. You can use either MAPI or SMTP protocols.

### MAPI - E-mail Client
- Enter the path information for the program used for e-mail.
MAPI - E-mail user name - Enter the default user profile you want to use for e-mail settings.

SMTP - Provide the information about the SMTP server used to send and receive e-mail.

**Miscellaneous**

Go to **SysMgr**  **Options**  **Misc.**

![Options - Misc.](image)

**Default currency** - Defines the currency base for company-wide reporting. Individual shops can use different currencies. The conversion parameters found in Units of Measure convert shop currencies into the company currency specified on company reports.

**Default shop** - Defines the default Shop ID to use for all transactions. This is useful if most or all transactions are in one Shop.

**Allow Override of system generated Number** - If this option is checked, the user can change the order number for any order. If it is not checked, the order number field is disabled and cannot be changed by the user (and sticky notes will not be available for the order number). This option is checked by default.

**Fuel tickets require trip tickets** - If this selection is checked, each time a Fuel Ticket is created, a Trip Ticket Number must be assigned to the Fuel Ticket. If not checked, indicates that Trip Tickets are not required for Fuel Ticket entry.

**Record segments by distance** - If this selection is checked, the Trip Ticket entry records the distance traveled in each state by the length of the trip segments. If it is not checked, Trip Ticket entry records the distance traveled in each state by the beginning meter reading and ending meter reading for each trip segment.

**Auto zero-fill numbers** - If this selection is checked, the leading zeroes in front of an order number are ignored when the system searches for an order. If it is checked, you must key in the leading zeroes when searching for an order.
9 Digit VMRS Codes - Converts the ATA VMRS code system to the newer 9-digit format. This conversion requires significant system resources and takes time to complete.

Allow Future Dates - If this box is checked, orders can be created with future dates. If it is not checked, future dates are not allowed on orders.

Do not create exceptions for invalid meters - If checked, invalid meter readings that are imported using Data Import will not create exceptions. They are imported and marked ignored. If unchecked, invalid meter readings cause an exception.

Unit Information First on Non-Company Units - If this option is checked, when the Non-Company Unit dialog is displayed, the Unit Information tab has focus instead of the Customer Information tab. The default is to be not checked. The setting applies to TMT Fleet Maintenance/SQL, Shop Planner, and Mechanic Workstation.

Prompt for batch... - If an order type is checked, the batch management window is displayed. This allows a batch number to be added to a group of orders. If this option is checked, a batch number is required.

Road Calls

To to SysMgr > Options > Road Calls.

Require Driver Number on Road Calls - When this option is checked, a driver number is required to create a road call in the Road Call program. If it is not checked, a Unit ID is the only required data to create a road call. (This option is used only if you have purchased the Road Call Module.)

Move Call History Log to RO Comments - If this option is checked, the road call history log will be moved to the RO Comments when the repair order that is associated with a road call is closed.

Road Call Mapping Type - this option determines the type of mapping the Road Calls program uses to create a map for the vendor location, the unit location, and the route from the unit to the vendor. Valid choices are None, MapPoint, or Internet.
Internet. If Internet is selected, the user can select MapQuest or Verizon Super-Pages for the mapping capability (this is done in the Road Calls Options). If Map-Point is selected, Microsoft MapPoint software must be installed on the machine running the Road Calls program. When either MapPoint or Internet is selected, a new Map-It tab is added to the Road Calls interface, and a section is added to the Information tab with Locate Vendor and Locate Unit buttons. Also, a Map Route button is added if MapPoint is selected. Locate Vendor requires that a Vendor ID is selected on the road call. Locate Unit displays the Map-It screen where the physical location of the unit can be entered. The Map Route button creates a route from the unit to the vendor if MapPoint is used for mapping.

Tina

For information about the TINA tab, see the TMT Fleet Maintenance INterActive User Guide.

License

Go to SysMgr > Options > License.

TMT Fleet Maintenance is installed with licenses for 25 units. After installing TMT Fleet Maintenance, you must enable the additional features that you purchased by obtaining a registration code from TMT Fleet Maintenance Customer Support.

You can also limit the number of units in the database. When the database contains the maximum number of units, those units that are inactive, sold, retired, or otherwise no longer in service must be removed from TMT Fleet Maintenance before new units can be added.
**Unit Limit** - The total number of units that can be maintained in the system. When the total number of units in the unit master reaches this limit, no more units can be added to the system. To increase the unit limit, purchase a unit limit upgrade from TMT Software; Customer Support can give you a code over the telephone to instantly update your unit limit count.

**Unit / Misc / User License Code** - To add additional licenses, enter the code in the Unit/Misc license code field on this form, then click the **Register** button, then close and re-start TMT Fleet Maintenance/SQL. This implements the additional functionality that you purchased. Note: Any License Code is valid only for the day the code is provided by TMT Fleet Maintenance Customer Support, so it should be installed when it is received.

Miscellaneous Units are units that are tracked in TMT Fleet Maintenance but that have restrictions on them. If you go to Masters > Units and look at a Miscellaneous Unit you will notice the following tabs are missing: Fluids, Specs, Warranty, Licenses, After Market, Drivers and Accessories. As a result you are not able to track Component Serial numbers, Fuel/Fluid tickets, OEM, Extended and After Market warranties, Campaigns, registration and license stickers. You also cannot create Inspection tickets, Trip tickets, Driver Assignments, Road Calls and accessories. The primary purpose of a Miscellaneous Unit is for tracking non-rolling, non-road based equipment such as Trash containers and roll off boxes in the Waste Industry, pallet Jacks in warehouses, Dock Plates in food/warehouse marketplaces, batteries for forklifts in warehouses, EMS equipment on emergency vehicles, lawn mowers, weed trimmer, chainsaws, hoses tarps, chains and Maintenance shops or any other low valued assets.
Modules

Go to SysMgr > Options > Modules.

This tab displays the current configuration for the system, including the TMT Fleet Maintenance version, modules purchased, Interface purchases, and add-on programs purchased. This section is also used to modify your system’s settings. Additional modules and interfaces can be added by entering a code supplied by TMT Fleet Maintenance Customer Support in the Module License Code field.

**Module License Code** - Enter the module license codes for various TMT Fleet Maintenance modules (for example, the Accounting Export module or the Invoicing module), along with interfaces and add-on programs provided by TMT Fleet Maintenance.

If you have the TMWSuite Interface program installed, the path to the data files is set up by clicking **PowerSuite Options** button.

User Options

Options selected from SysMgr > User Options are accessible on any computer that connects to TMT Fleet Maintenance. Changes made in User Options affect any workstation that the user logs onto. The global options set in SysMgr > Options serve as default values for the user options until they are changed at the user level. This must be considered if multiple users share the same login name. Be aware that the login name referred to here is the TMT Fleet Maintenance Database login name, not your network login name.
Interface Options

Go to **SysMgr**  **User Options**  **User Interface**.

### Maximized Windows
- If this selection is checked, all forms open in the maximized or full screen condition. This is useful for displays using 640 x 480 resolution so fields are not hidden from view when opened. This is a global selection, which means that all forms on all workstations open maximized. If this is not checked, all forms open in the window mode, which can cause some fields to be hidden from view on low-resolution workstations.

### Confirm dialog Cancel
- If this selection is checked, when you cancel a dialog box, a confirmation window pops up to let you know that you will lose changes. If it is not checked, the dialog box closes without warning you that you will lose changes.

### Enable AutoComplete
- If this option is checked, as characters are typed into the drop-down list boxes, the first value that matches in the list is selected; the selection is further refined as additional characters are typed. For example, if the Unit Type has as valid choices F250 and F350 and an F is typed in the field, F250 is selected. If F3 is typed, F350 is selected.

### Treat Enter key as Tab
- If this selection is checked, the Enter key responds like the Tab key to move to the next field. If this is not checked, when you press the Enter key, the dialog box closes instead of moving to the next field.

### Sound With Error Messages
- If this selection is checked, pop-up error messages are accompanied by a tone or beep from the computer system speaker. If it is not checked, pop-up error messages are silent.

### E-Mail Interface
- Links your current e-mail system to TMT Fleet Maintenance/SQL so you can send and receive e-mail without leaving the application. You can use either MAPI or SMTP protocols.

### MAPI - E-mail Client
- Use the Browse button next to this field to locate and select your e-mail program.

### MAPI - E-mail User Name
- Type the default e-mail user name.
SMTP - Provide the information about the SMTP server used to send and receive e-mail.

**Printing**

Go to **SysMgr > User Options > Printing.**

This screen sets up printing options for barcode label printing only. See “Printing” on page 50.

**Misc**

Go to **SysMgr > User Options > Misc.**

**Default Shop** - Click on the Search icon to display the Shop Search screen, and then click Search. Select a default shop from the search list. If no Shop is entered, no Shop will be added to new records by default. Initially, the default shop entered
in the global options screen controls the default shop. After a user selects a default shop, that shop is used whenever that user logs in to TMT Fleet Maintenance/SQL. The default shop is computer-specific.

**Download Data Files for Palm** - If the Advanced Barcoding module has been purchased, checking this option creates the file necessary to update the Palm device with the most recent list of Units, Shops, Physical Locations, Meter Definitions, and Fuel Types when TMT Fleet Maintenance/SQL is started. Since the number of units and shops might be large, which would cause TMT Fleet Maintenance/SQL to pause when starting up; this option should be checked ONLY for the user who will be updating the Palm programs.

**Road Call Mapping Type** - For an explanation of this option, see “Road Call Mapping Type” on page 53.

**TINA**

Go to **SysMgr > User Options > TINA**.

**Print Mechanic Sign Off Sheet** - If this option is checked and a Crystal Reports file name is identified, when a mechanic logs out of a repair order that has at least one section with a part charge, the Crystal Report will run providing a sign off sheet.

**Transman INI**

The Transman.INI user option can be used to set some (but not all) of the settings maintained in the /TRANSMAN.INI file, including the General and Background groups.

**NOTE:** The Database settings are not available using this editor. To edit Database settings, see “Making Other Changes to TRANSMAN.INI” on page 60.
Go to **SysMgr** User Options Transman INI.

Only those options that can be edited are displayed. The screen you see displayed might appear differently than the one in the example.

### General Section

**Background** - Enables selection of a bitmap (*.BMP) file to be displayed in the background area within TMT Fleet Maintenance.

**BackgroundType** - Determines how the background image will appear. TILE or CENTER are valid values.

**HelpFile, LangFile, DLIFILE** - These are files set by TMT Fleet Maintenance and **should not be modified** unless you are directed to do so by TMT Software Customer Support.

### Additional Sections

The path information for additional sections can be updated using the INI interface, including:

- Tina for Palm
- Meter Readings
- Parts Inventory
- Parts Requisition
- Yard Check
- Physical Inventory
- Fuel Tickets

If any of these sections exist in the TRANSMAN.INI file, they are displayed as a section of the Transman.INI node in User Options and a directory Browse button will enable the path to be changed from within TMT Fleet Maintenance/SQL.
Making Other Changes to TRANSMAN.INI

To edit the Database section of the TRANSMAN.INI file, or to make changes that cannot be done using the menu process described above, edit the file using the Windows file editor.

1. Go to Start > Run
2. Type Transman.INI in the Open field.
3. Click OK

The TRANSMAN.INI file is opened for editing.

Note: Be careful when editing this file. Incorrect settings can prevent TMT Fleet Maintenance/ SQL from opening or running correctly.

Specifying User Defined Fields

1. Go to SysMgr > User Defined Fields. The User-Defined Fields are fields that are tied to specific master records. To add a User-Defined Field to a master record, you must first define the field here.

2. Click the Table field drop-down and select the type of master record for which you want to define a user-defined field from the Lookup Table screen and click on OK.
To insert a new field, click on **Edit**, then **Insert Record**, or use the CTRL-INS hot-key. Enter the appropriate information and tab out of the field.

You can also use the Masters menu to access a masters form and enter a new field by clicking on the User Fields tab and clicking on the Define Fields button at the lower right corner of the screen. The User Fields tab is available on all of the masters forms except the Parts Catalog master. The code will be displayed along with the description a pipe (|) will separate them. If one of the fields is blank a pipe will be displayed with nothing in front of or after it depending on which field is blank.

**Note:** The fields shown in the illustrations in this section are offered only as examples. They will not exist in TMT Fleet Maintenance unless you create them.
Codekeys Setup

As you implement more advanced functions of TMT Fleet Maintenance/SQL, you might need to add or modify additional codes as well. Good initial design of these code sets can greatly enhance the versatility and usefulness of your data reporting capabilities.

Each code set offers a different perspective on your company’s maintenance costs.

The Code Setup is essential to the successful setup of the TMT Fleet Maintenance/SQL system. Go to **SysMgr**  System Setup  Codekeys, or type **ALT + G**, then **Y**, then **C**.

To meet the specific needs of your company, you must set up:

- PM Codes
- Company Departments
- Company Divisions
- Cost Centers
- Unit Activities
- Unit Model
- Unit Type

The type of record displayed in the Codekey form can be filtered. There are three types of Codekey records:

- **TMT** = Internal TMT Fleet Maintenance/SQL code. You cannot modify or delete these codes.
- **ATA** = ATA VMRS standard code. You cannot modify or delete these codes.
- **USER** = User Defined. If you add a record, the type is USER.

**NOTE:** Verify all Codekeys before inputting the Master records. The specific needs of your company might require that you modify some of these codes. Uncheck the ACTIVE check box to remove unwanted ATA or TMT codes from user access (Inactive codes are not deleted, but are not displayed to users).
You can create Reasons Group Codes for grouping Accounting Transactions in
SysMgr System Setup Codekeys Reason Codes for Accounting Transactions.

Charge categories for services are created automatically when a new Charge Category is entered into SysMgr System Setup Codekeys Charge Category Type.

You can set up Payment Types for CASH, CHECK, and CREDIT CARD; these work in conjunction with the Great Plains Accounting Interface. You can also assign an account to each Company Division that will be used as the Inter-Company account in the Great Plains Accounting Interface and the McLeod Interface. COMCHECK is processed in the same way as CHECK.

User-defined codes can be assigned to a reason for repair, and after it is assigned, it can be made optional or required when the reason for repair is used on a repair order section. To enable this feature:

1. Select a Reason for Repair code
2. Click New Code.
3. Enter a user code and description. This becomes a new codekey in the codekey tree and will display (User Code) beside the description in the tree.
4. Click the Prompt for Code checkbox. The User-Defined Codes drop-down menu is enabled. Select the user code you entered in the previous step.
5. If the code should be required when creating a repair order section, click the Required checkbox.
6. Click Post.
7. Right-click on the Codekey Tree and select Refresh Data.
8. Find the codekey you just added.
9. Enter valid values for the new codekey.

NOTE: This is required for values to be selected for the new codekey when a section is created with the reason for repair selected in step 1.

Printing Codekey Reports

You can print or view a listing of the Codekeys entered in the Codekey Master form.

Go to SysMgr Reports Codekeys. You can select the printer you want to use with the Options button. In addition, a radio button can select one or all category of codes. If one category is selected, the list box is displayed and you can select the Codekeys you want to print or view. To print or view, select the appropriate button on the right side of the form.
Units of Measure

Go to SysMgr System Setup Units of Measure. The Units of Measure form defines the Units of Measure for:

- Area
- Currency
- Distance
- Length
- Quantity
- Temperature
- Time
- Volume
- Weight

Select ALL in the Category drop-down list to display all units of measure. This is the default.

In many cases, no modifications are required to the existing units of measure.

This form also contains the conversion factor from the base Unit. The existing base Unit for each category is denoted by a To Factor of 1. You can change the base unit for each category by changing the To Factor to 1 for the desired base unit and adding the appropriate To Factor for the remaining units in that category.

You can add or delete units of measure as necessary for your application. The other Units of Measure under the same category have the conversion factor in the To Factor field according to the base Unit.

There is also a To constant that is added to the conversion value after it has been multiplied by the To Factor.

For example, the To Factor for Fahrenheit is 1. Therefore, the base Unit is Fahrenheit. The To Factor for Celsius is 1.8 and the To constant is 32. This yields a formula of F=[C(1.8) + 32]. This is true because 0 degrees Celsius is 32 degrees Fahrenheit.

The value in the Decimals column defines the number of decimal places that can be recorded for a given unit of measure. For example, if you do not want users to
be able to charge a fraction of a part that is inventoried with a unit measure of EACH, the
value of 0 in the decimals column prevents the entry of a decimal quantity when that unit of
measure is charged. If you stock parts that are usually charged in pairs or sets, create units
of measure in the Quantity category with a number of decimals appropriate to the fractional
quantities that you might need to charge.

Company Setup

To access the Company Setup form, go to SysMgr Company Setup, or press ALT + G + C. The Company Setup screen is displayed. This is the first Master record that must be filled out.

There are two additional tabs on this form that contain vital Company information used throughout the system.

- For information about the Accounting Year tab, see "Accounting Export Module Setup" on page 282. Creation of an Accounting Year is not needed if the Period Close process will not be used.
- For information about using the User Defined Fields tab to create user-defined fields, see “Specifying User Defined Fields” on page 60.

Company Definition

The Company Definition tab is the default tab. This form contains the Address, Phone and Fax numbers, E-mail address, and Company Currency type. The Currency field contains the currency that is used for any Company level reports. This allows Shops in various geographic locations to use a different default currency. However, when that particular Shop information is reported at a Company level, the information is displayed in the Currency type shown on this form.
You can store graphic images or documents associated with a customer and publish it to the web-based Customer Inquiry screen. Go to User Fields and click the Images button, then upload the document or graphic image. To publish the image, the Publish to Customer Inquiry Screen check box must be checked.

Tools Catalog Setup

You can use the TMT Fleet Maintenance/SQL tool catalog feature to create a database of tools that can be assigned to employees or to shops. You can also add tools to the catalog as needed.

For information on setting up the tools catalog, see “Tracking Shop and Employee Tool Inventories” on page 277.

Auto Fleet Definitions

Go to SysMgr > System Setup > Auto Fleet Definitions. The Auto Fleet Definitions program is used to designate the type of Fleet Code to assign to a particular Unit ID. The Fleet Code is based on fields in the Unit Master that can be selected in this form
The fields for **Engine**, **Capacity**, and **Wheel Base** in the Unit Master record are *not* validated fields. Therefore, *8 cylinder* and *Eight Cylinder* are two different engines. *16 T.* and *16 Ton* are two different capacities. These fields require careful data entry to ensure consistency.

**NOTES:**

*Changes made to fleet definitions have an adverse impact on Diagnostics and Part Pick List assignments by Fleet Definition.*

*If changes are made to a large fleet, this program could run for quite some time. The program must re-calculate and re-assign all Units to a new code.*

**Repair Order System Setup**

The Repair Order system tracks the Complaint, Cause, and Correction of each Unit repair. This is necessary for warranty reasons and the codes minimize data entry. Position Codes track multiple Components on a Unit by the location of the component on the unit. You must also set up Diagnostics, Part Pick Lists, and Unit Inspection Definitions, if you are using Online Repair Orders.

Although the basic system is configured with usable codes, these codes might not be specifically appropriate for your equipment. You might want to improve on these code lists and their component associations as you use the system.

**Complaint, Cause, and Correction Codes**

Complaint, Cause and Correction Codes can be associated with System or Assembly level codes depending on which level of codes you plan to use in the Repair Order system. Using System level codes makes it easier to get started if your staff is not familiar with the VMRS code system. Using Assembly level codes provides more articulate cost reporting. Codes associated with the System level migrate to all the Assembly and Component level codes belonging to that System.

If the check box in the *Available on Handheld* is checked, the code can be used on Palm devices.
Complaint Code

The Complaint Code is used in the Repair Order to identify the complaint or the reported discrepancy with the unit. Cause Codes are used on the Labor Charge lines of the repair order to indicate the cause of the failure. Correction Codes are used on the Labor Charge lines to indicate what the technician did to correct the failure.

Identify the System or Assembly code you want to work with by selecting from the Component Search for (click the flashlight search icon beside the Component field at the top left of the form) or type the code into the Component field. Codes can be added to the selected list by selecting from the All list (select multiple items by holding down the CTRL key while left-clicking) and then clicking the single left-facing arrow button. Codes can be removed from the selected list by selecting from the list (select multiple items by holding down the CTRL key while left-clicking) and then clicking the single right-facing arrow button.

Go to SysMgr > Repair Order Setup > Complaint Codes. Complaint Codes are assigned to individual Component Codes and are referenced in the Repair Order system. The figure below shows the Complaint Codes form where all Complaint Codes for all Component Codes are entered.

The example below shows the assignment of a group of the Complaint Codes to the Component Code of 013-Brakes. You can browse these assigned Complaint Codes when you enter the Repair Order.
Cause Codes

Go to SysMgr > Repair Order Setup > Cause Codes.

The **Cause Codes** are similar to the Complaint Codes and are attached to specific Component Codes. They are the cause of the complaint that initiated the repair.

If you change a component code on a repair order, the complaint and reason for repair fields are cleared and new codes must be entered.

Correction Codes

Go to SysMgr > Repair Order Setup > Correction Codes.

The **Correction Codes** are set up identically to the Complaint and Cause Codes. The Correction Code gives the corrective action taken to resolve the problem. The “three C’s” are necessary in warranty recovery and are the basis for the repair analysis.
Position Codes

Position Codes are used by the After Market Parts Warranty Tracking function to identify components that are located in more than one position on a unit. This allows warranty tracking on specific individual parts that may be installed in more than one location on a unit. After Market Part Warranty tracking is done on the Component Code level (that is, the complete 9 digit VMRS component code). For this reason, the position code must be associated at the Component Code level.

For each Component Code that you want to track warranty, delete all position codes from the Selected list if the part is found in only one position on a unit (for example, a water pump). For parts that are found in more than one position, only appropriate position codes should appear on the Selected list (for example, for Double Filament Sealed Beam Head lamp, only Left and Right position codes should remain). Assigning correct position codes to those components that you want to track warranty on helps to prevent user errors from causing missed claims.

Go to SysMgr Repair Order Setup Position Codes. Position Codes identify multiple Components on a Unit. For example, a piece of equipment may have more than one engine or PTO. You can track this Component separately. Position Codes also track the position of tires on a Unit. It is important for warranty purposes to identify what position the Component is in if multiple Components exist on a particular Unit. The following example shows the Position Codes form, and is similar to the Complaint Codes.
Position codes are assigned to components using the same method used to assign Complaints, Causes, and Corrections to components. You do not need to assign Position codes to components that exist in only one position on a unit.

Position assignment is essential for warranty tracking when a component is used in more than one location on a unit.

Proper setup of position codes is essential for effective after-market parts warranty recovery. Appropriate position codes should be assigned to the full 9-digit ATA VMRS code for each part in your inventory that is located in more than one location on your units, and on which you are tracking warranty information. Also, part codes that appear in only one location on units should have all position codes excluded. This prevents users from inadvertently selecting inappropriate position codes during data entry and thereby defeating the function of the warranty tracking system.

**Meters, Fluids, PMs Setup**

This menu enables you to set up information about meters, fluids, and preventive maintenance (PM).
Meter Setup

Go to SysMgr > Meters, Fluids, PM's Setup > Meter Setup. This is where Meters are set up and defined. All Meters for Units are present on this screen. You should define all the Meter Types within your Fleet and group these into standard groups during system setup. Meter Groups are associated with units only when Unit Master records are created. Changes made to Meter Groups do not affect Unit Master records for units created prior to the change. Changes can be made manually in each Unit Master record as required.

Enter the Meter Type that you want to create and complete the rest of the grid line to define the attributes of that Meter. The PHYS? column designates the meter as a Physical Meter. Use the space bar or double-click to mark or unmark the box. For example, fuel usage is not a physical meter, it is a virtual meter that tracks the actual fuel usage. This can meter a Unit but is not a physical meter that can be read. Months and days are also virtual meters.

The Component Code is the VMRS Component Code that identifies that Meter as a part. If you click in this grid box, a lookup option is available for the Codekey table.

The Meter UOM is the base Unit for the Meter Type. It defines the increment of measure for that Meter.

The last column is a description field for the specified meter.

Meters can be replaced when a repair order or fuel ticket exists for a unit. (In previous versions of TMT Fleet Maintenance/SQL, a meter replacement was not allowed for a unit until all repair orders and fuel tickets for the unit were closed and processed into the history files).

Also, you can enter meter data with an older Down Date and a greater meter on a repair order or fuel ticket if a replacement meter exists with a newer date. This enables you to enter repair orders and fuel tickets that occurred prior to the meter replacement and have not yet been entered into TMT Fleet Maintenance/SQL.

Meter Groups

After all Meter Types are entered, you can group the different Meters according to the Unit Type.

For example, a company might have several ready-mix trucks with an hour meter, an odometer, and a revolution counter. The bulk cement trailers might only have a
Hub meter. Within the Meter Group tab, you can set up two different groups: one for ready-mix trucks and one for bulk trailers.

When you create a new Unit or open a Repair Order on a particular Unit Type, you are prompted for information about the appropriate Meters. This creates an unlimited number of Meters and assigns them to equipment based on the equipment type.

It is recommended that you:

- Assign a Days meter to all units
- Assign a Fuel Meter to all fuel-burning units
- Assign Physical Meters to units that have them.

An example of a Meter Group tab is shown below. The SEMI-TRK units have an Odometer and a Days meter.

A description for each column is shown below.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort order</td>
<td>The entries in this column define the order in which meters are displayed on all meter screens.</td>
</tr>
<tr>
<td>Meter Type</td>
<td>The type of meter being used.</td>
</tr>
<tr>
<td>Meter Position</td>
<td>Indicates the physical position on the vehicle where this type of meter is used to capture multiple readings. Only needed if more than one meter of the same type exists.</td>
</tr>
<tr>
<td>Max Daily Utilization</td>
<td>Determines a daily amount beyond which the meter reading cannot go. If zero, this check is not performed. (Functions on physical meters only.)</td>
</tr>
<tr>
<td>Required on Fuel</td>
<td>Put a check mark in the check boxes to indicate that a meter reading is required on a fuel ticket or a repair order (RO).</td>
</tr>
<tr>
<td>Required on RO</td>
<td></td>
</tr>
<tr>
<td>Primary Meter</td>
<td>You must designate one meter as the primary meter. This is the default meter reading for most reports and other functions within the system. Only one meter in the list can be designated as a primary meter.</td>
</tr>
</tbody>
</table>
## Fluid Setup

Go to **SysMgr > Meter, Fluid, PMs > Fluid Setup**. The Fluid Definitions setup is similar to the Meter Definitions described earlier. This is where all Fluids are set up in the system. This is also used for inventory purposes for bulk oil, antifreeze, and fuels. It is necessary to set up all fluids that may be charged on Fuel Tickets in TMT Fleet Maintenance/SQL. Use of the Fuel Ticket to charge use of fluids to units enables consumption reporting for that fluid. Only fluids charged on Fuel Tickets contribute to consumption reporting.

To define a new Fluid Type, complete these fields:

- Fluid Type
- Description
- Additive Type
- Component Code

The Additive Type is set up in the Codekey table. The Component Code is the VMRS Component Code that is also located in the Codekey table.

After the Fluids are defined, they can be grouped by Unit Type. It is important to define Fluid Groups to enhance the Unit Master setup process. Fluid Groups are associated with units only at the time of Unit Master record creation. Changes made to Fluid Groups do not affect Unit Master records for units created prior to the change. Changes can be made manually in each Unit Master record as required.
Fluid Groups

The Fluid Groups tab assigns a group of Fluids to a Unit Type. As with the Meter Definition screen, the Sort Order is the order in which the Fluid Types are shown on the Unit Master and other forms. The Fluid Type is the value on the Fluid Definition tab along with the description of the Fluid. Select an appropriate unit of measure from the drop-down list. The fluid capacity field is informational and optional.

The Primary Fluid check box designates the fluid type to which the Fuel Ticket form defaults.

Press the space bar or double-click the field to mark or unmark the box.

<table>
<thead>
<tr>
<th>Column</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort order</td>
<td>The entries in this column define the order in which fluid types are displayed.</td>
</tr>
<tr>
<td>Fluid Type</td>
<td>The type of fluid being used (defined in the Fluid Definition tab).</td>
</tr>
<tr>
<td>Fluid Type Description</td>
<td>A description of the fluid type.</td>
</tr>
<tr>
<td>Fluid Unit of Measure</td>
<td>The unit of measure for the fluid type. Examples include gallons, quarts, liters, and so forth.</td>
</tr>
<tr>
<td>Capacity</td>
<td>The total amount of fluid by unit of measure that the unit can contain. For example, 50 gallons, 8 quarts.</td>
</tr>
<tr>
<td>Primary Additive?</td>
<td>If this is the main fluid for the unit type, put a check mark inside the check box. The Fuel Ticket Fluid Type defaults to the primary additive. If it is not the main fluid for the unit type, leave it blank. This field is optional.</td>
</tr>
</tbody>
</table>

PM Setup

Go to SysMgr > Meter, Fluid, PM’s Setup > PM Setup. You can define or create the preventive maintenance standards for similar pieces of equipment. This aids in the setup of the Unit Master as this PM setup is read and associated with the Unit.
being set up. PM Groups are associated with units only when a Unit Master record is created. Changes made to PM Groups do not affect Unit Master records for units created prior to the change. Changes can be made manually in each Unit Master record as required.

The PM Setup form designates the PM assembly level codes used for preventive maintenance operations for each Unit Type. Those PMs designated as Dependent PMs indicate that these PMs are a part of a Levelized maintenance program and require a rank or order that determines the sequence in which they are to be performed. A PM that is not designated as Dependent is assumed Independent, and therefore has no rank or order. The actual intervals between PMs and their scheduling factors are defined in each Unit Master record.

Adding Component Specifications

Go to SysMgr Component Specifications. You can add Component Specifications based on the VMRS Codekey table. For instance, if you would like to see the engine specifications such as Fluid capacities, torque, RPM settings, compression ratios, or just specific Part Numbers for these Components, you can create the custom specification on that particular Component Code. You can define Component Specifications as String text or Numeric text. A hint or help text for each specific item can be entered in the Hint area at the bottom of the form.
You can access the data in this form under the Specs tab on the *Unit Master* screen. When a custom specification is created for a Component, and that Component is added to the Specs tab, the additional field can be accessed by scrolling down below the standard fields.

### Accounting Features
For information on setting up and using the accounting features in TMT Fleet Maintenance/SQL, see “Accounting Export Module Setup” on page 282.

### Tax Rates and Fees
Go to *SysMgr > Tax Rates and Fees*. You can assign Tax Rates to a Shop or a Vendor within the TMT Fleet Maintenance/SQL system. The Tax Rates apply to the purchasing system.
The setup is a multi-step process. Create the codes for the Taxes and Fees for which your shops are liable. The remaining steps must be postponed until after the Shop Master and Vendor Master records are created. Return to this form later to resolve any conflicts between Shop based tax rates and Vendor based tax rates.

To set up tax rates and fees:
1. Create the Tax Rates for all taxes that will be charged to your Company. State and Federal taxes and any city taxes should be set up on the Tax Codes tab in this form.
2. Set up any tire, battery, or waste oil disposal fees or other charges that might occur in relation to parts or fluids.

The Tax Type is a Codekey value. To create a new tax Code, type the new Tax Code and continue filling out the grid row. The Flat Tax column is for a flat fee such as a tire disposal fee. The Tax % column is for a percentage tax rate. You can specify either a flat tax or a percentage, but not both, for an entry. The percentage is the Tax Rate in percentage value. A tax rate of 5% is written as 5.0, which is actually 0.05 in decimal form.

**NOTE:** An accounting disbursement rule is automatically created when a new tax is created.

**Resolving Tax Rates**

TMT Fleet Maintenance/SQL provides a method for designating which tax rate is used when there is a tax rate in the Shop Master record and a different tax rate in the Vendor Master record. This is useful when you are using the Invoicing module and your tax liability is defined by the vendor location. The default preference is the rate specified in the Vendor Master record.

To specify the tax rate to use, go to **SysMgr > Tax Rates and Fees**, and click on the **Purchase Order Tax Resolve** tab. Select the Shop and Vendor by clicking inside the fields to display a flashlight (search) icon, then click the search icon to display a search selection screen for the Shop or Vendor. Click inside the **Use Tax Rates for** field, and then click the down arrow to select Shop, Vendor, or No Tax.
Pay Grades

Shop personnel Pay Grades should be set up before any Employee Master records are created. If you elect to use the Shop Rate method for labor cost, creation of individual Pay Grades is optional; however, at least one Pay Grade must be created to use in the required Pay Grade field in the Employee Master record. If you decide to use the Burden Labor method for labor cost, you must create Pay Grades for each level of compensation that you use for your mechanics.

You can create an unlimited number of Pay Grades. You can enter Hourly rates, as well as burden rates on the Pay Grade form. A burden rate is the load or expense to a facility in dollars for each hour of work performed by an employee, including costs of employment such as employer taxes and benefits.

Go to **SysMgr > Pay Grades**.

The Pay Grades screen is displayed, which shows a list of all of the pay grades that are defined for your company.
Create a New Pay Grade

To create a new pay grade, right-click in the grid and select **Insert Pay Grade**.

Enter a Pay Grade name. You can also enter a description in the optional Description field. Click **OK** to save the pay grade or **Cancel** to quit without saving.

Edit a Pay Grade

To edit an existing pay grade, double-click the entry in the list.

You can assign the pay grade to a specific shop. If a Shop ID is selected, the pay grade rate applies only to labor created in that shop. To apply the pay grade to all shops, leave the Shop ID field blank.

This feature enables you to set a pricing code for a customer that can be different in different shops. For example, a customer can be charged $50 in one shop and $60 in another shop. It also enables you to set different pay grade rates for the same task in different shops. This is often used when a shop uses a higher rate than other company shops because of location premiums.

**NOTE:** If a shop detail record is created but no labor rates are entered, when a labor line is created for that shop, the labor rate will be $0.00.

Pay Grades and Labor Rates

TMT Fleet Maintenance/SQL uses different methods for posting the labor cost of maintenance:

- **Hourly Rate** - represents the hourly wage of the mechanic. This does not include the cost of the mechanic’s time to the company. It can be an averaged cost (for example, all Level 2 Mechanics can have an hourly rate of $30).
• **Burden Labor Rate** - represents the cost to the company of the mechanic's Hourly Rate plus the specific costs of employment associated with this specific employee (including employment taxes, benefits, and other costs of employment).

• **Shop Rate** - represents the cost of labor based on a shop's cost of doing business and if used, is defined in each Shop Master record. Usually calculated by dividing the total cost of operation of the shop by the number of available labor hours for that period of time.

A pay grade that is being used on an employee record or in a price table cannot be deleted from the pay grades tables.

**NOTE:** If you set up a pay grade where the labor rate equals zero and associate this pay grade with an invoice price table for labor, the invoice charges that labor rate at a rate of $0.00. In previous versions of TMT Fleet Maintenance/SQL, actual labor cost was charged.

### Work Shifts

Go to **SysMgr > Work Shifts**. Both Employees and Units can be assigned to Work Shifts. The assignment (optional) of a Unit to a Work Shift defines the desired period of Unit availability when evaluating Unit downtime.

To create a new work shift, press **CTRL + INS** or select **Insert Record** from the Edit menu.

You must create at least one work shift to use in the required Work Shift field in the Employee Master record.

The Calendar function at the bottom of the screen enables you to view a calendar from which you can perform scheduling functions.

### Defining Jobcodes

Go to **SysMgr > Repair Order Setup > Jobcode Definitions**.
The **Jobcode Definitions** screen enables you to define jobcode, assign jobcode, create tasks, and assign tasks.

The **Jobcode** tab lists all of the jobcodes that were defined for your company’s installation of TMT Fleet Maintenance/SQL.

The **Tasks** tab is the tasks master. New tasks can be created and existing tasks can be edited or deleted. A task can be required, a task comment can be required, and a task can be made active or inactive. If a task is required, it must be checked in Mechanic Workstation before the repair order can be marked Complete. If a task comment is required, a comment must be entered for that task when the task is checked. If a task is marked inactive, it is not displayed on the Task Assignments tab, but it is included on the Tasks tab.

**NOTES:**

Changes for requirements are not reflected on existing repair orders with tasks already assigned. Changes are reflected whenever the specific task is assigned in the future.

A task that was assigned to a jobcode cannot be deleted unless it is removed from the jobcode assignment.

The **Task Assignments** tab is where tasks are assigned to a selected jobcode on the Jobcodes tab. Tasks that are active on the Tasks tab are displayed in the All Task Definitions list. To add a task to the jobcode, click on the **Include Selected** or **Include All** buttons. After tasks are assigned, the order in which they appear in Mechanic Workstation can be changed by dragging and dropping the tasks in the Selected Task Definitions list.
Chapter 4: Building the Structure of Your Business

This chapter covers the steps required to complete the Master File setup. All tabs on each master form are explained in this section. The correct setup of the Shop, Employee, Unit, and Inventory Masters is crucial in the successful implementation of TMT Fleet Maintenance/SQL.

Before you begin working with the master files, be sure to collect the necessary data. For more information, see “Preparing for Master Record Data Entry” on page 33; the data collection forms are in the appendix “Data Collection Forms” on page 367.

**NOTE:** Illustrations in this chapter are samples taken from a generic training database and are included only to show how a screen appears. Selections on these screens apply to the company in the example database; whether a field is selected or not in your specific application of TMT Fleet Maintenance/SQL depends on your company’s use of the database. Your screens will be different from the examples.

**Shop Master**

Go to **Masters** > **Shops**. The Shop Master File is the file that defines your shops, parts inventory locations, fuel inventory locations, and locations at which units are domiciled. The asterisk (*) next to the field description on all Master files indicates that a valid entry is required for the form. Notice the asterisk on the Shop ID field in the following example.

Click the right mouse button to access a Sticky Note. The information in the Sticky Note appears when you exit the Shop ID field after entering the Shop ID anywhere in TMT Fleet Maintenance/SQL.
The Shop ID field contains a drop-down list of active shops.

To make an active shop inactive, right-click in the Shop ID field and select Make Shop Inactive. Inactive shops are not reported on the Shop Listing report.

**Shop Definition**

You can select whether to use the shop rate. If the Use Shop Rate selection is Yes, the Shop’s Rate is used as the cost basis for labor charged to Units. If the selection is No, either the employee hourly base wage or the burden labor rate for that employee is used, depending on the condition of the check box Use burden labor rates in the Options form Repairs tab. The Shop ID, Description, Address, City, State, Zip Code, Currency, and Shop Type are all required fields in this form. Division, Cost Center, Department and Region are all different Shop categories set up in the Codekey program.

If your Parts Inventory Management system is not yet ready to use, be sure to leave the Track Inventory box unchecked. You can use the Repair Order system to start building cost history for your units while you continue with getting the Parts system ready to use. Once the Track Inventory check box is checked, it becomes disabled and cannot be unchecked.

You can select a pay grade for labor charges and set the automatic selection of weekend pay grades in Masters Shops Options. These settings take precedence over the Global options settings for this shop.

The Overtime option cannot be used with a burden shop rate selected in Shop Master. If Overtime options are selected, you can select a rate to charge labor for both repairs and indirect charges from a panel of radio buttons.

Along with address information, Currency, Shop Type, and Division are required fields.
If the *Allow Local Parts* check box on the Inventory tab is not checked, local parts are not allowed in the shop’s inventory. The Global option for Allow Local Parts is in effect until this box is changed for a specific shop.

You can use the buttons to select an appropriate rate for the labor line. TMT Fleet Maintenance calculates the charges based on the labor rate scale established for the selected mechanic’s pay grade and work shift. Overtime charges apply to repair orders and indirect charges. Overtime settings do not apply if the shop uses the Shop Burden Rate for calculating labor charges.

The Masters > Shops > Options > Repairs > Jobcodes menu provides a way to both create job codes and enter employee assignments.
Options in the TINA section override the global TINA options and create specific rules for how TINA can be used in this specific shop. Each shop can have different options specified for how TINA is used.

**Group Assignments**

Go to Masters Shops Groups.

Group Assignments are based on four fields:

- Codekey
- Code Description
- Effective date
- Until date

A history of the changes made to these fields is kept in the Groups tab. This can be useful for reporting purposes. To display the history information, the Show History check box must be checked.

**Tools**

Go to Masters > Shops > Tools.

Tools can be assigned to shops at a shop level or at an employee level. For more information about maintaining your tools inventory, see “Tracking Shop and Employee Tool Inventories” on page 277.
Orders

Go to Masters Shops Orders.

The Orders tab on the Shop Master form contains information about:

- Campaigns
- Estimates
- Fuel Tickets
- Indirect Orders
- Invoices
- Planner entries
- Purchase Orders
- Repair Orders
- Part Transfers
- Warranty Claim numbers

If a system-generated number is used, it stores the next number (Count) here.

The Prefix is a value (up to 4 upper-case alpha or numeric characters) that can be entered to prefix the generated number. For example, the next Repair Order number for the East Shop will be EAST-0000334. This number is previewed in the Next Order No field and is displayed on the next Repair Order form.

The Starting Constant in the Prefix is useful to separate the Repair Order numbers by Shop ID. This can be used as a filter criterion. If you want to key in your own numbers for any type of order, double-click the Generate box for that order type to remove the check and the system will not generate numbers for that order type.
If Invoicing is enabled, the lower portion of this tab enables you to define which items on an invoice are taxable, and to create an Invoicing Message to be printed on each invoice generated from this shop. This invoice message replaces any Invoice Message generated at the Company level (in SysMgr > Standard Messages).

**Expenses**

Go to **Masters Shops Expenses**.

The Expenses tab on the Shop Master form provides a quick overview of the costs the Shop has incurred by Order Type and Charge Category. This screen displays the overall costs associated with Repair Orders versus the costs for Fuel Tickets or Purchase Orders.

Type the **Starting Date** and **Ending Date** to create a more detailed cost analysis. To generate the expense information, click on **Generate**. Check the **For All Shops** box to see similar data for all shops.
Go to **Masters > Shops > Taxes.**

The Taxes tab enables you to define those taxes that must be paid based on the shop location. If you must collect sales taxes from customers using invoicing or if your state and local taxes are determined by the location of the shop, you must add each tax code that must be paid by the shop (most states base tax liability on the location of the vendor).

Most sales taxes are calculated using the **Standard** method.
NOTE: Recent changes to the purchase order system affect how taxes are calculated. Purchase orders default to the vendor’s tax rate, not the shop’s tax rate. Taxes can be passed from a purchase order to a repair order, indirect charge, or invoice without carrying it in inventory.

Accounting

Go to Masters > Shops > Accounting.

This tab enables payment methods for Accounts Payable and Accounts Receivable transactions to be associated with specific accounts. To utilize these payment methods to account associations, the Use Payment Account option is used on the Account Disbursement Detail screen. It is only available at these levels:

**Purchase Orders (Accounts Payable):**
- Blanket
- Credit
- Standard
- Vendor RO

**Invoices (Accounts Receivable):**
- Credit
- Direct Sale
- Fuel Ticket
- Repair

If a payment method is not provided and the *Use Payment Account* option is selected, the disbursement will roll to the *Purchase* level or the *Invoice* level, depending on the type of transaction.
Options  Go to Masters > Shops > Options.

The options selected in the Shop Master record only affect operations within the shop for which they are selected. The Shop Options form offer options relevant to Repair Orders, Purchasing, Inventory, Reports, Miscellaneous, and Mechanics Workstation.

In many cases, the same options exist in SysMgr > Options. Shop options and SysMgr options are interdependent. The global level options, once it is set in SysMgr, provide default conditions for Shop options and takes precedence over shop options. After an option is set in Shop Master, it then supersedes the options selected in SysMgr for that shop and takes precedence over the global option. This permits different shops to function differently.

Note: If rights are removed from each shop option, a message screen is displayed that states “Your security setting does not permit access to this information.”

Repairs  Go to Masters > Shops > Options > Repairs
Print bar-coded RO number - If this selection is checked, the RO number on the RO work card prints in bar code format and text. If it is not checked, the RO number prints in text only.

Enable Warranty Processing - If this selection is checked, the Repair Order process detects potential warranty claims and provides the Repair Order data to the Warranty Claim processing function of TMT Fleet Maintenance/SQL. If it is not checked, this function is disabled.

Labor Entry via Start/End Times - If this selection is checked, labor charges are entered by the beginning and ending time of the operation. If it is not checked, labor times are entered by the total number of decimal hours.

Check for Open ROs when creating New RO - If this selection is checked, when you open an RO for a unit, TMT Fleet Maintenance/SQL checks for the existence of other Open ROs for that unit and advise you of their existence. You can then add sections to the existing RO if you want, or continue to create the new RO. If it is not checked, this check is not performed.

Require Vendor for Vendor Lines on RO - If this selection is checked, charge lines on RO sections cannot be checked as Vendor Supplied unless a valid Vendor ID is recorded on the RO section. If it is not checked, any line can be marked as Vendor Supplied, even if there is no Vendor reference on the RO section.

Require Cause and Correction if under warranty - If this selection is checked, any RO section that is a potential warranty will require both Cause and Correction codes on the labor charge lines. If it is not checked, these codes are not required. This option should only be checked if Cause and Correction codes are provided for any system or assembly codes that you are likely to use.

Require Meter on Opening of RO - If this option is checked, a meter reading must be entered when opening a new repair order. If it is not checked, a meter reading is optional. This option enables warranty determination by the meter reading when the repair order is opened.

Prompt for Creating of Vendor Parts Records - If this option is checked, the system displays a prompt asking whether to create a Vendor Part master record when entering vendor parts on a repair order when the parts do not exist in the Vendor Parts master for the selected shop and vendor. If the option is not checked, no prompt is displayed and no opportunity is given to create a vendor parts master record for the vendor part entered.
Allow for adding items to Requisition List - If this option is checked, when a part and quantity is entered on a repair order and there is not sufficient inventory on hand, the system will display a prompt that allows the difference between the amount entered and the amount on hand to be added to a manual part requisition for that repair order. If this option is not checked, a normal error message is displayed that there is not sufficient inventory on hand, and the quantity will have to be changed to the amount on hand or the part entry will have to be cancelled if there are no parts on hand.

Check for Open VROs when creating New RO - This option will allow you to see all the Vendor Repair Orders on a unit on the Open Repair Orders List form. Standard ROs will still look at the ShopID to determine if they are visible, but the Vendor Repairs will not. All VROs for the Unit selected will be displayed. This will override the GLOBAL option set in SysMgr > Options > Repairs.

Chronic Repair Interval (Days) - When a value is entered for the number of days, the system will track a chronic repair as a repair that occurs more than once within the number of days selected for the repair shop, unit, and component code. When a new section is created on a repair order and the component code entered has been done on a previous repair order for the selected repair shop and unit, a yellow message is displayed in the section indicating how many repairs for the selected component code have occurred within the specified number of days. The message is also displayed when reviewing repair order sections in the repair order history.

Chronic Repair Level - Added Controls at which level the system looks for matches on the Component code for chronic repairs. For System it looks at the first 3 characters of a component code, for Assembly the first 6 characters and for part the first 9 characters. For example if the component code is 123-456-789 then System level looks at 123, Assembly level looks at 123-456 and Part level looks at 123-456-789.

Custom Repair Order - If checked, a crystal report file name and path can be entered. When printing a repair order work card, the OrderID will be passed to the report. The path to the Crystal Report including the Crystal Report name can be up to 254 characters.

Repair - Default Repair Class - Enables you to select a default repair class.

Repair - Default Repair Site - Enables you to select a default repair site.

Vendor RO - Default Repair Class - Enables you to select a default repair class for vendor repairs.

Vendor RO - Default Repair Site - Enables you to select a default repair site for vendor repairs.

Note: Selecting default values for these fields is reasonable if most of the work done in your shop is similar in class or site, but if not, providing a default value can result in users’ failure to select the appropriate code. This can lead to problems with accuracy in searching and reporting repair order data.

Max RO Component Level - This option determines the highest level of component code that can be entered on a repair order section. If System is selected, only a 3-digit code can be entered (for example, 013). If Assembly is selected, only a 3-digit or 6-digit code can be entered (for example, 013 or 013-001). If Part is selected, a 3-digit, 6-digit, or 9-digit code can be entered (for example, 013, 013001, or 013-001-001).

Repairs - Jobcodes - Go to Masters > Shops > Options > Repairs > Jobcodes
Select PMs Due to Create Sections - If checked and a repair order is created on a unit that has due PMs, those due PMs will be used to create sections.

Section Component Code for PM Parts - If checked, the section component code is used for parts charged on the repair order instead of the part component code. This option works when the reason for repair code has been marked Update PM in Codekeys.

PM Sections - Type or select the percentage used to trigger a Dependent PM or an Independent PM. This selection applies only to units domiciled in the selected shop. This overrides the Component match function from the part record in Shop Inventory.

Repairs - Jobcodes
Go to Masters > Shops > Options > Repairs > Jobcodes.
Employee and Jobcode Assignments - If checked, enables job codes and displays the job codes section of the repair order section when the Sections tab of a repair order is clicked. Job codes are created based on the fleet ID if Auto Create Job Codes Based on Fleet ID is checked. Job codes default using the system component code and complaint code if Auto default Job Code (Component Complaint) is checked.

Auto default Job Code (Component Complaint) - If checked, the job code will default using the repair order section's component code and complaint code.

Auto Create Job Codes Based on Fleet ID - If checked, a job code will be automatically created based on repair shop and fleet for a component complaint code combination if a job codes does not already exist in the job code database for that component and complaint.

NOTE: Job codes can be assigned without associating it with a shop. This is a change from previous versions of TMT Fleet Maintenance/SQL.

Allow Employee Assignment without a Job Code - If this option is checked, an employee assignment can be made without entering a jobcode. This also applies to Mechanic Workstation. This option can be set globally or at the shop level. For this option to work correctly when checked, the options Auto Default Jobcode and Auto Create Jobcode must be unchecked.
Repairs - Overtime

Go to **Masters > Shops > Options > Repairs > Overtime.**

This form is used to set how overtime will work with repair orders and indirect charges for a specific shop. Initially, the options for a shop are the same as the global options set in **SysMgr > Options > Overtime.** This allows a global option change that will filter down to the shop level. Once an option is changed on the Options tab for a Shop, that option setting becomes local to that shop and changes at the global level will no longer have any effect for that shop.

**NOTE:** The overtime option may not be used with a shop (burden) rate selected on the Definition tab of the Shop Master.

The Overtime option turns on and off the overtime feature. If turned on, a group of radio buttons is displayed on the Labor Entry screen. These buttons enable the mechanic to select whether that entry is marked and charged at the Standard, Overtime, Holiday, or Weekend rate. The program then uses the labor rate setup for that mechanic for the correct rate.

**Allow Paygrade selection** - If checked, when a mechanic charges labor to a repair order, he can select the paygrade to be applied: Standard, Overtime, Week-end, or Holiday.

**Auto selection of weekend paygrade** - If checked, the weekend paygrade is automatically applied if the work is performed on a weekend.
Purchasing

Go to **Masters > Shops > Options > Purchasing**.

![Purchasing Options](image)

### On-hand based Re-Order Formula

- **If this option is not checked**, the requisition system uses the following formula:

  \[
  \text{If Quantity on Hand + Quantity on Order is less than or equal to the Trigger Point, then Re-Order Quantity is equal to the Target Point minus the Safety Point.}
  \]

- **If this option is checked**, the requisition system uses the following formula:

  \[
  \text{If Quantity on Hand + Quantity on Order is less than or equal to the Trigger Point, AND Safety Point = 0, then Re-Order Quantity is equal to the Target Point minus the sum of Quantity on Hand and Quantity on Order.}
  \]

**NOTE:** If Safety Point is greater than 0, then the standard formula is applied.

Unless you are running a very large central purchasing operation, there is no reason NOT to check this option.

### Expense supplies to indirect charges

- **If this option is checked**, when a part with a Part Type of Supplies is received on a purchase order, the total quantity received and total cost for the part is charged to an indirect charge order. The Indirect Charge is automatically closed and is dated the same as the PO Closed Date. If it is not checked, parts with a Part Type of Supplies are added as they normally are to shop inventory.

### Print bar-coded receiving labels

- **If this option is checked**, barcoded labels for parts are printed when the part is received into inventory. If it is not checked, barcoded labels for parts are not printed when the part is received into inventory.

### Use Shop Tax (instead of Vendor Tax)

- **If this option is checked**, the tax amounts for purchase orders is based on the tax rates set up on the Shop Master for the shop for which the purchase order is being created. If it is not checked, the tax amounts is based on the tax rates set up on the Vendor Master for the vendor that will be used for the purchase order.
Use external PO system - If this option is checked, it disables the recalculation of the quantity on order for parts so that information can be imported from an external PO system.

Don’t Allow Vendor Parts on POs - If this option is checked, vendor parts cannot be created on purchase orders. This is a global and shop level option.

Use Bid Prices for Vendor Price on PO - If this option is checked, the bid price for the vendor is used as the price when a part is created on a purchase order (for a vendor with a bid price).

Can Not Override Bid Price on PO - If this option is checked and the Use Bid Price Instead of Vendor Price option is checked, the price field is disabled if the part has a bid price for the selected vendor and you will not be able to change the price. The price can only be changed when the purchase order is received.

Require Payment Method - If this option is checked, it requires a payment method to be entered when creating a purchase order or a vendor repair order.

Print Custom Purchase Order Report - If this option is checked, when a purchase order or purchase receipt is printed, TMT Fleet Maintenance/SQL uses the Crystal custom purchase order report to present the purchase order data. The system will still print the normal account disbursement report if the option is selected or the report is selected.

Inventory
Go to Masters > Shops > Options > Inventory.

Default Bin - Designates an existing Bin as the default location for incoming Shop Inventory items. Each shop must have a default bin. If you add a default bin with a Bin ID that begins with an asterisk (for example, *NONSTOCK), it will be very easy to exclude that bin from a range of bins in your parts room when doing physical inventory counts.

Default Inventory Account - If an account type is entered, whenever a part is created in the parts catalog, shop inventory, or from a purchase order, the account
type will be defaulted to the value in this field unless a different account type has been set at the shop level.

If a value is entered at the global level, the shop level will be equal to this value. The shop level value can be changed to a different account; however, the shop level value cannot be null.

A value entered here overwrites the account type set on the parts catalog when a part in the parts catalog is created in a shop, unless the shop level account has been changed to something different than the global.

This field displays the Account ID, Account Type, or Account Description, based on the Global Account Type option.

**Track fuel in inventory** - If this selection is checked, it indicates that you maintain your company fuel inventory in this software system. If it is not checked, it indicates that you do not maintain your company fuel inventory in TMT Fleet Maintenance/SQL.

**Use Vendor from Parts Catalog** - When this box is checked, changes made in the Vendors tab in the Parts Catalog are updated to the Vendors tab in the Shop Inventory. If it is not checked, changes made in the Vendors tab in the Parts Catalog are not updated to the Vendors tab in the Shop Inventory.

**Allow Local Parts** - When this box is not checked, local parts cannot be created when the parts catalog is being used. This forces all parts in the shop inventory to come from the parts catalog. If the parts catalog is not being used or if you want shops to be able to set up local parts, the box should be checked.

**Allow Parts Transfers from Part Requisition** - If this option is checked, parts can be transferred to a shop to satisfy a parts requisition.

**Invoicing**

Go to **Masters > Shops > Options > Invoicing**.

**Enforce Invoice Estimate** - If this option is checked, an estimate amount is required to create a repair order for a customer.
NOTE: If the Enforce Customer Limits option is checked and limits are established for a customer, the invoice estimate is automatically required for that customer when creating a new repair order.

Show Running Invoice Prices on Repair Orders - If this option is checked and the repair order has a customer, a Price field is displayed beside the Total field at the bottom left-hand corner of the repair order with a running total based on the customer’s invoice price table. The running total does not include taxes and fees.

Labor Time Options - Sum Labor for Invoice by Job Code - If this option is checked, labor is summed based on the jobcode. A jobcode can have the following types of time – Flat Rate, SRT Time, User-Entered Estimated Time, and Estimated Time – set up on the jobcode master. When summing jobcodes on the invoice, the program checks the jobcode master and uses Flat Rate unless there is no Flat Rate time. If there is no Flat Rate time, the program uses SRT Time. If there is no SRT Time, the program uses a user-entered estimated time, which is entered when the assignment is created. If the user did not enter an estimated time, the program uses the estimated time set up on the jobcode master. If there is no estimated time for the jobcode, the system uses the sum of the labor hours on the section and creates a line with the description for the jobcode. If a section does not have any jobcodes, a single line for the total labor hours on the section is created on the invoice.

If two or more different job codes exist on a section, the invoice contains each job code and the time for each job code based on the Flat Rate, SRT Time, or estimated time rules described above. If two or more of the same job codes exist for a section, the invoice contains a single labor line for that job code and the time is based on the Flat Rate, SRT Time, or estimated time rules described above with the time being for a single job (not a sum of the time for the multiple job codes).

NOTE: If the same jobcode exists on two assignments on a repair section and an estimated time is entered on one of the assignments containing that jobcode but not the other assignment, the program treats this as two different jobcodes. Both assignments must have the same user-entered estimated time for the system to recognize this as the same jobcode.

If Actual cost for labor is used on the Invoice Price Table for the customer, the highest labor rate for each section is used as the cost basis for all labor time on that section.

The default setting is unchecked and disabled. This option is unchecked and disabled if either the Sum Labor by Paygrade Type or Make Minimum Labor Line a Separate Line option is checked. This option is controlled at the Global, Shop, and Customer level.

Sum Labor by Paygrade Type - If this option is checked, the labor lines are summed together by paygrade type of Standard, Overtime, and Weekend and a line is displayed for each type. The price is based on the paygrade type. If this option is not checked, all labor lines are rolled into a single line called Shop Labor and uses the base rate to calculate the price. The default for this field is checked. This option is controlled at the Global, Shop, and Customer levels.

Make Minimum Labor Line a Separate Line - If this option is checked and a minimum labor line is required to achieve the minimum labor hours, the minimum labor amount is displayed on a separate line. If it is not checked, the amount is
rolled into the Shop Labor line. The default for this field is checked. This option is controlled at the Global, Shop, and Customer levels.

**Min Labor Line Description** - If the *Make Minimum Labor Line a Separate Line* is checked, the description for that line can be user-defined. The default value is *Minimum Labor Adjustment*. This option is controlled at the Global, Shop, and Customer levels.

**Custom Invoice** - Using Seagate Crystal Reports, you can create a custom report for Repair Invoices and Direct Sale Invoices. After the Crystal Reports version of the report is created, you can check which TMT Fleet Maintenance/SQL reports will be replaced by a Crystal Report and the path to that Crystal Report. This option can be overwritten with a different custom invoice at the Customer Master level. If the Use PARADOX Tables for Custom Invoices option is checked, the system will use the Crystal Reports that were created using Paradox tables. If it is not checked, the system uses the Crystal Reports that link directly to the TMT Fleet Maintenance/SQL database. Use the Filename field to specify the file name of the Crystal Report you want to use.

*NOTE:* The path for a custom Crystal Report cannot exceed 60 characters.

**Printing**

Go to **Masters > Shops > Options > Printing**.

![Screenshot of Shops menu]

**Print Shop Name in place of Company Name on POs and Invoices** -
When this box is checked, the shop name is used on purchase orders and invoices instead of the company name.
Miscellaneous

Go to Masters > Shops > Options > Misc.

Do not create exceptions for valid meters - If checked, invalid meter readings that are imported using Data Import for the selected shop do not create exceptions. They are imported and marked ignored. If unchecked, invalid meter readings continue to create an exception.

Allow override of system generated Number - If this option is checked, the user can change the order number for any order created. If it is not checked, the order number field is disabled and cannot be changed, and sticky notes will not be available for the order numbers.

TINA (TMT Fleet Maintenance INterActive)

Go to Masters > Shops > Options > TINA.
Enforce Shift Times - If checked, an employee cannot log into Mechanic Workstation outside the assigned shift without entering an authorization code obtained from a supervisor. This option also enables buffer time and maximum allowable shift time.

Buffer Time - If this option is checked, you can enter a buffer time in minutes. The buffer time is used to determine whether the overtime feature should be triggered. For example, if the mechanic logged in 5 minutes late and 5 minutes is the buffer time, the overtime feature would not be triggered if the mechanic logs out 5 minutes late at the end of the shift.

Maximum Allowable Shift Time - If this is checked and the mechanic exceeds the maximum shift hours, when the mechanic logs in the next day, a warning is issued that maximum shift hours have been exceeded and the mechanic is not allowed to log into TINA. A supervisor must correct the problem before the mechanic can log in. If maximum shift hours were exceeded because the mechanic forgot to sign out on the previous day, the warning allows the mechanic to log off of the current job.

Print warranty part tags - If this option is checked, the mechanic is given the option to print a warranty tag when a part is added to the repair order. The label contains the repair order number, purchase order number, unit ID, shop ID, part number, date, meter, and component code.

Use Parts Workstation for Parts Requests - If this option is checked, the Parts Workstation module is turned on in TMT Fleet Maintenance/SQL. If Parts Workstation is enabled, the system also prompts to add parts on pick lists to the Parts Workstation requisitions for the repair shop and repair order. The prompt can be disabled, which causes the parts to be added automatically to the Parts Workstation requisition without any prompt if the Repair Order option Show Pick List Prompt is disabled. This repair order option will only be visible if Parts Workstation is in use. The Parts Workstation program will be used to fill all parts requests.

Auto Create Shop Plans - If this option is checked, when a repair order is
created, a corresponding shop plan is also created. If it is not checked, when a repair order is created, a plan is not automatically created. The default value is checked. This option is available at both global and shop levels.

Create plans when plan w/o RO Exists for a Single Unit - If this option is checked, a plan will always be created when a new repair order is created for a single unit. If it is not checked and a plan exists for a unit without an associated repair order, new plans will not be automatically created when a new repair order is created for that unit. This option works only if the option Auto Create Shop Plans is checked.

Mechanic Workstation

Require passwords at login - If this selection is checked, a technician logging into TMT Fleet Maintenance INterActive is required to enter a password. If it is not checked, a password is not required. Passwords are established on the TINA tab of the Employee Master.

Allow RO creation from within TINA - If this selection is checked, a technician can create a new RO from the TMT Fleet Maintenance INterActive workstation. If it is not checked, this function is disabled.

Allow Section creation within TINA - If this selection is checked, a technician can create a new RO section from the TMT Fleet Maintenance INterActive workstation. If it is not checked, this function is disabled.

Allow Paygrade Selection in TINA - If checked, when the mechanic charges labor in TINA, he can select the paygrade to be applied - Standard, Overtime, Weekend, or Holiday.

Show line item monetary amounts - If this option is checked, monetary amounts will be displayed in TMT Fleet Maintenance INterActive for repair orders.

Print TimeCards at logout - If this selection is checked, the Employee Time Card will be printed for each technician when they log out of TMT Fleet Maintenance INterActive. If it is not checked, the Time Card is recorded but not printed.
Allow Overriding of Estimated Times - If this option is checked, the mechanic can change the estimated time for jobcodes that have the option User Changeable checked. If this option is not checked, the mechanic is unable to change the estimated time for a jobcode within Mechanic Workstation, regardless of the User Changeable setting for that jobcode. The default setting is checked.

Require Cause and Correction Codes - If this option is checked, the mechanic must supply a cause and correction code before logging out of a repair order as complete or incomplete.

Only Allow Access to RO Assigned to Employee - If this option is checked, the ALL tab is disabled in Mechanic Workstation. This prevents a mechanic from seeing any orders except the ones that are assigned to him.

Allow Parts Requests - If this option is checked, parts requisitions can be issued by a mechanic using TINA.

Allow Job Pause - If this option is checked, a mechanic logged into Mechanic Workstation can click the Pause button to pause a job to work on something else without logging out of that job. When the mechanic returns and logs back in to Mechanic Workstation, he is prompted to add the paused time to a new repair order, to an existing repair order, or to an indirect charge, and then the time resumes on the job he was on before he used the Pause feature. If this option is not checked, the Pause button is not displayed.

All Labor Lines via TINA Only - If this option is checked, labor lines can only be entered on a repair order through Mechanic Workstation; the labor lines can be edited using TINA Edit, and labor lines cannot be deleted from the repair order using TMT Fleet Maintenance/SQL.

Allow closing of Repair Orders - If this option is checked, a mechanic has the ability to close a repair order that he is logged into when he logs out of the repair order by clicking on the Close button. If it is not checked, the Close button is not displayed.

Allow Vendor Lines within TINA - If this option is not checked, a mechanic is prevented from entering vendor-supplied parts and services when the section has a specified vendor.

Section Comments Read Only - If this option is checked, section comments can be viewed but cannot be added or modified within Mechanic Workstation.

Require Comment Lines to Complete RO - If this option is checked, a mechanic must enter at least one comment line before he can exit the repair order as either complete or incomplete.

Require Signoff on Checkoff Lists - If this option is checked and changes are made to the checkoff list, the mechanic is required to enter a password confirming that he made the change when he logs off the section. If a mechanic makes no changes, he is not required to enter a password to log off the section. This option works only if the option Require Passwords at Login is checked.
Parts Workstation

Allow Items to be moved to Pending orders - If this option is checked, the repair order can be closed if parts are on order, but not if the parts are on request. When the repair order is closed, a section warning dialog is displayed indicating that there are parts on order, with the option to move the section to a Work Pending or to abort the repair order close. If a pending order has parts on order, all the sections on that pending order do not appear in the Work Pending/PMs Due dialogs, nor be automatically created on a new repair order for the unit (Repair Order option Auto-Create Sections is checked) until the parts on order are received. After the parts are received for the pending order, the pending section can be selected or will be automatically created on a new repair order for the unit, but only in the repair shop for the shop that had the part. This applies to all sections on that pending repair order.

Print pending tags upon item request - If this option is checked, the system prints a Reserved Part Tag when receiving items that are associated with a Pending Order. This option works in conjunction with Allow items to be moved to Pending orders.

Disallow Purchase Order Access - When this option is checked, a mechanic cannot access the New PO form or the PO Search dialog from within Parts Workstation. This is a global and shop level option. Since the New PO and RO search icons are available on the Parts Workstation toolbar without a Parts Department screen with a shop selected, the global option should be checked and the individual shops unchecked to prevent unauthorized access.

Drivers Master

Go to Masters > Drivers.
The Driver Master maintains a list of drivers. A driver can be a Driver Only or an Employee/Driver. Drivers can be specified within the Road Call and Trip Tickets functions.

If an employee is a Driver Only, the driver’s record can be viewed only by using the Drivers Master. If an driver is an Employee Only or Employee/Driver, his master record can be viewed from both the Employees and Drivers Master records.

A Driver Only cannot charge labor against repair orders or charge labor in Mechanic Workstation.

Units can be assigned to drivers.

---

**Personal Information**

Go to Masters > Drivers > Personal Info.

The required fields on this form have an asterisk (*) next to them. The required fields for the Drivers form are:

- Driver ID
- First Name
- Last Name
- Shop ID
- Address
- City
- State
- Zip Code
- Status
- Hire date

Click the right mouse button in the Driver ID field to reveal a pop-up menu offering **Renumber Driver ID** and **Sticky Notes** features.
NOTE: If alphabetic characters are contained in a new Driver ID, those characters must be upper-case.

There are several informational fields such as phone numbers, emergency contact, and so forth. All fields can be used to generate reports through Crystal Reports.

NOTE: There is a field for Social Security Number, but be aware that without appropriate security control, it may not be wise to provide that information here.

The Status and Terminated fields are intuitive and work together. If the status is changed to TERM (terminated), the Terminated field will default to the current system date (you can change this date if necessary). If the terminated date is removed, the status will automatically become ACTIVE. If a date is typed into the Terminated field, the status will automatically become TERM.

NOTE: After a Driver master is saved, the First Name and Last Name fields become disabled. This is done to comply with DOT audit restrictions to prevent using the same Driver ID and changing the driver’s name.

To renumber a driver, right-click in the Driver ID field and select Renumber Driver ID. Enter a new driver number and click OK. Alphabetic characters contained in new Driver ID numbers must be upper-case.

Unit Assignments

Go to Masters > Drivers > Units Assigned.

The Units Assigned tab contains a list of units to which this driver is assigned. A driver does not have to be assigned to any units; no fields are required.
Right-click in the grid to assign a unit to the driver, unassign an assigned unit, or reassign a unit.

**Employee Master**

Go to **Masters > Employee**. The Employee Master File contains information for each mechanic, clerk or technician. This tabbed form contains the employee’s Work Shift, Personal Information, and Work History.

**Search for Employees**

From the Employees screen, click the Flashlight (Search) icon next to the Employee ID field. The Employee Search screen is displayed.

Click **Search** to display a list of all employees.
If the *Show RO Enabled Only* check box is checked, the list of employee records displayed will include only those employees who have the necessary permissions to create or update repair or purchase orders, shop plans, or assignments. If the box is not checked, all employee records are displayed.

If the *Show Terminated* check box is checked, all Employee records are displayed. If it is not checked, employees with a status of Terminated are not displayed.

From the Employee Search screen, double-click on an entry in the list to display the Employee master record.

**Personal Information**

Go to **Masters > Employees > Personal Info.**

The Personal Info tab is displayed when the Employee Master File is opened. Click the right mouse button in the Employee ID field to reveal a pop-up menu offering **renumber Employee ID** and **Sticky Notes** features.

![Employee Information Form](image)

The required fields for this form are denoted by the asterisk (*) next to the field name. The required fields for the Employee form are:

- Employee ID
- First Name
- Last Name
- Shop ID
- Classification
- Pay Grade
- Primary Shift
- Address
- Status
- Hired date
- City
• State
• Zip Code

There are several informational fields such as phone numbers, emergency contact, and so forth. All fields can be used to generate reports through Crystal Reports.

**NOTE:** There is a field for Social Security Number, but be aware that without appropriate security control, it may not be wise to provide that information here.

If a driver-only ID is entered in the Employee Master, an error message is displayed that the ID is already being used as a Driver ID.

The Status and Terminated fields are intuitive and work together. If the status is changed to TERM (terminated), the Terminated field will default to the current system date. If the terminated date is removed, the status will automatically become ACTIVE. If a date is typed into the Terminated field, the status will automatically become TERM.

To **renumber an employee**, right-click in the Employee ID field and select Renumber Employee ID. Enter a new employee number and click OK. Alphabetic characters contained in new Employee ID numbers are automatically converted to upper-case.

**NOTE:** You cannot make any other changes to employee information when you renumber. Any additional changes to the employee's information must be saved either before or after the Employee ID is renumbered.

Sticky notes associated with an Employee ID are automatically changed to and associated with a new Employee ID if *Renumber Employee ID* is used.

### Skills

Go to Masters > Employees > Skills.

This screen lists the employee's skill level using a list that you define. This could represent any state or federal certifications as well as Component certifications such as brakes, transmissions, and so forth.
The User Defined skill set contains a Description, Effective and Until dates, and a date of original certification. Add the employee skill codes in the Codekey section under Mechanic Skills.

**Shift Assignments**

Go to Masters > Employees > Shift Assignments.

Work Shifts for the Shops were added in the section for "Work Shifts" on page 81. This is where the Work Shifts that have been assigned to the mechanic are viewed.

The Shift is assigned in the Primary Shift field on the Personal Info tab. As the shift is changed, the history of the change is stored in the Shift Assignments form. The information available includes the Shift Name, dates the shift is effective, and the dates the shift was modified. The check box indicates that the shift is the primary Work Shift for the employee.
**Work History**

Go to **Masters > Employees > Work History**.

You can view the work performed by an individual employee by entering a date range. Type the starting and ending dates in the appropriate fields, then click **Search**.

The Repair Orders and Indirect Labor charges for that Employee for the specified date range are displayed. You cannot edit this grid. However, you can double-click a Repair Order to view the Repair Order detail.

**Tools**

Go to **Masters > Employees > Tools**.

You can view a list of tools that are assigned to the employee.
Misc

Go to Masters > Employees > Misc.

An employee can be assigned to a specific department and manager and given a Driver ID.

The Employee Type can be set to Employee Only, Driver Only, or both. If an employee is a Driver Only, go to Masters > Drivers to view the driver’s record. If an employee is an Employee Only or Employee/Driver, his master record can be viewed from both the Employees and Drivers Master records.

An employee’s TMT Fleet Maintenance INterActive (TINA) password is set using this screen.

If you have purchased TMT Fleet Maintenance INterActive and the International version, you can enter a language DLL here. Whenever this mechanic logs into Mechanic Workstation, the language specified here will be used.

If the RO Enabled check box is checked, the employee can enter labor charges on a repair order. If it is not checked, the employee cannot enter labor charges or be assigned to a repair order section.

The Manager ID is optional and is used to indicate the employee’s manager.

The Driver ID field is available only if the employee is a Driver/Employee or is being changed from an Employee Only to a Driver Only or Driver/Employee. The default value is the same as for Employee ID.

The Language.DLL field is used to select the language that is used when the employee logs into Mechanic Workstation. The default is English. To select a different language, click Browse. The additional language modules are available from TMT Software.

If the Allow Mechanic to go Remote field is checked, the mechanic is required to go remote from within Mechanic Workstation, which will synchronize the mechanic to a Palm device. When he returns to the shop, the mechanic must synchronize the Palm device back to the Mechanic Workstation, which uploads the mechanic’s remote activity.

NOTE: This option is only available if the Advanced Barcode module is installed. To utilize this feature, you must use Mechanic Workstation.
If the option *Allow Charging of Parts from Mechanic Workstation* is checked, this employee is able to charge parts using Mechanic Workstation.

**Unit Master**

Go to **Masters > Units**. The Unit Master file is one of the most important records in TMT Fleet Maintenance/SQL. This information determines the way that most costs in the system are defined. It is important to have complete information in all Unit Master file records. The Unit Definition is the default screen and contains the most common information for the Unit.

Click the right mouse button in the **Unit ID** field to pop-up a menu offering **Re-number Unit** and **Sticky Note** options. Alphabetic characters used in Unit IDs must be upper-case. If a unit is renumbered, any sticky notes associated with that Unit ID are also renumbered with the new Unit ID.

The information in the Sticky Note is displayed when you exit the Unit ID field for this unit anywhere in TMT Fleet Maintenance/SQL.

You can easily *clone* units (create new unit definitions that are based on current units). TMT Fleet Maintenance/SQL copies all applicable values, including user-defined values on the User Fields tab, from the original unit to the cloned unit. The values are not seen, however, until the newly created unit is posted (by pressing F6). The information contained on the Meters, Fluids, Specs, PMs, Warranty, and License tabs are copied. Only items that do not already exist on a tab for the receiving unit are cloned; existing information is not changed, updated, or deleted.

**NOTE:** You can define only the number of units that are licensed for TMT Fleet Maintenance/SQL. If this value is exceeded when you attempt to add a new unit, a warning message is issued and the unit will not be added. This unit limit value is shown in the Unit Limit field in **SysMgr > Options > License**. For more information, see “License” on page 54.

**Unit Definition**

Go to **Masters > Units > Definition**.

The Unit definition tab contains the most common information for a Unit.

**NOTE:** The **Customer ID** field can only be used if the Invoicing Module is enabled.
An asterisk (*) next to the field name indicates a required field. The required fields, except for the domiciled location (Shop ID), are set up in the Codekey section.

When you install TMT Fleet Maintenance/SQL, it is very important to carefully design the required fields in this screen. You can change the fields at any time and in some cases, the system tracks the history of changes made.

In order to start creating Unit Master records, the Shop and Company Master must be set up as well as the necessary Codekey values. The Notes icon can be used to access a text memo field that can retain any text information you want to associate with this unit. This feature can be used as a unit “bulletin board.”

The License field on the definition tab is the field referenced by the Unit Search form License field.

The In Service Date field is a required field regardless of whether you are creating a new unit or cloning another unit. It is used to populate the Warranty tab as well as the Last Done date for PMs when PM Levels are created or cloned from another unit. The default In Service Date is the system date for the day the unit is created or cloned. It can be changed to a different date if necessary.

When you clone a Unit Master, the VIN/Serial Number and License Tag are not copied to the new unit master. You must enter the data for these fields yourself.

Alphabetic characters in Unit IDs must be upper-case. Alphabetic characters in the VIN Number field are automatically converted to upper-case.

**Unit Meters**

Go to **Masters > Units > Meters**.

The Unit Meter tab shows the meters associated with the particular Unit ID. The Meters on this screen are automatically added to the Unit Master according to the Unit Type field entered on the Definition tab according to the setup performed in Chapter 3. Defining the Meter Groups is also important in the setup process.
You can add a new Unit Meter from within this form at any time by pressing **CTRL+ INS**, or **right-click and select insert from the pop-up menu**. It uses the Meter Group definition only when the Unit Master record is created.

The **meter type** is listed with the unit of measure used for that meter. The **position** of the meter is listed when multiple meters of the same type are required. It also shows the **maximum daily average change** for that meter reading. This warns you when entering more mileage or other utilization than is probable. This reduces mistakes and ensures better data integrity.

The date when the Meter was last updated by the system and the Meter reading are in the next two columns. The last three columns indicate if the Meter is the primary Meter and if the reading is required on either the Repair Order or the Fuel Ticket or both.
**NOTE:** NEVER require a non-physical meter reading on Repair Orders or Fuel Tickets.

If the meter is non-physical, the meter history can be viewed by clicking the History button in the Reading field.

We recommend creating a Days meter for all units, a Fuel meter for all powered units, and any physical meters installed on unit with those meters.

The primary meter determines the default utilization on many reports. A primary meter must be selected in order for any reporting, including PM scheduling, to function.

You cannot add a meter to the Warranty tab for lifetime warranty utilization unless that meter exists on the Meters tab of the Unit Master. The only exception is Months, which can be selected if it is not set up on the Meters tab of the Unit Master.

The *Life To Date* meter value is displayed by default.

**Unit Fluids**

Go to Masters > Units > Fluids.

The Unit Fluids form lists all fluids associated with the unit for which consumption reporting is desired. Only fluids defined for the unit here can be charged on a Fuel Ticket. The Fuel Ticket order is the source of consumption reporting. The capacity field is only for your information. The Primary Fluid determines the default fluid for the Fuel Ticket order form, which in most cases should be the fuel consumed in the greatest quantity.

When a fuel ticket is added for a unit, the Last Added date is updated for the fuel type of the fuel on the fuel ticket.

Fluids can be added by pressing **CTRL + INS** or right-clicking to select **Insert** from the pop-up menu. Fluids are assigned by Unit Type as set up in Chapter 3.
If you add a Fluid to a unit, the Fluid Type and Unit of Measure (UOM) are both required fields for that fluid.

**Unit Specification**

Go to **Masters > Units > Specs**.

The Unit Specification (Specs) tab contains a list of the Components for this Unit ID. You cannot edit the specification grid directly.

To add or insert a Component to the grid, right-click the grid and select **Insert**.
From this form, you can search for a component by clicking on the flashlight. This displays the **Component Search** screen shown in the next section. On this screen, you can enter the necessary component. The specification box with the manufacturer’s number can also contain any additional component information fields you may design. For more information, see Chapter page 277.

**Component Search Option**

From the Component Master, you can search for a specific component by the component number or a text string. Type in the text string and click on **Search**. You can also search by number and description. The example shows the search results when **TRANSMISSION** was entered in the Description field.

Depending on the criteria you enter, some of the search fields might be disabled. Only those fields that can be used to select appropriate data are enabled. For example, you cannot choose an Assembly until a System is selected.
If you need to enter Extended Warranty information on a component that has a warranty, the **Extended Warranty** button accesses the Extended Warranty record form. This form is discussed further in the section about "Unit Warranty" on page 122.

**Unit PMs**

Go to **Masters > Units > PM**.

The Unit PM tab contains the preventive maintenance setup for the Unit ID. The PM setup is automatically set up for a Unit by Unit Type from the PM Groups when the Unit Record is created.

The PM form shows the Dependent and the Independent PMs that were scheduled for this Unit ID. The last PM date and meter scheduling intervals are shown in the grid box. If a meter interval of 0 is specified, the unit is not scheduled by that meter.

Double-click on the PM system code (or select **Edit** from the pop-up menu that is displayed when you right-click the mouse in this form) to modify the PM. The **Dependent PM Schedule** screen is displayed. When Last done dates are added to the PM record, you are prompted to provide any needed meter readings for the dates provided when you click **OK** on the dialog box.
To insert or delete a PM, right-click in the corresponding PM grid and select Insert or Delete from the pop-up menu, or press CTRL + INS to insert a new PM or CTRL + DEL to delete the selected PM.

When inserting dependent PMs, you must be sure to add the PM codes in the order in which you want them done.

NOTE: When Units are assigned to work shifts and scheduled for PMs by Days, only those days of the work shift when the unit works are counted to schedule the next PM.

Unit Warranty

Go to Masters > Units > Warranty.

The Warranty tab displays the Unit’s warranty information. This form shows the OEM Warranty at the top of the form, and the Extended Warranty in the grid on the lower half of the form.
The OEM Warranty is sometimes referred as the glove box or bumper-to-bumper warranty. The In Service date is displayed with the maximum warranty coverage amount for each meter, and is a required field.

Select any meters for which you want to track Life to Date utilization. When you press F6 to save the record, you will be prompted to provide a Meter In Service reading for each physical meter selected. This provides the starting point for utilization tracking.

The Extended Warranty list-view grid box is for each Component. To add information, right-click in that section and select Insert.

When the Unit screen that contains the Extended Warranty information is displayed, you are prompted for the component and the warranty information for that component. Select meters matching the warranty stipulations for the component and provide a warranty lifetime for each meter. The Start Date should reflect the beginning date of the component warranty. On a new unit, this will be the same as the Unit In Service date.

On repair orders, a Vendor ID is required for an OEM warranty if a meter is added for warranty. A Vendor ID is required for an Extended warranty unless the component is marked as expendable.

If the Expendable field is checked, any warranty meters and lifetime amounts are erased, and the part is ignored for warranty.

**Unit Cost**

Go to Masters > Units > Cost.

You can enter the information for the unit and display the depreciation of the unit based on a monthly, yearly, and total value. The Base Date is the date when the depreciation starts. These fields retain the fixed cost of depreciation for reporting purposes.
Unit Shifts

Go to Masters > Units > Shifts.

The standard grid box in the Unit Shifts tab shows the current Work Shift and the Work Shift history for the Unit ID. The Unit Work Shift determines the down time and whether the Unit is available for service or is working.

**NOTE:** When Units are assigned to work shifts and scheduled for PMs by Days, only those days of the work shift when the unit works are counted to schedule the next PM.

![Image of Unit Shifts grid box]

The View button on the bottom right-hand side of the form displays the Work Shift Master form.

![Image of Work Shift Master form]
**Unit Groups**

Go to **Masters > Units > Groups**.

You can display the current and historical group assignments for:

- Unit
- Activity
- Cost Center
- Department
- Division
- Domicile
- Shop ID
- Customer
- Status

As these items change, the history of the employee who made the changes is maintained in the Changed and Changed By columns. The history is displayed if the **Show History** check box is checked.

---

**Unit Licenses**

Go to **Masters > Units > Licenses**.

The **Unit License** form enables you to track expiration dates for vehicle registrations, fuel permits, DOT stickers, and any other periodically renewable forms of license or fixed cost.
To add a new license, press **CTRL + INS** or right-click in the form and select **Insert**. The Insert Unit License screen is displayed.

The License Type is a codekey. License Types can be added to provide a means to record fixed cost information like insurance or business property taxes.

**Miscellaneous Information**

Go to **Masters > Units > Misc**.

You can use the Misc tab to keep track of the physical location of each unit.
These fields are tied to the Shop Planner. The fields can be left blank without affecting any TMT Fleet Maintenance/SQL functionality, but will become populated if the corresponding entries are made in the Shop Planner. Reassignment of a domicile shop on the Unit Master Definition tab will not update the Physical Shop Location on the Misc tab.

**Unit’s Physical Location** - This is the *current* physical location of the unit (for example, In-Shop, On-Road, or Deadline). Changes made to this value in the Shop Planner update this field in the Shop Master when plans or work orders are created or closed. External systems (like dispatch systems) can interact with this field in order to populate the TMT Fleet Maintenance/SQL program with physical location data.

**Unit’s Physical Shop Location** - This field identifies the current physical Shop location where the unit is located. It can be in the shop or yard of a non-domicile shop. The Shop Planner updates this field in TMT Fleet Maintenance/SQL when plans or work orders are created or closed. This field can be updated from external systems (like dispatch systems) that enter data when a unit enters a shop’s yard or shop location.

**Loaner** - This box can be checked when the unit is designated as a loaner unit, which enables you to loan out units via the Shop Planner.

**Asset Number** - This field contains an asset number that you supply.

**Weight** - This field contains the weight of the vehicle.

**Color** - The color of the unit, specified via a drop-down menu. Colors can be added by typing in the field, or by adding them to the setup in `SysMgr > Setup > Codekeys`.

**Parking Facility** - The location where the unit is parked when not in use.

**Parking Facility Name** - The name of the parking facility where the unit is stored.

**Parking Slot** - The number of the parking space where the unit is parked.
**Unit Manager** - This field contains the name of the manager to whom the unit is assigned, if appropriate.

**Price Table**

You can assign an invoice price table to a specific unit. If a price table exists on the unit, that price table is used when an invoice is created from a repair order. If a price table does not exist on the unit, then the price table for the customer is used when the invoice is created from a repair order.

**After Market Warranty**

Go to **Masters > Units > After Market**.

This form displays a list of the repair orders that contain after-market part warranty records for this unit.

Right-click anywhere in the grid to view associated repair orders, print a detail report, or print a section detail report. The displayed data can be printed or exported. The after-market warranty record can be marked Inactive; marking a record as Inactive removes it from the potential warranty.

**Drivers**

Go to **Masters > Units > Drivers**.

This screen displays a list of drivers who are assigned to the unit.

This information is used in the Road Calls module when entering the Unit ID to select the appropriate driver, or when entering the Driver ID to select the appropriate unit.
To assign another driver, right-click anywhere in the grid and select Assign Driver. To remove a driver assignment, right-click and select Unassign Driver.

Units User-Defined Fields

You can add or update user-defined fields using the User Fields tab.

To define a new field, or rename a field, click Define Field. To add graphic images or documents associated with this unit, click Image.

To make it easier to locate renamed user-defined fields, the Codekeys list in SysMgr > System Setup > Codekeys displays Type UDF # after the Description for a renamed field. For example, if the Unit UDF 1 field was renamed Boom Serial...
Number, it is displayed in the Codekeys Explorer as *Boom Serial Number (Unit UDF 1)*.

**Vendor Master**

Go to Masters > Vendors. The Vendor Master Files are required to create the Parts Catalog and Parts Inventory records, and to use the purchasing system. A Vendor is any company that supplies a shop with parts, tires, fluids, or services.

Click the right mouse button when the cursor is in the Vendor ID field to pop-up a menu offering Renumber Vendor and Sticky Note options. Alphabetic characters used in Vendor IDs must be upper-case. If a vendor is renumbered, any sticky notes associated with that Vendor ID are also renumbered with the new Vendor ID.

The information in the Sticky Note is displayed when you exit the Vendor ID field for this vendor in TMT Fleet Maintenance/SQL.

**Vendor Definition**

The required fields for adding a Vendor Master are:

- Vendor ID
- Vendor Name
- Vendor Type
- Currency

The Definition tab displays additional information that you might need to order parts - for example, Address, Phone/Fax, Terms, and so forth.

If the Payment Method field contains a value, when a purchase order is created for this vendor, the payment method on the purchase order defaults to the value in
this field. Values are available from a drop-down menu and are set in SysMgr > System Setup > Codekeys > Payment Method. If the ComData module is installed, you can accept ComChecks or ComData MasterCards.

The Warranty Markup field designates the warranty markup table used to establish the correct warranty reimbursement rates for your company with this vendor. This issue is discussed further in “Setting up the Warranty Claims Module” on page 325.

The Vendor Rating field can be a value from 1 (the default) to 10. You can also enter a National Account Number.

If the vendor was created from the NATC Vendors, the NATC Vendor check box is checked. Also, NATC vendors can be linked to TMT Fleet Maintenance vendors; however, this can be done only when the NATC import is performed.

If the On-Site Service check box is checked, the vendor provides on-site service.

Search for Vendors

To search for vendors, click the Flashlight icon next to the Vendor ID field. A Vendors search screen is displayed.

![Vendor Search Screen]

To work with the master record for a vendor displayed in the list, double-click on the Vendor.

NATC Locator

If your company purchased the NATC Locator module, the Locator button is displayed. This provides access to the Service Locator search, which enables searching for an NATC vendor using telephone number, city/state, latitude/longitude, and name. The search results will be shown by distance from you.
but the columns are customizable and can be rearranged by any criteria. You can also resize the columns and by right clicking and selecting customize columns you can add and delete columns from the results screen. After an NATC vendor is located, that vendor can be imported into the TMT Fleet Maintenance vendors.

The **Locator** button displays the NATC vendor information for a Locator Vendor when a vendor is double-clicked in the Service Locator screen.

After a vendor has been imported into TMT Fleet Maintenance, some (but not all) fields can be edited. The editable fields include Hours of Operation, Contact Information, Comments, Opened 24 Hours check box, and Service Type. The reason only imported vendors can be edited is so that the original NATC-provided information is not changed.

When the **Locator** button is used from the **Vendor Search** screen, the **Service Locator** screen is displayed.

This allows an NATC vendor to be located using the following:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Search Radius</td>
<td>Determines the radius to search for vendors. This field is relevant only to searching by Telephone, City/State, and Lat/Long. Valid choices are 10, 25, 50, 75, 100, 125, or 150 miles.</td>
</tr>
<tr>
<td>Telephone</td>
<td>Enter an Area Code and Exchange (first 3 number after area code)</td>
</tr>
<tr>
<td>City/State</td>
<td>Enter a city and state.</td>
</tr>
<tr>
<td>Lat/Long</td>
<td>Enter a Latitude and Longitude. Both decimal and degree/minute/second formats are supported.</td>
</tr>
<tr>
<td>Name</td>
<td>Enter any text to find that text in the Name field of the vendors. Can be restricted to a particular state. Use % as a wildcard; for example, to find</td>
</tr>
</tbody>
</table>
all vendors with the word “tire” in their name, enter %tire%.

<table>
<thead>
<tr>
<th>Details Section</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
</tr>
<tr>
<td>Enter a vendor category. Valid choices are</td>
</tr>
<tr>
<td>Engine Repair, Fuel, Leasing, Other, Preventive</td>
</tr>
<tr>
<td>Maintenance, Reefer, Tires, Towing, Trailer,</td>
</tr>
<tr>
<td>Transmission, Truck Dealers, Truck Repair, and</td>
</tr>
<tr>
<td>Truck Wash.</td>
</tr>
<tr>
<td>Brand</td>
</tr>
<tr>
<td>Further restricts the selected category. The field values change depending on which category is selected</td>
</tr>
<tr>
<td>Open 24 Hours</td>
</tr>
<tr>
<td>Restricts the search to only those vendors that have information in the 24 Hour field.</td>
</tr>
<tr>
<td>Road Side Service</td>
</tr>
<tr>
<td>Restricts the search to only those vendors that have information in the Road Service field.</td>
</tr>
<tr>
<td>Note</td>
</tr>
<tr>
<td>Enables searching on the Note field.</td>
</tr>
</tbody>
</table>

**Adding a NATC locator Vendor to TMT Fleet Maintenance**

To add a vendor from the NATC Vendors database to TMT Fleet Maintenance, select a vendor in the grid and click **OK** on the Service Locator screen. The Vendor Master screen is displayed with the information from NATC.

The Vendor ID defaults to the first 12 characters of the vendor’s name and can be changed before posting to adhere to your company’s vendor ID scheme. Make any necessary changes to the vendor and then post. the Vendor Master form closes and the vendor added is displayed in the Vendor Search screen.

**Link a NATC Locator Vendor to a TMT Fleet Maintenance Vendor**

You can also link an NATC Locator Vendor to a TMT Fleet Maintenance vendor that already exists in the Vendor Master. To do this, enter a current TMT Fleet Maintenance vendor ID in the Vendor ID field.

If a link has already been made to an existing TMT vendor, a warning is issued asking you to confirm re-linking to the selected vendor. If no link has been made, a prompt is displayed showing the address information from TMT Fleet Maintenance along with the option to confirm the link or cancel it.
Viewing NATC Vendor Information

To view an NATC vendor’s information, double-click on a vendor. The Locator Vendor screen that is displayed shows all of the vendor fields.

If the vendor has already been imported into TMT Fleet Maintenance's Vendor master, a green check mark is displayed in the lower left corner next to the words **Imported to TMT Fleet Maintenance**. Immediately after that will be a box with the TMT Fleet Maintenance Vendor ID in it. The **Import** button is disabled, and the **Edit** button is enabled.
If the vendor has not been imported, the **Import** button is enabled, the **Edit** button is disabled, and the NOT symbol (red circle with a line through it) is displayed in the lower left corner next to the words **Imported To TMT Fleet Maintenance**.

### Updating NATC Information

To update the NATC data, go to **SysMgr > Service Locator > Update**. **Note:** You must have system administrator rights to import NATC vendors.
Update File(s) Location - The location of the update files that are to be imported.

Update Button - Updates TMT Fleet Maintenance with the vendor information.

View Button - Updates the Files to Update window with the files left to be updated.

Error Log Button - After the import is complete, click the Error Log button to display any errors that were encountered during the import process.
E-commerce/E-Mail Adapter

If the E-Commerce/E-Mail Adapter module is installed, an extra field, **EPurchChk-Fld**, is displayed on the search screen.

A check mark in this field next to a vendor indicates that the vendor has e-purchasing set up for a shop on the Accounts tab in the Vendor master.
Contacts

Go to Masters > Vendors > Contacts.

The Vendor Contacts tab shows a standard list box of the contacts for the Vendor ID. This list is unlimited in size and contains the name, telephone number and extension of vendor contacts.

Taxes

Go to Masters > Vendors > Taxes.

The Taxes tab shows the taxes associated with this Vendor ID. Taxes are sorted in Sequence order, then Tax Code name order.
The Tax Codes selected on this form are applied to items purchased from this Vendor in the Purchase Order system if:

- no Shop Tax Rate is designated, OR
- the Purchase Order Tax Resolve tab in **SysMgr** **Tax Rates and Fees** indicates a preference for the Vendor Tax.

Select the **Tax Calculation Method** appropriate for your local tax regulations, **Standard (Side-by-Side)** or **Tax on Tax**. After Shop and Vendor Tax Rates are selected, go to **SysMgr > Tax Rates and Fees** to resolve which tax rate to apply, depending upon the requirements of your local tax laws.

Add the **Tax Code** and **Description** using the drop-down edit box in the Tax Code field.

**NOTE:** The tax rate entered on the Vendor Master is used by the purchase order system as the default tax rate, instead of the shop’s tax rate.

### Accounts

Go to **Masters > Vendors > Accounts**.

This form assigns Vendor Account numbers to each shop. The account number of the generating shop will print on each Purchase Order. This makes it easier for vendor to bill the correct shop for their purchases.
You cannot add the same shop to the Accounts tab more than one time. Each line must have a unique Shop ID.

**Services**

Go to **Masters > Vendors > Services**.

The Services tab defines what services the Vendor provide and the associated cost for these services. There is also a check box that tells the system if the service is taxable.

**Remit**

Go to **Masters > Vendors > Remit**.

Use this form to enter a "remit to" address for the vendor. A remit to address is printed in the Remit To section of a purchase order underneath the vendor name.

*NOTE:* If any value is entered in the upper Address field, the Remit To address is printed.
The **AP Remit Code** field is a 24-character field used for the Great Plains accounting interface. The value in the field is not validated. This value is exported instead of the Vendor ID. This is useful when payment is made to a corporate office instead of the local vendor.

**Inactive Vendors**

You can specify vendors that are inactive.

Inactive vendors cannot be selected from the Vendor field or vendor search and will no longer be included in reports. Inactive vendor purchase orders can still be searched from the Order Inquiries or Purchase Order Query screens.

A vendor cannot be made inactive until there are no open purchase orders and no parts with the vendor marked as the primary vendor.

To make a vendor inactive, right-click on the Vendor ID and select **Set Vendor Inactive**.
Parts Catalog Master

Go to Masters > Parts Catalog. The Parts Catalog provides reference information about parts stocked in a Shop inventory. Kit definitions can be created at the Parts Catalog level. Superseded and substitute part cross-references are added at this level as well. Even if you have only one shop, the catalog is the source for all cross-references, and is therefore very important.

The information in the Mfg Code and Mfg Part ID field in the Parts Catalog, if it exists, is copied to the same fields for the part in Shop Inventory on the Vendors tab. For this to happen, the Use Vendor from Parts Catalog check box must be checked.

Click on the right mouse button in the Part ID field to pop-up a menu offering Renumber Part and Sticky Note options. The Sticky Note option is also available in the Component Code and Manufacturer fields.

Alphabetic characters used in Part IDs must be uppercase. If a part is renumbered, any sticky notes associated with that Part ID are also renumbered with the new Part ID.

The information in the Sticky Note is displayed when you exit the appropriate field anywhere in TMT Fleet Maintenance/SQL.

When a change is made to the Manufacturer or the Manufacturer Number on the Parts Catalog, all corresponding parts in the catalog are automatically updated. Manufacturers that are inactive (using codekeys) are not displayed in the Manufacturers drop-down dialogs and cannot be selected.

Obsolete parts can be deleted from the Parts Catalog. When the part is deleted in the Parts Catalog Master, that part is also deleted in all shops containing that part as long as there are no parts on hand for the part in any shop. A part cannot be deleted if the part is on an open indirect charge, an open repair order, or an open purchase order. If a part has a quantity on hand or quantity on order greater than
zero, the part cannot be deleted. It also prevents parts from being deleted outside of the TMT Fleet Maintenance/SQL client.

If a part is a parts catalog part, the component code is controlled by the Parts Catalog master. The component code cannot be changed in the shop inventory, and any change to the component code on the Parts Catalog will change the part's component code for all shops.

A part ID must start with a valid alphanumeric character and it must be uppercase. A leading blank is not allowed.

The Part ID field uses the AUTOCROSS feature as outlined in “Part Cross-Reference” on page 147. If a substituted or superseded part ID, component code, or manufacturer part ID is entered in the Part ID field, the correct TMT part is selected. If more than one part has the substitute or superseded part ID, component code, or manufacturer part ID that was entered, a list is displayed that enables selecting the correct part.

**NOTE:** *Substitute and superseded parts cannot be created as a new part.*

Four user-defined fields are available for parts. User-defined fields are displayed on the Definitions tab if a value was entered for them in **SysMgr > System Setup Codekeys > Part User Defined Field 1 through 4.**

**VMRS Lookup** - Whenever you add a new part to TMT Fleet Maintenance/SQL and the Part ID matches a part ID for more than one vendor in the VMRS table, the Resolve VMRS Part dialog is displayed. This dialog enables you to select the appropriate part ID for the correct vendor and click **OK.** The VMRS lookup feature is available only if VMRS codes were imported for vendors and the option **Lookup VMRS Codes for New Parts** is checked in **SysMgr > Options > Inventory.**

**Importing Parts Information**

You can import parts information from a number of vendors into the Parts Catalog using TMT Fleet Maintenance/SQL’s import function. The import process only adds or updates parts in the Parts Catalog - it is not used to delete parts. You can also update the supplier information for the part when performing the import. A part import can be run automatically during off-shift hours, or it can be run attended. Part information that cannot be correctly imported can be corrected as part of the process. If a part import is run unattended, an e-mail function enables a log file to be sent to an employee or list of employees notifying them about the status of the import job. For more information, see “Importing and Exporting Data” on page 345.

**Parts Catalog Definition**

The Definition tab lists the part information. Remember this is a catalog Master and not the actual inventory in the Shop’s stock.

The Definition tab lists the VMRS Component Code, the manufacturer of the part, and several other part characteristics. After-market part warranty is tracked by the full 9-digit component code.
The **part classification** determines if the part is Standard, a Tool, Kit, Fluid, Tire, or Supplies, or other part type that your company has added. If the Part Type is **Fluid**, a separate Fluid Type drop-down edit box is displayed below the Part Type field. If the part type is Fluid, you must also select a Fluid Type code.

All parts must have an **Account Type** selected so that part transactions can be reflected in a period close. Select an appropriate account type for the part. This is a required field. The account number can be changed on the Parts Catalog master at any time. When the account type is changed, it only changes the Parts Catalog record.

**NOTE:** An **Account Type** must be unique. Two account IDs cannot have the same account type assigned to them.

The **Inventory Method** is defined in the selection box in the lower left-hand corner of the form. If no boxes are checked, the part is a **non-stock** part. The part can also be a **Stocked** or **Consignment** part. The Inventory Method provides sort categories for parts. There is also a place for core tracking information. This field is an information field only.

The **RO Requirements** section enables **position**, **component match**, or **serialized part** requirements on the repair order.

- If the **Position** check box is checked, a position is required when charging the part on repair orders.

- If the **Component Match** check box is checked, the part’s component code must match the section’s component code when charging the part on a repair order. If the section code is a system code, the part can be included as long as the part’s system code matches. If the section’s component code is an assembly code, the part’s component code must include that system and assembly. For example, if the section component code is 016, then a part with 016-001, 016-001-001, or 016-002-001 are allowed. If the section component code is 016-001, then only parts with 016-001-xxx are allowed.
If the Serial Part check box is checked, a serial number is required on a repair order when installing the new part. The old serial number is recorded, but is not required.

Changes made on the Parts Catalog are filtered down to all shops containing that part; however, the setting can be changed at the shop level.

You can enter the Warranty Information for this part in the Warranty Information area. This tracks the warranty for the item as it is used in the system. Specify the meters and lifetimes as specified by the warrantor of the part. Part warranty is tracked by the 9-digit VMRS component code. Be sure that if warranty information is provided, that the complete and correct VMRS component code is provided. You can also indicate if the part is expendable.

If the global system option Use VMRS Descriptions as Part Description is enabled, when a new part is created and the component code is entered, the description for the part is automatically populated with the description for that component code. For example, if 034-001 is typed into the component field, the description will become Headlamps.

If the check box for the Expendable Item field in the Warranty Information section is checked, the Meter Type and Lifetime fields are disabled and this part will not create potential warranty records for part level warranty.

Searching the Parts Catalog

In the Parts Catalog master, click the Flashlight icon next to the Part ID field. The Parts Catalog Search dialog box is displayed.

Click Search to search the parts catalog.
Click Advanced Search to display the Part Unit X-Reference Search dialog box.
This enables a part to be searched based on the unit cross-reference information entered in the parts catalog master and some of the parts definition information. The following Parts Master fields can be queried: Part ID, Part Type, Manufacturer, Part Description, Mfg Part Number, and Component Code; cross-reference fields that can be searched include Component Code, Narrative, Make, Model, Model Year, Engine, Capacity, Wheelbase, Unit Type, Activity, and Unit User-defined Fields 1 through 8.

**Renumber a Part**

You can renumber a part through the Shop Master if the part is a local part, or through the Parts Catalog if the part is contained in the parts catalog. This is useful if the part is a superseded part, or if there were duplicate entries in the parts catalog for the same part using different Part IDs (for example, 123456 and 123-456).

1. Go to **Masters > Parts Catalog**.
2 Click the Flashlight icon next to Part ID to display a list of parts.
3 Find the part that you want to renumber and double-click the part.
4 Right-click in the Part ID field on the Parts Catalog master and select Renumber Part ID.

5 The *Renumber Part ID* dialog box is displayed. Enter the new Part ID, update any options as necessary, and click **OK**.

6 A confirmation message is displayed asking if you want to post the change. Click Yes to save the change, or No to discard the change.

The procedure is the same for renumbering from the shop inventory master.
Parts Catalog Kit Configuration

If the Part Type of the part is listed as **KIT** on the Definition tab, you can define existing parts used in the Kit on the Kit Config tab. The Kit functions as a data entry shortcut when charging parts for routine work. When you enter a kit on a Repair Order, the actual parts used in the kit are exploded as individual part charges.

The following figure shows the Search window available on the Part ID.

---

Part Cross-Reference

The **X-Reference** tab retains the part cross-reference numbers and superseded Part Numbers for a given part.

Our patented AUTOCROSS® feature uses the information in the superseded and cross-reference grids. The AUTOCROSS program is used in the Repair Order and other programs when part resolution is needed. The AUTOCROSS routine checks
the parts inventory, superseded part numbers, cross-reference numbers and the VMRS System-Assembly-Part number to find any match. If more than one match is available, a part resolution screen appears and you must select the correct part.

The name of the user who created the part in the Parts Catalog and the date when it was included are displayed in the grid for substitute parts and superseded parts. This enables tracking and accountability for updates and changes.

Parts Catalog Vendors

List the vendors from whom this part is available. Indicate the preferred source by checking the Primary check box. The requisition system uses the Primary Vendor when suggesting a reorder. Different shops can use different Primary Vendors.
Double-click on a vendor in the list to access the Part Vendor screen. This screen enables you to enter price, target point, quantity unit of measurement, manufacturer code, manufacturer part ID, and bid information for the part.

**NOTES:**

A part type of Kit cannot be used in a Vendor Part Master.

A part type of Kit cannot be transferred to another shop. Only individual parts can be transferred.

**Parts Catalog - Shops**

The Shops tab in the Part Catalog shows where each part is inventoried in your company. There is a line for each shop in which the selected part is inventoried. This shows the current quantity on hand, quantity on order, and last cost at that shop.

If the **Add Parts to Local Inventory** button is clicked, the Add Parts to Local Inventory screen is displayed.
This form displays a list of those parts that exist in the Parts Catalog but do not exist in the specified shop as an inventory part. You can select one or more parts to be added to a local shop’s inventory. After selecting the appropriate shop, select or de-select parts by holding down the **CTRL** key as you click on the items to be select or de-selected. The parts selected are added to the chosen shop’s inventory records.

![Add Parts to Local Inventory](image)

The **Add Current Part to Local Inventory** button works in a similar way, but only the currently-selected part is added.

Shops where the part already exists in local inventory are not available in the drop-down Shop list.

**Parts Catalog Unit Cross-Reference**

The Units Cross Reference tab enables you to cross-reference a part to a unit. The cross-reference record can be created using any combination of the following fields: **Narrative, Make, Model, From Year, To Year, Engine, Capacity, Wheelbase, Unit Type, Activity, Component Code**, and **Unit User-Defined Fields 1 through 8**. If no From Year or To Year information is entered, the system assumes all years apply. If you click the Advanced Search button on the **Shop Inventory Search** or the **Parts Catalog Search** screens, the system uses this information to search for parts.

**Updating Parts Prices**

To update parts prices:
1. Select the Shop ID to update. If a shop is not selected, all shops are updated.
2. Select a part manufacturer to update. If a manufacturer is not selected, all manufacturers are updated.
3. Select a price category to update by the entered markup amount. If a price category is not selected, all price categories will be updated to the markup amount entered. For example, if you have three price categories - Wholesale 10%, Retail 25%, and
Employee Discount 15% - and need to mark up your Fram air filters by 10%, if you do not select a price category, all three price categories will be changed to 10%. If a price category is identified, that category is marked up with the 10%.

4 Select a component range to update. If a component range is not selected, all components are updated.

5 Select which prices to update. Select Catalog to update only the prices of parts that are in the Parts Catalog for the selected criteria. Select Local to update only prices of parts that are in the Shop Inventory master but not in the Parts Catalog. Select Both to update the prices for both Parts Catalog parts and local parts.

6 Check the Calculate on Average Price check box to have the new parts price calculated as the markup percentage entered in the Price Range Markup Grid multiplied times the average price of the part.

7 The Price Range Markup Grid can be used to mark up all prices or prices in a range. To mark up all prices, enter the percentage to mark up the prices in the Markup % column. To mark up prices that fall in a certain range, enter the low price, the high price, and the markup percentage. You can enter as many price ranges as necessary. For example, to apply a 50% markup to the prices in the range of $0.00 to $25.00 and a 100% markup to the prices from $50.00 to $100.00, add the following lines to the grid:

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>0.00</td>
<td>25.00</td>
<td>50%</td>
</tr>
<tr>
<td>50.00</td>
<td>100.00</td>
<td>100%</td>
</tr>
</tbody>
</table>

8 Click the Update Prices button. When the prices are updated, a screen is displayed with the quantity of records updated.
Shop Inventory Master

Go to Masters > Shop Inventory. The Shop Inventory Master records are created for any item that a Shop inventories, such as stocked parts, bulk oil, or antifreeze. This form is where all inventoried items are set up and viewed.

Click on the right mouse button in the Part ID field to pop-up a menu offering the Sticky Note option, and, if the part is a local part (one that did not come from the catalog) a Re-number Part ID option. Alphabetic characters used in Part IDs must be upper-case. If a part is renumbered, any sticky notes associated with that Part ID are also renumbered with the new Part ID.

The Sticky Note option is also available in the Component Code and Manufacturer fields. The Sticky Note is displayed when you exit the appropriate field anywhere in TMT Fleet Maintenance/SQL.

Parts in shop inventory cannot be deleted if the quantity on hand or the quantity on order are greater than zero.

Shop Inventory Part Definition

The Part ID and Shop ID is displayed at the top of the Shop Inventory form. The Shop Inventory Part Definition form is divided into five areas.

- **Part Classification** defines the Part Type and the Component Code. There are also three check boxes to denote if the part Uses Cores, if the part is a Taxable part and if the system should print Bar Code Labels for parts upon receipt. Use the Notes icon to add additional information about a part.

- **Inventory Method** indicates if it is a Stocked or a Consigned part. If neither is checked, the part is a Non-Stocked part. The part unit of measure and account type are also defined here.

- **Stock level** status is unavailable from this screen. The Purchase Order system, Part Charges, and Physical Inventory adjustment routines maintain these values. Trigger Point and Safety Point values can be entered in this section, along with Average Cost, which lists the average cost of the part. TMT Fleet Maintenance/SQL can use FIFO, LIFO, or Average Cost as its accounting method for parts costing.

- **Manufacturer's Part Info** (Information) lists the VMRS make code and the Manufacturer’s Part No. (Number). This is the Part Number used on the printed Purchase Order.

- **RO Requirements** enables you to require position, component match, and serialized part entries on repair orders. These fields are available for editing only if the part is a local part.
NOTE: You cannot edit a Part if that part is on an open physical inventory. You cannot delete a part if it is contained on an open indirect charge, an open repair order, or an open purchase order.

Shop Inventory Bins

Go to Masters > Shop Inventory > Bins.

Each inventory item in each shop must be associated with a physical location. The Bins tab facilitates the maintenance of the locations in which parts are stored.

- Parts can be stored in multiple bins.
- Multiple parts can be stored in the same bin.

The Item Max column indicates the maximum number of the specified item that can be stored in this bin. The Pick Order column indicates the order in which the items are removed from inventory as they are charged on repair orders.

The entry designated Pick Order 0 indicates the primary bin location.
If you right click in the form and select **Insert New Bin**, or press **CTRL +INS**, the **Insert Bin** dialog box is displayed. Select an existing bin from the drop-down list, or enter a new **Bin ID** to create a new bin. Provide the Pick Order and optional Max Items fields as needed.

You can have bins with the same name in multiple shops, but you cannot have bins with the same name in the same shop. TMT Fleet Maintenance/SQL checks for duplicate Bin IDs and will not allow a duplicate to be saved in the database.

A Bin Unit of Measure can match the Part ID Unit of Measure.

**Shop Inventory Kits and Cores**

Go to **Masters > Shop Inventory > Kits & Cores**.

Kits are parts that are grouped, such as an Oil Change Kit that could contain oil, filters, O-rings, gaskets, and other items that could be used for an oil change. Other kits might include Transmission maintenance or Brake repair kits. Kits can contain other kits (but a kit cannot contain itself).

For example, an Engine Replacement Kit might contain an oil change kit, a water pump kit, a radiator kit, an electrical cable kit, and so forth. You can define a kit for the detail that you require for your shop.
The information for a kit is automatically entered when the part is added from the catalog and the Parts Catalog item is defined as a kit. Core information is tracked manually at the bottom of this tab.

**NOTE:** The current version of the software does not automate the Core Tracking process.

When entering manual requisitions for kits, rules that specifically apply to vendors are:

- If a vendor ID is added on the manual requisition form for a kit, all parts in the kit are assigned that vendor.
- If no vendor is entered on the manual requisition form for a kit, the primary vendor for each part in the kit should be used. If a part has no primary vendor, the vendor information will be blank.

**Shop Inventory Warranty Information**

Go to Masters > Shop Inventory > Warranty.

The Warranty Info tab shows the Meter and allowed utilization for the warranty period. Warranty information for non-local parts (catalog items) must be updated in the Parts Catalog. Part warranty information can be updated on this Warranty tab for Local parts only.
Shop Inventory Vendors

Go to Masters > Shop Inventory > Vendors.

The Vendors tab shows the Vendors that supply this part. This is similar to the Parts Catalog Vendor tab and can be automatically populated if it is added using the Parts Catalog ID. You can select a Vendor ID in this form to be the primary Vendor for this item. The Primary Vendor - usually the one who gives you the most favorable prices or service - is the vendor used by the requisition system. Price, Currency, Target Point, and Quantity Units of Measure are shown. Each shop can add or delete vendors for specific parts. Shops are not restricted to using the vendors suggested by the catalog.
A Primary Vendor must be chosen to allow the Automatic Part Requisition system to operate. The Target Point for the Primary Vendor is used to establish Re-order quantities for parts by the Automatic Requisition system.

### Shop Inventory Costs

Go to **Masters > Shop Inventory > Costs**.

The Costs tab contains a list-view grid box and three inactive edit boxes. The list-view grid box lists the detailed quantity and costs for the given part. The fields at the bottom contain the average cost of the part, the last purchase price of the part and the inventory method being used.

This tab displays the records that are the source for maintaining FIFO, LIFO, or AVG COST accounting methods.

Records are displayed for items currently on-hand. The quantity is relieved as parts are used. Average Cost is only recalculated when part are received.

Right-click options for this grid include **View Order** and **Print PO**. If the cost line was created from a purchase order and View Order is selected, the purchase order is displayed. If Print PO is selected, the purchase order is printed.

### Shop Inventory Prices

Go to **Masters > Shop Inventory > Prices**.

This screen enables you to set wholesale or distributor, retail, or maintenance contract pricing for a part. You can charge a set price or indicate a percentage to be used for markup.
If there are multiple prices based on a percentage, all prices are updated to the current price when this tab is clicked.

**Shop Inventory History**

Go to **Masters > Shop Inventory > History**.
This tab enables you to view the item cost history for a part record. The information on the History tab can also be printed or exported to XLS, HTML, XML, or TXT files.

**NOTE:** Item Cost History for parts prior to TMT Fleet Maintenance/SQL version 8.10 might be inaccurate, due to changes in the way that changes to the history were recorded.

### Customer Master

Go to **Masters > Customers**. The Customer Master records contain identifying information about your customers and define which price table is used for each customer.

You cannot delete a customer if the customer is associated with an order.

### Customer Definition

Customer Type is a normal codekey in **SysMgr > Codekeys > Customer Types**. New Customer Type values can be added to the codekeys definitions from the Customer Definitions tab by typing a new value and clicking Yes when a prompt is displayed asking if you want to add it to the Codekeys list.

Click the right mouse button in the Customer ID field to pop-up a menu containing the **Renumber Customer ID** and **Sticky Note** options. Alphabetic characters used in Customer IDs must be upper-case. If a customer is renumbered, any sticky notes associated with that Customer ID are also renumbered with the new Customer ID.

After providing the identifying information for the customer, drop-down the list of Price Tables and select the price table to be used for this customer.

A customer can be marked as inactive. Use the right-click menu in the Customer ID field on the Definition tab of the Customer Master and click on Set Customer Inactive.
Customer Contacts

The Contacts tab provides a place for you to list the people you deal with at a customer’s office and their telephone numbers.

Assigning Units to Customers

The Units tab assigns and unassigns company and non-company units to a customer. Click the right mouse button to pop-up a menu with Assign, Unassign, Reassign, and Company Unit options.

If a non-company unit is unassigned from a customer, it becomes a company unit. The Customer master field is disabled. Non-company units must be unassigned or reassigned to other customers from the Customer Master > Units tab.

If a price table is associated with a non-company unit, when a repair order is created for that non-company unit, the price table associated with the unit is used instead of the price table of the customer.

Use Reassign to move a unit quickly from one customer to another.
Use the Company Unit option to designate an existing Unit Master record as a non-company unit. This causes the repair order header form to prompt for unit and customer information, allowing the generation of invoices for units that are not being tracked in TMT Fleet Maintenance/SQL.

Use the right-click menu to assign, unassign, or reassign a unit, or to designate a unit as a company unit or non-company unit.

You can also go to Masters > Units and select the unit you want to assign. Add the appropriate Customer ID to the Customer field on the Unit Definition tab. (See “Unit Definition” on page 115.) The Customer field on the Repair Order Header tab then defaults to the customer associated with that unit in the Unit Master record. The customer can be changed on the repair order if appropriate. When this is done, a customer can be selected on the repair order header. The customer selected on the repair order header is the customer for whom the invoice is generated.
Go to Customers > Options tab and click on Invoicing in the left pane.

**Tax Exempt** - If this customer has been provided tax-exempt status, check this box. If this box is checked, no taxes are charged on an invoice for this customer.

**Require PO** - If this option is checked, when a repair order or direct sale invoice is created for this customer, a customer purchase order is required. If it is not checked, a customer purchase order is optional.

**Create Invoice from RO** - If this option is checked, when a repair order for this customer is changed to Closed status and posted, the invoice is automatically created and the repair order form closes. This feature works only if the Repair Order option Insert After Post is not selected.

**Unit Information First on Non-Company Units** - If this option is checked, when the non-company unit form is displayed, the Unit Information tab has focus instead of the Customer Information tab. This setting applies to TMT Fleet Maintenance/SQL, Shop Planner, and Mechanic Workstation. The default is unchecked.

**Terms** - The Terms fields indicate the payment terms for this customer. Examples include Net 10, Net 20, Net 30, and so forth. Payment terms are established in SysMngr > System Setup > Codekeys > Payment Terms. If a user has security privileges to the New Codekeys form, new values can be added for these fields on the fly by typing in a new value and exiting the field. The user is prompted to add a new codekey.

**Receivables Account** - If the Account Disbursement Detail for an invoice transaction has Use Customer Account checked, the receivables account selected here is used for that customer. This works the same way Use Inventory Account works for Inventory transactions. Only accounts created in the Receivables section of the Chart of Accounts is displayed in the drop-down list for this field. If you set up any disbursement rules to use the customer account, all customers must be assigned a Receivables Account.

**Suspend Service** - If this customer should no longer receive maintenance service, check the Suspend Service box. When a repair order is started for this
customer, a warning is displayed indicating that the customer’s service has been suspended.

**Enforce Credit Limits** - If this option is checked, a credit limit is enforced for the customer. The limits include credit limits and invoice limits. The Credit Limit is based on the total balance due for the customer. The Invoice Limit is the maximum amount an invoice can be for the selected customer. If a zero is in the limit field, this is interpreted as “no limit.” As lines are added to the repair order, the marked up amount is tracked to determine if the estimate amount is exceeded. The global option Show Running Invoice Prices on Repair Orders (located in **SysMgr > Invoicing**) can be checked to display the marked up amount on the repair order. When creating repair orders, the repair order estimate field is enforced for repair orders with that customer and requires a value to be entered. The amount entered is checked against the Invoice Limit first, then the Credit Limit. If limit is exceeded, the repair order cannot be created and an error message is displayed indicating that the limit has been exceeded.

**Credit Limit** - If applicable, enter a dollar amount that cannot be exceeded on all invoices for this customer.

**Invoice Limit** - If applicable, enter a dollar amount that cannot be exceeded on a single invoice.

**Labor Time Options - Sum Labor for Invoice by Job Code** - If this option is checked, labor is summed based on the jobcode. A jobcode can have the following type of time - Flat Rate, SRT time, User-Entered Estimated time, and Estimated time - set up on the Jobcode master. When summing jobcodes on the invoice, TMT Fleet Maintenance/SQL checks the jobcode number and uses Flat Rate unless there is no Flat Rate time. If there is no flat rate time, the program uses SRT time.

If there is no SRT time, the program uses a user-entered estimated time, which was entered when the assignment was created. If the user did not enter estimated time, the program uses the estimated time set up on the Jobcode master. If there is no estimated time for the jobcode, the system uses the sum of the labor hours on the section and creates a line with the description for the jobcode. If a section does not have any jobcodes, a single line for the total labor hours on the section is created on the invoice.

If two or more different jobcodes exist on a section, the invoice contains each jobcode and the time for each jobcode based on the Flat Rate, SRT Time, or estimated time rules. If two or more of the same jobcodes exist for a section, the invoice contains a single labor line for that jobcode and the time is based on the Flat Rate, SRT Time, or estimated time rules with the time being for a single job (not a sum of the time for multiple jobcodes).

**NOTE:** If the same jobcode exists on two assignments on a repair section and the user has entered estimated time on one of the assignments containing that jobcode but not on the other assignment, the program treats this as two different jobcodes. Both assignments would have to have the same user-defined estimated time for the system to recognize this as the same jobcode.

If actual cost for labor is used on the Invoice Price Table for the customer, the highest labor rate for each section is used as the cost basis for all labor time on that section. The default setting is unchecked and disabled. This option is unchecked and disabled if either Sum Labor by Pay Grade Type or Make Minimum Labor Line a
Separate Line is checked. This option is controlled at the global, shop, and customer levels.

**Labor Time Options - Sum Labor by Paygrade Type** - If this option is checked, the labor lines are summed together by paygrade type (Standard, Over-time, and Weekend) and a line is displayed for each type. The price is based on paygrade type. If it is not checked, all labor lines are rolled into a single line called Shop Labor and the Base Rate is used to calculate the price. The default for this field is checked. This option is controlled at the global, shop, and customer levels.

**Labor Time Options - Make Minimum Labor Line a Separate Line** - If this option is checked and a minimum labor line is required to achieve the minimum labor hours, the minimum labour amount is displayed as a separate line. If it is not checked, the amount is rolled into the Shop Labor line. The default for this field is checked. The option is controlled at the global, shop, and customer level.

**Enforcing Credit or Invoice Limits**

The Options tab enables you to enforce customer limits on repair orders. The limits are the credit limit and invoice limit. The Credit Limit is based on the total balance due for the customer. The Invoice Limit is the maximum amount an invoice can be for the selected customer. If a zero is in the limit field, there is no limit. As lines are added to the repair order, the marked up amount is tracked to determine if the estimate amount is exceeded.

*Show Running Invoice Prices on Repair Order* is a global option (located in SysMgr u Invoicing). This option can be checked to display the marked up amount on the repair order. If Enforce Credit Limits is checked on the Customer master, the repair order estimate will be enforced for repair orders with that customer and requires a value to be entered. The amount entered is checked against the Invoice Limit first, then the Credit Limit. If either limit is exceeded, the repair order cannot be created and an error message is displayed indicating that the limit has been exceeded. As lines are added to the repair order, the estimate on the repair order header is checked. After the repair order estimate amount is exceeded, an error message is displayed that the estimate is exceeded and you cannot post the charges made without deleting the line (or lines) that caused the estimate to be exceeded or changing the estimate amount. If the estimate amount is changed, it is checked against the invoice limit, and then the credit limit before the change is accepted. If the change causes the customer limits to be exceeded, an error message is displayed and the amount rolls back to what was originally on the repair order.

**Customer Options - Printing**

Go to Customers > Options tab and click on Printing in the left pane.
Using Custom Invoices

Using Crystal Reports (Business Objects version), you can create a custom report for Repair Invoices and Direct Sale Invoices. After the Crystal version of the report is created, you can check which TMT Fleet Maintenance/SQL invoices will be replaced by a Crystal Report and enter a path to the appropriate Crystal Report. This option can be overwritten with a different custom invoice at the Customer Master level if you have customer-specific invoices.

If Use PARADOX Tables for Custom Invoices is checked, the system expects the Crystal Reports that were created using Paradox tables. If it is not checked, the system expects the Crystal Reports that link directly to the TMT Fleet Maintenance/SQL data-base and the TMT Crystal Viewer must be installed on the computer that will be creating the invoices.

A path for a custom Crystal Reports report cannot exceed 60 characters. If you exceed this limit, move the Crystal Reports to a higher-level directory, or shorten the directory names.

Customer Inquiry Options

The Customer Inquiry options allow access to customer inquiry screens. Specific types of access can be granted or denied.
The Invoicing node contains all of the options related to invoicing. You can print a custom invoice for fuel invoices. The Printing node contains the options to use a custom Crystal Invoice (remember that the path information for a Crystal Report cannot exceed 60 characters). The Customer Inquiry node contains the options related to the web-based Customer Inquiry System. You can also print invoice details on fuel invoices, which lists all fuel tickets on an invoice.

**Customer Taxes**

The Taxes tab enables you to set up tax information for the customer. If tax information is set up for a customer, when an invoice is created for the customer, those tax rates are used. If no tax rates are set up for a customer, the shop’s tax rates are used for the invoice.

Sales taxes are calculated using three criteria:

- the location where the sale is made
- the customer’s tax status
- the item or service

Tax rates can be applied against parts, labor, service, Fees/Misc, a part line with a charge category of Supplies, and a part line with a charge category of Fluids.

If all items are taxed at the same rate, establish one tax record with all the categories checked. If certain items are taxed at different rates (for example, labor is taxed at one rate, while parts are taxed at a different rate), set up a tax rate and indicate which category to which the tax should be applied.
To set up a tax code, press **CTRL + INS**, or right-click in the grid and select *Insert Tax Code*.

Select a tax code from the pull-down list and press **F6**. Tax rates are set up in *SysMgr > Tax Rates and Fees*. If the tax is for a US customer, select Standard as the Tax Calculation method. If the tax is for a Canadian customer located in a province that uses tax on tax, select Tax on Tax as the calculation method; otherwise, select Standard.

**NOTE:** Only taxes set up as type *Sales Tax* can be selected. If different tax rates must be applied to different line types, a tax code can be set up for each line type that will use that tax code.

### Making Customers Inactive

Making a customer inactive removes the customer from customer searches and customer reports, and no further order activity can take place for that customer.

To make a customer inactive:

1. Go to **Masters > Customers**.
Click the Flashlight icon next to the Customer ID field to display the Customer Search screen.

2 Search for a customer by clicking Search. Select the customer you want to work with by clicking on the customer in the results list.

3 On the Customer Master for the customer, right-click in the Customer ID field and select Set Customer Inactive.

4 A confirmation dialog box is displayed. Click on Yes to make the customer inactive, or No to cancel.

**Customer Taxes** - Use the fields on this tab to set up tax information for the customer. If tax information is set up, when an invoice is created for the customer, those tax rates are used. If no tax rates are set up for a customer, the shop’s tax rates are used for the invoice.

To set up a tax rate for a customer, press CTRL+INS or right-click in the grid and select Insert Tax Code. Select a tax code from the drop-down list and press F6. Tax rates are set up in SysMgr u Tax Rates and Fees. If the tax is for a US customer, select Standard as the Tax Calculation Method. If the tax is for a Canadian customer located in a province that uses tax on tax, select Tax on Tax as the calculation method, otherwise select Standard.

Only taxes set up as type Sales Tax can be selected.

If different tax rates will be applied to different types, a tax code can be set up for each line type that will use that tax code.

---

**Adding User-Defined Fields**

Go to Customers User Fields.
This tab displays the User-Defined Fields that were set up for the Customer Master. User-defined fields are a way to capture information about an item that the standard TMT Fleet Maintenance/SQL fields do not provide. User-defined fields are set up in SysMgr > User Defined Fields, or they can be edited on the fly by clicking the Define Fields button on this screen.

The Images button enables you to link images of documents or graphics to a customer master.
If the Publish to Customer Inquiry Screen check box is checked, a user can publish a document or image to the web-based Customer Inquiry screen.

**Part Pick Lists**

Go to **SysMgr > Repair Order Setup > Pick List Definitions**. TMT Fleet Maintenance/SQL provides a Pick List for frequently completed repairs. The Part Pick List prints with the Online Repair Order Workcard. The Pick List groups Parts for routine maintenance or repair operations. The **Parts** tab lists available parts.

The **Assignment** tab links the part to a unit or group of similar units.
Diagnostic Definitions and Check Lists

Go to SysMgr Repair Order Setup Diagnostic Definitions. Diagnostic Definitions provide a way to create PM checklists or diagnostic information that is tied directly to a Component Code. The Diagnostics are printed on the Repair Order section when using the Online Repair Order Workcard.

The Definition tab provides information about the diagnostic.

You can create a diagnostic or check sheet for any type of test or inspection that is required. You can assign these diagnostics to a specific Unit ID, Fleet, Component, and Complaint or any combination on the Assignment tab of this form. This creates a powerful matrix to apply to preventative maintenance, statutory inspections, or normal system diagnostic aids.
NOTE: You can use a word processor to create diagnostics and then use the Windows Copy and Paste commands to copy the diagnostic into this form. Be aware that the functions of this form do not support columns; therefore, do not use the column feature of your word processor to create columns in the diagnostic. You can use the Tab key or the space bar.

You can add images, text files, or PDF files to a diagnostic definition. Images can be added to the Definition or the Assignment. If an image exists on both tabs, only the image on the Assignment tab will print.

Image types that can be added include JPEG image, bitmap image, text file, rich text file, or PDF files.

When printing a work card, the image prints on the last page.

If using a PDF file: Adobe Acrobat must be installed on the computer workstation that is used to print the work card. Because of limitations imposed by Adobe, when a work card is printed that has a PDF file attached, a PDF preview window is displayed. The Print button must be pressed on the PDF preview, then click OK on the TMT Fleet Maintenance print dialog. When the progress indicator displays 100%, the PDF preview window can be closed.

Part Fee/Tax Assignments

Go to Inven > Part Fee/Tax Assignments.

Some parts have charges associated with them that should be charged when you create a Repair Order or Purchase Order. These types of charges include the Hazardous Waste Disposal Fee for oil, or perhaps a Tire Scrap Charge for bad casing.
Type the Part ID on this line and select the Tax Rate or fee and the Order Type to be used for this part. Fees can be associated with parts and applied when the parts are purchased, and the fee cost can be passed to the unit getting the part on the Repair Order.

Fixed Costs

TMT Fleet Maintenance/SQL can track several types of fixed costs for a unit. Fixed costs are expenses that are not usage-based. Examples include taxes, license fees, interest, and insurance.

Fixed costs are reported on Period Close reports, Unit Cost of Ownership reports, and the Unit Life Cycle Cost report.

Go to Activities > Fixed Cost.

Select the type of fixed cost you want to maintain. Default fixed costs are Administrative Salaries, Depreciation, Insurance, Interest, License Fee, and Taxes.
(To create additional fixed cost categories, go to SysMgr > System Setup > Codekeys > Unit Fixed Cost.)

To open a new fixed cost form, click New.

Select a Fixed Cost Type from the drop-down list, and enter a description. Complete the other fields as required. When you click the X in the upper right corner of the form, a dialog is displayed asking if you want to save changes to the fixed cost entry. Select Yes to save the changes, No to quit without saving, or Cancel to return to the form.

To display a fixed cost history, right-click on a fixed cost record and select Show History, or double-click the record and select the History tab. This data can be sorted and printed.
Fixed Cost History

To display a history screen for a fixed cost, double-click the entry on the Fixed Cost screen, then click on the History tab, or right-click on the entry in the Fixed Cost screen and select Show History from the drop-down menu.
Chapter 5: Using TMT Fleet Maintenance/SQL

The previous chapters provided information about setting up TMT Fleet Maintenance/SQL. The remaining chapters describe how to use the TMT Fleet Maintenance system.

This chapter covers basic TMT Fleet Maintenance/SQL functions: Repair Orders, Indirect Charges, Purchasing and Inventory Management, Fuel Tickets, and Trip Tickets.

Repair Orders

The Repair Order system is the heart of any computerized maintenance management system.

Here is some information to keep in mind about Repair Orders:

• You cannot cancel a repair order if it contains any sections with line items.
• The Unit ID cannot be edited after a section is entered on a Repair Order.
• A Repair Order section cannot be closed if parts are on order for that section. A repair order cannot be closed if any section on the repair order has parts on order.
• If the Global/Shop option Check for Open ROs When Creating New RO is checked, when opening a new repair order for a unit that has open repair orders, the Open Repair Orders List screen is displayed so that the repair order to use can be selected.
• You can open a closed repair order by right-clicking on it. If you do not use a mouse, the closed can be opened for viewing using control command CTRL + E. The section appears to be read-only, but the Status field can be changed to OPEN using the up/down arrow keys. The reopened section can then be edited.
• A standard message can be printed on a repair order. The message can be global or shop specific. Set up repair order messages in SysMgr > Standard Messages.
• Information for units designated as non-company units is verified in some fields to prevent entering invalid data. Fields that are verified include Make, Model, and Year. If you attempt to post an invalid entry in one of these fields, an error message is displayed.

Creating Repair Orders

Go to Orders > Repair Orders.

The Search Repair Orders form shown below displays Repair Orders based on the selection criteria provided in the fields at the top of the form. After you type in the required information and click on Search, the system retrieves the Repair Orders that match those criteria.

The display can be sorted by any column by clicking on the desired column header. Whether the column is sorted in ascending or descending order is indicated by the up or down arrow in the sorted column.
On the search screen, color coding is used to make it easier to search for specific types of repair orders.

- Lines highlighted in blue indicate that the repair order is open but all of the sections are closed, or it has no sections.
- Lines highlighted in red indicate that an employee is logged onto a repair order in TMT Fleet Maintenance INterActive. (The TMT Fleet Maintenance INterActive module must be installed.)
- Lines highlighted in green indicate a closed repair order that can be invoiced. If an invoice has already been created but was not closed, it is highlighted in green. If a repair order is marked as non-billable, it will not have a green highlight.

Right-click in the grid and then select Customize Columns to change the fields that are displayed in your default view. Click on a column heading and drag it onto the grid, then drop it where you want it displayed.

If a repair order has been invoiced, the invoice number is displayed in the results grid.
Other Functions

Additional functions can be accessed by right-clicking in the display grid. Some functions shown in the example might not be available, depending on the type of repair order, its status, and so forth.

You can:

- Open an existing repair order
- Create new part, labor, service, comment, tax, or fee lines
- Open a repair order template for a single unit or multiple units
- Change a vendor associated with a repair order
- Create or open an invoice (from a closed or complete repair order)
- Print a work card, or a work card section
• Print a detail report or a section detail report
• Print a purchase order that is attached to a repair order
• Print a work card checkoff list
• Close a repair order
• View items on a repair order
• Update the amount paid on an invoice
• Create sticky notes
• Customize the display columns (add or remove columns, change display order, and so forth)

Open an Existing Repair Order
To open an existing repair order, highlight the repair order you want to open and click Open, or press CTRL+E, or double-click on the repair order, or right-click in the grid and select Open. The Repair Order Header is displayed. If the repair order is closed, no editing is allowed.

Delete a Repair Order
A repair order can be deleted if the repair order status is not CLOSED and there are no sections that have a status of CLOSED.

To delete a repair order, select the repair order in the grid, then press CTRL+DEL or right-click and select Delete from the drop-down menu. A confirmation message is displayed to confirm the deletion.

Closing Repair Orders
After all charges are entered on the appropriate sections and the work is complete, the Repair Order can be closed. Closing the Repair Order indicates the completion of the documentation process. Once closed, no changes can be made to the Repair Order unless it is re-opened. If the accounting period in which the RO was closed is closed, if an invoice has been generated, or if the accounting data has been exported, the RO cannot be re-opened.

To close a Repair Order, go to the Header tab on the Repair Order screen.

• If the job has just been completed, simply change the status to Closed and tab out of the field. This causes the closed date and time to default to the current system date and time. The difference between the opened date and time and the closed date and time defines unit down time.
• If the work was completed sometime earlier, enter the appropriate date and time in the closed date and time fields rather than changing the status. This closes the Repair Order with the correct date and time of completion.

If you are using batch entry mode, when you press F6 after entering the charges, the RO closes and opens a new RO for continued data entry.

You cannot close a repair order if:

• The repair order contains any open sections. Delete all sections, and then close the repair order.
NOTE: On a vendor repair order, all charge items must be deleted before the section can be deleted.

- There are parts on order or parts on request for a standard repair order. The Status and Close Date fields are disabled until all parts on the purchase order have been received for that repair order.
- You cannot cancel a repair order if it contains any sections with line items.

Re-open a Closed Repair Order
To reopen a closed repair order, go to SysMgr > Re-open Closed RO. Enter the repair order number and click Search.
The repair order information is displayed. Click OK to reopen the repair order.

Repair Order Status
A repair order can have one of several status types that are used to indicate the progression of the unit repair. They include:
- OPEN - the unit is being repaired. Additional work can be performed on new sections, and existing sections can be edited. Can be CLOSED.
- CLOSED - no changes to the repair order are allowed without re-opening the RO section.
- PENDING - The unit is on hold (for example, waiting for repairs to be started, or for parts to arrive). RO Sections can be created, but charges cannot be assigned to the sections.
- CANCELED - after a repair order was created, the repair was canceled.
- COMPLETE - Repair work has been completed. Can be CLOSED.

Repair Order Entry Options
You can define the mode of operation and the options that occur while in that mode. If you click the Options button, the Repair Order Entry Options screen is displayed. The options selected here affect only the work station where they are set, and the settings are retained until they are changed.
**Default Order Type** - This field displays the default repair order type (Standard or Vendor) that is selected when a new repair order is created. The default is Standard.

**Default Modes** - The Repair Order system can operate in two modes:

- **On-line mode**
- **Batch mode**

*Batch entry mode* is used when data entry is required after work is done and previously documented. *On-line mode* is used in a real-time situation - that is, a Repair Order is created when the job is started, charges are added as the work progresses, and then the Repair Order is closed when the work is complete. The difference is in the process and timing of the data entry flow. The actions required in either case are the same.

**NOTE:** Shop ID is a required field and must be completed before other actions can be taken in Batch Management. This enhances shop level security and assures individual batches are restricted to one Shop ID.

- The **on-line mode** for repair orders checks the *Auto-create Sections* and *Print Work Card* options.
- The **batch mode** for repair orders checks the *Close Order on Post*, *Insert Order After Post*, and *Print RO Detail Report* options. If batch mode is turned on for invoices, an invoice cannot be created unless a batch has been selected.

**NOTE:** The default modes are intended to be used as a guide for the options; however, the options can be mixed and matched based on the needs of the shop. For example, if a shop does batch repair orders, but a repair order detail report is not needed, the batch mode can be selected with the *Print RO Detail Report* option left unchecked.

**Close Order on Post** - This option allows you to specify if the repair order is automatically closed after the charges have been posted (by pressing F6). This is a batch entry option.

**Insert Order After Post** - This option creates a new repair order after you press F6 to post the prior repair order. This is a batch entry option.

**Insert Assignments After Section Post** - When this option is checked, the Job Assignment dialog will pop up when you post a new section to enable you to enter your employee job code.

**Insert Assignments After Post** - When this option is checked, while on the Job Assignment dialog, pressing F6 posts the current employee data and clears the fields so that you can enter the next employee.

**Auto-Create Sections** - If the global option *Check for Open ROs when creating a New RO* is NOT checked, checking this option will automatically create a new section for PM repairs that are due on the unit. If there is a work pending repair order on the unit, the sections on the work pending repair order are moved to the newly-created repair order. If the global option is checked and this option is checked, the *Select Pending for Repair Order* screen is displayed. This form enables you to select which PMs or work pendings will be performed on the repair order. This is an on-line entry option.
**Work Pending Repair Orders** are created by the system when a Repair Order is closed with sections that have no parts or labor charges to them. They can also be created when you open a standard Repair Order, create the sections without charges that are to be done, then change the RO Status on the header to Pending. This is also where Campaign Work Pendings are introduced to the Repair Order.

If a work pending is selected to create a repair order, the Work Pending/PM dialog box does not appear if Auto-Create Sections is turned on in Repair Order options. This ensures that duplicate work pending sections are not created.

**Print Work Card** - If this option is checked, TMT Fleet Maintenance/SQL automatically prints a work card as soon as the section information is posted. You can print or re-print a work card for any section whenever you want. This is an on-line entry option.

If a repair order is created from an inspection ticket and the Print Work Card option is enabled, the work card prints first, and the newly-created repair order can then be displayed.

**Print RO Detail Report on Close** - This option prints a detailed listing with charges and section totals when you close the RO. This Batch mode entry option assumes the repair is complete and the Repair Order total must be printed. Completed RO Detail can be printed at any time. You also can specify that no printing is done. This is a batch entry option.

**Show Pick List Prompt** - This option is displayed only if the global option Use Parts Workstation for Parts Request is checked in SysMgr > Options > TINA. If it is checked, when a section is added to a repair order that has a pick list associated with it, a prompt is displayed to create a parts request for the parts on the pick list. The parts request will be accessible from Parts Workstation. If it is not checked, no prompt is displayed and the parts request will be created automatically.

**NOTE:** The following discussion of the RO process assumes that you are using the on-line entry mode. The actions required for batch entry is the same, but are all accomplished sequentially in a single data entry session.

**Tracking Chronic Repairs**
When a value is entered on the Chronic Repairs global shop option for the number of days, the system tracks a chronic repair as a repair that occurs more than once within the number of days selected for the repair shop, unit, and component code.

When a new section is created on a repair order and the component code that is entered has been done on a previous repair order for the selected repair shop and unit, a yellow message is displayed in the section dialog indicating how many repairs for the selected component have occurred within the number of days selected. The chronic repairs message is also displayed when reviewing repair order sections in history.

**Repair Order Entry**
You can create or view the Repair Orders from the Repair Order screen. To start a new Repair Order, click on the **New** button, or press **CTRL + INS**.
You can also open a new repair order from the Preventive Maintenance and Work Pending screens. When these repair orders are created, the Unit ID is marked as disabled and cannot be changed.

If a customer is selected, the Customer Estimate field is also displayed. If a value is entered in this field, as lines are added to the repair order the marked up amount is tracked and compared to the estimate amount. If the amount of the lines entered exceeds the estimate amount, an error message is displayed when F6 is pressed to post the changes, but the lines will be saved. If the global option Enforce Invoice Estimate is checked (in SysMgr u Options u Invoicing), the repair order cannot be created unless an estimate amount is entered. If lines entered cause the marked up amount to exceed the estimate, the lines that cause the limit to be exceeded will not be saved when posting. If the customer has Enforce Credit Limits checked on the Customer master, the estimate amount entered will be enforced for repair orders with that customer and requires a value to be entered. The amount entered is checked against the Invoice Limit first, then the Credit Limit. If limit is exceeded, the repair order cannot be created and an error message is displayed indicating that the limit has been exceeded. As lines are added to the repair order, the estimate on the repair order header is checked. After the repair order estimate amount is exceeded, an error message is displayed that the estimate is exceeded and changes cannot be posted without deleting the line or lines that caused the estimate to be exceeded, or changing the estimate amount. If the estimate amount is changed, it is checked against the invoice limit, and then the credit limit before the change is accepted. If the change causes the customer limits to be exceeded, an error message is displayed and the amount rolls back to what was originally on the repair order.
In the Repair Shop field, type in the Shop ID or click the Shop Search icon and select the appropriate shop. After you select the Repair Shop, press the Tab key.

TMT Fleet Maintenance/SQL automatically generates the Order Number (if this feature is enabled on the Orders tab under Masters > Shops). Enter the Unit ID to be repaired. A Vendor ID must be supplied only if the repair is being done by an outside company.

**Vendor Repair Orders**

When a vendor repair order is created, a purchase order is automatically created with PO type Vendor RO. The purchase order is automatically synchronized with the repair order as lines are created. The vendor purchase order that was created cannot be received and lines cannot be added from the purchase order. Also, when a vendor repair order is closed, a vendor purchase order can be printed automatically if the purchase order option *Print Receiving Document on Closed or Received Status* is checked.

Complete the remaining repair information fields.

To change vendors for a repair order when the status is Open, Complete, or Pending, right-click on the repair order in the repair order query grid and select Change Vendor. A confirmation dialog box is displayed to confirm the vendor change. Click Yes, then select the new Vendor ID in the Editing Vendor dialog box.

You can print a purchase order that is associated with a vendor repair order. Right-click in a vendor repair order and select *Print Attached PO*. 
Printouts for purchase orders associated with vendor repair orders include the following unit information in place of the Ship To shop information: Unit ID, Unit Description, Unit’s Domicile Shop, make, Model, Model Year, VIN #, In-Service Date, Cost Center, and License.

If the ComData module is installed, you can request payment by a ComCheck.

**Sticky Notes** - You can associate a sticky note with a repair order. Click the right mouse button in the Order No field to pop-up a menu to enable the sticky note option.

Sticky notes are shop-specific. The heading at the top of the sticky note indicates the shop and the order number. In the example above, the shop ID is shop 11 and the order number is 0000000001.

**NOTES:**

*The Customer ID field is usable only if the Invoicing Module is enabled. This field identifies the customer for whom the invoice is generated for this repair.*

*Part Warranty is tracked by Component Code and position code. The indicator is activated when a previously-charged warrantable part replaced with another part having the same component code and position is selected.*

Information about the Warranty Lights is stored in the order history. This makes the warranty lights reflect the appropriate warranty status at the time of the repair instead of calculating the status when the repair order is opened for review.

TMT Fleet Maintenance/SQL maintains a history of all Unit Meter Readings that are entered. This history can be accessed by clicking the [...] button next to the Meter Reading field. A meter reading added on any date must fall between the reading before and after the date on which it was entered. Backdated Meter Readings are validated because TMT Fleet Maintenance/SQL knows the dates for actual readings both before and after the date you enter. The **Utilization** column displays the difference between the previous reading date and the reading on that date.

All utilization reporting, including PM Due reporting uses the sum of the utilization records for the date range specified by the report run. This increases the integrity of the Meter Readings in the system. For more information, see “Meter Readings” on page 201.
Use the **Print** button on this screen to print the meter reading information.

If a section is closed, you cannot use the right-click menu to edit or delete sections. The only right-click menu options available for closed sections are to re-open the section, create a new section, or print the section.

## Sections Tab

After you complete the Header information, click on the Sections tab. You can also double-click any Open Repair Order and go directly to the Section tab. The **Section view** screen is displayed.

This screen shows all of the sections assigned to the repair order. It also shows the total for each section in the bottom right corner of the screen.

A section cannot be deleted if the section contains any lines. To delete a section, all lines must first be deleted.
If there are any errors in a section (such as insufficient parts), an error message is displayed with descriptions for the errors.

Codekeys assigned to reason for repair are supported. If a reason for repair is entered on a section and has a user codekey assigned to it, the field is shown below the reason for repair. IF the code is required, the OK button is not enabled until a value is entered for the field. (For more information on setting up codekeys for reason for repair, see “Codekeys Setup” on page 62.

If you right-click in the upper left grid of the Sections tab, you can add a section using a template and display all available sections for the repair shop, edit a section, print the section work card, print the section detail, view items on order for the section, and customize the display.

Vendor repair orders can have negative charges. If all of the charges on a vendor repair order are negative, the information is exported to a purchase order as a credit memo.

**User Fields - Images**

The Images button on the User Fields tab enables you to add images that can be published on the CIS Web Interface. If an image is available, the RO Query form contains an Images column with a check mark.

**Add New Repair Order Section**

To add a new Repair Order section, right-click in the section (upper grid area) and select **New Section**, or press **CTRL + S**. TMT Fleet Maintenance/SQL opens a Repair Order section dialog box with a new section number.

The required fields are:

- Component
• Status (defaults to Open)
• Opened date (defaults to the system date)
• Complaint
• Repair reason

**NOTE:** The Repair Reason for preventative maintenance is always PM or Statutory Inspection.

If the repair work on this section is done by an outside company, provide a Vendor ID. Different sections can be done by different vendors; however, the vendor reports refer only to the vendor shown on the header.

Notice that there is a Status and an Opened and Completed date for each section of the Repair Order. The Status and completion date can help you keep track of which portions of a large repair are complete.

If a PM section is completed with PM or Statutory Inspection as the Reason for Repair, the PM schedule function is updated. The Comments box provides a space for you to enter any additional information needed by the mechanic. Comments entered here are printed on the work card for the mechanic’s reference. The work card is printed to provide a working reference for your mechanic.

When the form is complete, click on the **OK** button to return to the Sections tab on the Repair Order screen.

Press **F6** to print the Work Card if you are using the Online mode.

**Viewing Line Items**

To view a line item, double-click on the line in the Repair Order. The Line Item dialog box is displayed.

For lines purchased via a purchase order, the PO Number and Vendor ID fields are added to the form. This information does not display on vendor repair orders. This information is also controlled by the inventory method used. Even if a part is direct received from a purchase order to a repair order, the part goes through inventory
so that the purchase order and vendor information will reflect the purchase order and vendor that applied to the part used from inventory when it was originally purchased.

Add New Lines to Repair Orders

You can now add new part, labor, services, or comment lines. Put the cursor over the lower grid and right-click the mouse. A selection box is displayed.

The program opens a dialog box for the new section information.

New Part Line

If you click the New Part Line option, the New Part screen is displayed.

Enter the Part Number.

**NOTE:** If the Vendor-supplied check box is checked, the part number is not validated from the Parts Inventory database.

TMT Fleet Maintenance/SQL does not allow vendor parts received directly from a purchase order to be deleted or edited on a repair order, as could be done in previous versions of TMT Fleet Maintenance/SQL. This change was made to eliminate an accounting error where a vendor part could be purchased and received directly to a repair order and then deleted from the repair order. Since the part would never be expensed, it causes a growing balance in the suspense account that will never be relieved.

Use the Search icon for the Part Number to display the standard search form for Part Numbers. When a Part Number is entered, the AUTOCROSS program checks the VMRS component code, parts inventory numbers, manufacturer’s part
numbers, superseded part numbers, and cross-reference part numbers. If the AUTOCROSS program finds more than one part with the number entered, a separate dialog screen is displayed with a list of the part numbers found so that you can select the correct part number. If you do not know the part number, you can put in the VMRS component code and the AUTOCROSS program finds all parts that match that component code.

The Positions section enables you to pick multiple positions if the quantity value for the part is two or more. The Position Codes help to better define and report on warranty items. If the Position check box is checked on the Parts Catalog Master, a position code is required on the repair order.

The Charge Amount and the Component Code are pulled from the Part Master File.

If a part has the Serialized Part check box checked in the Parts Catalog, a serial number is required when installing the new part on a repair order. The old serial number is also recorded, but is not required.

If the part is supplied by a vendor and the PO Required for Vendor check box is checked on the Repair Order global options, the part must be received to the repair order from a purchase order. The Vendor Supplied check box is disabled for all line types created on the repair order. The Vendor ID is also disabled on the repair order section.

After a shop part is charged on a repair order, the Part ID and Quantity cannot be changed. This prevents inventory problems that occur when the Part ID or quantity is changed on an existing part.

If a part in inventory is out of balance, the error Inventory is out of balance for this part, please contact Support is displayed when you attempt to charge the part on a repair order. A part is considered “out of balance” when the quantity on hand does not equal the quantity in the bins or does not equal the quantity on cost records.

New Labor Line

If you right-click in the grid and select New Labor line, the Labor Line screen is displayed.
If the labor is supplied by a vendor, make sure there is a check in the Vendor Supplied check box.

Mechanic ID and decimal hours for labor time are required for Shop Labor. Vendor supplied labor is posted by entering the labor cost charged in the Labor Rate field. No Mechanic ID is required and Hours should be left at 1.

The description of the labor is defined by the combination of the Cause and Correction Code descriptions. You can select the Cause and Correction Codes from the List Boxes on the right side of the form.

You cannot enter zero labor hours on a repair order. You cannot enter a Start and Stop time with the same value (for example: Start 8:00 AM, Stop 8:00 AM).

**New Service Line**

If you right-click in the grid and select New Service line, the Service Line screen is displayed.

The Services Line item is very flexible and allows you to charge Company or Vendor services performed on the Unit by providing a description and a cost.

If the service is supplied by a vendor and the PO Required for Vendor check box is checked on the Repair Order global options, the service must be received to the repair order from a purchase order. The Vendor Supplied check box is disabled for all line types created on the repair order. The Vendor ID is also disabled on the repair order section.

**New Comment Line**

If you right-click in the grid and select New Comment line, the Comment Line screen is displayed.

Comment lines added this way print on the completed Repair Order. (Comments added in the Comment box on the section are printed on the Work Card.) Each comment line allow up to 60 characters of text. If you need more, add successive comment lines.
If you add a Comment Line, a comment is required. Blank comments are not posted.

**Tracking Warranty Information**

There are three warranty indicator lights displayed in the Status area at the bottom of this screen.

These indicator lights indicate warranty status:

<table>
<thead>
<tr>
<th>Indicator Light</th>
<th>Light is GREEN</th>
<th>Light is RED</th>
<th>Light is OFF</th>
</tr>
</thead>
<tbody>
<tr>
<td>OEM (Original Equipment Manufacturer)</td>
<td>Unit is covered by an OEM warranty.</td>
<td>OEM Warranty is expired.</td>
<td>No OEM warranty is set up for this unit.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The light is activated as soon as the unit number and meter reading are entered.</td>
</tr>
<tr>
<td>Extended</td>
<td>An extended warranty is in effect for this unit.</td>
<td>Extended warranty is expired.</td>
<td>No component information is set up in the Unit Master.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>The light is activated when an extended warranty section is created.</td>
</tr>
<tr>
<td>After Market</td>
<td>An after-market warranty is in effect for this unit.(see Notes below)</td>
<td>The after-market warranty is expired.</td>
<td>No part under warranty was charged to this unit.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Activated when covered parts that are added to the unit from the Shop inventory are selected.</td>
</tr>
</tbody>
</table>

The Repair Orders search screen provides an easy way to view repair orders that have active warranty tracking. The invoice entries in the screen are shown on a green or red background to indicate warranty status.
You can create templates for repair orders. A template can have fields holding data that is specific to your company. A template has sections, parts, labor, services, and comment lines, and can be a Vendor RO or a Standard RO. After a template is created, repair orders can be created for a single unit or multiple units from the right-click menu options RO Template Single Unit or RO Template Multi Unit on the RO Template Query or Repair Order Query.

To access the Repair Order Template functions, go to Orders > Repair Order Templates. The Repair Order Templates screen is displayed.

The Repair Order Templates screen is used to create new repair order templates, view or edit existing repair order templates, make repair order templates inactive, delete templates, and create repair orders from an existing template.
Repair order templates are used to create repair orders for one or many units at one time. A repair order template could be created for PMs, truck washes, or any repair that needs to be applied across many units at one time.

**Create New Repair Order Template**

To create a new repair order template:
1. Click **New** or right-click in the grid and select **New**.
2. On the **Header** tab, **Required Fields**: The Shop ID and Description for the template are required fields. The RO Template Type defaults to STANDARD, but you can select VENDOR RO. The RO Template Number defaults based on the next order number in Shops u Orders tab u ROTEMPLATE unless the Generate check box is checked. If the Generate check box is not checked, enter a template order number. The default Status is Open; you can also select a status of Complete or Pending.
3. On the **Header** tab, **Other Fields**: Enter a Vendor ID and a confirmation dialog box is displayed that enables you to make the template a Vendor RO. The Repair Class and Repair Site default to whatever is set up for a STANDARD repair order or a VENDOR repair order for the selected repair shop. If the template is for a specific customer, enter the Customer ID. The template defaults to Active. To make a template inactive, uncheck the Active check box.
4 On the Sections tab: Enter the sections and lines for the sections the same as you would for a normal repair order.

5 Click OK to save the template.

Create Repair Orders from Templates - Single Unit

To create a repair order from a repair order template for a single unit:
1 Right-click on the template you want to use and select Create Single RO.
2 Select the Unit ID.
3 If the *Require Meter Readings on Open* option is set, the meter reading is required; otherwise, the meter reading can be left blank.
4 If the repair order being created should be backdated, enter that date and time in the *Open Date* field; otherwise, the current date and time is used.
5 When all required fields are entered, the OK button is enabled. Click OK.

A progress message is displayed when the repair order is created.

**Create Repair Orders from Templates - Multiple Units**

To create a repair order from a repair order template for multiple units:
1 Right-click on the template you want to use and select *Create Multiple ROs*.
2 An Enter Date dialog box is displayed. If the repair orders will be backdated, enter that date and time in the *Open Date* field; otherwise, the current date and time are used.
3 On the Unit Selection tab, enter any criteria to refine the list of units.

4 Click the Results tab. To select the units, right-click and pick Select All, or press **CTRL + A** on the keyboard. To select individual units, hold the CTRL key and click on each unit to select it.

5 After units are selected, the **OK** button is enabled. Click **OK**. Progress messages are displayed as repair orders are created.

Create RO from Repair Order Query Using RO Templates

From the repair order query screen, select the right-click option **RO Template Single Unit** or **RO Template Multi Unit**, then follow the directions above for single or multiple units.

Create RO from Shop Planner Using RO Templates

From the Open Orders tab, select the right-click option **RO Template Single Unit** or **RO Template Multi Unit**, then follow the instructions above for single or multiple units.

Repair Order Work Card

The Repair Order Work Card is printed when the Repair Order is posted if the option settings are set to **Print Work Card**. It can also be printed from the menu displayed when you right-click in the Repair Order screen and select **Print Work Card**.
An example of the work card is shown below.

![Repair Order Work Card](image)

If your company does not use TMT Fleet Maintenance INterActive Mechanic Workstation, employee work assignments are printed on a work order. The Employee Assignment information includes the employee and the job code.
Repair Order Detailed Print

When a Repair Order is closed, a detailed Repair Order printout can be created. This shows the work done and the total cost for each section as well as the part and labor cost breakdowns. All other repair information is shown.

Re-Opening Closed Repair Orders

To re-open a RO, go to SysMgr > Re-open Closed RO. Enter the repair order number. You can use the wildcard %; for example, to find all repair orders ending in 1, enter %1. After you enter the search argument, click on the Search button. Note the date and time it was originally closed. These fields will be blank on the reopened RO.
Click on OK to close the dialog and re-open the Repair Order.
Then, search the Repair Orders to locate the re-opened repair order. Make any needed changes, enter the closed date and time that you noted when you reopened the repair order, and close the RO again using the normal process.

Meter Readings

Go to Activities > Meter Readings to update meter readings on your units.
Enter the date of the meter reading, select the unit number, and press the Tab key. Enter the required meter, and press F6. Continue with your next unit.
Meter readings can contain values with up to three decimal points (for example, 12345.321).

If the Physical Only check box is checked, only physical meters are displayed. If the box is not checked, all meters are displayed.
A log of the meter readings entered during this session is displayed in the right portion of the form. The [...] button next to the meter allows access to the meter reading history of the unit, the Replace meter function, and the Edit function. The life-to-date utilization information is displayed at the top of the screen. You can use the Print button to print the meter reading information shown on this screen.
After a meter reading is entered for a specific unit, the Unit ID is disabled on several forms. This ensures that the meter reading data entered for this unit cannot be linked (accidently or purposefully) to another unit.

The Meter History dialog also displays the user who modified the meter (instead of the “created by” user, since not all meters will have a created by user field).

Click on the Replace button on the Meter Readings Search screen to display the Meter Replacement form. This form enables the user to change a meter on a unit when the meter has stopped working or is defective. When a meter is replaced, all relative readings are re-calculated.

**NOTE:** No subsequent reading can be entered on the date of the meter replacement.

The Unread Estimate field enables you to enter an estimate of the meter amount that you believe elapsed between the time of meter failure and the time it is actually replaced. The Unread Estimate contributes to utilization calculations on the unit.

Click on the Edit button on the Meter Readings Search screen to display one of two forms.
The purpose of this form is to allow a specific meter reading to be edited or marked ignored. This is used to correct specific readings where the meter was input incorrectly. A reading marked as ignored is not used in any calculations done by the system such as PM scheduling or utilization reporting.

This form can also be used to make an ignored reading valid again. Click on an ignored reading and then click on the Edit button. The Mark as Ignored field has focus. Click on Edit Reading and then click on OK. This makes the reading active again.

The purpose of this form is to allow the relative reading to be edited for a meter that was replaced. This form is only available if Edit is pressed for a meter marked REPLACED on the Meter Readings Search screen.

**Using Palm Devices to Enter Meter Readings**

From the TMT Software menu, click **Meter Readings**.

The Meter Readings screen is displayed.

Enter the Unit ID and the meter reading. Click **Post** to save the data.
You can manage meter reading data from this screen. Click Manage Readings. A screen is displayed that lists all of the readings you entered. You can edit or delete readings from this screen.

Indirect Charges

Direct charges are charges for labor and parts that are used for repair and maintenance of a tracked unit. Indirect charges are costs incurred in operation of the Shop facility and include items such as supplies, facility maintenance, employee training, and so forth.

Whether the Indirect Charges are applied to the Unit to capture true maintenance cost is left up to the individual company to decide how they want to report costs. However, if you use a shop rate, it should include the Indirect Charges that contribute to shop overhead. The shop can purchase and relieve inventory for shop supplies and other items such as bay repairs. The Indirect Charge system can be used as a tool to help develop the shop rate.

NOTES:

There is a global option on Master > Shops > Options TINA tab called All labor lines via TINA Only. If this option is checked, labor lines cannot be created, edited, or deleted on Indirect Charges through TMT Fleet Maintenance/SQL. They must be done using the TMT Fleet Maintenance INterActive module.

If an employee is logged into an indirect charge in Mechanic Workstation, that indirect charge cannot be closed.

Indirect Charge Order Query

The Indirect Charge Order Query screen is similar to the Repair Order and Purchase Order query screens. It shows all Indirect Charges and can be filtered and sorted.

Go to Orders > Indirect Charges. The system remembers the last filter entered on this form. It shows in the grid the data found on the query.
This query shows the Order Number, Shop ID, Status, Date Opened, Date Closed, and the Total charge. From this screen you can start a new order or open an existing order by clicking on the **New** or **Open** buttons.

**Sticky Notes** - You can associate sticky notes with Indirect Charges.

![Sticky Note Image]

Sticky notes are shop-specific. The heading at the top of the sticky note indicates the shop and the order number. In the example above, the shop ID is shop FN and the order number is 0000000002.

**Indirect Order Entry**

Click on the **New** button to insert a new Indirect Charge:

The **NEW Indirect Charge Order** screen is displayed.

![Indirect Charge Screen]

Enter a Shop ID or select a shop using the Search icon.

An order number is automatically created when you tab past the Order Number field. You can change the order number if necessary.

Right-click in the grid to enter a new part, labor, service, or comment line item.

The standard line item form displays. The Charge Date can be changed to allow the entry of charges from different dates on the same order. The labor charge screen prompts for an Indirect Charge Code and a Charge Category. You can indicate the pay basis for the indirect charge.
When a part is charged from inventory, the PO Number and Vendor ID are copied from the inventory information. This information is controlled by the inventory method used and if a part is directly received from a purchase order to an indirect charge, the part goes through inventory so that the purchase order and vendor are determined by the cost line retrieved from inventory.

Purchasing and Inventory Management

Physical Inventory Process

The Inventory Management system enables you to receive parts into inventory through parts purchase (Purchase Orders), transfers from other shops (Part Transfers), or through direct electronic import (Part Import Program).

The inventoried items are relieved from the inventory system by charging the parts to a Repair Order, Indirect Charge Order, Part Transfer, or Credit Purchase Order. As you use the system, errors can accumulate for a number of reasons. In order to compensate for these errors, you should perform corrections periodically. The process provided to accomplish these corrections is called a Physical Inventory Adjustment.

Physical Inventory Adjustments can range from a minor adjustment in quantity for a single part to a complete physical count of your entire parts room inventory.

Go to Inven > Physical Inventory.

To update a Physical Inventory: - From the list of inventories, select the inventory you want to update.

NOTE: You can add a comment to an inventory in this list. The comment is displayed in the right pane, as shown in the example. Comments cannot be changed after the inventory is closed.
For a new **Physical Inventory**: - Select the appropriate shop, right-click and select **New Inventory**, or press **CTRL + INSERT** to create a new physical inventory record. The **New Physical Inventory** screen is displayed.

You can define the extent of the inventory you want to count. Partial inventories are useful for maintaining inventory levels as you use the system. However, when you are initially setting the system up for use, a full inventory should be done to provide the inventory information required so you can charge parts on various orders. For more information, see “**Your First Physical Inventory Count**” on page 210 for suggestions on creating your initial inventory.

After counting your physical inventory, click the **Counts** tab to input the actual counted items.
NOTE: During the time when you conduct a physical inventory, no parts should be charged to repair orders, or received on purchase orders.

On open inventories, the User Name and Date Changed fields identify who updated the inventory and when.

Physical inventories cannot include kits. A kit is made up of individual parts, each of which is counted separately.

After you update all item counts, you can close the inventory. To close the inventory, select the inventory to be closed on the Inventories tab, then pull down the Inventory menu item on the Physical Inventory dialog and select Close.

You can also right-click in the grid and select Close Inventory from the pop-up menu.

If you switch focus by clicking on the Inventory tab, if there are any pending changes, a prompt is displayed asking you to save your changes. This prevents loss of data if F6 is not pressed after entering the counts.
Once an inventory is closed, it cannot be re-opened or changed. There is an option to print a closed inventory exceptions report on the pop-up menu that is displayed when you right-click in the grid. This prints all items that were adjusted by the physical count. Items that had an actual count equal to the expected count do not appear on this report.

A sample of a Count Sheet printout is shown below.

<table>
<thead>
<tr>
<th>Part Number</th>
<th>Description</th>
<th>Bin Location</th>
<th>Expected</th>
<th>Actual</th>
<th>Difference</th>
<th>Adjusted Cost</th>
</tr>
</thead>
<tbody>
<tr>
<td>10074</td>
<td>Bulb</td>
<td>BMNT</td>
<td>0</td>
<td>10</td>
<td>10</td>
<td>9.40</td>
</tr>
<tr>
<td>107091-1.0PM</td>
<td>Clutch Assembly</td>
<td>BMNT</td>
<td>0</td>
<td>2</td>
<td>2</td>
<td>114.50</td>
</tr>
<tr>
<td>1117916N</td>
<td>Alternator 115 Amp</td>
<td>BMNT</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>75.00</td>
</tr>
<tr>
<td>127223</td>
<td>Brake-Clutch</td>
<td>BMNT</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>22.00</td>
</tr>
<tr>
<td>13884N</td>
<td>Brake Shoe</td>
<td>BMNT</td>
<td>0</td>
<td>5</td>
<td>5</td>
<td>68.75</td>
</tr>
<tr>
<td>16-056095L</td>
<td>Headlight Housing</td>
<td>BMNT</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>35.00</td>
</tr>
<tr>
<td>16-08302</td>
<td>Tail Lamp</td>
<td>BMNT</td>
<td>0</td>
<td>1</td>
<td>1</td>
<td>42.00</td>
</tr>
<tr>
<td>38M4322RX</td>
<td>Starter</td>
<td>BMNT</td>
<td>0</td>
<td>2</td>
<td>2</td>
<td>840.00</td>
</tr>
</tbody>
</table>

**TOTAL ADJUSTED COST: $1,206.05**

An abbreviated process is available from the **Inventory** menu, or when you right-click in the grid to display a pop-up menu on the Inventories tab and click on **Adjust Inventory**. Use this option to correct inventory counts for single items.
Upon entering the actual count for the item, click the OK button on the screen. This closes the inventory and posts the adjustment to the item record. The inventory adjustment is recorded in the system as a Physical Inventory by Part Range for the part specified.

**Your First Physical Inventory Count**

Your first physical inventory adjustment creates inventory quantities and the initial value of your inventory assets. After creating Shop Inventory records, the Transman/SQL Inventory Management System contains information about parts and supplier prices, but because you did not use the system to purchase those parts, TMT Fleet Maintenance is not aware of the cost of the parts currently in your parts room.

In order to establish the value of the parts you already have, you must provide cost and quantity information during this initial inventory process.

Use this procedure to make this process flow smoothly:

1. After creating all of your Shop Inventory part records, but before you do your actual count, open a full inventory and print the count sheets using the type of sort that you will use when you actually perform the physical count.
2. Delete the open inventory you just created. (Select the open inventory and right-click, then select *Delete Inventory* and confirm the deletion.
3. Research your part costs. Using the count sheets you just printed, write the unit costs for each part in the blank provided in the Quantity column. You will use this sheet when entering the part counts to provide cost information.
4. When you are ready to perform the actual count, make sure the Track Inventory check box in the Shop Master record is checked. Open a new full inventory and print the count sheets. Count the parts and enter the actual counts in the Quantity column of the new count sheets.
5. After the count is complete, place page 1 of the new count sheets over page 1 of the count sheets with the part costs listed so that the Quantity column on the cost sheet is visible to the right of the count sheet with the counts. The cost information for each part is then shown to the right of the count for the same part. As your counts and costs are entered, position each pair of count sheets in the same way.
6 In TMT Fleet Maintenance/SQL, select your open inventory and click the Counts tab. The parts listed appear in the same order as on your count sheets. For each part, enter the count and then the cost. Whenever you enter a count that is greater than the Expected count, you can enter the cost for the parts quantity that is greater than the expected quantity. Since all quantities are zero, the cost provided will before the entire quantity entered.

7 After providing counts and costs for all parts, close the inventory (select the inventory, right-click and select Close Inventory).

8 Select the closed inventory, right-click and select Print Closed Inventory Exceptions. Since all counts started at zero and you have now provided counts and costs for all the items you have, this report is a valid inventory listing, and the adjusted value provides the initial value of your inventory. You can print the report sorted by bin or sorted by part by using the right-click menu.

After an inventory listing is created, the sort order that was used is saved and used again when the option to reprint count sheets is used. The reprinted count sheets use the same sort order as the original count.

Requesting Parts

You can request parts in two ways. An employee can generate a requisition for parts, either manually in TMT Fleet Maintenance/SQL or by using the parts requisition process in Mechanic Workstation. The system can also automatically generate a requisition list based on the reorder parameter setup in the Item Inventory Master.

The Part Request form manually adds items to the Part Requisition List. This enables a mechanic or parts-room clerk to request parts when they are needed. If purchasing is done in a separate facility, the request is available immediately and is separated from the automatic-generated request. The item or part can then be ordered. To add an item or part request, go to Inven > Part Request Form. The Part Request Form screen is displayed.

If you enter a kit on the Part Requisition for parts that are supplied by vendors:

- If a vendor is added on the Part Requisition form, all parts are assigned that vendor.
- If no vendor is entered, the primary vendor for each part is used. If no primary vendor exists, the vendor information is blank.

Requisition List

The Automatic Requisition system uses one of the following formulae to calculate recommended reorders, when the On-hand based Reorder Formula option is selected on the Purchasing tab in Masters > Shops > Options.

- Standard Formula - If Quantity on Hand plus Quantity on Order is less than or equal to the Trigger Point, then the recommended re-order quantity is
equal to the Target Point minus the Safety Point. If Safety Point is greater than zero, formula 1 is used.

\[
\text{If } QoH + QoO \leq TrP \text{ then } RoQ = TgP - SP
\]

On-Hand Based Reorder Formula - If Quantity on Hand plus Quantity on Order is less than or equal to the Trigger Point, and Safety Point is zero, then the recommended re-order quantity is equal to the Target Point minus the sum of Quantity on Hand and Quantity on Order.

\[
\text{If } QoH + QoO \leq TrP \text{ and } SP = 0 \text{ Then } RoQ = TgP - (QoH + QoO)
\]

Note that if the Safety Point is greater than zero, the system reverts to the standard formula. This feature allows you to use both formulae depending on the nature of the part by choosing the appropriate Safety Point.

Go to Inven Requisition List. The Requisition List screen is displayed. You can order parts from inventory using the automatic generation routine and the manual part request forms. You must select a Shop ID to display the requested parts. You can use the grouping feature to help sort the list.

The manual requisitions are shown in the top portion and the automatic requisitions are shown in the bottom portion of the screen. Shop ID, Vendor ID, and Part type filter the Query form. This lets you see shop-specific parts that need to be reordered as well as checking the parts to order for a particular Vendor ID before you place the order.

Double-click the line item to edit a part on the Edit Requisition screen.
The requisition list can automatically generate a Purchase Order for all or a selected number of items. There are three command buttons on the Requisition list:

- **Automatic** runs the auto-generate procedure and populates the automatic requisition portion of the grid. This is done for the selection criteria shown.

- **Select All** highlights all the parts shown on the manual and automatic requisition list grid. After clicking on this button and selecting all parts, you can auto generate Purchase Orders for these parts. To select individual items for reorder, hold down the **CTRL** key and click on the items you want to order. Use the same method to deselect a selected item that you don’t want to order.

- **Create PO**. After you select all of the items you want to order, click **Create PO** and the system automatically generates Purchase Orders for the selected items and removes the items from the requisition list.

If a shop has the option **Allow Parts Transfers from Parts Requisitions** checked in **Shops Options Inventory**, you can right-click **Add to Manual Requisition List** in the Automatic Requisitions grid to add the part to a manual requisition list. If this is selected, the part requisition form displays with focus in the Shop ID field, allowing this automatic requisition to be changed to a manual requisition for any shop. Note that a user’s purchase order limits are enforced when selecting parts from a requisition list to create a purchase order. If the total cost times the quantity requested exceeds a user’s purchase order limits, the Create PO button is disabled and the error message *Over PO Limit, PO Cannot be Created* is displayed in the title of the requisition list.

If a part in a source shop’s inventory is out of balance, the error message *Inventory is out of balance for this part, please contact support* is displayed when attempting to transfer the part to another shop. A part is considered out of balance when the quantity on hand does not equal the quantity in the bins or does not equal the quantity on cost records.

### Prices Used on Requisition Lists

Requisition lists use the last cost recorded for a part. If the Use Bid Price option is enabled in SysMgr and the part in the requisition list is created for a vendor with a bid price, the new purchase order will use the part’s bid price instead.

### Using Palm Devices to Enter Parts Requisitions

From the **TMT Software** menu, click Parts Requisition.

The Parts Requisition screen is displayed.
Enter a Shop ID. If the parts are being requisitioned from a repair order, enter the repair order number and section. Click **Enter Parts**.

Enter the Part ID, the quantity, and the vendor ID if appropriate. Click Post to save the data.

**Searching Purchase Orders**

The *Search Purchase Orders* or *PO Query* screen displays Purchase Orders in a sorted listing that is defined by the search criteria and column sorting options defined on the screen. It shares these features with other Search Orders screens in TMT Fleet Maintenance/SQL.

Go to **Orders > Purchase Orders**. Click **Search** to display all purchase orders, or select a shop and click **Search**.
To display a list of backordered items, click the check box next to the Backorders Only field.

Purchase orders created by vendor repair orders can also be searched. The column Ref Order Num can be added so that the relationship between the vendor repair order and the purchase order can be seen. This column is not visible unless you customize the grid.

Printouts for purchase orders associated with vendor repair orders include the following unit information in place of the Ship To shop information: Unit ID, Unit Description, Unit's Domicile Shop, make, Model, Model Year, VIN #, In-Service Date, Cost Center, and License.

The Purchase Order Query displays both a purchase order account number and a vendor account number. You can search on either account number.

You can select a purchase order and right-click to see a list of actions that can be performed on the purchase order. Actions that cannot be performed for the selected purchase order are greyed.
If a purchase order does not have any closed or received receipts, the *Print Purchase Receipt* selection is disabled. Also, when a Print Receipt dialog is displayed, it will only display receipts that are closed or received.

If the *View Associated ROs* option is selected and a purchase order has parts assigned to repair orders, the Repair Order Number, Section Number, Section Status, Unit ID, Part ID, and Part Description are displayed. If the line is a service line, only the description has a value.

You can also customize the display. Additional fields available from the right-click customize menu are Company Unit, Component Description, Opened Date, Order Status, Order Type, Order ID, Shop ID, and Vendor ID.

A number of printing options are available when you click on Print.

You can print a standard or custom purchase order, the purchase receipt, a disbursement report, bar code labels for a part, a receiving worksheet, a stocking worksheet, or the entire query.

The purchase order system can be used to purchase inventoried items, services, and vendor repairs. There are three different ways to use the system:

1. **Direct Receive**
   When parts are ordered and received with an invoice at a shop, the Purchase Order can be directly received to inventory on post by checking the *Directly Receive to Inventory on Post* check box on the PO header when the purchase order is created. This permits the creation of the purchase order, the receipt to inventory, and the closing of the purchase order to occur in a single step.

   This method should only be used when the invoice is present when the parts are received. Enter the invoice number, date, and amount billed on the invoice when creating the purchase order.

   Vendor parts charged from a purchase order cannot be deleted or edited on a repair order.

2. **Standard Purchase Order with Invoice at Receipt**
   A standard purchase order is usually created to replenish stock. The standard PO can be created manually or by the Requisition system, and can be faxed or e-mailed (using the TMT Fleet Maintenance/SQL e-Purchase module) to the vendor to fill the order. After the PO is created, it will remain open in TMT Fleet Maintenance/SQL until all items on the PO have been received or canceled.

   When the items are received on an invoice, the PO can be received in full or in part. Enter the invoice number, date, and amount billed on the invoice screen when receiving the PO. Correct any price changes or quantities delivered. When the PO receipt is posted, you can indicate whether any undelivered part should be back-ordered or canceled.

   Each invoice receipt can be closed individually to make it available to Accounts Payable with its invoice information.
3 **Standard Purchase Order with Delayed Invoice**

When parts have been received but no invoice is available, a PO can be received without closing it. This allows items to be received into inventory and used while leaving the PO in a Received status until the actual invoice arrives. When the invoice is in hand, the PO (or Received PO section) can be edited to reflect any inaccuracies in pricing, and then closed. Any variance in closing price from receipt price is available to the Accounting Data Export for posting. Enter the invoice number, date, and amount billed on the invoice screen when closing the PO or section receipt. Enable the use of this third option by checking the Do No Automatically Close on Receive option on the *Purchase Order Options* screen.

There are three additional buttons on the bottom of the query screen:

- The **Receive** button receives into inventory the parts in the open purchase order that is highlighted on the grid.
- The **Open** button opens the highlighted purchase order.
- The **New** button displays the *Open Standard Purchase Order* screen and prompts you for the Vendor ID and the Shop ID in the Header tab.

![Image](https://example.com/image.png)

The *Header* tab contains values for the fields that are used to create the purchase order header.

The *Detail* tab lists all the parts, labor, services, and comment lines for the purchase order; also, any miscellaneous and freight charges and sales tax are displayed.

The *Invoices* tab is used to create or maintain invoices for a purchase order that has not been closed. To add a new invoice, right-click and select Insert Record. To edit existing purchase orders, double-click the record or right-click and select Edit Record. Existing invoices can be deleted by right-clicking on the invoice and selecting Delete Record or by pressing CTRL+DEL on the keyboard after highlighting the record you want to delete.

The *User Fields* tab displays user-defined fields that were set up for purchase orders in SysMgr u User Defined Fields. They can be edited from this screen by clicking on the Define Fields button.
**Purchase Order Options**

To display the *Purchase Order Options* screen, click the **Options** button on the upper right corner of the *Search Purchase Orders* screen. The options you select are workstation-specific, and will remain as checked until they are changed.

The check boxes enable the following actions:

**Insert New Order after Post** - If checked, a blank Purchase Order header is displayed on the screen when a completed Purchase Order is posted (using F6). If it is not checked, the purchase order form is cleared and the previous screen is displayed.

**Directly Receive to Inventory on Post** - If checked, all Purchase Orders will be in Direct Receive mode. If it is not checked, any individual purchase order can be made Direct Receive by checking the Directly Receive to Inventory on Post box on the PO header, but they will normally be received at a later time if that box is not checked when the PO is created. This option should only be used when the Direct Receive method is your normal mode of purchasing.

**Do Not Automatically Close on Receive** - If checked, a dialog box is displayed when a purchase order is received that asks if you want to close the purchase order at that time. If you respond Yes, the PO closes. If you respond No, the PO remains open in a received condition until it is closed. This enables you to make final adjustments after an invoice is received. If it is not checked, the PO is closed when all items are either received or canceled. This option should not be used in tandem with Insert New Order After Post or Directly Receive to Inventory on Post.

**Print Document after Posting new Purchase Order** - If checked, a purchase order document will be printed when a newly created purchase order is posted using F6.

**Print Receiving Document on Partial Receipt** - If checked, a purchase order receiving document is printed when parts are received into inventory and parts that have not yet been received remain on the purchase order.

**Print Receiving Document on Closed or Received Status** - If checked, a receipt document is printed when the PO is received or closed (for the three-step purchase order process).
Print Account Disbursement Report with Receiving Document – If checked, a separate report is printed with account totals. If the accounting features are enabled in SysMgr > Options > Misc, the document provides a breakdown of account credits and accounting debits. This option is only available if Print Receiving Document on Partial Receipt or Print Receiving Document on Closed or Received Status is checked. On Repair Order Work Cards, Repair Order Section Work Cards, Repair Order Details, Repair Order Section Detail, Purchase Orders, Purchase Order Receipts, and Purchase Order Disbursement Reports, you can right-click to print the form.

Purchase Dollar Amount Limits
The TMT Fleet Maintenance Security Administration program enables the TMT Fleet Maintenance/SQL Administrator to set dollar amount limits for users. The limits can be set for individual users, or for classes or groups of users. For more information, see the online help in the Security Administration (SecAdmin) program. Go to Start > Programs > Transman > SecAdmin to view the online help.

NOTE: The SecAdmin program is installed on the TMT Fleet Maintenance/SQL Administrator’s workstation and is not available to general users. If you cannot access the SecAdmin program, ask your TMT Fleet Maintenance/SQL Administrator about your dollar amount limits.

Creating and Updating Purchase Orders
Click the right mouse button when the cursor is in the Order No. field displays a pop-up menu offering the Sticky Note option. This saves a Sticky Note attached to this specific purchase order that appear whenever you exit the order number field. The Sticky Note is viewable regardless of the PO status and can be edited as long as the PO status is not Closed.

Sticky notes are shop-specific. The heading at the top of the sticky note indicates the shop and the order number. In the example above, the shop ID is shop 05 and the order number is 000000001.

After you enter the Shop ID and Vendor ID, TMT Fleet Maintenance/SQL automatically populates the Shop To address and assigns an automatic Purchase Order number.
At this time, you can fill out the other order information. When this is complete, click **Post** to save the changes. Then click the **Detail tab** to display a Detail view.

From this screen, you can enter the items to be ordered. The three types of line items that you can add are: **part** (an inventoried item), a **service**, and a **comment** line.

The part line item is the part, tire, or fluid to be ordered. Right-click the mouse when the cursor is in the grid to display the **Purchase Order Line Item** screen.
The check boxes enable the following actions:

**Vendor Supplied** - If checked, the item passes directly to a currently open Repair Order. When checked, a valid repair order and section are required.

**Taxable** - If this part was set up in inventory with the Taxable option checked, the part should have tax calculated when purchased. If the Taxable option was not selected, the field is not available.

**Use on Next** - If checked, retains the purchase order section number and passes it to succeeding lines to facilitate charging a number of items to the same repair order.

**NOTE:** A repair order number and section number are required for Vendor Supplied Parts.

To purchase and charge vendor parts directly to a repair order, click the Vendor Supplied check box. This expands the Purchase Order Line Dialog to display the Component Code, Category, and Charge UOM. The Quantity UOM, Taxable, and Description fields become enabled if the combination of Shop ID, Part ID, and Vendor ID have not been previously defined.

Vendor parts cannot be deleted if they exist on an open purchase order.

When a vendor repair order is created, a purchase order is automatically created with PO type Vendor RO. The purchase order is automatically synchronized with the repair order as lines are created. The vendor purchase order that was created cannot be received and lines cannot be added from the purchase order. To update the purchase order, update the vendor repair order.

When prices for parts are updated in TMT Fleet Maintenance/SQL, if a Vendor ID is entered, only parts that have the selected vendor as the primary vendor are used to insert or update the pricing information. This feature enables you to carry the same part from two different vendors with two different prices associated with the appropriate part.

TMT Fleet Maintenance/SQL provides fields for Bid Price and Bid Date on the Vendors tab in the Parts Catalog that can be used to track which part should be purchased from a specific vendor and the data that the bid starts or ends. This information can be easily updated for a particular vendor. The updates occur on the Parts Catalog vendor record and will filter to the shops based on the option **Use Vendor from Parts Catalog** set at the global or shop levels. The fields that can be used as search criteria include: Vendor ID (required), Bid Number, Bid PO Number, Bid Date, and Bid End Date. After the parts for the criteria are returned, you can then select multiple parts to update. The edit screen enables entry of a Bid PO Number, Bid Date, Bid End Date, Big Number, and the ability to mark the vendor as primary. Any changes to these fields are applied to all the selected parts. The Bid Price can
also be edited for each individual part in the grid. Bid Price changes are only applied to that individual part.

You can only assign a Repair Order and section to a Purchase Order line item if the Repair Order Shop ID matches the Purchase Order Shop ID. When searching for a repair order, you cannot edit the Shop ID field to access Repair Orders from another shop for Purchase Order line items. This ensures that the correct inventory is credited if line items are cancelled.

After you enter the part, you can:

- Press **F6** to post the record and add a new record. The screen is cleared so that you can enter information for another part. At this time, the Line type can be changed and the form changes appropriately.
- Click **OK** to close the dialog box, then right-click in the grid and select a new line type from the pop-up menu.

After you enter the Part Number, the description and price is entered if the part exists in the database and you are prompted for the quantity. If the part number does not already exist and the Allow Local Parts option is checked, the program prompts you to add the parts. Otherwise, the system will check the Parts Catalog for the part. If the part does not exist in the catalog, you will not be able to add the part to local inventory. In this case, the part must be set up in the parts catalog before adding it to the purchase order.

The Add Local Shop Inventory Part screen is displayed.

![](image)

This dialog creates the Shop Inventory record for the new part. The Purchase Order can be generated and inventory items can be added simultaneously. When you enter a line item for a Purchase Order, several items on the Header tab are unavailable and cannot be edited.

The other two line types are services and comments.
The services line item is used for vendor-supplied repairs and services provided to a Shop, Unit or Parts.

![Purchase Order Line Item](image)

The Comment Line screen is used to enter comments.

![Purchase Order Line Item](image)

To add multiple services or comment lines to the Purchase Order, press F6 after completing a line item. The system prompts you for another line item. The line item type can be changed from the drop-down edit box and a different line item entered. This saves time and speeds data entry of the purchase order.

**NOTE:** Purchase Orders use the Vendor tax rate by default, not the Shop rate unless a Purchase Order Resolve has been established.

After you enter all line items, press **ALT + O**, or click on the **OK** button to close the line item dialog box. The detailed view is displayed again. Press **F6** to post this completed purchase order, or click on the **X** in the top right hand corner of the window. The system prompts you to save the changes and you must click **OK** or press the Enter key to save the changes.

The Purchase Order prints (or not, depending on your options settings) and returns you to the Purchase Order Query screen.

If a Remit To address has been entered for the vendor, the Remit To address prints on the purchase order underneath the vendor name.

Although TMT Fleet Maintenance/SQL automatically calculates taxes on purchase orders, you can enter tax amounts other than the one provided by the system, including an amount that is higher than the system-provided amount.

If a purchase order is created from a requisition list and parts have been assigned to a repair order and section and there is more than one line for the same part assigned to repair orders, those lines will not roll up into one line on the purchase order. Parts not assigned to repair orders will roll up into a single line. This ensures that parts requested but not on hand could be ordered and filled and the system can properly update the request record.

When adding services to purchase orders, if the Service Lines on PO Require an Order option is enabled in SysMgr > Options > Purchasing, the **OK** button is not enabled until an order number and section number are entered.
Changing Vendors on Purchase Orders

You can change a vendor on an open STANDARD purchase order as long as no receipts were made.

Go to Orders > Purchase Orders. From the Purchase Orders screen, right-click on the invoice you want to change, and select Change Vendor.

A confirmation message is displayed. Click Yes to continue, or No to quit.

Select a new vendor from using the search function, then click OK to save the change.

Receiving Purchase Orders

After creating and printing a Purchase Order, the next step is to receive the item into inventory. Remember if the Purchase Order is direct receive, an Open PURCHASE ORDER does not print and it is automatically received into inventory.

Open the Purchase Order query screen and find the Purchase Order to be received.

To receive the Purchase Order, click on the PO line to select the item (the arrow-head is pointing at the Purchase Order you want to receive). Click on the Receive button to display a details screen.
There are two command buttons at the top left-hand side of the screen. The **Mark All** button marks all of the items as received. The **Clear All** button unmarks all of the items.

If there are items that were not received, do not mark these items. If a partial shipment of items was received, key in the quantity that was received in the first cell. If the quantity received does not equal the quantity ordered, the item is labeled *back-ordered*.

If the invoice for the received items indicates a different price than the price ordered, you must enter the price in the Receiving Price cell.

To enter invoice information, go to the Invoices tab and right-click to select Insert Record. Provide the invoice number, date, and amount billed (invoice total).

To remove an invoice record, right-click and select Delete Record.

If the check box for *Require Invoice Amount to match PO receipt total* in SysMgr > Options is checked, the invoice amount billed must match the purchase order total.
If the global purchasing option *Do not allow duplicate invoice number by vendor* is checked, the same invoice number cannot be used twice for a vendor.

After all the items are received, the Purchase Order is considered closed. Before the Purchase Order is closed, the invoices received and other payment information can be added into the invoice screen. The invoice number, date, and amount billed should be added to this screen. You can have multiple invoices for a Purchase Order. The amount paid and check number fields are available for use by your accounts payable department.

When you use the right-click menu to print purchase orders, the *Print Purchase Receipt* menu is disabled if there are no closed or received receipts. (This restriction also applies to the *Print Receipt* grid.)

If the ComData module is installed, you can request a check to pay for purchase orders.

After the Purchase Order is received, bar code labels are printed.

TMT Fleet Maintenance/SQL uses the standard windows printer drivers, which allows you to fax Purchase Orders directly from the computer using a fax printer driver.

TMT Fleet Maintenance/SQL can also e-mail purchase orders to your customers (this function requires the E-Commerce Module).

Back-ordered Purchase Orders are treated as an open Purchase Order until all items are received or cancelled. At the time the partial receipt is made, you are prompted when the record is posted to either cancel or back-order the item.
Using Blanket Purchase Orders

A blanket purchase order enables you to add additional receipts and invoices to the purchase order and leave the purchase order open.

To use a blanket purchase order:
1. Create a purchase order with a purchase order type of BLANKET.
2. Add parts and services to the purchase order.
3. Create an invoice for the parts and services.
5. A confirm dialog is displayed indicating the Purchase Order was received and asking if you want to close it.

If you select No, the purchase order will remain open and steps 2 through 4 can be performed again. If you select Yes, the blanket purchase order is closed and no additional parts or services can be added.

6. If you have several receipts on a blanket purchase order that has not been closed, right-click on the purchase order on the Purchase Order Query screen and click Close Receipts to close the purchase order.

Printing Purchase Orders

1. From the Purchase Orders screen, click on the purchase order you want to work with to select it.
2. Right-click and select Print.
3. From the pop-out menu, select the type of printout you want to print.

NOTE: All printing functions are now grouped under the Print menu.
4 The report you requested is printed on your workstation’s default printer.

**Printing Bar Code Labels from a Purchase Order List**

1. From the Purchase Orders screen, click on the purchase order you want to work with to select it.
2. Right-click and select Print.
3. From the pop-out menu, select Print Bar Code Labels.

A label is printed for each part and the total quantity ordered for each part.

**NOTE:** A bar code printer must be set up for the labels to print. To set the bar code printer globally, go to SysMgr > Options, click on the Printing tab, choose the correct bar code printer, and set up the fonts. On a user level, go to SysMgr > User Options, click on the Printing tab, and choose the correct bar code printer and set up the fonts.

**Part Transfers**

To locate a part in your system, go to Activities > Part Search by Shop. The Parts Search by Shop screen is displayed. Enter a Part ID.

You can view the Quantity on hand in each of your shops for the specific Part ID.
Once you have located the part you need, you can use the Part Transfer functions to transfer parts from the inventory of one shop to another shop in the company.

Go to Inven > Part Transfer. The Part Transfers search screen is displayed.

To transfer parts, click the New button in the lower right corner of the form to display the Parts Transfer Request screen.
To request a transfer of parts either to or from a shop, provide the **Source Shop ID** and the **Destination Shop ID**, then either press **CTRL + INSERT** or right-click in the grid and select **New Part Line** from the pop-up menu. The **Transfer Line Item** screen is displayed.

Add the items needed to the transfer request. The items are transferred when the transfer request is posted using **F6** or by clicking **OK**.

**Transfer Parts from Requisition List**

Parts needed to satisfy a parts request can be transferred from another shop on the **Requisition List** screen.

When the feature is not enabled, the top of the **Requisition List** screen looks like this:

To enable this feature, go to **SysMgr > Options** and click on Inventory. Make sure the **Allow Parts Transfers from Parts Requisition** check box is checked.
After the option is enabled, and the Requisition List screen is populated, a Parts Transfer section is added to the top of the Requisition List screen.

To transfer a part from another shop to satisfy a parts request, select the part in the list on the Requisition List screen. Click the Transfer Part(s) button at the top of the screen, or right-click on the part and select Transfer Part(s). The Shop ID dialog box is displayed.

Select the shop where the part exists and click OK.

Fuel System

Use the Fuel Ticket/Trip entry system to enter fuel purchases for equipment from road or company purchases. The system can track any Fluid Type such as oil and fuel for the Unit ID. Only fluids that are defined for a unit in the Unit Master record’s Fluids tab can be charged to a unit on a fuel ticket. Fluids charges on fuel tickets contribute to consumption reporting in the Unit Fuel Utilization report. Fluids charged on Repair Orders do not contribute to consumption in this report.
Fuel Tickets

Go to Orders > Fuel Tickets. A query view screen is displayed. This screen works like other order query screens; the selection criteria and the sort column functionality is the same.

The Shop ID, Fuel Type, Unit ID, Vendor ID, or date range fields can be used to filter the ticket listing grid. The Fuel Ticket does not have a status of opened or closed. Once the ticket is added, it is posted and added to the system.

The Fuel Ticket history listing can be sorted by column. To change the sort order, click on the heading of the column you want to use to sort. The arrow indicator shows the sort order (ascending or descending).

To display by grouping, drag a column header to the grouping area. The list is sorted again using the new criteria.

The detailed information for a Fuel Ticket can be viewed by double-clicking on the Fuel Ticket in the Fuel Ticket grid.

To create a new Fuel Ticket entry, right-click anywhere in the Fuel Ticket grid and select New Fuel Ticket, or click on New. A data entry screen is displayed.

Enter the Shop ID and click New Batch. The NEW Fuel Ticket screen is displayed.
Fuel Ticket Entry

The Fuel Ticket Order form provides a way to manually enter fuel purchase information. Electronically imported fuel ticket data creates fuel tickets identical to manually-created fuel tickets, and can be viewed in the same way. The Batch Management function provides a batch total report to check your data entry.

Fuel tickets are opened and closed in a single operation, and once a ticket is closed, it cannot be edited. To correct errors on posted fuel tickets, you must post another ticket to compensate for the error. For example, if you charged 50 gallons too much fuel to a unit, enter another fuel ticket for the same unit with a quantity of 50 (negative quantity) gallons.

1 To begin the data entry session, set up the fuel ticket form to reflect the tickets you need to enter.

2 Select the appropriate Shop ID. All company tickets entered will relieve the fuel inventory for that shop if the Track Fuel in Inventory option is checked in Shop options. Whether you want to track the on-hand quantity or not, a shop inventory record for the fluids you are entering on fuel tickets must exist in shop inventory. You must enter a Shop ID, even though all the tickets to be entered might be road purchases.

3 Also select Ticket Type and Charge Date. These fields will remain as set until they are changed so that as you enter successive tickets, they will all be the same type and post to the same shop on the same date. For Ticket Type, the only valid selections are Company or Road.

4 The required fields differ between Company and Road purchases. Company tickets require a Unit ID, ticket date, any required meter readings, and a quantity. Road purchases require these fields and extended price and Vendor ID. On a Road purchase,
the unit price is calculated by dividing the extended price by the quantity. On a Company purchase, the unit price comes from the inventory record and the extended price is calculated by multiplying the unit price by the quantity.

5 If you have selected the option to require Trip Numbers on Fuel Tickets, the Trip No. field must also be completed. This feature can be useful if you use TMT Fleet Maintenance/SQL to generate Interstate Fuel Tax data.

6 As each record is complete, press F6 to post the record. The Fuel Ticket entry form is cleared for you to post the next ticket.

7 When you are finished, click the OK button to clear the Fuel Ticket Entry form from the screen.

**NOTE:** If a credit fuel ticket is entered and the inventory method is AVGCOST, the credit will use the average cost. If the inventory method is LIFO or FIFO, the last cost is used.

### Using Palm Devices to Enter Fuel Tickets

You can use Palm devices to capture company or road fuel tickets.

The Palm device captures information about:

- Ticket type (company or road)
- Vendor ID (for road fuel tickets)
- Shop ID
- Fuel Type/Use Primary Fuel Type

From the TMT Software screen, click Fuel Tickets.

The setup screen is displayed. You can select a shop, specify road or company fuel tickets, specify a Vendor ID, and specify whether a primary fuel type is used. The number of records is displayed.

To enter a fuel ticket, click **Enter Fuel Tickets**.
After supplying this information, a second detail form is used to collect the remaining data for a single complete record:

- Unit ID
- Quantity
- Primary Meter Reading
- Cost

Enter the fuel ticket data and click **Post**.

After the data is collected and validated, you can save the Fuel Ticket record and enter the next fuel ticket. The Palm device continues to display the same detail form to enter more fuel tickets until you exit the screen.

Fuel ticket records that are created on the Palm device are copied to the host PC using the Palm HotSync application that ships with the Palm device and the TMT Conduit DLL (TMTConduit.dll) that is installed when the host PC is configured. The TMT Conduit DLL will be installed in the same folder as the Palm Desktop software and manages all data transfers between the TMT Palm-based applications, including transmitting TMT data to the Palm device that is used for data validation.

The data transferred by the TMT Conduit is moved from the Palm device to the main TMT Fleet Maintenance/SQL server using position-delimited text files named FuelTicket- Road.txt (for Road Fuel Tickets) and FuelTicketCompany.txt (for Company Fuel Tickets), which are located in the path specified in the TRANSMAN.INI file under the [Slimscan] section FilePath key.

The Road Fuel Ticket files contain only records that represent fuel obtained from an external vendor (that is, the truck stops at a filling station that does not belong to one of the company’s shops).
The Company Fuel Ticket files contain only records representing fuel obtained from a company shop.

When you connect the Palm device to a HotSync cradle or cable and initiates the HotSync, the HotSync application uses the TMT Conduit to access the TMT data on the device. The data is copied from the Palm device to the appropriate text file as noted above. You must then execute the Fuel Import dialog to complete the transfer from the text file to the main TMT Fleet Maintenance/SQL database server.

**NOTE:** Do not mix Primary meter fuel tickets with selected meter fuel tickets. The fuel data import program does not handle this.
TMT Fleet Maintenance/SQL can import fuel purchased using a Comdata MasterCard. The import process uses a predefined import that is shipped with the TMT Fleet Maintenance/SQL database and an application that takes the fuel from the format that is sent to the customer and converts it into a .TXT file that TMT Fleet Maintenance can import.

To start the Data Import Setup for Fuel go to **SysMgr > Imports > Fuel Import Setup**.

![Image of TMT Fleet Maintenance/SQL interface]

You must set the location for the application by clicking on the **Browse** button to the right of the **Application Name** field and navigating to the TMT Fleet Maintenance directory for the location of the application.

You must also set the location to where the Comdata MasterCard file will be located by clicking on the **Browse** button to the right of the **Input File Name** field and navigating to the location for the Comdata file, which also should be in the TMT Fleet Maintenance directory for the program to function correctly.

Note that the **File Name** field enables you to set the location of the file that you are importing. You can browse for this file or file type in the location. You must create a .TXT file for the system to recognize. This file also should be in the TMT Fleet Maintenance directory for the program to function correctly.

The program can also delete or purge the file after it has been imported. If this file is appended to rather than deleted, duplicate fuel entries would result.

This import will always use the vendor COMDATA; therefore, a vendor called COMDATA must be set up in the Vendor master.
Use the Cross References field to use files that were created with other information that is not in TMT Fleet Maintenance/SQL. These are limited to only Unit, Site, Fuel Type, and Vendor.

To set up the cross-reference field, right-click and select Insert. The cross-reference screen is displayed.

From the drop-down menu, select UNITID, tab to the Import Value field, and insert the value that is being cross-referenced. Then tab to the TMT Value field and either type in the UNITID or search for the unit using the search facility.
After the cross-reference is selected, TMT Fleet Maintenance/SQL displays the values inputted in the Cross-Reference tab.

After creating these files, click on the Specification tab, then click the ASCII Import button.

TMT Fleet Maintenance/SQL displays the ASCII tab where you can view the data that is being imported. View the information and determine if the data is correct. If it is not correct, then go back to the Specification tab and check the entries.
If the information in the ASCII tab is correct, then go back to the Specification tab and click the Data Import button. A progress bar is displayed. After the import is complete, the Translation tab will be displayed.

The Translation tab indicates which records are imported correctly and the information that was imported. After viewing this information, go to the Exceptions tab to review the records containing information that is incorrect.

On the Exception tab, the Import Status has a description of the reason why the record was not imported.
If you double click on a line posting an error, the program redirects you to the Fuel Ticket Entry screen.

On this screen, you can correct the entry manually. When the entry is correct, it will automatically be removed from the Exception tab. If the entries in the Exception tab are records that you do not want to correct, you can delete them by highlighting that record and clicking the Delete button, or you can delete all of the Exceptions at one time by clicking the Delete All button.

To run the Utilization import process, go to Activities > Data Imports > Fuel Data Import.
Choose the Import Specification to import and click the **Import** button. This starts the import process.

After the process is complete, the exceptions are displayed (if there are any) and can be corrected in the same way as described in the setup. There is also a filter applied to this screen, so if your company has more than one person doing the fuel import, each person can review and correct their exceptions only.

**Trip Tickets**

The Trip Ticket program captures the miles driven for each Unit and the state in which the miles were driven. Trip Tickets are entered into a screen and the data calculates the miles driven for each state. This is used for Fuel Tax computations.

You can specify the driver ID for trip segments, and indicate whether the unit was empty or loaded (the default). Each trip segment contains a Notes field.

*NOTE*: The meter reading entry in the Trip Ticket program does not record meters in the Unit Meter History, and is not subject to the error trapping routines that meter readings entered on Repair Orders and Fuel Tickets are.

**Display a List of Trip Tickets**

To display a list of trip tickets, go to **Orders > Trip Tickets**. Select any search criteria necessary to define the search, and then click on **Search**. A list of trip tickets that match the search criteria is displayed.
Entering New Trip Tickets

To enter Trip Tickets, go to Orders > Trip Tickets. Right-click anywhere in the grid and select New Trip Ticket. The Trip Tickets screen is displayed.

Type the Unit ID or select it using the search icon. Use the Tab key to advance to the other fields to complete the data entry. Comments can be added to each Trip Ticket at the bottom of the form.

If your company scans receipts, log entries, or other paper forms, you can include an image of the scanned data in the User Fields tab. Before you can use this feature, you must first define the user fields.
Setting Trip Ticket Options

Click on the Options button on the Trip Tickets search screen to set the options for trip tickets.

![TripOptionDlg]

**Default Mode** - Select On-Line or Batch.

**Close Tickets on Post** - If this check box is selected, the trip ticket is automatically closed when F6 is pressed to exit.

**Insert Ticket After Post** - When this option is selected, a trip ticket form is added when F6 is pressed.

**Prompt for Close on Post** - When this option is selected, a dialog box is displayed when F6 is pressed. Select one of the options displayed in the dialog box to complete the process.

After selecting the options you want, click on OK to close the dialog box.

Editing Trip Tickets

To edit segments of an open trip ticket, right-click on the segment you want to edit and select Edit Segment.
NOTE: You cannot edit closed trip tickets.

The Trip Segment screen is displayed.

Closing Trip Tickets

To close an open trip ticket, right-click on the trip ticket and select Close Trip Ticket. The Trip Ticket Close dialog box is displayed.
Click on OK to close the trip ticket, or on Cancel to quit without closing.

**Deleting Trip Tickets**

To delete a *segment* on an open trip ticket, double-click on the trip ticket (or right-click on the ticket in the search list and select *Open Trip Ticket*).

The *Trip Ticket* screen is displayed. Right-click on the segment you want to delete and select *Delete*. 
To delete an open trip ticket, right-click on the segment you want to delete and select Delete. The segment is deleted immediately (no confirmation message is displayed).

**NOTE:** You cannot delete closed trip tickets.
Chapter 6: Management Reports

A variety of management reports are available in TMT Fleet Maintenance/SQL.

- Output with the word *Report* in the title was designed as a printed report, and although it can be viewed on screen, it is most usable on paper.
- Output with the word *Inquiry* in the title was designed as an on-screen reference tool. It can be printed, but does not look as good on paper as a Report.

This chapter serves as an overview of TMT Fleet Maintenance/SQL reports. For more information about the reports available in TMT Fleet Maintenance/SQL, including instructions on how to create a report and an explanation of the fields displayed in each report, see *TMT Fleet Maintenance/SQL Management Reports*.

TMT Fleet Maintenance/SQL can also print specific custom invoice reports (such as a custom repair order invoice or a direct sale invoice). For more information, see “Custom Invoices” on page 275.

Creating a Report

There are three tabs on most report forms:

- The **Selection** tab enables you to define the basic selection criteria for the report.
- The **Additional** tab defines additional sort criteria or groupings. Sort criteria can be different for each report; only those sort criteria that apply are displayed for each report.
- The **Date Range** tab enables you to select the date range for the report.

**NOTE:** Some reports do not have date range options. Listing and status reports always reflect current conditions and therefore have no date range options.

Masters Reports

The following reports can be created from the Masters menu:

- Customer Reports
- Employee Reports
- Jobcode Reports
- Parts Catalog
- Shop Reports
- TINA Reports
- Unit Repair Inquiries
- Unit Inquiries
- Unit Reports
- Vendor Reports
Customer Reports

Go to Masters > Reports > Customer Reports. There are ten customer reports available:

- Customer Cost Summary
- Customer Listing
- Customer Gross Profit Report
- Customer Units Listing
- Customer Invoices Listing
- Customer Unit Cost of Ownership Report
- Customer Unit Component Cost Report
- Customer Unit Component Cost Summary Report
- Customer Unit Life Cycle Report
- Customer Unit Reason for Repair Analysis

From the Report Title drop-down menu, select the type of customer report you want to create. Click Preview to view the report on your computer monitor, or on Print to print it.

Employee Reports

Go to Masters > Reports > Employee Reports. There are four reports available:

- Employee Indirect Labor Log
- Employee Labor Log
- Employee Listing
- Employee Time vs Work Time Report
From the Report Title drop-down menu, select the type of employee report you want to create. Click Preview to view the report on your computer monitor, or on Print to print it.

For the Labor Log reports, the Additional tab enables you to include or exclude specific indirect labor codes.

**Jobcode Reports**

Go to Masters > Reports > Jobcode Reports. There are two reports available:
- Jobcodes by Shop Report
- Jobcodes by Component Report

From the Report Title drop-down menu, select the type of jobcode report you want to create. Click Preview to view the report on your computer monitor, or on Print to print it.
Parts Catalog  

Go to Masters > Reports > Parts Catalog. There are four reports available:

- Parts Catalog Listing
- Parts Catalog Kits Listing
- Parts Catalog Substitute Parts List
- Parts Catalog Superseded Parts List

From the Report Title drop-down menu, select the type of parts catalog report you want to create. Click Preview to view the report on your computer monitor, or on Print to print it.

Shop Reports  

Go to Masters > Reports > Shop Reports. There are six reports available:

- Shop Component Cost Analysis
- Shop Cost Analysis
- Shop Direct/Indirect Labor Log
- Shop Foreign Repair Analysis
- Shop Listing
- Shop Reason for Repair Analysis

The Shop Reports are printable reports that can be defined by a number of different criteria. The criteria available to define the report will depend upon the report title chosen.
NOTE: Some reports do not have date range options. Listing and status reports always reflect current conditions and therefore have no date range options.

TINA Reports

Go to Masters > Reports > TINA Reports. There are two reports available:

• TINA Employee Time Analysis
• TINA Employee Time Card Report

From the Report Title drop-down menu, select the type of report you want to create. Click Preview to view the report on your computer monitor, or on Print to print it.
Go to Masters > Reports > Unit Repair Inquiry, or use the Toolbar icon.

The Unit Repair Inquiry reports are designed to be view on-screen by the Shop Manager or Shift Supervisor to access historical repair information for a specific unit.

Enter a Unit ID (or search for a unit using the Search icon).

The Closed Repair Orders tab is the default view and displays all closed repair orders for this Unit ID. If a Component Code is entered, the display is restricted to all closed repair orders with sections defined by that component code. The cost of each section for a repair order is displayed, and a summary of the Warranty Cost and Section Total columns is displayed at the bottom of the screen.

The Open/Pending tab displays a list of all open Repair Orders and pending Repairs for the selected Unit ID. A summary of the Section Total columns is displayed at the bottom of the screen.
The **PM Info** tab lists all Preventive Maintenance Due for the selected unit in the top portion of the form. The bottom portion displays all completed PM repair orders for the unit. The Status field indicates whether a PM section is closed or canceled. A summary of the **Total** columns is displayed at the bottom of the screen.

The **Specs** tab provides access to the same component specification information as the **Specs** tab in the Unit Master form. Additional fields that you created for component specifications are not visible here. They must be accessed from the **Specs** tab in the Unit Master record.
You can print the repair order work card or detail report by right-clicking on the Closed Repair Orders tab, the Open/Pending tab, or the PM tab. You can sort on any column by clicking the column header on these tabs.

**Unit Inquiries**

Go to Masters > Reports > Unit Inquiries. The Unit Inquiries reports are designed to be viewed on-screen by the Shop Manager or Shift Supervisor to access information about groups of units.
The **Options** tab enables you to define the unit grouping on which you want a report. You can enter as many selection criteria as needed on this form.

The **Unit Inventory** tab lists all units meeting the criteria defined on the Options tab.

The **Utilization** tab displays the utilization for all meters defined for all the units meeting the criteria on the Options tab. Life to Date utilization is also displayed.

The **Due PMs** tab lists all Preventive Maintenance due on units meeting the criteria on the Options tab. You can create PM repair orders from this tab. To select multiple PMs for the repair order, hold down CTRL and click the PMs you want to include, then right-click and select Create Plan/RO from the drop-down menu.

The **Expenses** tab lists costs by Order Type, Charge Category and Total for the criteria on the Options tab.

### Unit Reports

Go to **Masters > Reports > Unit Reports**. There are seventeen reports available:

- Unit Component Cost Report
- Unit Component Cost Summary
- Unit Cost by Utilization Report
- Unit Cost Detail Report
- Unit Cost of Ownership Report
- Unit Cost Summary Report
- Unit Down Time Analysis
- Unit Fuel Ticket History Report
- Unit Fuel Utilization Report
- Unit Inventory Report
- Unit Life Cycle Report
- Unit Parts Usage Listing
- Unit PM Due Report
- Unit PM Master Listing
- Unit Reason for Repair Analysis
- Unit Repair Costs by Repair Shop
- Unit Utilization Report

The Unit Reports are printable reports that can be defined by a number of different criteria. The criteria available to define the report differ depending upon the report title chosen.

There are three tabs on this form. The **Selection** tab enables you to define the selection criteria for the report. The **Additional** tab defines additional options such as grouping, sorting or filtering. The **Date Range** tab enables you to select the date range for the report.
NOTE: Some reports do not have date range options. Listing and status reports always reflect current conditions and therefore have no date range options.

• If a unit does not have a primary meter or any meters set up, it will not be shown on the Unit Cost Summary Report.

• On the Unit Component Cost Report, a check box on the Additional tab enables you to select a Detail Report. The detail report provides additional information about individual units.

Vendor Reports

Go to Masters > Reports > Vendor Reports. There are six reports available:

• Vendor Listing
• Vendor Part Supplier Report
• Vendor Purchases Report
• Vendor Part Listing
• Vendor Part Usage
• Back Order Report
From the Report Title drop-down menu, select the type of vendor report you want to create. Click **Preview** to view the report on your computer monitor, or on **Print** to print it.

**Orders Reports**

The Orders menu contains an option to obtain a report about order inquiries.

**Order Inquiries Reports**

Go to **Orders > Reports > Order Inquiries**. The Order Inquiries function enables you to search and view your data using a flexible query form. Provide as much information as you have about the item you are looking for on the **Parameters** tab, then go to the **Results** tab to view the results of your query.
When an Order Type is selected, additional fields are displayed in the lower right area of the form to provide additional query options. The additional fields revealed are different for different order types.

If an Orders menu option is disabled, that order type is not selectable from the Order Type drop-down menu on the Parameters tab. Order types that can be disabled include Repair, Fuel Ticket, Purchase, Indirect, Invoice, Warranty, Campaign, and Transfer.

The example shows the additional fields that are displayed when the order type REPAIR is selected.

The Non-Company section is displayed for Order Types Invoice and Repair. It enables you to search for criteria based on non-company units.

If you need to run another query, click the Reset button in the lower left corner of the form to clear the form and enter a new set of criteria.

Click on the Results tab to display the results of the search. The example shows the results of a search for an order type of Indirect.
You can also customize how the results are displayed. Right-click in the Results grid and select Customize (or press F9). A list of additional fields is displayed. Note that the list of fields is different for each type of order inquiry. Click and hold the field name you want to display, then drag it to the header bar and drop it where you want the field to be displayed.

Exporting Order Inquiry Data

You can export specific data from the Results tab of the Order Inquiries screen by right-clicking on the repair order and selecting Export Data. This feature is useful for saving data queries.

You can select and export single or multiple lines from the Results screen.
The Save As dialog box is displayed. You can use the drop-down menu for the Save As Type field to save as an Excel (.XLS), HTML (.HTM), XML (.XML), or text (.TXT) file. Navigate to the appropriate directory and provide a file name, then click on Save. The data for the repair order is saved in the format you selected. The example shows the exported data in XML format for a repair order.

Inventory Reports

There are four inventory reports available:

- Parts Usage Report
- Part Inventory Reports
- Physical Inventory Reports
- Parts on Pending Orders Reports
Parts Usage Reports

Go to Inven > Reports > Parts Usage Reports.

The Parts Usage Report can be run for specific time periods, for all parts, specific part types, or part number ranges.

You can also print usage reports for vendor parts. You can also select how Non-Stock parts will be shown on the report (included, excluded, or printed only).

Part Inventory Report

Go to Inven > Reports > Part Inventory Reports. There are seven reports available:

- Part Inventory Listing
- Part Inventory Listing by Bin
- Part Inventory Listing by Cost
- Part Inventory Summary by Shop
- Part Inventory Summary by Part Type
- Part Inventory Kit Listing
- Part Reorder Point Analysis

The Part Inventory Report can be run for specific part types part number ranges, or bin ranges. However, it is always a current status report, so you cannot specify a date range.

Complete as many fields as necessary on the Selection tab.
You can specify additional criteria on the **Additional** tab:

The *Include parts with zero quantity on hand* check box enables you to print a report that contains all parts in the catalog.

You can also specify how the report is filtered on the **Filters** tab.
Physical Inventory Reports

Go to Inven > Reports > Physical Inventory Reports.

The Physical Inventory Adjustment Report can be run for a range of part numbers, a range of user names, and date ranges.

Parts on Pending Orders Report

Go to Inven > Reports > Parts on Pending Orders Reports.

The report displays a list of repair orders that contain parts. This report is used in conjunction with the Parts Workstation option Allow Items to be moved to Pending Orders.

Activities Reports

The Activities menu contains options to obtain reports about warranty claims and fixed costs.

Warranty Reports

Go to Activities > Reports > Warranty Reports. These reports print all potential warranty claims generated by the warranty tracking system for the specified date range.
The **Aftermarket Potential Warranty Claim Report** lists repairs made that could be covered by an after-market warranty. It includes only those parts under warranty that were replaced within the warranty period for the specified warranty life-time.

The **OEM/Extended Potential Warranty Report** includes both the OEM Warranty Claims and the Extended Warranty Claims.

The **Unit Components Warranty Status Report** provides an analysis of specific components in a unit that are covered by an extended warranty that was established in the unit master file on the warranty tab.

The **Units Warranty Status Report** provides information only about a unit’s bumper-to-bumper or glove-box warranty and reports on the current OEM warranty status that was established in the unit master file on the warranty tab.

The **Units with After-Market Part Warranties Report** enables you to identify the after-market warranty coverage by part number.

Both types of Potential Warranty Claim Reports can be printed for a specified date range. The three Unit Warranty Status reports are always current, and therefore have no date range options.
SysMgr Reports

You can use the SysMgr menu to obtain reports about Codekeys, Diagnostics, and Tools.

Codekey Reports

Go to SysMgr > Reports > Codekeys.

A report can be created for any codekey in your TMT Fleet Maintenance/SQL system. To select the type of codekey for the report, click on the down arrow next to the Codekey field.

Diagnostics Reports

Go to SysMgr > Reports > Diagnostics. The Diagnostics report enables you to print the settings located in SysMgr > Options and the error log.
Use the Globals field values and the options available on the Additional tab to refine the granularity of the report. You can obtain a report on company, shop, or user options settings. Select the appropriate type of report in the Owner field.

**Tools Reports**

Go to **SysMgr > Reports > Tools**. There are three reports available:

- Master Tools List
- Employee Tools List
- Shop Tools List

From the Report Title drop-down menu, select the type of tools report you want to create. Click **Preview** to view the report on your computer monitor, or on **Print** to print it.

The Tools reports can also be used to perform an inventory count.

**Period Close Reports**

The purpose of the Period Close is to provide beginning and ending period inventory asset value. When you close a period, you are doing three things: (a) preventing the period from having any transactions added to it, (b) capturing the beginning inventory for the period and all inventory transactions during that period, and (c) calculating the ending inventory for the period for reporting purposes.

The Period close process is initiated by closing the very first period. The first period is used to provide a starting point for all subsequent period closes. All orders are posted to that period. The period close report run for the first period only shows the ending balance of the period. After the initial close process, any new period close process closes and posts only the orders within the date range of the new period. The system picks up the period posted date, not the actual date of the order. For example, open Physical inventories are given the current date on your workstation. If an inventory adjustment must be made to correct inventory
dollars, you must set the date on your workstation to a date which falls within the period you are closing.

Only closed orders are posted during a period close, but the charge date of the line item determines what period the line is posted in. For example, if a repair order is opened in May and closed in June before the May period close, when May is closed the order lines that are in May will go into the May period close and the order lines for June will go into the June period close.

If an order is OPEN or COMPLETE when the period close is run, the lines will not be posted until the order is closed when the period close is run. For example, if an order is opened in May and closed in June AFTER the May period close is run, the entire order will be posted when the June period close is run.

Preparing For The Period Close Procedure

On the last day of the period, conclude all transactions for the current period, including Fuel tickets, Repair Orders, Indirect Charges and Purchase Order receipts. No data should be entered during the period close process. All transactions should be closed. The process should be run at night or in the early morning when there is little traffic on the network. In fact, no one should be in the system when you are closing a period. It is a time-consuming process; however, if the process is done as noted here, the process runs smoothly.

Your First Period Close

1. Go to SysMgr > Company Set Up > Accounting Year.
2. Define the Calendar or Fiscal Accounting Year.
3. Enter current year’s periods by defining the accounting periods for your company and establishing a basic accounting structure. Set up the number of accounting periods in the year with the beginning and ending dates for each period.
4. Set up the Account Types to be used for inventory. Examples of Account Types are: Part Inventory, Tire Inventory, and Shop Supplies. All Parts must be assigned an Account Type. The account type should be an alphanumeric name (up to 12 characters) for the
account. Account types are created in: **SysMgr > Accounts > Chart of Accounts**. You might have established some Account Types at the creation of the Part Catalog master file or the Shop Inventory master file.

Warning: An Account Type is a required field for all records added to the Parts Catalog Master and the Shop Inventory master. If any parts are created without Account types, contact TMT Customer Support for further assistance.

5 Go to **Masters Parts Catalog**. On the Definition tab, enter all parts in the parts catalog and assign an account type for each part. On the Shops tab, populate each shop’s inventory with the appropriate parts. If the Parts Catalog is not going to be used, set up
each part in the Shop Inventory master file and select an account type for each part. DO NOT ENTER A QUANTITY ON HAND FOR PARTS IN THE SHOP INVENTORY MASTER.

Go to Inven > Physical Inventory. Select the Shop from the drop-down menu. Highlight the open status line to indicate what you are going to inventory, and right-click. A pop-up box is displayed. Click on the new Inventory. The new physical inventory dialogue box is displayed.

On the New Physical Inventory dialogue box, select the parts for the physical inventory and set the options for the Count Sheet.
When your selection is complete, click on **OK**. A preview of your Count Sheet is displayed.

### Inventory Count Sheet

**TMT Software Company**

<table>
<thead>
<tr>
<th>Part Number</th>
<th>Description</th>
<th>Bin Location</th>
<th>Comp. Code</th>
<th>Mfg. Part ID</th>
<th>UOM</th>
<th>Quantity</th>
</tr>
</thead>
<tbody>
<tr>
<td>02-04934</td>
<td>Washer 34</td>
<td>BM11</td>
<td>015-003408</td>
<td>02-04934A</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>02-04935</td>
<td>Washer 34</td>
<td>BM10</td>
<td>015-003203</td>
<td>02-04935A</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>10004</td>
<td>Bull</td>
<td>BM11</td>
<td>030-004019</td>
<td>10004</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>10700-10R1M</td>
<td>Clutch Assembly</td>
<td>BM11</td>
<td>023-00202</td>
<td>10700-10R1M</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>109440</td>
<td>10W40 Motor Oil</td>
<td>BM11</td>
<td>023-004616</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1108655</td>
<td>Alternator</td>
<td>BM11</td>
<td>051-000401</td>
<td>1108655</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>1117951X</td>
<td>Alternator 115 Amp</td>
<td>BM11</td>
<td>051-000101</td>
<td>1117951X</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>1156</td>
<td>Tail Light</td>
<td>BM11</td>
<td>024</td>
<td>1156</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>1157</td>
<td>Tail Light</td>
<td>BM11</td>
<td>024</td>
<td>1157</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>127200</td>
<td>Brake Clutch</td>
<td>BM11</td>
<td>023-00322</td>
<td>127200</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>13000EN</td>
<td>Brake Shoe</td>
<td>BM11</td>
<td>015-00013</td>
<td>13000EN</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>16-00635L</td>
<td>Headlight Housing</td>
<td>BM11</td>
<td>054-000101</td>
<td>16-00635L</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>18-00432</td>
<td>Tail Light Assembly</td>
<td>BM11</td>
<td>044-000222</td>
<td>18-00432</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>24071</td>
<td>Filter Cartridge</td>
<td>BM11</td>
<td>015-007201</td>
<td>24071</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>24300</td>
<td>Main 38</td>
<td>BM12</td>
<td>070</td>
<td>24300</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>280402X</td>
<td>Starter</td>
<td>BM11</td>
<td>023-00202</td>
<td>280402X</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>47079</td>
<td>Bearing</td>
<td>BM11</td>
<td>023-0020</td>
<td>47079</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>555</td>
<td>Fender</td>
<td>BM12</td>
<td>034</td>
<td>555</td>
<td>EACH</td>
<td></td>
</tr>
<tr>
<td>DIESEL</td>
<td>Diesel Fuel</td>
<td></td>
<td>DIESEL</td>
<td>002-098012</td>
<td>GALLON</td>
<td></td>
</tr>
<tr>
<td>0402181</td>
<td>Regular Gasoline</td>
<td>CAS</td>
<td>053-000014</td>
<td>0402181</td>
<td>GALLON</td>
<td></td>
</tr>
<tr>
<td>OIL ABSORB</td>
<td>Oil Absorbent</td>
<td>BM11</td>
<td>053-096</td>
<td></td>
<td>EACH</td>
<td></td>
</tr>
</tbody>
</table>

*Generated by 3306DIA*  
*Converted by TMT Software*  
*Page 2 of 20*  
*10/20/09 07:47:06 PM*  

**TMT Fleet Maintenance/ SQL Workbook**
7 Print the Count sheets. (There are more than one sheet).
8 Take the sheet to your warehouse and do a physical count. List quantity on hand in the section provided on the sheet.
9 After you take a physical count, go back to the Physical Inventory dialogue box. Click on the Counts tab. All the parts that were selected based on the criteria entered on the New Physical Inventory form are listed on the Counts tab. The Expected column is the amount of parts on hand when the inventory was created. On the Actual column, you list the number of parts found in each bin. You must enter a count for each item.
When this process is complete, go back to the Inventories tab. Right-click on the inventory status line that you want to close. A pop-up box is displayed. Click to close inventory.

Take a physical inventory for each shop and close the inventories. Make sure you have accurate part costs. This figure provides starting balances for parts.

Go to Activities Period Close. Select a Shop ID. A Shop ID must be selected for each period close report. Although a period close is completed for the entire company, the period close reports (Account Type Analysis report, Purchase Order Analysis report, Non-Inventory Analysis report, Invoice Analysis Report) are run by shop.

Select the way usage is reported on the period close report. Unit type, Cost Center, Division and Department are broken down into total dollars for each group.

Select the year and the period number.

Click the Preview button to print a period close report for the selected shop and view your transactions BEFORE YOU CLOSE THE PERIOD. Once the period is closed, it cannot be reopened or modified. Repeat steps 11 through 15 for each shop.

If everything appears to be in order, click on the Close Period button.

You now have a starting balance for the next period.

**Period Close On An Existing System**

Use this procedure to perform a period close on an existing system (one that has had an initial period close already completed):

1. Go to SysMgr > Company Set Up > Accounting Year. Enter your current accounting year's periods.

---

**TMT Fleet Maintenance/ SQL Workbook**
2 All parts must be assigned an Account Type. Account Types are created in **SysMgr > Accounts > Chart of Accounts**. Set up the Account Type to use for the inventory. An example of an account type is Part Inventory, Tire Inventory, Shop Supplies. You might have established some Account types when you created the part in **Masters > Parts Catalog** or **Masters > Shop Inventory**.

3 If you use the Parts Catalog, enter in the account type for each part in the parts catalog. Next, enter an account type for each local part. If you do not use the Parts catalog, enter an account type for all Shop Inventory Master records.

4 Take a physical inventory for each shop. If possible, stop any Part transactions. If this is not possible, you will have to count all Parts taken out of your parts room from the moment you opened the inventory.

5 Make sure you have accurate part cost. This provides a starting balance.

6 Go to **Inven > Physical Inventory**. Right-click on the item you want to select. A pop-up box is displayed. Click on new inventory.

7 Select the parts for the physical inventory and the options for the Count sheet. When your selection is complete, click on OK.

8 Print your count sheet. Take the count sheet to your warehouse and take an actual part count. List the quantity on hand on the sheet.

9 After you have taken an actual count, go back to the Physical Inventory Dialogue box. Click on the Counts tab.

10 The parts you selected on the New Physical Inventory form are listed on the Counts tab. The Expected column list the quantity on hand when the inventory was opened. On the Actual column, list the number of parts found in each bin. You must enter a count for each item.

11 When step 10 is complete, click on the File menu and click on Close.

12 Enter all transactions for the current period (Fuel tickets, Repair Orders, Indirect Charges, Purchase Orders). All transactions must be closed.

13 Go to **Activities > Period Close**.

14 Enter the Year/Period for the current accounting year.

15 Click on Close Period. This provides the starting balance for the next period.

16 To print a report for each shop, enter the shop ID and click on Print.

---

### Custom Invoices

You can create and print custom invoices for:

- repair order invoices
- direct sale invoices.

Custom invoices can be assigned at the customer level. This enables custom invoices to be created that are customer-specific. TMT Fleet Maintenance/SQL uses the Custom Invoice for the customer if one is set up. If no customer level report has been set up, TMT Fleet Maintenance/SQL then uses the shop level custom report (if there is one) and then the global level custom report.

To use this feature, Crystal Reports software must be installed on the workstation being used to print the reports. Some preliminary setup must be completed; for more information, see the **TMT Fleet Maintenance/SQL Installation and Administration Guide**.

To create the custom reports, go to **User > Reports** and navigate to the report you want to create. The setup for the reports must have been completed previously.
Chapter 7: Advanced TMT Fleet Maintenance Features

Tracking Shop and Employee Tool Inventories

Tools Catalog

The Tools Catalog is not required to set up and use TMT Fleet Maintenance/SQL. The Tools Catalog creates a catalog of available tools for inventory purposes on the Shop and Employee Master Files.

Go to SysMgr > System Setup > Tools Catalog.

The tools can be separated by the Tool Category (Codekey - Tool Categories) or by the three Tool Groups:

- Standard
- Metric
- Miscellaneous (any tool that is not classified either as Standard or Metric)

These tools can be selected from the database and added to the Employee or Shop tool inventory listing. The ATA Mechanic’s Personal Tool Inventory is provided as a starting point. You can add or delete tools as required for your shops and employees.

Shop Tools

The Shop Tools tab (go to Masters > Shop > Tools) shows the tool inventory for a particular Shop. There is a light bulb icon next to the Tools Group radio group that indicates that a pop-up menu is available. If you right-click anywhere on the form, a pop-up menu is displayed from which you can filter the tools by Tool Group or Tool Category.
The Tool Category or TOOLTYPE is added in the Codekey section of the **SysMgr** menu.

![Screenshot of the Tools tab in SysMgr](image)

The tools that are available to be added to the Shop menu or the Employee menu are set up under **SysMgr > System Setup > Tools Catalog**. The tools are added using the **Add Tools** button located next to the **Tools Group** radio buttons.

When you click on **Add Tools**, a selection screen is displayed from which you can select tools. To select multiple tools, hold down the **CTRL** key and click on the tools that you want to add.

**Employee Tools**

The Tools tab (go to **Masters > Employees > Tools**) shows the tool inventory assigned to a specific employee or mechanic. If you right-click anywhere on the form, a pop-up menu is displayed from which you can filter the tools by Tool Group or Tool Category.

The Tool Category or TOOLTYPE is added in the Codekey section of the **SysMgr** menu.
The tools that are available to be added to the Shop menu or Employee menu are set up under **SysMgr > System Setup > Tools Catalog**.

**Inspection Tickets**

**Inspection Tickets Setup**

Go to **SysMgr > Repair Order Setup > Inspection Tickets**. This section of the Repair Order Setup deals with the vehicle inspection items and the assignment of these items. The U.S. DOT (Department of Transportation) requires that certain equipment is inspected annually for critical maintenance items. The inspections often determine repairs that must be completed by the repair facility. Here you can enter the inspection that was performed and create work orders from this inspection form.

This is a two-step process.

1. Define the inspection items that are required. The inspection items can pertain to any type or class of equipment and are associated to a particular Component Code.
2. Assign the inspection criteria to the specific Unit Type. During the inspection ticket entry, you are prompted with the inspection items attached to that Unit Type.

The following illustration shows the setup of inspection tickets by unit type.
This form is used to assign the previously defined inspections to specific Unit Types using the same method as the Complaint, Cause, and Correction assignments to components.

**Using Inspection Tickets**

Go to Orders > Inspection Tickets.

Click on Search to display a list of all inspection tickets. You can refine the search by adding criteria to the search fields. The search results are displayed in the lower pane.
Double-click an inspection ticket in the list to open it, or right-click and select Open. To open a new inspection ticket, click on New. The Inspection Ticket screen is displayed.

Double-click on an entry in the Details pane to review the inspection details.
The list of items included in the Inspection Items grid changes on each inspection ticket. Only valid inspection items are included in the list.

Enter meter information as necessary. Click the [...] button next to the meter fields to display a meter history.

Click an inspection item to add it to the detail. A Complaint Code must be selected from the drop-down menu in the Complaint Code dialog box. Click the X in the upper right corner to close the Complaint Code dialog box.

Click OK to save the inspection ticket.

If a repair order is created from an inspection ticket and the Print Work Card option is enabled, the work card prints first, and the newly-created repair order can then be displayed.

**Accounting Export Module Setup**

Before you can export accounting data for repair and purchase information, or use the Period Close process, you must first set up the Accounting Export module.
For guidance with setting up the Accounting Data Export feature, contact TMT Customer Support.

The Accounting Setup process categorizes the charges in the maintenance system to the account codes in your company’s accounting system. Therefore, the Chart of Accounts must be set up to match your company’s accounting system Chart of Accounts.

For more information about how TMT Fleet Maintenance/SQL can be used for integrated accounting functions, see “ Accounting Integration” on page 286.

---

**Set Up the Chart of Accounts**

Go to **SysMgr > Accounts > Chart of Accounts**.

A default Chart of Accounts is shipped with TMT Fleet Maintenance/SQL. You cannot delete the core Base account or the 5 base accounts (1000 to 5000). You can add first-level accounts under the base accounts. You cannot add sub-accounts to first-level accounts created for the base accounts.

TMT Fleet Maintenance/SQL will not allow you to delete any account that is used anywhere in the system. For example, an account used for any part included on a repair order (open or closed) cannot be deleted.

If you upgraded to the current level of TMT Fleet Maintenance/SQL and previously created sub-accounts for first-level accounts created for the base accounts, those accounts will no longer be displayed in the system. To delete those sub-accounts, you must delete sub-accounts from the lowest level in order to delete the next higher-level account. You will receive a warning message when you are unable to delete any account with a sub-account (children).

**NOTE:** A Windows feature places a + in front of the lowest-level sub-account, even when there are no children. This + symbol must be clicked open to delete the lowest-level sub-account.

The Chart of Accounts is displayed in a directory tree format that shows the hierarchy of the accounting system. The main branch contains the major account categories: assets, liabilities, expenses, equity, and revenue. You can divide these accounts into sub-accounts, and assign these sub-accounts to particular charge actions within the system. You have the flexibility to duplicate the accounting structure of your Company. You can export accounts payable (AP), accounts receivable (AR), and general ledger (GL) data directly from TMT Fleet Maintenance/SQL. You can also export Unit User-Defined fields 1-8, Part User-Defined fields 1-4, and the Vendor AP Remit Code.
You can add new levels to the Chart of Accounts anywhere under the top level of Accounts. Click on the plus or minus sign to the left of the tree to explode or collapse the directory tree. Press CTRL + INSERT and enter the Account Number, Name and Account Type to create a new account definition. The Account Type created here is used in the part records to establish the account to which each part is reported in the Period Close process. Avoid creating Asset accounts below the secondary level.

**Accounting Year**

In order to use the Period Close process in TMT Fleet Maintenance/SQL, you must define time in accounting terms. If you decide not to use the Period Close process, this part of the setup process is not required.

**NOTE:** The Accounting Export setup does NOT require the creation of Accounting Years.

Go to SysMgr > Company Setup > Accounting Year. This form enables you to define accounting periods for your company. You must create an accounting year in the database for your current accounting year. The date format displayed in this form and on other forms is defined in the Windows Control Panel > Regional Settings.
Press **CTRL + INSERT** to insert a new record. Type in the year you want to define.

- If you start your year on January 1 and indicate 12 periods, the system defaults to a calendar year. You can then redefine the beginning and ending dates of each period as required if you are using a fiscal accounting year.

- If you select a beginning date other than January 1, or a number of periods other than 12, you must define the beginning and ending date of each period. If you are creating an accounting year that has the same beginning and ending dates as the previous year, check the *Base on last year* box to duplicate the periods.

The Period Close process allows TMT Fleet Maintenance/SQL to meet the needs of a maintenance manager who wants to view unit history with actual dates, and the needs of an accounting department worker who wants to view costs by period posted. These two dates may not be the same for many practical reasons.

### Period Close Process

The purpose of the Period Close Report is to provide beginning and ending period Inventory Asset value. When you *close* a period, you are doing three things:

1. Preventing the period from having any additional transactions posted to it.
2 Capturing the beginning inventory for the period, all inventory transactions during that period.

3 Calculating the ending inventory for the period for reporting purposes.

In order for the period close process to work, two things must be established:

1 All parts have to be assigned an account type. Account types are established in **SysMgr > Accounts > Chart of Accounts**. This account type is set up when the part is created (in **Masters > Parts Catalog** or **Masters > Shop Inventory**). If all parts were created without account types, contact TMT Customer Support for further assistance. Once a period is closed, Account Type is a required field for all future records added to the Parts Catalog Master and Shop Inventory Master.

2 In order to initiate the process, all Orders (Repair Orders, Purchase Orders, Fuel Tickets, and so forth) and all Order Lines in the system must be closed. TMT Customer Support can provide a SQL script to facilitate meeting this requirement. The process does not execute until all orders are closed.

The period close process is initiated by closing the first period. All orders - regardless of the date on the order - are posted to that period. Subsequent period closes after the initial close post only the orders within the date range of that period. The period close process should be run at night or in the early morning when there is not heavy traffic on the network. It is a time-consuming process so plan accordingly.

The reports generated by the first period close do not generate useful data, but this process is used to establish a starting point for subsequent periods. Periods must be closed in sequence from the first to the current. Periods can be closed at any time after the end of the period.

The period close process generates four reports:

- **The Account Type Analysis** provides a detailed or summary analysis of all part transactions by account type for the period.

- **Purchase Order Analysis** details the Miscellaneous Charges, Freight Charges, and Taxes on purchase orders for the period.

- **Non-Inventory Analysis** details the following non-inventory transactions: services, labor, vendor charges, indirect services, and indirect labor.

- **Invoice Analysis** reports the cost amounts, sale amounts, and gross profit for invoices during the period.

The period close process is global in nature. When a period is closed, it is closed for the entire company. The period close reports are run for individual shops. The reports can be run prior to closing the period in order to preview the data so that any needed changes can be made prior to closing the period. Changes cannot be made to data in a period once the close process is run.

### Accounting Integration

Accounting transactions generated by TMT Fleet Maintenance/SQL can be exported in two ways:

- Using the TMT Fleet Maintenance/SQL program

- Using the command line helper application

Before you continue, ensure that you have set up the Accounting Export feature as described in the previous section. See “Accounting Export Module Setup” on page 211.
It is necessary to review this entire section to determine the correct setup method for your company's accounting data. For best results, ask your Accounting Department for help before you set up the Accounting feature or export any data. If you plan to use the Great Plains Interface, review the section "Exporting Data Using the Accounting Export Program" on page 299.

About the Accounting Export Program

The Accounting Export program is a TMT Fleet Maintenance/SQL helper application that enables you to export transactions outside of the main TMT Fleet Maintenance/SQL application. The Accounting Export program is a command-line application that simply connects to the TMT Fleet Maintenance/SQL database and exports accounting transactions. Since this application is executed on the command line, it can be scheduled to run without user interaction.

**NOTE:** Accounting transactions can still be exported inside TMT Fleet Maintenance/SQL using the existing screens. You can use both TMT Fleet Maintenance/SQL and the command-line helper applications to export data. The same data is exported regardless of the method you choose to use.

Using Transman/SQL To Export Accounting Data

If you use TMT Fleet Maintenance/SQL to export accounting data, it must be configured so that it can correctly export accounting transactions. You must set up TMT Fleet Maintenance/SQL to match your company's accounting system.

**NOTE:** The Chart of Accounts and Account Disbursements rules must be configured by your company's accounting staff.

Before you continue, determine whether you want to export to a text file or to tables used by the Great Plains Interface. To determine the appropriate type of export, contact your Accounting department.

Creating Export Configurations

You can create multiple export configurations (for exports from TMT Fleet Maintenance/SQL) that establish the parameters used to export specific accounting data to a file.

1. Go to **SysMgr > Accounts > Export Transactions** and click on the **Options** tab.
2. Type in a new export configuration name and press Tab.
3. A dialog box is displayed asking you if you want to create a new configuration. Click **Yes**.
4. Type in a description for the new configuration.
5. Select **Fixed Length Text File** or **Delimited Text File**. If Delimited Text File is selected, type the appropriate field separator, select which fields to enclose in quotes (All Fields, Strings, None) and type the number of decimal places to include for numeric fields.
6. Select whether to include debits and credits on the same line.
7. Select each field to export from all available fields. To select a field, double-click or press the space bar in the **Export** box next to the field name.
8. Press **F6** to save changes.

Exporting Using TMT Fleet Maintenance/SQL

Each time an order or physical inventory is closed, accounting transactions are recorded based on the transaction rules and sub-rules set up in **SysMgr >**
Accounts > Account Disbursements. The accounting transactions can then be exported for use in an accounting package.

1. Select the Export Type. Valid choices are: GL Transactions (all accounting transactions), AP Transactions (all purchase order transactions) and AR Transactions (all invoice transactions).

2. Select one of the following options: Non-Exported only (transactions that have never been exported), Exported Only (transactions that have been exported), Exported and Non-Exported (transactions that have been exported and transactions that have not been exported). These options determine what transactions will appear on the Tables tab and will be exported.

3. Select the Transaction Date Range.

4. Type in the file name to be created when the transactions are exported. Use the Browse button to navigate to the location you want the file to be created and name the file to be created.

5. Click the Options tab. Select the appropriate Export Configuration.

   **NOTE:** You should only have to do this once unless you have multiple export configurations.

   For the Delimited Text File, type the appropriate field separator. Select which fields to enclose in quotes (All Fields, Strings, None). Select the number of decimal places for numeric fields.

6. Optional: On the Tables tab, review the transactions and transaction accounts for accuracy. To review the tables, check the View Transaction Tables check box. You do not have to view the transaction tables to export the transactions.

7. Optional: Click the Preview button. The Preview Export tab will be displayed. Check the View Preview check box to view the transactions as they will appear when the export file is created. This offers a final opportunity to review the transactions. You do not have to preview the export to export the transactions.

8. Click the Export button. A confirmation dialog box is displayed; click on OK to export the data. The export file will be created.

   **NOTES:** After they are exported, repair orders and indirect charges cannot be re-opened.

   For Great Plains users, a warning message is displayed when the Export button is clicked, warning that if the export is done it will prevent transactions from being exported to Great Plains.

Text File Export

The Accounting Export feature sends data to a generic accounting export table contained in a text file. This detail data, called transaction data, is gathered whenever an order is closed. The order detail can be taken from a repair order, purchase order, invoice, or inventory adjustment. The date of the order is held in the accounting export table within the TMT Fleet Maintenance database. As a result, a delimited or fixed length ASCII file can be generated for exporting to your accounting program. Your accounting program can import the data using its data import functions.

There are up to 159 pieces of information that can be collected for export. The selected data is placed in the accounting export table. It is necessary to prepare your accounting package to receive the information it needs to gather, process, and use for accounting purposes. Your accounting department might decide that only 10 to 15 pieces are required for your company. Therefore, your program must be set up to process the appropriate data. That data will then be received from the
You can export accounting data from within TMT Fleet Maintenance/SQL, or from a command line.

To export data to a text file:

1. Configure an export format to export transactions to a text file.
2. Define data fields and positions.
3. Define the export file name.

**Requirements for Exporting Accounting Data**

- The Accounting Export module is required.
- You can export data with the Accounting Export program or with TMT Fleet Maintenance/SQL.
- TMT Fleet Maintenance/SQL and the Accounting Export program must be installed on the same workstation.
- To export to Great Plains, the Great Plains Integration program must also be installed (see the *TMT Fleet Maintenance/SQL Installation and Administration Guide* for more information about installing this program).

**Exporting to a Text File from TMT Fleet Maintenance/SQL**

The steps necessary to use the Export Transactions feature to export text data files are:

1. Set up all accounts in the *Chart of Accounts*.
2. Set up any sub-rules needed for transaction rules in *Account Disbursements*.
3. Assign the debit and credit accounts to all base rules and sub-rules in *Account Disbursements*.
4. Turn on the Accounting transactions feature in *SysMgr > Options > Accounting > Enable Accounting Features*.
5. Enter repair orders, invoices, fuel tickets, transfers, indirect charges, inventory adjustments, and purchase orders normally.
6. Review the transactions and accounts on the *Tables* tab of *Export Transactions*.
7. Set up the *Options* for the file being created.
8. Preview the file that will be created by the export process in *Export Transactions*.
9. Export the transactions.

**NOTE:** *After transactions have been exported, repair orders cannot be re-opened through *SysMgr > Re-open Closed Repair Order*. Click on the Export Transactions screen to view the help on the form.*

For more information about accomplishing these steps, see the instructions starting on page 292.
When using the Microsoft Business Solutions - Great Plains Interface®, the interface formats the data in a format acceptable by Great Plains. Transactions in TMT Fleet Maintenance/SQL are scheduled for regular exports. No TMT Fleet Maintenance/SQL user interaction is required; the process is performed automatically. Accounting staff can import transactions as needed.

Using the Great Plains interface, the accounting staff imports transaction batches into Great Plains as needed. The transactions are imported using the Integration Manager. Transactions are then view and posted in Great Plains.


The Great Plains accounting export procedure is different from a text file export.

1. Transactions are generated when orders are closed.
2. Transactions are exported, as scheduled, to an interface table.
3. Transactions are exported, as scheduled, to Great Plains import work tables.
4. Transactions can then be imported into Great Plains.

Because the exports are performed differently, it is necessary to perform some set up before exporting to the Great Plains Interface. These steps are in addition to the normal setup for the Accounting Export module.

Both the accounting export program and the Great Plains Interface programs can be scheduled. Use the Windows Task Scheduler to schedule each program to run, and be sure to allow enough time between each specific scheduled task for each program to complete execution.

Requirements for Exporting to Great Plains

- TMT Fleet Maintenance/SQL must be version 6.0 or later.
- The TMT Fleet Maintenance/SQL Accounting Export module must be purchased and installed.
- The TMT Fleet Maintenance/SQL Great Plains Interface module must be purchased and installed.
- SQL Server client drivers must be installed.
- Microsoft Business Solutions - Great Plains Interface version 7.5 or later must be installed.
- Microsoft Great Plains Integration Manager version 7.5 or later must be installed.
- Account Types must be unique to a specific Account ID. Two different Account IDs cannot use the same Account Type.

*NOTE*: TMT Fleet Maintenance/SQL is NOT required on the same workstation as the Great Plains interface executable.

Customizing the Great Plains Interface

**Batch IDs** - The default format for batch assignment is:

TMT + Accounting Type + Accounting Year + Accounting Period + Sequence ID.
Batch IDs are assigned according to the transaction date for the order and converts it to an accounting year and period. Each time an export is performed, a sequence number is appended to uniquely identify the batch. The accounting years and periods are those configured in **SysMgr > Company Setup**.

Each time an export is run, it creates a unique batch ID for the period. For example:

<table>
<thead>
<tr>
<th>Batch ID</th>
<th>Period</th>
</tr>
</thead>
<tbody>
<tr>
<td>TMTGL200311-001</td>
<td>Nov. 2003 GL transactions</td>
</tr>
<tr>
<td>TMTGL200312-001</td>
<td>Dec. 2003 GL transactions</td>
</tr>
<tr>
<td>TMTGL200401-001</td>
<td>Jan. 2004 GL transactions first run</td>
</tr>
<tr>
<td>TMTGL200401-002</td>
<td>Jan. 2004 GL transactions second run</td>
</tr>
</tbody>
</table>

- **GL transactions** use the transaction date.
- **Invoices** use the Invoice date.
- **Purchases** use the Invoice date.

You can modify this format if desired. The stored procedure `SP_INTERF_GP_GETBATCHID` can be modified to change the format. Note that Great Plains limits the BatchID length to 15 characters and they must be upper-case.

**Account Formatting** - If there is a special need for formatting of account numbers between TMT Fleet Maintenance and Great Plains, then they can be customized.

You can modify this format if desired. The stored procedure `SP_INTERF_GP_FORMATACCOUNT` can be modified to change the format.

**Deleting Batches** - After integrations are executed, a prompt is displayed to delete the imported transactions. Whether and how this prompt is displayed can be changed in a VBScript that executes after the integration is processed. To make these changes:

1. In Integration Manager, select **Open Integration**.
2. From the dialog box that is displayed, choose **TMT AP Table Import**.
3. The **TMT AP Table Import** view is opened.
4. Right-click on the name of the integration labeled **TMT AP TABLE IMPORT**.
5. Select **TMT AP Table Import Properties**.
6. Select the Scripts tab and double-click on **After Integration**. This script displays the process that deletes the transactions. This script can be modified to reflect your company’s needs.

To modify the script so that the batches are deleted, make sure the name of the database is correct for the TMT Fleet Maintenance database from which you are importing your Great Plains Information. The name of this database is usually set by default as **TFW**. After the changes are made, save the changes and test the process.

**NOTE:** For each integration, the AR import and the GL import contains an identical script that must be modified to work for their respective imports.
About Integration Manager - The integrations provided by TMT Fleet Maintenance are basic imports of information that is available in TMT Fleet Maintenance/SQL. You can customize the integrations to work in your business environment. One example of modifying a default behavior is seen in Invoicing.

If a customer uses the default configuration provided by TMT Software for importing Receivable batches, the heading *TMT Import Interface* is printed on customer invoices in the Description field. One way to change this is to edit the Integration parameters for TMT AP Table Import. The Destination Mapping for the Receivable Document Description field could be set to *Use Constant*. A value such as *Fleet Service/Repair* can be entered. This allows the imported invoices to get this description and display on invoice statements.

Setting Up the Export Transaction Function

The process for setting up the export transaction function is the same for both text file exports and Great Plains exports.

These steps must be completed in the designated order.

1. Create the Chart of Accounts

   Go to **SysMgr > Accounts > Chart of Accounts**.

   The Chart of Accounts is used to set up the current accounts used in your company's accounting system. These accounts must be established to use the Account Disbursement function of the system. Avoid duplicating or deleting account types. Press **F6** to save each account type you create, and then click on **OK**.

   **NOTE:** Base accounts are Assets, Liabilities, Owner’s Equity, Revenues and Expenses. To make a Base Account more specific, a Sub-Account can be created.

2. Create Sub-Accounts

   To create sub-accounts:

   1. Click on the base account for which you want to create a sub-account. The base account is highlighted.
2. Right-click and select **Insert**. The **Account Setup** screen is displayed.

3. Enter the Account ID, Account Name, and Account Type. The Account ID can be up to 24 characters in length and usually is the number used by your accounting department for the sub-account. The Accounting Name is the complete name for this sub-account and can be up to 60 characters long. The Account Type can be up to 12 alphanumeric characters and must be unique. Account Types are used throughout the system to select accounts.

4. Click **OK**. The information on the new Account ID is displayed under Account Data in the Chart of Accounts dialog box.

3. **Create Disbursement Rules**

Go to **SysMgr > Accounts > Account Disbursements**.

TMT Fleet Maintenance/SQL is designed with a set of transaction rules. If a transaction occurs and no rule has been assigned for that kind of transaction, the rule called **BASE** is used. To make the standard base rules more specific, a sub-rule can be used.

Only those order types that can create accounting transactions are included in the list.

Accounting Disbursements Rules cannot be created or deleted. Only sub-rules can be created or deleted. The Account Disbursement Rules cannot be edited except to change a rule’s active status and the sub-rule requirements.
The **Show Inactive Rules** check box can be left unchecked to show only active rules, or checked to show all rules, both active and inactive.

**NOTE:** You must create a detail for BASE first, before any other distributions can be added. The base rule itself cannot be edited.

You can create new base rules or new sub-rules for existing rules.

You can right-click on a rule and make the rule inactive.

Double-click on the rule at the line type level, or on a sub-rule, to display the dialog box used for editing the rule’s status or requirements, or the sub-rules values for required fields.

The icon next to the rule represents the rule’s status. The rule can be Inactive, Active with No Disbursement Detail, or Active with Disbursement Detail. The icons are:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Disbursement Rule</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Inactive rule" /></td>
<td>Inactive rule</td>
</tr>
<tr>
<td><img src="image" alt="Active rule" /></td>
<td>Active rule with no account disbursement detail</td>
</tr>
<tr>
<td><img src="image" alt="Active rule" /></td>
<td>Active rule with account disbursement rule</td>
</tr>
</tbody>
</table>

Hotkeys for the Account Disbursement dialog box are: ALT+A to change the cursor focus to the first rule in the Accounts list, and ALT+D to change the cursor focus to the Account Disbursement detail grid.

Underneath each base rule there is a branch for each order type. Underneath each order type, there is a branch for the sub-order type. Underneath the sub-order type, each line type is displayed (except for repair orders, where there is an additional branch for repair group, then line type). This enables accounting disbursement details to be set up at the order type level or sub-order type level, and for repair orders, at the repair group level.

For example, if all repair orders debit a specific account, you can set the debit account at the repair order level, then set the credit accounts and either the sub-order level, repair group level, or line item level.

You can also select the Repair Shop or the Domicile Shop to create sub-rules for repair orders, fuel tickets, and invoices created from repair orders.

## 4. Create a New Base Transaction Rule

To create accounting disbursement base rules:

1. On the Account Disbursement screen, right-click on the Base rule and select Insert. To edit an existing base rule, right-click on the rule and select Edit.
2. The Account Disbursement Base Rule screen is displayed.

3. If sub-rules are going to be created for the selected base transaction rule, the items that will be used for the sub-rule must be checked in the **Required Sub-rules** section. If they are not checked, any sub-rules created will be ignored.

**Making a Rule Inactive** - To make a rule inactive, check the **Set Rule Inactive** check box to inactivate a base rule. This will remove the rule from the Active Rules list displayed in Account Disbursements. Inactive rules can be seen by selecting **File > Show Inactive** from the Account Disbursements screen.

5. **Create Transaction Sub-rules**

To make a base transaction rule more specific, a sub-rule can be created. A sub-rule makes a base transaction specific by using any combination of the following fields:

- Unit Type
- Shop ID
- Activity
- Division
- Department
- Cost Center

Sub-rules are only appropriate for unit-related transactions (for example, Repair Orders, Invoices, and Fuel Tickets).

After creating the transaction rule:

1. On the Account Disbursement screen, under the Account Disbursement Detail section, right-click a base rule and select **Insert**, or right-click on a sub-rule and select **Edit** to access the Account Disbursement Subrule screen.
NOTE: For the fields to be enabled on the sub-rule screen, they must be checked on the base rule (see the section on creating base rules).

2. On the Account Disbursement Sub-rule dialog box, enter the Unit Type, Shop ID, Activity, Division, Department, or Cost Center. Then click on **OK**.

3. Repeat this process to add as many sub-rules as you need.

6. Turn On Accounting Transactions in SysMgr

Go to the **Accounting Features** section in **SysMgr > Options > Misc.**

- If **Enable accounting features** is checked, the system creates accounting transactions using information set up in **Accounts > Chart of Accounts** and **Accounts > Account Disbursements** and allows that data to be exported using **Accounts > Export Transactions**.
• If *Ignore Inactive Disbursement Rules* is checked, the system will not create accounting transactions for those rules that are set to Inactive. If it is not checked, inactive rules will go to the base rule’s accounts.

• If *Prompt for GL Accounts on PO Lines* is checked, the system creates accounting transactions only for Purchase Orders and Vendor ROs and will require entering GL Accounting numbers at the time purchase order lines or vendor RO lines are created. This will disable the Period Close process as well as other accounting rules processing.

**NOTE:** After any of these options is checked, it cannot be changed.

You can now begin to enter repair orders, invoices, fuel tickets, transfers, indirect charges, inventory adjustments, and purchase orders.

### Exporting Account Data

Each time an order or physical inventory is closed, accounting transactions are recorded on the transaction rules and sub-rules that were set in Account Disbursements. The accounting transactions can then be exported to a text file for use in an accounting package.

You can export data in tables or to text files, depending on the requirements of your accounting programs.

You can export accounting data from within TMT Fleet Maintenance/SQL, or from a command line.

#### Exporting Data Using TMT Fleet Maintenance/SQL

1. Go to *SysMgr > Accounts > Export Transactions*.
2 In the Retrieve Options section, select your export type. These options determine the transactions that will be displayed on the Tables tab and that will be exported:

- **GL transactions** export all accounting information that effect the General Ledger, including repair orders, purchase orders, indirect charges, invoices, part transfers, physical inventories, and fuel tickets.

- **AP transactions** export any transactions related to accounts payable (all Purchase Orders).

- **AR transactions** export any transactions related to accounts receivable (all Invoices).

3 Transaction tables are not shown by default. To display the transaction tables, ensure that there is a check in the View Transaction Tables check box.

4 Enter the transaction dates.

5 In the Export File As field, enter the name of your text file as it will be stored on your hard disk (include the path information), or use the Browse Folders icon next to the field to navigate to an appropriate directory. Your accounting package will search for this file name.

6 If you want to use a filename for which a file was already created during an previous export, check the Overwrite Existing File check box. If you want to keep previously exported data files, leave the check box blank.

7 Review the Tables, Preview Export, and Options tabs.

**Tables Tab** - If you checked the View Transaction Tables check box, your transaction is automatically displayed.

**Preview Export Tab** - Transactions shown on the Tables tab are displayed as they will when the Export file is created. This tab enables you to preview the files before you export. If the Preview table is blank, check the View Preview check box.

The **Accounts** button enables you to access the Chart of Accounts directly from this screen. The **Disbursements** button allows access to the Account Disbursements. Both buttons enable you to access features without first closing the Pre-view Export screen.

To re-disburse accounting transactions, right-click on an order and select Re-Disburse Order. This feature works in conjunction with the **Accounts** and **Disbursements** buttons. For example, if you have orders hitting the error trap accounts, you can set up new accounts using the **Accounts** button and set the disbursement rules for the transactions using the **Disbursements** button, then right-click on the order to reimburse based on the new disbursement rule.

**Options Tab** - Set the options for the file being created (see the next section).
Setting Options - To set options:

1. Click the Options tab.
2. Enter the name of your file in the Export Configuration field.
3. Enter a description for this export file in the Description field.
4. Your accounting package will require a specific format so that it can process the export file. In the Export Format field, you can select Fixed Length Text File or a Delimited Text file. Your choice also determines how the information is displayed in the Export Layout box.

**Fixed Length Text File** - defines the starting point and length of each field.

**Delimited Text File** - uses separators (such as tabs, spaces, or commas) and can be enclosed in quotes. These blank boxes must be completed.

5. In the Decimal Places field, always enter a minimum of 2.
6. If the Include Debits & Credits on Same Line check box is not checked, debits and credits are exported on separate lines in the export file. Check with your accounting department to determine which format they need.
7. After you set up the Options for the file being created, check the fields needed for your export in the Export Layout box.
8. Click on the Preview Export tab to review your file. Make corrections as necessary.
9. Click on OK to export the transactions.

**NOTE:** After transactions are exported, repair orders cannot be reopened by using SysMgr > Re-Open Closed Repair Order.

Exporting Data Using the Accounting Export Program

The Accounting Export program is a helper application that enables you to export accounting transactions outside the main TMT Fleet Maintenance/SQL application. It is a command-line interface that simply connects to the TMT Fleet Maintenance/SQL database and
exports accounting transactions. Since the application is executed on the command line, it can be scheduled to run without user interaction.

**NOTE:** Accounting transactions can still be exported outside of TMT Fleet Maintenance/SQL using **SysMgr > Accounts > Export Transactions**.

The Accounting Setup process categorizes the charges in the maintenance system to the account codes in your company's accounting system. Therefore, the Chart of Accounts must be set up to match your company's accounting system Chart of Accounts.

For more information about how TMT Fleet Maintenance/SQL can be used for integrated accounting functions, see “Accounting Integration” on page 286.

**Export Data Modes**

Data can be exported using two different modes: to a text file or to tables. Exporting data to a text file is the same as exporting from TMT Fleet Maintenance/SQL. Transactions can also be exported to accounting export tables. These database tables enable reporting of exported transactions and provide an interface layer for importing into accounting systems. The switch to control which mode is set is the CfgID. If CfgID is not set, then the data is exported to tables by default.

**Database**

The export program uses your Transman.INI file to find your database. This can be changed by providing the server and database name parameters. It overrides the username and password with the provided parameters, or you can set the NT authentication parameter. Currently, there is no additional security to prevent a user from exporting using this application, so caution must be exercised when pro-viding access to this program.

**Requirements**

The Accounting Module must be purchased and configured to have accounting transactions to export. To export to a text file, an export configuration must be previously set up using TMT Fleet Maintenance/SQL. This program must be installed on a computer with the TMT Fleet Maintenance/SQL client. This can be a workstation or server. This uses the Borland Database Engine (BDE) to connect to the TMT Fleet Maintenance/SQL database. The TRANSMAN.INI file must point to the TMT Fleet Maintenance/SQL server and database unless the server and database parameters are provided.

**Launching**

The application is launched from the Windows command line. If no parameters are specified, then the parameter list below is displayed. You can also pass it an Accounting Export Configuration ID (CfgID) that you have previously created. If the CfgID is supplied, then the file must also be specified. Optional parameters are used if they are formatted correctly. It validates all parameters and output error messages to the screen and log file.
AccountingExport Parameters

- SRVR: "SRVR:" followed by server overrides Transman.INI
- DBNAME: "DBNAME:" followed by database overrides Transman.INI
- NTAUTH "NTAUTH" use NT Authentication instead of user and pw
- *UName Transman UserID, omit if using NTAUTH
- *Pword User Password, omit if using NTAUTH
- *AcctType ("GL", "AP", "AR")
- **CfgID Export Configuration ID
- **File Export file target
- OVERWRITE "OVERWRITE" is optional and defaults to false
- FromDate and ToDate: are optional, format is from local settings
- RetType ("NonExported","Exported","All") defaults to NonExported
- FILEONLY "FILEONLY" is optional and defaults to false

All parameters must be in the specified order.
* denotes required fields.
** denotes required fields when saving to a text file.
ConfigID, File, Overwrite, and FileOnly are only used when exporting to a text file.
Parameter Descriptions

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SRVR:</td>
<td>plus the server name override the server in the TRANSMAN.INI file</td>
</tr>
<tr>
<td>DBNAME:</td>
<td>plus the database name overrides the TRANSMAN.INI database</td>
</tr>
<tr>
<td>NTAUTH</td>
<td>Use NT Authentication instead of username and password</td>
</tr>
<tr>
<td>*Uname</td>
<td>TMT Fleet Maintenance UserID. Do not use if using NTAUTH.</td>
</tr>
<tr>
<td>*Pword</td>
<td>User Password. Do not use if using NTAUTH.</td>
</tr>
<tr>
<td>*AcctType</td>
<td>Type of transaction to export (&quot;GL&quot;,&quot;AP&quot;,&quot;AR&quot;) where GL is General Ledger, AP is Accounts Payable, and AR is Accounts Receivable.</td>
</tr>
<tr>
<td>**CfgID</td>
<td>Accounting Export Configuration ID for text export created in TMT Fleet Maintenance/SQL.</td>
</tr>
<tr>
<td>**ExportFile</td>
<td>Path and name of export file; required when writing to a text file.</td>
</tr>
<tr>
<td>Overwrite</td>
<td>Indicates whether the export file should be overwritten (OVERWRITE). Defaults to not overwrite.</td>
</tr>
<tr>
<td>FromDate</td>
<td>Date to start a limit for which transactions should be exported.</td>
</tr>
<tr>
<td>ToDate</td>
<td>Date of end of limit for which transactions should be exported.</td>
</tr>
<tr>
<td>RetType</td>
<td>Retrieval Type: Which transactions should be exported (NonExported, Exported, All). Depends on whether the transactions have been previously exported. Defaults to Non-Exported.</td>
</tr>
<tr>
<td>FileOnly</td>
<td>Export transactions to file only without marking records in database as Exported; (&quot;FILEONLY&quot;) defaults to not false.</td>
</tr>
</tbody>
</table>

*Denotes required. Required parameters must be specified and must be in the order designated.

- ConfigID, File, Overwrite, and FileOnly are only used when exporting to a text file
- Case is not important except for the password.
- Parameters containing spaces must be surrounded with double quotes.
- If provided, SRVR, DBNAME, and NTAUTH must be the first parameters.
- If overriding the server and database in the Transman.INI file, both the server and database parameters must be specified. The order does not matter for optional parameters except for FromDate and ToDate.
- The date format is from the local machine's regional settings. In the US, this is usually mm/dd/yyyy.
• If using NT Authentication, the user executing the program must be granted access to the TMT Fleet Maintenance database and granted the TFWUser role. This would be best done by creating a Windows domain group and granting that group access to TMT Fleet Maintenance. Also the username and password would not be specified. To use NT Authentication, the client machine must be configured according to the instructions in the file NT Authentication Using the Borland Database Engine.doc.

Execution Examples

The following are examples of how to execute AccountingExport.exe providing parameters.

Export to a Text File

Export GL transactions for Export Config. ID of GLINVENTORY for all Non-Exported records and write to file c:\my data\glinventory.txt and overwrite the file.

Use user, password, and TRANSMAN.INI

AccountingExport myuser mypassword gl glinventory "c:\my data\glinventory.txt" overwrite

Use NT Authentication

AccountingExport NTAUTH gl glinventory "c:\my data\glinventory.txt" overwrite

Use NT Authentication and override server and database

AccountingExport SRVR:myserver DBNAME:TFW NTAUTH gl glinventory "c:\my data\glinventory.txt" overwrite

Export to Tables

Use user, password, and TRANSMAN.INI

AccountingExport myuser mypassword gl

Use NT Authentication

AccountingExport NTAUTH gl

Use NT Authentication and override server and database

AccountingExport SRVR:myserver DBNAME:TFW NTAUTH gl

Log File

The program creates an application log called AccountingExport.log. The log stores the times when the export started and completed. All error messages are written to the log. The log file is written in the same directory as the AccountingExport program.

Schedule Jobs

Schedule export programs in Windows Scheduled Tasks on the database server.

• The format is SQL Server username, password, and accounting type. The database used will be from the TMT Fleet Maintenance.ini file on the same machine.

  • c:\program files\TMTSoftware\transman\accountingexport.exe user password gl
  • Accounting Export GL 12:01am
  • Accounting Export AR 12:05am
Exporting Data to Great Plains

The Great Plains Interface program is a TMT Fleet Maintenance/SQL helper application that exports accounting transactions from the accounting interface tables to Great Plains interface tables in TMT Fleet Maintenance. The Great Plains Interface program is a command-line application that simply connects to the TMT Fleet Maintenance database and exports non-exported transactions in a format that is compatible with Great Plains. Since this application is executed on the command-line, it can be scheduled to run without user interaction. This program is scheduled to run on the database server as part of the interface setup. Each accounting type is exported independently. All transactions exported at the same time are assigned a batch ID with the date. New batches are appended to the Great Plains interface tables. Transactions must be deleted after a successful import or they will be re-imported the next time an import is run.

Security - The Great Plains Interface program requires a database user in order to access the TMT Fleet Maintenance/SQL database. Scheduling a Windows task also requires a user in order to execute. See the TMT Fleet Maintenance/SQL Installation and Administration Guide for instructions on how to create the GPI interface user.

NOTE: The interface uses ADO to connect to the database server. This means that the TRANSMAN.INI file is not used when making a database connection. The database server and database name are parameters that are set by the user.

Integration Workflow - Each night, new transactions that have not been exported are written to database tables. Transactions that have not been imported are written to Great Plains Interface tables. These entire interface tables are imported into Great Plains when Integration Manager is run. The accounting clerk can import the TMT Fleet Maintenance transactions on a schedule that is set up by your company. After each integration is run, a message is displayed requesting whether to delete the imported transactions. Select Yes if the import was successful. Select No if warnings or errors were displayed. If errors occurred, then correct the problem in Great Plains and attempt the import again. Answering Yes to delete is the only way transactions can be deleted. The imported data is then cleared from the interface tables after the transactions are imported into Great Plains.

Launching the Great Plains Interface - Launch the application from a Windows command line. If no parameters are specified, then the parameter list below will be displayed. The first 5 parameters are required. Optional parameters will be used if they are formatted correctly. It will validate all parameters and output error messages to the screen and log file. The normal execution is to export non-exported transactions.

Parameters - The parameters for the command are:

`AcctType Server Database UName Pword FromDate ToDate RetType`

NOTE: An asterisk (*) indicates a required parameter. Required parameters must be specified and must be in the order designated.
<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
</table>
| * AcctType | GL (General Ledger)  
AP (Accounts Payable)  
AR (Accounts Receivable) |
| * Server | TMT Fleet Maintenance/SQL Server |
| * Database | TMT Fleet Maintenance/SQL Database |
| * UName | TMT Fleet Maintenance/SQL User ID |
| * Pword | User Password |
| FromDate | Date to start a limit of which transactions should be exported. Optional; format is from local settings |
| ToDate | Date to end of limit of which transactions should be exported. Optional; format is from local settings |
| RetType | Retrieval Type is which transactions should be exported  
Non-Exported (default)  
Exported  
All |
| Today | Include G/L transactions for the current day - FOR TESTING ONLY. Normally G/L transactions will not be exported for the current day. This is to prevent double-posting of a day’s entries, since they are summed by day. To override this during testing, pass this parameter. |

**Examples** - Export Accounts Payable transactions on the current server that have not been imported.

```
c:\program files\TMTSoftware\transman\greatplainsinterface.exe ap TFW gpinterface password
```

**Log Files** - The Great Plains Interface program writes to a log file named `GreatPlainsInterface.LOG` that is contained the directory it is run from. Any warning messages or errors are written to this file.

---

**Troubleshooting Accounting Export**

**Log Files**

The AccountingExport program and the GreatPlainsInterface program each writes to log files in the directory where they are run. Each is named `PROGRAM_NAME.LOG`. Use the log files to determine if and when the programs ran. Any errors are written to the log files.

If a program ran and no data is available to import, verify the data in the TRANSMAN.INI file on the server. If the database name is changed here, then the interface will run against the wrong server. Do not change the TRANSMAN.INI file on the database server.

To display the current version of the Great Plains Interface, in TMT Fleet Maintenance/SQL, go to **Help > About > System Info**. The interface version is displayed.
Deleting Batches

The GreatPlainsInterface program deletes all integration batches after it is configured. If the integration batches are not being deleted, check the following:

1. Is the integration completing successfully? If the integration is not completing successfully, then the file will not be marked for deletion and the user will not be prompted to delete the batch.

2. Is the After Integration script set up? The Great Plains Integration Manager has scripts that need to be configured to point to the correct database so that the batches can be deleted. To configure these scripts, see “Deleting Batches” on page 291.

Scheduling Exports

The interface jobs for both the AccountingExport and GreatPlainsInterface programs should be scheduled in conjunction with the database and server backups. An example schedule could be:

<table>
<thead>
<tr>
<th>Schedule</th>
<th>Task</th>
<th>Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>SQL server database backup</td>
<td>11:00 PM</td>
</tr>
<tr>
<td>2</td>
<td>Interface programs</td>
<td>12:00 AM - 12:30 AM</td>
</tr>
<tr>
<td></td>
<td>Accounting Export G/L</td>
<td>12:01 AM</td>
</tr>
<tr>
<td></td>
<td>Accounting Export A/R</td>
<td>12:05 AM</td>
</tr>
<tr>
<td></td>
<td>Accounting Export A/P</td>
<td>12:10 AM</td>
</tr>
<tr>
<td></td>
<td>GreatPlains G/L</td>
<td>12:15 AM</td>
</tr>
<tr>
<td></td>
<td>GreatPlains A/R</td>
<td>12:20 AM</td>
</tr>
<tr>
<td></td>
<td>GreatPlains A/P</td>
<td>12:25 AM</td>
</tr>
<tr>
<td>3</td>
<td>Server tape backup</td>
<td>1:00 AM</td>
</tr>
</tbody>
</table>

The Accounting Export and Great Plains Interface programs must be scheduled to run as a Windows task on the TMT Fleet Maintenance/SQL database server. Schedule the following tasks on the TMT Fleet Maintenance/SQL database server using the GPInterface user:

TMT Fleet Maintenance Export

The format is:

```
SQL_server_username password accounting_type
```

The database used will be from the TRANSMAN.INI file on the same workstation.

Examples:

```
c:\program files\TMTSoftware\transman\accountingexport.exe gpinterface password gl
```
```
c:\program files\TMTSoftware\transman\accountingexport.exe gpinterface password ar
```
```
c:\program files\TMTSoftware\transman\accountingexport.exe gpinterface password ap
```
Great Plains Interface Export

The format is:

```
accounting_type database_server SQL_server_username password
```

Examples:

```
c:\program files\TMTSoftware\transman\greatplainsinterface.exe
gl server_name TFW gpinterface password

c:\program files\TMTSoftware\transman\greatplainsinterface.exe
ar server_name TFW gpinterface password

c:\program files\TMTSoftware\transman\greatplainsinterface.exe
ap server_name
TFW gpinterface password
```

Printing Bar Code Labels

For detailed information about setting up TMT Fleet Maintenance/SQL for printing barcoded parts labels, see the *TMT Fleet Maintenance/SQL Installation and Administration Guide*.

Go to Activities > Bar Code Labels. This form enables you to choose the type of label you want to print and to specify a range and quantity of labels to be printed.

![Print Bar Code Labels](image)

You can use the Print Bar Code Labels > Part Labels by Bin menu to select a single bin or a range of bins, and then print bar code labels only for those bins. You can also select the number of labels to be printed using this function.
If the *Marked Parts Only* check box is checked, TMT Fleet Maintenance validates whether the Bar Code Label check box is checked on the item record in the Shop Inventory. If it is not checked, all labels will print. If it is checked, only parts with Bar Code Label checked on the Shop Inventory will print.

The *Print Parts Within Bin* check box enables you to select a single bin or a range of bins and print part labels only for those bins. You can select the number of labels to print while using this function.

Bar coded part labels are printed for each part received through the Purchase Order system if the *Print bar-coded receiving labels* check box in **Masters > Shops > Options** (see “Print bar-coded receiving labels” on page 97) is checked and the Print Label box is checked in the Shop Inventory record (see “Shop Inventory Part Definition” for the part).
Setting up and Using the Invoicing Module

The Invoicing module was designed to facilitate billing customers (both internal and external) for the maintenance and repair work done in your shops, or for direct sales. Several very flexible methods of providing cost basis and markups can generate invoices designed specifically for individual customers or groups of customers.

You can create an invoice only from a repair order that has billable sections. If no billable sections exist for that repair order, an error message is displayed. If the Customer master has the option Create Invoice from RO checked, when the repair order is closed, no invoice is created. Additionally, you can bill different amounts for the same service based on individual units.

Setting Up the Invoicing Module

Go to SysMgr > Invoice Price Tables. The Price Tables are used to create different markup plans for different customers.

You can base markup percentages or amounts on either the cost of the part or for components in general.

Markups based on components will roll up to the highest component level. For example, a part component markup for 031 is 25%; for 034-001, it is 30%; and for 034-005-001 it is 10%. If a part with component 034-001-001 is entered, the markup is 30% because it rolls up to the 034-001 percentage. If a part with component code 034-002-001 is entered, the markup is 25% because it rolls to the 034 level markup. If a part with component 034-005-001 is entered, the markup is 10% because it matches the 034-005-001 specification. This enables you to set up percentages based on the system level or assembly level component code.

The method used for calculating markups is (price x markup percentage)/100 + price = marked up price. This is the same method that calculators use. You do not multiple the price times the percentage to get your answer. For example $1 + 50%=$1.50 not $1 x50%=.50, $1 + 100%=$2 not $1 X 100%=$1 or $1 + 101%=$2.01 not $1 x 101%=$1.01.

TMT Fleet Maintenance/ SQL Workbook
Enter a name for the Price Table to be created. You can assign a price table to a unit that is used when an invoice is created from a repair order (and if a price table does not exist for the unit, the price table for the customer will be used).

On the **Parts** tab, select the Cost Basis to be used for markup. The Cost Basis can be any of the three available inventory methods (FIFO, LIFO, or Average Cost), actual cost (the inventory method in use), or prices established for each part in the shop inventory record on the **Prices** tab.

Once the Cost Basis is defined, you can decide to use a flat markup by checking the **Use Flat Markup** box. A flat markup of 0% results in no markup on the cost basis selected. If this box is not checked, the markup is determined by a user-definable markup matrix in the left grid, or by component code groups in the right grid. Component markups override the markup matrix.

Use the **Labor** tab to define the cost basis of labor to be marked up. Labor cost basis can be actual cost (the labor cost method in use), or any defined pay grade. You can define pay grades specifically for billing purposes. The markup is like the price markup except that you can specify a minimum labor time charge.

When the total labor hours on the invoice are less than the minimum labor hours on the price table for the customer, the system calculates the difference between the total labor and the minimum labor and adds a labor line called **Minimum Labor Adjustment** to the last section of the repair order to account for the difference in labor hours.

The **Services** tab establishes markups for services purchased from outside vendors or contractors. The markup functions like the parts and labor markups except that the only cost basis available for Services is **actual cost**.

The **Vendor Charge** tab establishes markups for parts and labor purchased from outside vendors or contractors. The markup functions like the parts and labor markups except that the only cost basis available for vendor charges is **actual cost**.
The **Fuel Tickets** tab sets markup criteria that is applied only to invoices created from road and company fuel tickets.

The **Misc Fees** tab establishes the assessment of a fee charge on the invoice. This is typically used for a shop supply or environmental surcharge to help recover overhead costs.

Provide a description for the fee item and select either a fixed flat fee per invoice section, or a percentage of the parts, labor, and services charges on each invoiced section. A maximum fee amount can also be stipulated. This generates a fee line on the invoice in section 0 along with the taxes.

If a charge category that is not contained in the fee table is entered on an invoice, a description is required and Flat Fee is selected by default. If the charge category is removed, the description is removed and no fee type is selected. This prevents fees from being charged on invoices that have no associated category in the accounting export programs.

The Charge Category field enables the selection of a fee type to use for the charge category of the fee when it is added to a repair invoice. (In previous versions of TMT Fleet Maintenance/SQL, this defaulted to STANDARD.) Fees are set up in **SysMgr > Tax Rates and Fees**.

**NOTE:** New invoice Price Tables can no longer use the STANDARD charge category for the Misc fee; a charge category set up in Tax Rates and Fees must be selected. Previously-created invoice Price Tables can still use STANDARD until they are changed.

The **Min Amount** field used for percentage-based fees allows a minimum amount for the fee that will always be charged on a repair order invoice.

The **Taxable** check box allows the fee to be taxable or non-taxable on repair invoices. If the fee is marked taxable, the shop must have the option **Tax on Fees**.
checked and the customer must not be tax-exempt in order for the fee to be calculated.

A tax override function can be used on direct sales invoices to remove or modify taxes. If the Override check box at the bottom of the Invoice form is checked, all taxes and fees are recalculated on section 0. If the Override check box is not checked, all taxes and fees are recalculated on post and any modifications are lost.

Batch Mode

If Prompt for Batch is turned on for invoices, an invoice cannot be created unless a batch is selected.

Adding Invoice Messages

After creating Price Tables, go to SysMgr > Standard Messages. This form enables you to create a message that prints on all invoices. This could be used for a statement of warranty policy, payment terms, or both. The message created here is the default message for all shops. Individual shops cannot create messages (this was possible in previous versions of TMT Fleet Maintenance/SQL).

**NOTE:** The order types of CIS-WEBLOGIN and CIS-WEBMSG are used by the web-based Customer Inquiry System.

The Shop Master Orders tab also has check boxes to indicate which types of charges should be taxed on the invoice. The tax that is applied is determined by the tax rates listed on the Shop Master Taxes tab.

Shop Inventory Prices

The Prices tab indicates the price of the part by category. The category is added in SysMgr > System Setup > Codekeys. This could list the fleet, jobber, or list price of a given part.
Prices differ from costs in the sense that the **cost** is what you pay for an item, and the **price** is what you charge for it. Prices for parts can be established as a specific amount or as a percentage markup on the part cost. The **Prices** tab can be used by the Invoicing module in determining the prices charged to your internal or external customers by the invoicing system. Prices can be updated by going to **Activities > Parts Price Update**. This displays the Parts Price Update form.

If a price is set to $0.00 for a shop part and that part is used with the invoice price table for the customer, the part is charged at $0.00. This price can be overridden on the invoice, if necessary. Setting a price to $0.00 enables you to include prices on an invoice for which there is no charge.

**Generating Invoices**

You can generate invoices based on open or closed repair orders or indirect sales, or you can create custom invoices.

**NOTE:** If a repair order has no billable sections, an invoice cannot be created. If you right-click on the repair order, an error message is displayed: Only ROs with
billable sections can be invoiced. If the customer has the option Create Invoice from RO checked, when the repair order is closed, no invoice is created.

Invoice Status

An invoice can be updated to an interim status of COMPLETE. This status allows changes to be made to the invoice before it is closed. Each time the invoice is printed in COMPLETE status, it will print as an original invoice.

An invoice can be created from a repair order that has a status of COMPLETE. If an invoice is generated from a COMPLETE repair order, the repair order must be changed to CLOSED before the invoice can be closed.

All lines can be regenerated for an OPEN or COMPLETE invoice. This is useful if the repair order is in a COMPLETE status and has had additional items added to it. By regenerating the invoice, the new lines will be added to the invoice.

Invoices for Closed Repair Orders

Go to Orders > Invoices. This displays the Search Invoices form, which has similar features to other Search Orders forms.

Specify any search criteria you want to use, and click on Search to display a list of invoices. To display all invoices, click Search without specifying any criteria.

This screen can serve as a link to purchase orders. Right-click in the grid and select Customize Columns, then select Purchase Order from the list of available columns. The Purchase Order column displays the purchase order associated with the invoice.
For information about how invoice status codes work, see “Invoice Status Codes” on page 317.

Double-click on a closed Repair Order to view the invoice form.

This form has two tabs: Header and User Fields. The User Fields tab enables you to add images and define fields that are specific to your company. The Header tab contains all of the information that is used to create and work with an invoice.

The prices that are visible are specific to the section that is highlighted. Taxes and fees are always added in section 0. Prices can be changed by double-clicking on a part line item. If there are no tax lines, no fee lines, and no section comments in section 0, this section does not print on the detail invoice. Prices for part lines are displayed with three decimal points (for example, 10.995); this type of pricing is frequently used for fuel tickets.
Part, Service, and Fee lines are highlighted in yellow when the actual cost is greater than the price being charged. Note that highlighting is not applied to credit invoices and lines where the total is negative.

**NOTE:** For numbered sections that contain Part lines, the Price field reflects the price displayed on the invoice. Previously, this field displayed the part’s last cost.

Right-click in the Customer ID field to view Sticky Notes for the customer on the invoice, or on View Info to display customer information (shown below).

<table>
<thead>
<tr>
<th>Customer Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cust ID: 10714</td>
</tr>
<tr>
<td>Name: Brachex Enterprises</td>
</tr>
<tr>
<td>Address1: 2516 NC 24/27 North</td>
</tr>
<tr>
<td>City: Brevard</td>
</tr>
<tr>
<td>State: NC</td>
</tr>
<tr>
<td>Zip Code: 28614</td>
</tr>
<tr>
<td>Phone: 513-773-7049</td>
</tr>
<tr>
<td>Ext:</td>
</tr>
<tr>
<td>Active: Y</td>
</tr>
</tbody>
</table>

Only the sections of the repair order designated as billable create charges on the invoice (see “Repair Order Entry Options” on page 181).

With the Invoicing module installed, after entering a repair order number to be invoiced, the program displays (one at a time) each part and labor charge for final approval before the hardcopy invoice is printed. Sales price and costs are displayed. Sale price can be changed to ensure correct billing; prices that are updated as an invoice is created are automatically updated on the invoice. After the invoice is complete, a receivable record is created for collections and a complete and concise invoice is printed. Duplicates are easily created. Receiving payment is quick and easy: enter the customer number and invoice number to view the invoice information with total customer costs. A credit memo can also be created.

You can associate a custom Crystal Report version of an invoice. Note that the total length for the path to the custom report must be 60 characters or less.

If a repair order has an image, the image is copied to the associated invoice when it is created or regenerated. Images can be displayed on the Customer Inquiry screen if the CIS Web Interface is used. A column named Images can be displayed on the Invoice Query form so that if an invoice contains an image, the column is checked.

**Sticky Notes** - You can associate Sticky Notes with invoices.
Sticky notes are shop-specific. The heading at the top of the sticky note indicates the shop and the order number. In the example above, the shop ID is shop 020-15A and the order number is 000000001.

**Invoice Status Codes**

Status codes are displayed on the *Create Invoice from Order* screen.

An active invoice has a status of OPEN. All lines can be regenerated, changes can be made, and each time the invoice is printed, it prints as an original draft invoice. Any repair orders associated with this invoice cannot be deleted.

An invoice with a status code of COMPLETE prints as an original invoice. This status indicates that the repairs have been completed and the invoice is waiting for payment information to be recorded.

An invoice with a status code of CLOSED can be changed only if it is reopened. If a closed invoice is printed, it prints as a duplicate invoice.

Invoices that have been exported through *Activities > Data Export* display a status of EXPORTED.

**Re-Open a Closed Invoice**

You can re-open closed invoices (unless it has already been posted to an accounting period or exported).

To re-open a closed invoice, go to *SysMgr > Re-Open Closed Invoice*.

![Re-Open Closed Invoice](image)

Click the Search icon next to the *Shop ID* field and select the shop. The *Invoice number* field is required. Type the invoice number you want to re-open, or, to see a list of all closed invoices, type 0 in the field (which searches on the initial 0 in the default TMT Fleet Maintenance/SQL invoice number sequence), then click *Search*. 
Posted invoices cannot be re-opened. Check the status column to determine if the invoice you want to work with has been posted. If the Status column is empty for the invoice, click on the invoice in the list that you want to re-open, and then click OK. In this example, only invoices 000000000027 and 000000000028 can be re-opened.

If a posted invoice cannot be re-opened, an error message is displayed.

If the invoice is re-opened successfully, no message is displayed, and the dialog box is closed. You can now work with the re-opened invoice.

**Direct Sale Invoices**

The Invoicing module must be installed for this feature to operate.

A direct sale invoice can be used for over-the-counter part sales as well as labor and service sales that could not be charged on a repair order.

On direct sale invoices, the Vendor Supplied check box is not available.

From the Invoice Listing screen, click on Direct Sale. The Create Direct Sale Invoice screen is displayed.
Select the shop that will provide the parts, labor, and services. Then select the customer that is being billed for the parts, labor, and services. The Direct Sale Invoice screen is displayed.

![Direct Sale Invoice Screen]

This screen is used to create an invoice for a direct sale of stock or non-stock parts to a walk-in customer. Parts are charged at a rate predetermined by a personalized customer record, or by a markup matrix table that is applied to all customers. TMT Fleet Maintenance/SQL maintains a running dollar total on parts being charged.

In the Sections block, a section 0 labeled Taxes/Misc is automatically created. Use this section to invoice parts, labor, and services. Additional taxes and fees can also be added.

Taxes can be overridden if the calculated amount is different than what should be charged to the customer. To override the tax on an invoice, check the Override Taxes and Fees for this Invoice check box on the invoice form. This will prevent the tax line from being updated as new lines are added and posted. Once tax has been overridden, the only way to change the tax is to edit the tax line manually.

You can print (or close and print) the invoice like any other invoice.

**NOTE:** Credit Invoices printing options work the same way as direct sale invoices.

## Creating Custom Invoices

You can use Crystal Reports to create custom invoices.

**NOTE:** Custom invoices are created in Crystal Reports version 8.0 and that version or later is required to edit the custom invoices.

For more information, contact TMT Software Customer Support.

## Invoice Payments

Invoice payments can be recorded from several screens.
From the Invoice - Go to Orders > Invoices. If you know the invoice, enter it in the Invoice # field, or use the Search button to find the invoice. Double-click the invoice to open it.

Record the payment in the Amt Paid field at the bottom of the form.

To view previous payments applied to this invoice, click the Payment > button.

From the Invoices Screen - Right-click on an invoice in the Invoices screen and select Update Amount Paid. The Invoice is displayed.
Right-click in the lower grid and select **Insert**.

The Payment - Inserting dialog box is displayed.
Enter the payment information and click Ok to save, or Cancel to quit without saving.

**Multiple Payment Methods**

Invoices can reflect a number of different payment methods. A customer can issue payments using several different payment types that can be included on an invoice.

- The Customer master contains a Pay Method field that enables you to indicate a standard payment method for a customer.
- On the payment screen, the Number field (formerly called the Check Number field) allows 24 characters.
- On the payment screen, the pay method can be selected for each payment and if the customer has a default payment method, it is used by default.

The Invoice reports contain a column showing the payment method that was used on the invoice.

Payment methods include CASH, CHECK, and CREDIT CARD. ONACCOUNT is used when a vendor or customer is billed but is not making an immediate payment.

**Printing Invoices**

Go to **Orders > Invoices**.

There are two printing options for invoices: the *repair invoice* and the *invoice detail*.

The *repair invoice* prints out the header and each section has a total for parts, labor, and services. This is the printout that is usually sent to the customer for payment.

The *invoice detail* option prints the detail line items for each section of the repair order being used to create the invoice.

- If the invoice is *open*, a draft invoice can be printed and the words DRAFT - DO NOT PAY are printed in the upper left-hand corner. You can print both repair invoices and invoice detail invoices.
- If the invoice is *closed*, the invoice will print DUPLICATE in the upper left-hand corner. You can print only invoice detail invoices.

To print a repair invoice, select the open invoice you want to print from the list, then right-click and select **Print > Repair Invoice**.

To print an invoice detail, select the invoice, right-click and select **Print > Invoice Detail**.

If Print Preview is checked on the File menu, either report is displayed in a preview window for on-screen viewing. If Print Preview is not checked, the report is sent directly to the printer.

To print the report, click the **Print** button and close the preview window.

To print invoices for multiple repair orders, select the invoices while holding down the CTRL key, then right-click and select **Print**.
You can print both repair invoices and invoice detail invoices if the repair type is REPAIR or CUSTOM. If the invoice type is DIRECTSALE, only the invoice detail can be printed.

A global option in Reports enables you to print the Shop’s name instead of the Company name on invoices.

You can also double-click on an invoice in the list and the Invoice screen will be displayed. Click on Print.

NOTE: If one of the selected invoices is DIRECTSALE, only the invoice detail can be selected. Print these types of invoices separately if you need to produce repair invoices for other types of repairs.
When Close and Print Original Invoice is selected, a Close Date field is activated. The date defaults to the current system date and can be changed.

Additional printing options can be selected from this dialog.

Cause codes, Correction codes, and Jobcodes are printed on the printout. For job-codes, if the option to sum by Jobcode is off, no Jobcodes print if there are no job-codes assigned to the labor lines on the invoice. If there are Jobcodes assigned to labor lines on the invoice, then Jobcodes are printed. If the option is on, Jobcodes print on the invoice unless there were no Jobcodes entered on the repair order section. In that case, Jobcodes will print if they are assigned to labor lines on the invoice.

Comment lines from a repair order can be edited on an invoice. The changes are not reflected on the repair order. You can also add comment lines to an invoice; these invoice comments are not reflected on a repair order.

Invoicing Reports

Two TMT Fleet Maintenance/SQL reports are enhanced when using the Invoicing module.

• Gross Profit Report - This report charts the gross profit per customer. The report is run for the individual customer or for a shop location. Each customer is totaled separately and a total for the shop is provided. A new column, Discount Amounts, has been added to record any discounts applied to invoices (instead of including them in the Gross Sales column). The Gross Profit column is net of discounts and calculated as Sales - Cost of Goods Sold - Discount. Note: This calculation did not change from TMT Fleet Maintenance version 10.00.01 when discounts were added.

• Customer Cost Summary Report - This report provides unit repair information by customer. Maintenance cost is displayed from a customer’s perspective.

Processing Warranty Claims

The Warranty Module was designed to facilitate creating, tracking and receiving warranty claims for the maintenance and repair work done in your shops. Several very flexible methods of providing cost basis and markups can generate warranty claims designed specifically for individual vendors or groups of vendors.
Go to SysMgr > Claims Price Tables. The Price Tables provide the means to create different markup plans for different vendors. Once created, these claims tables can be assigned to vendors in each vendor’s master record. See “Vendor Definition” on page 131.

Enter a name for the Claims Table you want to create. On the Parts tab, select the Cost Basis to use for markup. The Cost Basis can be any of the three available Inventory Methods (FIFO, LIFO, or Average Cost), actual cost (the inventory method in use), or prices established for each part in the shop inventory record on the Prices tab.

Once the Cost Basis is defined, you can use a flat markup by checking the Use Flat Markup box. A flat markup of 0% results in no markup on the cost basis selected. If this box is not checked, the markup is determined by a user-definable markup matrix shown in the left grid, or by component code groups shown in the right grid. Component markups override the markup matrix. These functions are similar to the corresponding functions in the Invoicing Price tables.

The Labor tab defines the cost basis of labor to be marked up. Labor cost basis can be actual cost (the labor cost method in use) or any defined pay grade. You can define pay grades specifically for warranty purposes. The markup is like the price markup except that you can specify a minimum labor time charge.
The **Services** tab establishes markups for services provided to internal or external customers. The markup functions like the parts and labor markups except that the only cost basis available for Services is *actual cost*.

The **Vendor Charge** tab establishes markups for parts and labor purchased from outside vendors or contractors. The markup functions are like the parts and labor markups except that the only cost basis available for vendor charges is *actual cost*.

After creating Price Tables, go to **SysMgr > Standard Messages**. Use this form to create a message that prints on all generated claims. This could be used for a statement of policy, terms, or both. The message created here is the default message for all shops.

**Sticky Notes** - You can associate sticky notes with warranty claims.
Sticky notes are shop-specific. The heading at the top of the sticky note indicates the shop and the order number. In the example above, the shop ID is shop 01 and the order number is 0000000003.

Generating Warranty Claims

Go to Orders > Warranty Claims. This displays the Search Claims form, which has similar features to other Search Orders forms.

The Warranty Status field is informational and requires data entry to be populated. The codes used in this field are set up in SysMgr > System Setup > Codekeys Warranty Status.

The Total, Received, and Balance columns display summary amounts at the bottom of the screen.

Click on the New button to display a Search Repair Order form that displays only closed Repair Orders that have potential warranty conditions.

Enter search criteria if necessary, and then click on Search.

Click on the RO to expand it to display the potential claims in the right-hand pane.
Select a warranted section in the left-hand pane. The warranty details are displayed in the right-hand pane. Descriptions for a line item are also displayed.

Click on **Generate Claim** to generate a claim form.
The prices visible are specific to the highlighted section. Taxes and fees are printed in the Other Charges section of the Warranty Claim form. Prices can be changed on the claim by double-clicking on the charge line. Service lines are printed individually in the Other Charges section.

The icon at top center of the form displays the repair order from which the claim was generated. The Notes icon to the right of the comments area enables you to add or edit comments. Comments do not print on the claim form.

Click the **Claim Form** button to add or edit information about the claim.

Click **OK** to exit this form and return to the previous form.

The **Print** button at the lower left generates either a printed draft claim or a final original claim. Printing an original claim closes the warranty claim and prints an original claim form. You can specify a close date. If the date is a future date, TMT Fleet Maintenance/SQL uses the global option **Allow Future Dates** to determine whether the date you entered can be used.
You can print only the warranty claim, both the claim and payments forms, only the payments form, or specify no printed output. Print options are available for all status types: OPEN, FILED, and CLOSED.

You can change the status of this warranty claim to FILED and enter a Filed Date. (A warranty claim status can be OPEN, FILED, or CLOSED.)

The printed claim uses the ATA-approved universal claim form which should be accepted by most trucking industry manufacturers and vendors.

When a universal warranty claim is printed, TMT Fleet Maintenance/SQL first checks for Odometer or Hub Meter; if neither is found, the primary meter type and meter reading are printed.

After a claim is created, the potential claim is removed from the Potential Claim listing. If the claim is deleted, it will be added back to the Potential Claim listing.

TMT Fleet Maintenance/SQL can record serialized parts so that both an old part number and a new part number are recorded for parts that are serialized. The old part number entered for a part prints in the Serial Number field in the Part section of the Warranty Claim form.

To apply a credit amount against a warranty claim, enter a negative number in the Amt Paid field. This is occasionally necessary when a warranty claim was paid but a part of the claim (or the entire claim) was disallowed on a later warranty recovery check.

**Printing Warranty Claim Payments**

To print warranty claim payment information:

1. From the Warranty Claims screen, right-click on the Warranty Claims query and select Print Claim Payments.

![Diagram of Warranty Claim Payments](image)

**TMT Fleet Maintenance/SQL Workbook**
Campaigns

A Campaign is a common task to be performed on a group of units. Campaigns could include a recall by a manufacturer, an OEM-mandated campaign, or a campaign mandated by management.

You can use TMT Fleet Maintenance/SQL’s Campaign feature to create work pending repair orders for all of the units included in the campaign. A campaign could include a recall by a manufacturer, an OEM-mandated campaign, or a campaign mandated by management. For example, you might need to repaint all the vehicles that are model year 1997, or there might be a recall on all Freightliner trucks for a faulty throttle, or you might want to perform pre-delivery checks on a group of units that were just purchased.

Go to Orders > Campaigns. The Campaign Listing screen is displayed. This screen lists all current campaigns. You can view or edit information about a current campaign, add a new campaign, cancel campaigns, or close a campaign after all of the associated work pending repair orders have been closed. You can use the grouping area at the top of the grid to change how the campaigns are displayed.

Add a New Campaign

To create a new campaign, right-click anywhere in the grid and select New Campaign, or click on New at the bottom of the screen.
The Campaign # - New Campaign screen displays the campaign header.

**Shop ID** - If the campaign is specific to a shop, enter the Shop ID. If the Shop ID is selected on the header and there is no default shop setup, a prompt for Shop ID is displayed when units are assigned to the campaign.

**Campaign Number** - The campaign number is automatically generated if a Shop ID is entered. The number follows the same conventions as order numbers found in the system. If a Shop ID is not entered, the campaign number must be entered manually.

**Description** - If the campaign number is entered manually, the campaign description will default to the campaign number. If the number is automatically generated based on the Shop ID, the description must be manually entered.

**Campaign Type** - The default campaign types can be Campaign or Recall. Additional campaign types can be created in Codekeys.

**Priority** - The priority level for the work to be done. Priority levels range from 5 (the lowest priority, and the default) to 1 (the highest level).
**Campaign Dates** - You can specify start and end dates for a campaign in the Dates field. Use the calendar buttons next to the fields to access a calendar to select the dates. Dates are not required. When a campaign is closed, the date closed will be used as the end date.

**Set Up the Campaign**

Campaign sections are used to set up what systems will be worked on for the campaign. They work just like repair order sections. Once a campaign is added to a repair order, the component code, complaint, and repair reason cannot be changed on the section on the repair order.

To add a campaign section, click on the Sections tab, then right-click in the grid and select **New Section**.

The *Campaign Section* screen is displayed.

The campaign section is used to set up the systems that will be repaired or worked on for the campaign. The form works the same way as a repair order section. After units are assigned to a campaign, the *Section* screen becomes disabled and cannot be edited.
The Component, Complaint, and Repair Reason fields are required. Complete the other fields as required, remembering that after units are assigned, these fields cannot be changed.

Click OK to save the campaign section, or Cancel to quit without saving.

**Assign Units**

A campaign is fully editable until units are assigned to it. After a unit is assigned, a line entry is displayed on the History tab with an Order Status of Pending. After this time, the campaign can no longer be edited. It is essential to include and record ALL data for the campaign before adding units.

To add a unit, go to the History tab.

Right-click in the grid and select **Create Pending**.

The Campaign Unit Selection screen is displayed.
Select the unit type you want to include in the campaign. Enter any additional selection criteria necessary to restrict the results to only those units you want included in the campaign. For example, if your company has 130 Ford trucks, and you only want to include 2001 model year Ford pickups, specify the additional criteria needed to restrict the results to only that subset of Ford trucks that you need to add to the campaign.

Click **OK** to add the section to the campaign.

**Sticky Notes** - You can assign sticky notes to campaigns. Sticky notes are shop-specific. The heading at the top of the sticky note indicates the shop and the order number.

**Edit a Campaign**

Double-click on an entry in the list to update the campaign.
You cannot change the status of a campaign to Cancelled unless there are no pending orders on the campaign. This prevents campaigns with pending repair orders from being deleted, leaving behind the pending repair order that cannot be deleted.

**View Campaign Sections**

A list of repair order sections that are included in a campaign are displayed in the Sections tab.

Campaign sections that are complete are displayed in green.

To view the repair order section, double-click on the section in the listing.

**Close Campaign Sections**

On a campaign with multiple sections, you can close the section on the campaign by right-clicking on the section in the Sections tab and selecting Close. This menu option is available only when units have been assigned to the campaign.

A campaign cannot be closed until that section has been closed on all repair orders.
The line entry for a campaign that is closed is displayed in green on the History tab.

**Delete a Campaign**

If a unit was assigned in error to the campaign, the pending order can be deleted by selecting the order on the History tab and pressing CTRL + DEL or right-clicking on the order and selecting Delete. A campaign section cannot be deleted or cancelled from the repair order system. If a campaign section is on a repair order and not completed, the section will be returned to a pending status.

**View Campaign History**

To view a complete history of campaign activity, click on the History tab.

You can use the History tab to quickly create a new repair order for a specific unit in the current campaign.

Lines for completed campaigns are shown in green.

In this example, the first repair order in the list has been expanded to show the RO sections. From this screen, you can select the unit you want to work with by right-clicking on the unit and selecting Create Pending, or by highlighting the unit in the list and clicking the Create Pending button. The Campaign Unit Selection screen is displayed.

You can cancel a campaign section from this screen (including pending sections) by right-clicking on a campaign section and selecting Cancel from the drop-down menu.

The Unit Selection screen provides a selection list of units that is based on the criteria you specify. The units displayed in this list can be added to the campaign.
Specify selection criteria as needed.

The *Serial Number Lookup* fields enable you to sort units by serial number. You can click **Range** to enter a range of serial numbers.

You can click **Find Similar** to enter a portion of a serial number. All matches are displayed.

When a pending RO is created, check the check box next to Use Unit Domicile if you want the RO to use the unit’s domiciled shop instead of its assigned shop.

Enter any combination of criteria and then click the Results tab to display the list of units that meet the criteria for selection.
Click to highlight the entry for the unit and then click **OK**. A new repair order for that unit is created.

**Grouping Campaigns**

To help with irretrievability, the column headers on the History tab can be moved to group the information. To arrange the information grouped by a column, drag and drop the column header into the grouping area. Grouping provides a convenient way to sort the data into “chunks” that are more manageable.

For more information, see “Using the Grouping Feature” on page 17.

**Printing Campaign Lists**

To print a list of what is displayed on the History tab, click **Print**.
E-Management Reporting

E-Management Reporting enables you to e-mail a selected group of exception reports in HTML format to a list of recipients at scheduled intervals.

To install the E-Management Reporting feature, see the *TMT Fleet Maintenance/SQL Installation and Administration Guide*.

After it is installed and the setup is completed, the reports are generated automatically.

Setting Up E-Management Reporting

Run the RpdSetup.exe program on the client machine. The *TMT Fleet Maintenance Exception Report Setup* screen is displayed.

The first five icons on the tool bar select the five setup functions.

Master Reports List

The Master Reports List icon displays all the reports defined in E-Management Reporting.

Click the right mouse button anywhere in the grid to access a pop-up menu that enables you to create, edit, or save a report. You can define the report name, report parameters and output, and the location of the HTML report file that is generated. The Filter Builder feature enables you to refine the level of detail that is produced; this process is based on choosing a field name, operation, and the field value you want to use to limit the report.

Master Server List

The second icon, Master Server List, enables you to define the database servers from which the E-Management Reporting system will extract data.
Click the right mouse button in the grid to access a pop-up menu to insert, edit, or delete a database server.

**Report Users List**

The third icon, Report Users List, enables you to maintain the distribution list for the report.

Click the right mouse button in the grid to access a pop-up menu to insert, edit, or delete a user from the list.
E-mail Accounts Master

The fourth icon, E-mail Accounts Master, enables you to define the e-mail client application to be used for the report distribution.

Click the right mouse button in the grid to access a pop-up menu to insert, edit, or delete e-mail client configurations from the list.

Open Application Settings - Globals and Scheduler Tabs

The fifth icon, Open Application Settings, opens the applications settings dialog box. There are two tabs: Global and Scheduler.

The Global tab enables you to define the name that appears as the sender of the report e-mail. The Subject defines the subject stated on the report e-mail, and the Body defines the text that is included in the body of the e-mail.
The Scheduler tab provides a facility for you to define the time of day that the E-Management Reporting feature performs its tasks and distributes the report to the list of e-mail recipients. The scheduling of the E-Management Reporting job can also be managed with the SQL agent.

Calendar

Go to SysMgr > Calendar Setup.
The Calendar feature enables you to set up a calendar that can be assigned to a work shift. When a calendar is assigned to a work shift, units that are assigned to that work shift will use the calendar to determine utilization and PM Utilization for the meter type of DAYS.

There are two types of calendar - *Include* and *Exclude*.

An Include calendar excludes every day unless that day has been specifically included by clicking on it. When a day is clicked on to include it, it is highlighted in green.

An Exclude calendar includes every day unless that day has been specifically excluded by clicking on it. When a day is clicked on to exclude, it is highlighted in red.

The weekends also have a setting of Include and Exclude.

- If weekends are set to *include* on an *Include calendar* type, the weekends automatically will be set to be included and are highlighted in green.
- If weekends are set to *include* on an *Exclude calendar* type, the weekends automatically will be set to be included and are not highlighted.
- If weekends are set to *exclude* on an *Include calendar* type, the weekends automatically will be set to be excluded and are not highlighted.
- If weekends are set to *exclude* on an *Exclude calendar* type, the weekends automatically will be set to be excluded and are highlighted in red.
Chapter 8: Importing and Exporting Data

TMT Fleet Maintenance/SQL includes several import and export features that allow it to interact with other software programs.

**NOTE:** Some imports require the purchase of additional modules. For more information, contact TMT Software Customer Support.

### Importing Data

You can import various types of data into TMT Fleet Maintenance/SQL, including:

- customer invoice data
- fuel ticket data
- meter reading data
- parts inventory data
- parts requisition data
- physical inventory data
- repair order data
- tire audit data
- unit data
- VMRS parts data
- yard check data

You can upload data from a Palm device or personal data terminal (PDT). TMT Fleet Maintenance/SQL is also able to import data from additional program modules, including FleetNet America (which is used to track on-the-road repairs), Penske (used to track vendor repairs), Budini tire audits, and customer invoices (which enables you to import invoices from another TMT Fleet Maintenance system to create repair orders). You can import normal TMT Fleet Maintenance/SQL repair orders, and vendor repair orders, including repair orders created in another TMT Fleet Maintenance system.

The Data Import Wizard program enables you to import various kinds of data:

<table>
<thead>
<tr>
<th>Import Name</th>
<th>Availability</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer Invoice</td>
<td>Purchased separately</td>
<td>Imports repair invoices from another TMT Fleet Maintenance system and creates repair orders for each invoice.</td>
</tr>
<tr>
<td>FleetNet America</td>
<td>Purchased separately</td>
<td>Used to import repair order data from FleetNet America.</td>
</tr>
<tr>
<td>Import Name</td>
<td>Availability</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Meter Readings</td>
<td>Standard Palm Programs</td>
<td>Used to import meter readings that have been uploaded from a Palm device.</td>
</tr>
<tr>
<td>Parts Inventory</td>
<td>Standard Palm Programs</td>
<td>Used to import parts inventories that have been uploaded from a Palm device.</td>
</tr>
<tr>
<td>Parts Requisition</td>
<td>Standard Palm Programs</td>
<td>Used to import parts requisitions that have been uploaded from a Palm device.</td>
</tr>
<tr>
<td>Penske</td>
<td>Purchased separately</td>
<td>Used to import repair order data from Penske.</td>
</tr>
<tr>
<td>Physical Inventory</td>
<td>Advanced Barcode Module</td>
<td>Used to import physical inventories uploaded from the PDT scanners.</td>
</tr>
<tr>
<td>Repair Orders</td>
<td>Purchased separately</td>
<td>Used to import repair order data from other systems.</td>
</tr>
<tr>
<td>Tire Audit</td>
<td>Purchased separately</td>
<td>Used to import tire repair order data from Budini.</td>
</tr>
<tr>
<td>TravelCenters of America</td>
<td>Purchased separately</td>
<td>Used to import service information from TravelCenters of America.</td>
</tr>
<tr>
<td>Unit Master</td>
<td>Purchased separately</td>
<td>Used to import unit master data exported from TMT Fleet Maintenance/400. You can also import unit data in XML format.</td>
</tr>
<tr>
<td>VMRS Code</td>
<td>Standard</td>
<td>Used to import updated VMRS Code and Description information from a flat text file.</td>
</tr>
<tr>
<td>Yard Check</td>
<td>Standard Palm Programs</td>
<td>Used to import yard location and meter readings from a Palm device.</td>
</tr>
</tbody>
</table>

All imports work the same way. You first select the import you want to perform then click **Next**. A screen that displays the options for that type of import is displayed. For example, the FleetNet America, Tire Audit, and VMRS Code imports display a screen listing the different import schemas that have been set up for that import. The Parts Inventory and Physical Inventories allow selection of an open inventory. The Meter Readings import gives the option to ignore invalid meter readings. Yard Check and Parts Requisition imports have no options available.

When you click **Next**, the import is performed and a progress meter is displayed. When done, the Failed Imports is displayed with the reason the record failed. A failed record can be edited or deleted. To edit a record, double-click on the record.

**Correct the Failed Records** - When failed records have been corrected, click the Retry Import button. This runs the import program again on only the failed records. This process can be repeated until all failed records are imported. Click the **Finished** button to close the Data Import Wizard.

**Edit Failed Records at a later time** - Failed records do not have to be corrected as soon as the import finishes. The import wizard can be closed and when the import is selected again, instead of importing new records, the failed records will be displayed so that they can be edited.
Additional Considerations

Keep these points in mind:

• All exceptions are written to a file and are displayed on the Exception tab. A global and shop option called Do Not Create Exceptions for Invalid Meters (if checked) will not create exceptions for invalid meters. If the program finds an invalid meter, it will be uploaded and marked IGNORED.

• If the fuel inventory is insufficient to complete a fuel report for any shop, a warning message is issued. No records will be uploaded until there is a sufficient inventory to upload all fuel tickets.

• A user name is included in the Exceptions file, and by default, isolates exceptions to the users logged into TMT Fleet Maintenance/SQL. If you want to view all exceptions, ensure the Show All Users check box is checked under the Exceptions tab.

• If more than 15 meter readings are posted for the same unit’s meter on one day, all readings after the fifteenth are ignored.

• If a unit does not have any meters set up, any meter readings for that unit will be ignored.

• The action buttons (ASCII Import, Data Import, and Post) are enabled or disabled on each tab in direct relation to the task being performed. If a button is not available, ensure that none of the required setup steps were omitted.

• For parts requisition imports, the autocross feature is activated when importing from a Palm device. If a part number has multiple part matches, it is considered a failure so the correct part can be selected manually.

• If the SysMgr > Options > Repairs option Do not allow meters that exceed the Daily Max is checked, the import setting Ignore Invalid Meter Readings causes the meter readings to be imported and then marked as ignored.

Setting Up Data Imports

The Import Wizard Setup is used to set up imports that require specific information before they can be run. These include:

• Repair Invoices - for more information, see “Importing Repair Invoices” on page 351.

• Units - for more information, see “Importing Units” on page 354.

• Fuel Data - for more information, see “Importing Fuel Data” on page 355.

• Fuel Tickets - for more information, see “Importing Fuel Tickets” on page 359.

• Parts Inventories - for more information, see “Importing Parts Inventory” on page 360.

• Parts Requests - for more information, see “Importing Parts Requests” on page 363.

• Meter Readings - for more information, see “Importing Meter Readings” on page 366.

• Yard Check Data - for more information, see “Importing Yard Check Data” on page 368.
• FleetNet America - for more information, see “Importing FleetNet America Data” on page 371.

• Tire Audit (Budini) - for more information, see “Importing Budini Tire Audit Data” on page 374.

• VMRS Code - for more information, see “Importing VMRS Codes” on page 376.

Go to SysMgr > Import/Export > Import Wizard Setup.

Select the import type from the Available Imports pane on the left. The right-hand pane displays different parameters, depending on the type of import you selected.

NOTE: The import setup for FleetNet America is shown in the example. Each import type displays a different screen, but the method for setting up the various imports is the same.

Select a schema if one exists, or click New to set up a new schema.

Make changes to the schema as required and click Close.

Specific instructions for setting up an import type are included in the procedures that follow.

Using the Data Import Wizard - Overview

Go to Activities > Data Import > Data Import Wizard. The Data Import Wizard program enables you to import various kinds of data.
To import data, click on the type of data you want to import. Click on **Next**.

Subsequent screens are displayed if specific parameters are needed, or to indicate how many records failed the import criteria, how many unprocessed records will be imported, and the total number of records.

**NOTE:** Importing data can be a time-consuming process, depending on the amount of data to be imported. Run this process at times when TMT Fleet Maintenance/SQL is not being heavily used.

### Uploading Data from Handheld Devices

Data collected using a portable data terminal (PDT) or a Palm handheld device can be uploaded into TMT Fleet Maintenance/SQL using the Upload WinScan Data program.

This is a two-step process. First, the data must be uploaded to a buffer from the handheld device (a PDT or a Palm device). Then the buffered data must be imported into TMT Fleet Maintenance/SQL.
Go to Activities > Data Imports > Upload WinScan Data.

To set up this function, check the communications parameters on the COM Options tab to ensure that the com port settings are correct for your computer. The COM Debug tab enables you to set up log files and to indicate whether the log functions should be turned on or off.

Use the Close button to exit and save changes made to these screens.

To upload data:

1. Transmit the data from the device and load it into the buffer:

   **To load data from a PDT** - insert the PDT scanner in the base and select the Upload Data option on the PDT to transmit the data to the computer.

   **To load data from a Palm device** - put the Palm device in the HotSync cradle and perform a HotSync using the manufacturer’s instructions.

2. After the data is transmitted, click the Process Records button when you are ready to update the TMT Fleet Maintenance/SQL database with the uploaded data.
A data import that imports repair invoices updates PMs if the incoming component code is a valid PM for the unit and the Reason for Repair is PM.

If a VIN is provided, it is used to determine the Unit ID.

If an invoice is imported and the option to treat non-company units as company units is checked and the non-company Unit ID has a customer assigned to it, that Customer ID will be populated on the repair order created from the imported invoice.

A Defaults tab is provided that displays the elements Additive Type, Cause, Charge Unit of Measure, Complaint, Component Code, Correction, Delay Reason, Fee Charge Category, Position, Quantity Unit of Measure, Repair Reason, Shop ID, Tax Charge Category, and Vendor.

Each element can have a
- cross-reference - the incoming value is cross-referenced and replaced by a valid TMT Fleet Maintenance/SQL value in the New Value field.
- <DEFAULT> - if a value being imported is null, use the TMT Fleet Maintenance/SQL value in the New Value field.
- <OVERRIDE> - no matter what value is imported, replace it with the TMT Fleet Maintenance/SQL value in the New Value field; if an override is set, cross-reference and default values are not needed.

NOTES:
The file ReplInvXRefMaster.XML must be placed in the same directory as the ImportSetup.DLL (normally the TMT Fleet Maintenance directory) for the defaults to load properly.

If you have a repair invoice import previously set up, you must set up the import...
again using the new defaults when you upgrade TMT Fleet Maintenance/SQL. Before upgrading, take a print screen of your existing setup to aid in setting up the new import after the upgrade.

If a VIN is provided in the Order node of the XML file, it is used to determine the Unit ID.

Create a Repair Invoice Import

TMT Fleet Maintenance/SQL can import repair invoices from another TMT Fleet Maintenance system and creates repair orders for each invoice.

1. Go to SysMgr > Import/Export > Import Wizard Setup > Repair Invoice. The General tab is displayed.
2 In the Schema Name field, type a name for the schema. This name can be up to 24 characters long. Click OK. When running the import, the name is used to select which schema to run.

3 In the Import Source File field, type the directory path and name of the file to be imported, or use the Browse button to navigate to the directory and select the file. A drive letter is not required to enter a path.

4 If you want to use FTP to import the file, or to use the Task Scheduler to set up an automatic job in Windows, put a check in the Use FTP check box. Two additional tabs - FTP Configuration and Log and E-Mail are displayed.

5 In the Repair Order Type section, indicate whether you want to import standard or vendor repair orders.

6 In the Final Order Status section, you can import open, complete, or closed orders.

7 If Zero-Fill RO Number is selected, repair order numbers are left-padded with zeroes. This provides the ability to easily and correctly search invoices.

8 Apply incoming order data to the open orders using - This section determines how the incoming invoice data are treated. You can match either the RO number or the PO number.

   If the Matching RO Number check box is checked, the incoming order number is tested to match an existing RO number based on Unit ID, RO Number, Order Type, Shop ID, RO Type, and Status=OPEN. If there is an RO match, the sections and lines are added to the existing repair order. If the RO number match fails, a new repair order is created using the order number from the XML file as the RO number. The Matching PO Number check box can be checked only if the Repair Order Type in setup is Vendor. If it is checked, the incoming order number is tested to match an existing purchase order number based on Unit ID, PO Number, PO Type=Vendor RO, Shop ID, and Status=OPEN. If there is a PO match, the sections and lines are added to the purchase order and the associated vendor repair order. If the match fails, a new vendor RO PO and Vendor RO are created using the order number from the XML file for both the purchase order number and repair order number.

9 If Purge non-repair orders is checked, data that cannot be linked to a valid repair order is purged.
10 If Treat incoming non-company units as company units is checked, imported units that are not assigned to a company will be imported and no exception records are generated.

11 The option Do not allow meters that exceed Daily Max (in SysMgr > Options > Repairs) is used when importing meter readings and the option Ignore Invalid Meter Readings is checked for the import. If Do not allow meters that exceed Daily Max is checked and the import has Ignore Invalid Meter Readings checked, the meter readings are imported and marked as Ignored.

If the option Ignore Invalid Meter Readings for Trailers is checked and the incoming unit number is a trailer and the meter reading provided for the trailer is invalid, the meter is marked as ignored and does not create a failure. If it is not checked, meters are processed normally for trailers and invalid meters produce a failure.

NOTE: If the option Ignore Invalid Meters is checked, this option is ignored as all invalid meters are marked invalid regardless of unit type.

12 Click the Close button to save the schema.

Importing Units

TMT Fleet Maintenance/SQL can import unit master data. This feature enables you to import data from TMT Fleet Maintenance/400 or other software systems. You can import in either text or XML format.

1 Go to SysMgr > Import/Export > Import Wizard Setup > Unit Master.

2 Click New.

3 In the Schema Name field, type a name for the schema. This name can be up to 24 characters long. Click OK. When running the import, the name is used to select which schema to run.

This import has several tabs. On the General tab:

4 If Use FTP is checked, files are transferred using FTP.

5 In the Download Folder field, enter the name of the folder where the data file was downloaded.

6 In the Import File Name field, enter the name of the data import file.
If Log Execution is checked, a log file is created for the import, and the Log File Name field is enabled. Enter a log file name in the field. The same name is used each time an import is performed, so if you need to save log files, be aware that performing a new import will erase a previous log file and create a new log file with the same name.

In the Archive Path field, enter the folder name where the original import files are copied after the import is performed.

On the FTP Configuration tab:

If Use FTP was checked on the General tab, associated FTP file information is entered here.

On the Task Scheduler tab:

A data import requires that a task is configured in Windows Task Scheduler in order for it to process the import. The selected task application must be TMTFTP.EXE and cannot be in use by another import schema when the task is scheduled to be run. After a task is configured in Windows Task Manager, it becomes available in the Tasks grid and can be selected for this import.

On the Unit Defaults tab:

Enter any defaults you want to use for Unit Model, Unit Type, Division, Department, Make, Status, or Cost Center. All of these fields are optional.

If the option Default values replacing Incoming values is checked, all fields on this tab become required fields, and when the data is imported, the values on this tab are used to create the new unit in TMT Fleet Maintenance/SQL. If it is not checked, none of the fields are required on the setup and if a field has a value to default, it will be used; otherwise, the normal TMT Fleet Maintenance/SQL validation is applied to the field when the record is imported.

Click the Close button to save the schema.

NOTES:

If you are importing in XML format, check Allow Unit Insert when a unit in the XML file does not exist in TMT Fleet Maintenance/SQL; it will be added. If Allow Unit Update is checked when units in the XML file exist in TMT Fleet Maintenance/SQL, they are updated with data from the XML file. Only the units on the Defaults tab are updated.

A column for Allow Update is displayed in the Unit Defaults grid. If the option Allow Unit Update is checked and a default value has Allow Update checked, that field is updated on existing units.

If the option Default values replace incoming values is checked and a default value is specified for that field, that value overwrites any incoming value. If a default value is not specified for a field, the value in the XML file is used and validated. If the option Default values replace incoming values is not checked, if a default value is specified for a field, the value is used only if the XML file has no value for the field or if the field does not exist in the XML file.

Importing Fuel Data

TMT Fleet Maintenance/SQL can import fuel data from text files supplied by outside vendors. The Fuel Data Import interface contains a number of sample imports.

The option Do not allow meters that exceed Daily Max (in SysMgr > Options > Repairs) is used when importing meter readings and the option Ignore Invalid Meter Readings is checked for the import. If the Do not allow meters that exceed Daily Max is checked and the import has Ignore Invalid Meter Readings checked, the meter readings are imported and marked as ignored.
Import Considerations

Fuel data records to be imported must meet these specifications:

- Each valid record in the ASCII file must be of fixed length.
- Required fields must always be in the same position for each record.
- Only one fuel update record will be read from each ASCII record.
- Records to be uploaded must be either all road purchases or all company purchases.
- The last line in the file must have a character return. If you get a data corruption error, open the text file and press Enter at the end of the file and try again.

To import fuel ticket data, including data from Palm devices or PDTs:

1. Go to **Activities > Data Imports > Fuel Data Import**.

2. Select the import specification to import fuel tickets. (Your screens might be different from the examples.) There are several tabs for this screen:

<table>
<thead>
<tr>
<th>Tab</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specifications</td>
<td>Establishes the position and length of each field within the text file,</td>
</tr>
<tr>
<td></td>
<td>any hard-coded values to be used, any cross-references used, and the</td>
</tr>
<tr>
<td></td>
<td>path to the text file.</td>
</tr>
<tr>
<td>Cross-reference</td>
<td>Used to set up cross-references for the imported file. Cross-references</td>
</tr>
<tr>
<td></td>
<td>can be set up for Fuel Type, Vendor ID, Unit ID, and Site ID.</td>
</tr>
<tr>
<td>Unit Data</td>
<td>This tab is not currently used; it will be implemented in a later</td>
</tr>
<tr>
<td></td>
<td>version of TMT Fleet Maintenance/SQL.</td>
</tr>
<tr>
<td>ASCII</td>
<td>Displays the raw values imported from the ASCII file. Used to verify</td>
</tr>
<tr>
<td></td>
<td>that the settings on the Specifications tab are correct.</td>
</tr>
<tr>
<td>Tab</td>
<td>Purpose</td>
</tr>
<tr>
<td>-----------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| Translations | Displays the translated values of the data being imported. Any cross-references or hard-coded values have been applied to the data on this tab.  
**NOTE:** If the data has exceptions, they will appear on the Exceptions tab with the reason why the record was rejected. |
| Exceptions | Displays any records that were rejected and the reason why the record was an exception. Exception records can be corrected by double-clicking on the record in this screen. |

3 On the Specifications tab, complete the information about the data fields as appropriate. Each field displays the start position of the field in the fixed-width ASCII file; you must also specify a length for each field. You must enter this data very carefully.

4 You can also specify that some data is always treated the same way by using the Hard Coded section.

5 The File Name field contains the name of the import file. The complete path must be specified. Use the Locate button to the right of the field to navigate to a file and select it.

6 Check the Purge File Upon Completion check box if you want the records in the ASCII input file to be erased after a successful import. This ensures that the same file cannot be uploaded more than once.

7 If the Use Preprocess Application check box is checked, a program can be specified that is run before the import program. If it is checked, an input file name is required, but if the preprocess application does not require a file to be processed, the file name you specify does not have to exist.

**NOTE:** An import profile is already set up for ComData imports. This import uses a program called ComFuel.EXE as a preprocess to convert the ComData data file into a format that can be imported; it requires use of the Use Preprocess Application option.

8 Click the Import button.

9 The Batch Management screen is displayed.

10 You can select an import batch from the list in the grid on the right, or click New Batch. Click OK.

11 If the location of the data file to be imported is not known, the File Open dialog box is displayed.
12 Navigate to the location of the import file and select it, then click **Open**.

13 The fuel records are imported and posted.

14 If there is a problem with a record, it is displayed in the **Import Exceptions** grid with an explanation of the reason why the record could not be imported.

15 To correct exceptions, double-click on an exception record. The **Fuel Ticket** form is displayed.
In the example, the cursor shows the field that is incorrect - the Vendor ID is not a valid ID.

16 Make the necessary corrections and press F6 to post the record.

17 If there are records that should not be imported, highlight the record and click Delete. To delete all exceptions in the window, click Delete All. Exceptions are held in the database and will not be removed unless they are deleted or corrected.

**Importing Fuel Tickets**

Use this procedure to import fuel ticket data.

1 On the Palm device, select TMT Fuel Tickets.

2 The Fuel Tickets screen is displayed.

3 Enter a shop ID. Shop ID is validated.

4 Select a Ticket Type. Road is the default. If Road is checked, a vendor ID must be entered.
5 Use Primary Fuel Type is checked by default. If unchecked, the Fuel Type selection is displayed below the Vendor ID field. **NOTE:** You should NOT mix Primary fuel types with selected fuel types in an import. The Fuel Ticket import does not support this.

6 Click **Enter Fuel Tickets**. The *Fuel Ticket Details* screen is displayed.

7 Enter the Unit ID. This is a validated field.

8 Enter the meter reading.

9 Enter the amount of fuel in the Quantity field.

10 If the ticket is type ROAD, enter the cost of the total cost for the fuel. This is required for ROAD fuel tickets.

11 Click **Post**. This posts the values entered, validates the entered data, and then clears the screen for the next entry.

12 Repeat this process for additional entries. When you are done, click **Back**, then **Close**.

13 To prepare the data for TMT Fleet Maintenance to import, do a HotSync. This populates the FuelTicketRoad.TXT and FuelTicketCompany.txt files located in the directory specified in the SlimScan section of the Transman.INI file.

The Fuel Ticket import works through the Activities > Data Import > Fuel Data Import and is set up through SysMgr > Imports > Fuel Import Setup. The TMT Fleet Maintenance Help file has detailed setup instructions for the two setups needed (road and company). After they are set up, this import works like any other fuel import.

---

**Importing Parts Inventory**

Use this procedure to import parts inventory data.

**NOTE:** A .SCH (schema) file is not required when performing a hot sync from the Palm device. If a .SCH file exists, a .TXT file is created; if a .SCH file does not exist, the data is written to an XML file. The import wizard can handle either type of file.

1 On the Palm device, select **TMT Parts Inventory**.

2 The *Parts Inventory* screen is displayed.
3 Select the Shop ID. This field is validated.
4 Select the Bin ID. Click **Enter Parts**.
5 The **Enter Parts** screen is displayed.

![Image of the Enter Parts screen]

6 Scan in or enter the part ID.
7 Enter the quantity.
8 Click **Post** to post the part and clear the fields for entry of the next part.

**NOTE:** An error message is generated if a Part ID/Bin ID combination has already been imported from the file being imported. For example, if on the Palm two different counts were entered for the same part and bin, the second record will fail because data for that part and bin has already been imported. If the failure is not deleted and the import retried, the second record will be imported and overwrites any previous counts that were imported. This feature is intended to flag conflicting
data, not fix it, because the programs cannot understand which data is correct. If your parts inventory is disorganized, organize the inventory first, then try to upload the data.

9. Click **Back** to change the shop or bin ID.

10. Click **Close** to close the program when you are finished.

11. Perform a HotSync to prepare the parts for importing into TMT Fleet Maintenance. This updates the PartsInventory.TXT file located in the directory specified in the SlimScan section of the Transman.INI file. If the HotSync appears to be unsuccessful, right-click on the HotSync icon, select **View Log…** and view the detailed summary of the HotSync.

12. In TMT Fleet Maintenance, go to **Activities > Data Imports > Data Import Wizard**. Select Parts Inventory, Click **Next**.

   **NOTE:** Physical Inventory is used for the PDT parts inventory imports.

13. A screen is displayed that shows all open inventories. Select the appropriate inventory and click **Next**.

14. A status bar shows the progress of the import. When done, a list of failed records is displayed.
15 Check the reasons why the parts failed. You can edit data directly in the grid or delete records. When you are finished with corrections, click **Retry Import**.

**NOTE:** If you were importing for Shop 01 and had shop 01 and shop 02 on the same Palm device, you must reset the wizard and select Shop 02’s inventory to import those records.

16 Click **Show Successful Imports** to review imported parts records.

17 Click **Print Report** for a printed copy of the successful and unsuccessful records.

---

**Importing Parts Requests**

Use this procedure to import parts requests.

**NOTE:** A .SCH (schema) file is not required when performing a hot sync from the Palm device. If a .SCH file exists, a .TXT file is created; if a .SCH file does not exist, the data is written to an XML file. The import wizard can handle either type of file.

1 On the Palm device, select **TMT Parts Request**.
2 The **Parts Requisition** screen is displayed.
3 Enter the Shop ID. This field is validated.
4 If you have an RO number and section, enter or scan this information. Section is required if an RO number is entered.
5 Click Enter Parts.
6 A new Parts Requisition screen is displayed.

7 Enter or scan the part ID.
8 Enter the quantity.
9 Enter the Vendor ID if it is known.
10 Click Post. This posts the record and clears the screen for the next part to be entered.
11 Click Back to return to the main screen.
12 Click Close to exit the program when you are finished.
13 Perform a HotSync to prepare the parts for importing into TMT Fleet Maintenance. This updates the PartsRequisition.txt file located in the directory specified in the SlimScan section of the Transman.INI file. If the HotSync appears to be unsuccessful, right-click on the HotSync icon, select View Log… and view the detailed summary of the HotSync.

14 In TMT Fleet Maintenance/SQL, go to Activities > Data Imports > Data Import Wizard. Select Parts Requisition. Click Next.

![Image of TMT Data Import Wizard]

15 Click Next.

16 A status bar shows the progress of the import. When done, a list of failed records is displayed.

![Image of Failed Imports]

17 Check the reasons why the parts failed. You can edit data directly in the grid or delete records. When you are finished with corrections, click Retry Import.

18 Click Show Successful Imports to review imported parts records.
Importing Meter Readings

Use this procedure to import meter reading data.

**NOTE:** A .SCH (schema) file is not required when performing a hot sync from the Palm device. If a .SCH file exists, a .TXT file is created; if a .SCH file does not exist, the data is written to an XML file. The import wizard can handle either type of file.

**PeopleNet** - You can import meter readings from PeopleNet. Fields that can be imported include Odometer, Engine Time, and Gallons of Fuel. Each meter that is imported must be set up with a name, unit of measure, and whether it is a physical meter. The first time meters are imported, the new meters are created in SysMgr u Meters, Fluids, Pms Setup u Meter Setup and on the Meters tab of the Unit Master.

The interval to check PeopleNet's website for new meter readings can be set for 1 to 10 hours.

1. On the Palm device, select **TMT Unit Meter**.
2. The **Unit Meter Readings** screen is displayed.
3. Enter/TMw Suiteter the Unit ID. This field is validated.
4 Enter the Meter Reading.
5 Click **Post Reading**. This posts the record and clears the screen for the next part to be entered.
6 Click **Manage Readings** to list all the readings that have been entered. A reading can be edited or deleted.
7 Click **Close** to exit the program.
8 Perform a HotSync to prepare the readings for importing into TMT Fleet Maintenance. This updates the MeterReadings.txt file located in the directory specified in the SlimScan section of the Transman.INI file. If the HotSync appears to be unsuccessful, right-click on the HotSync icon, select **View Log…** and view the detailed summary of the HotSync.
9 In TMT Fleet Maintenance, go to **Activities**  **Data Imports**  **Data Import Wizard**. Select Meter Readings. Click **Next**.

10 Click **Next**.
11 You have the option to ignore invalid meter readings. If checked, invalid meter readings are imported and marked invalid; otherwise, they are marked as exceptions and can be corrected. Click **Next**.
12 Check the reasons why the parts failed. You can edit data directly in the grid or delete records. When you are finished with corrections, click **Retry Import**.

13 Click **Show Successful Imports** to review imported parts records.

14 Click **Print Report** for a printed copy of the successful and unsuccessful records.

---

**Importing Yard Check Data**

Use this procedure to import yard check data.

**NOTE:** A .SCH (schema) file is not required when performing a hot sync from the Palm device. If a .SCH file exists, a .TXT file is created; if a .SCH file does not exist, the data is written to an XML file. The import wizard can handle either type of file.

1 On the Palm device, select **TMT Yard Check**.
2 The **Yard Check Master** screen is displayed.
3 Enter the Shop ID. This field is validated.

4 Select a location code. Location codes must match the location codes set up in TMT Fleet Maintenance.

5 Click **Enter Yard Checks**. A data entry screen is displayed.

6 Enter the Unit ID. This field is validated.

7 Enter the meter reading.

8 Use Primary Meter is checked by default. If it is unchecked, the Meter Type field is displayed and a meter type can be selected.

9 Click **Post** to save the records and clear the screen for the next record.

10 Click **Back** to return to the main screen.

11 Click **Close** to exit the program.

12 Click **Find Record** to edit or delete records.

13 Perform a HotSync to prepare the readings for importing into TMT Fleet Maintenance. This updates the YardCheck.txt file located in the directory specified in the SlimScan section of the Transman.INI file. If the HotSync appears to be unsuccessful, right-click on the HotSync icon, select **View Log...** and view the detailed summary of the HotSync.

14 In TMT Fleet Maintenance/SQL, go to **Activities > Data Imports > Data Import Wizard**. Select Yard Check. Click **Next**.
15 Click **Next**.
16 Click **Next**.
17 Check the reasons why the parts failed. You can edit data directly in the grid or delete records. When you are finished with corrections, click **Retry Import**.

18 Click **Show Successful Imports** to review imported parts records.
FleetNet America provides road breakdown management services, primarily to the trucking industry, including mechanical services, tires, and towing, through a vendor network of more than 60,000 independent shops.

The FleetNet Data Import enables you to automatically import road breakdown information and create a vendor repair order. After the data is imported, it becomes part of the TMT Fleet Maintenance/SQL database.

**Import Considerations**

- Each unique breakdown number will create at least one Repair Order and one Purchase Order of type Vendor RO within the TMT Fleet Maintenance/SQL database.
- *Dates* are in the format of “Mmddyyyy hhmm” Unless otherwise noted.
- *VMRS codes* are in the format of ‘xxx-xxx-xxx’.
- Meter readings are posted using the Breakdown Date of the comment record as the date the reading was taken.
- Meter readings of units, such as trailers, with a primary meter of DAYS or MONTHS are ignored.

**Setting Up the FleetNet America Import**

In order to import FleetNet America data, you must establish at least one setup record. Additional setup records can be created as needed. The Schema Name, Shop ID, Import Source File, Complaint, Initial Vendor ID, Initial Component Code, and Tax Charge Category fields are required.

If there are different FleetNet America files for different shops, create a setup record for each shop, then select the correct shop’s import from the Data Import Wizard.

**Step 1 - Preliminary Setup**

Some preliminary setup must be done in TMT Fleet Maintenance/SQL. This preliminary setup must be done only once.

Ensure the data in the Masters records is correct by following these steps:

1. Create a new shop just for FleetNet America transactions. Go to Masters > Shops to set up the shop.
2. Create a vendor of VENDOR1 in the Vendors master. This will be the FleetNet America vendor. Go to Masters > Vendors to set up this vendor.
   
   **NOTE:** This vendor must have an ID of VENDOR1 because this is a hard-coded value sent from FleetNet.
3. Create a new component code for FleetNet. Go to Company Setup u System Setup u Codekeys. Insert a new code under ATA. This code can be anything, but we suggest that you make it FNA. This prevents the component code from conflicting with the standard ATA codes.

**Step 2 - Data Import Wizard Setup**

1. Go to SysMgr > Import/Export > Import Wizard Setup.
2. Click on FleetNet in the left pane.
3 Click on the **New** button to create a new schema for FleetNet.
4 In the **Schema Name** field, type a name for the schema. The name can be up to 24 characters long. When running the import, the name is used to select which schema to run.
5 In the **Shop ID** field, enter the shop ID that you set up for FleetNet.
6 In the **Import Source File** field, type the directory path and name of the file to be imported, or use the **Browse** button to navigate to the directory and select the file. A drive letter is not required to enter a path.
7 In the **Complaint** field, select a default complaint. This is only used to create a temporary section during the processing. The complaint can be changed on the repair order after it is created.
8 In the **Initial Vendor ID** field, enter a default vendor for FleetNet America. Imports are done for each vendor.
9 In the **Initial Component Code** field, enter the default component code created for FleetNet America. This code is used to create a temporary section during the data import. Repair orders that have not had any cost recorded from FleetNet will have a section created with this code.
10 In the **Repair Order Type** section, indicate whether you want to import standard or vendor repair orders.
11 In the **Final Order Status** section, you can import open, complete, or closed orders.
12 If **Zero-Fill RO Number** is selected, repair order numbers are left-padded with zeroes. This provides the ability to easily and correctly search invoices.
13 If **Update PM Schedules** is checked, PM schedules are updated after the audit information is processed.
14 In the **Tax Charge Category** field, select a tax category from the drop-down menu.
15 The option **Do not allow meters that exceed Daily Max** (in **SysMgr > Options > Repairs**) is used when importing meter readings and the option **Ignore Invalid Meter Readings** is checked for the import. If the **Do not allow meters that exceed Daily Max** is checked and the import has **Ignore Invalid Meter Readings** checked, the meter readings are imported and marked as Ignored.
16 Click the **Close** button to save the schema.
Step 3 - Importing Data

1. Go to Activities > Data Imports > Data Import Wizard.
2. Select FleetNet America from the list of available import types and click Next.
3. Select the name of the schema (created in Step 2 above) and click Next.
4. The import will run. Any failures are identified in the Show Failed Imports grid with the reason why the record failed. All of the successful records that were imported are displayed when you click on Show Successful Imports.

Step 4 - Correcting Failures

1. When the Fleetnet import is run for the first time, there will be failures where the repair orders cannot be found. This is because the repair order headers were in a previous file sent by FleetNet. Those exception records must be deleted because the repair orders will not be created.
2 For all other exceptions, double-click on the record and the Exception Edit screen is displayed. Using the exception reason as a guide, correct the data and click on OK on the Exception Edit screen to save the change.

3 After all exceptions are processed (and either deleted or corrected), click Retry Import.

4 Repeat the actions described in this step to correct any remaining failures.

Importing Budini Tire Audit Data

To import Tire Audit data, you must have purchased the Budini Tire Audit program.

Import Considerations

In order to import Budini Tire Audit data, you must establish at least one setup record. Additional setup records can be created as needed. The Schema Name, Import File, Description, Shop ID, Component Code, Priority, Complaint, and Repair Reason fields are required.

If there are different Budini Tire Audit files for different shops, create a setup record for each shop, then select the correct shop’s import from the Data Import Wizard.

Step 1 – Preliminary Setup

1 Go to SysMgr > Import/Export > Import Wizard Setup.

2 Click Import Tire Audit on the list of available imports.

3 Click New to create a new schema for Tire Audit. The fields on the bottom section of the screen become enabled.

4 In the Import Name field, type a name for the schema. This name can be up to 24 characters long. Click OK. When running the import, the name is used to select which schema to run.

5 Provide a name for the new schema.
6 In the Import File field, type the directory path and name of the file to be imported, or use the Browse button to navigate to the directory and select the file. A drive letter is not required to enter a path.

7 In the Shop ID field, select the repair shop ID to be used to create the repair orders.

8 In the Component Code field, select the tire component code that will be used when creating the repair orders. All cost will be associated with the selected component code.

9 In the Priority field, select the priority level for the tire repair. The default value is 5.

10 In the Complaint field, select a default complaint. This complaint will be used for all repair sections created from the Tire Audit data.

11 In the Repair Reason field, select a default repair reason. This repair reason will be used for all repair sections created from the Tire Audit data.

12 The option Do not allow meters that exceed Daily Max (in SysMgr > Options > Repairs) is used when importing meter readings and the option Ignore Invalid Meter Readings is checked for the import. If the Do not allow meters that exceed Daily Max is checked and the import has Ignore Invalid Meter Readings checked, the meter readings are imported and marked as Ignored.

13 Click the Close button to save the schema.

**Step 2– Importing Data**

1 Go to Activities > Data Imports > Data Import Wizard.

2 Select Tire Audit from the list of available Import Types and click Next.

3 Select the name of the schema created in Step 1 and click Next.

4 The import will run. Any failures will be identified in the Show Failed Imports grid with the reason the record failed. All the successful records imported will be displayed when Show Successful Imports is clicked.

**Step 3 – Correcting Failures**

1 If an imported record is completely invalid and cannot be corrected, delete the record by selecting the record and clicking the – button. The record will be deleted.

2 For all other exceptions, double-click on the record and the Exception Edit screen is displayed. Using the exception reason as a guide, correct the data, and click OK on the Exception Edit screen to save the change.

3 After all exceptions have been processed (deleted or corrected), click the Retry Import button.
Repeat the actions described in this step to correct any remaining failures.

Importing VMRS Codes

The VMRS code import is a way to update the component code and description of parts in the Parts Catalog and Shop inventory.

Import Considerations

- The file to be imported must be of fixed length.
- The file must contain the Part ID, VMRS code, and Description.

Step 1 - Set Up the VMRS Text File

Because the data is imported from a fixed-length text file, you must use the Import Table Layout tab to specify the start position and length for each field. The starting position starts at 0 (not 1), so adjust start positions accordingly. When the data has been entered, click Post to save the changes.

To import VMRS Code data, you must have a flat ASCII text file with the following fields: Part ID, VMRS Code, and Part Description. A comma-separated file will not work with this import.

Step 2 – Tire Audit Data Import Setup

1. Go to SysMgr > Import/Export > Import Wizard Setup.
2. Select VMRS Code from the list of available imports.

3. Click New to create a new schema. The screen is reset with empty fields.
4. In the Import Name field, type a name for the schema. This name can be up to 24 characters long. Click OK. When running the import, this name is used to select which schema to run.
5 In the Import File field, select the file to be imported using the Browse button.
6 On the Import Table Layout tab, enter the starting position and length for the Part ID field, the VMRS Code field, and the Part Description field. (Remember, the very first start position in the file is 0, not 1.)
7 Click Post to save the schema.
8 Click Test Schema to test the import. The data from the file is displayed on the Import Table Data tab as it is imported. To make changes, return to the Import Table Layout, correct position and size, click Post, and retry the test.

Step 3 – Importing Data
1 Go to Activities > Data Imports > Data Import Wizard.
2 Select VMRS Code from the list of available Import Types and click Next.
3 Select the name of the schema created in Step 2 and click Next.
4 The import will run. If the part id exists, the part is updated with the new component code and description.

Exporting Data to Other Systems

TMT Fleet Maintenance/SQL’s Export Data feature can export many different kinds of data that can then be imported into various other programs. Types of data that can currently be exported include information about:

- ALK Batchpro exports for trips, fuel purchase, fuel tickets, and units
- Orders and fuel tickets
- Trip tickets, including ticket segments
- Units Master
- Vendors Master
- Employee Time Cards
- Meter readings
- LTD meter values
- PMs due
• Parts Catalog
• Parts requisition lists
• Tire Audit Meter values
• Customer Invoices
• Customer Master
• Estimates created in Shop Planner
• Closed warranty claims
• Closed repair orders.

**NOTE:** You can also export accounting transaction data. This function is described in “Using the Export Transaction Function” on page 195.

TMT Fleet Maintenance/SQL provides the ability to export customer master records to a text file. This can be useful for activities such as creating mailing lists.

You can also export XML data. The format of the XML file is generic and can be adapted for different schema. When a report generates the XML, it creates a `<METADATA>` section with a list of `<FIELDS>` that corresponds to the grid columns on the Tables tab of an export form. A list of `<ROW>` tags are generated that correspond to the rows of the grid in the Tables tab.

A schema must be created before an XML export can be used.

Customer invoices, repair orders, and unit exports now use a schema system. This provides two features:

• Multiple exports can be created for the same export type. For example, you can create an export for each customer in the Customer Invoice export, or you can create an export for each Shop ID in the Repair Order export. This feature is especially useful if you have a large amount of data and need to refine the output results or obtain only specific data to be exported. Before attempting multiple exports, a schema must be created. See “Exporting Data to Other Systems” on page 377 for more information about creating a schema.

• The data export program enables exporting to an FTP address and scheduling that export. On the FTP tab, if Use FTP is checked, you must enter FTP information and assign a scheduled task on the Scheduling tab. Before exporting to an FTP address, a schema must be created. See “Exporting Data to Other Systems” on page 377 for more information about creating a schema.

---

**Exporting Data**

Go to Activities > Data Export.

**NOTES:**

*If your database contains a large amount of un-exported data, it can take several seconds to display the Export Data screen.*

*The list of export types displayed in your company’s list might vary from the screen examples shown. Some export types require the purchase of a module license before a specific type of export can be done.*
From the list in the Export Type pane on the left, select the type of data you want to export. TMT Fleet Maintenance/SQL populates the Tables tab on the bottom section of the screen using the criteria that was saved from the last time the data export function was used (or with the defaults if the function has not been used previously). If you update any of the selection criteria, the information in the bottom pane changes to reflect the selections.

Each type of data export is explained in the next section.

Options that are not available for a specific type of export are greyed and cannot be selected or changed.

• In the Export Filename field, type (or select by using the Browse button) a filename for the exported data file.

• In the Retrieve field, choose the type of data you want to export: non-exported data only, previously exported data only, or both non-exported and previously exported data.

• In the Dates fields, you can select a date range to reduce the number of records being exported, or leave the date fields blank to export all data.

The Tables tab is open by default. It displays a preview of each field that will be exported. The data is displayed in a columnar format for easier viewing; this is not how the data will actually be exported.
The Record Is Exported is a right-click option available on this grid. If an exported record is selected, a check mark is displayed beside the menu option. Non-exported records do not have check marks. Click the option to flip the status.

The Print function is also available by right-clicking on this grid and selecting Print Grid. Click this option to display a detailed Print Preview screen that enables you to change some of the printing parameters.

Click on the Export Options tab to specify how the data will actually be exported. You can select fixed-width or delimited text files. The number of decimal places to be used in a numeric field can also be specified; however, this affects ALL numeric fields. The fields that will be exported are detailed in the Export Layout section.

Click on the Preview Export tab to display the data as it will appear when it is exported to a file. By reviewing the data, you can determine if the way the data will be exported is correct for the file that needs to be created.

Some data export types can export the data in XML files. Other export types use a specific schema system that treats a data export type in a specific way depending on how it is defined.
Exporting as XML

Many types of data export include an export type of XML. These export types include: ALK - Company Fuel Purchases, ALK - Road Fuel Purchases, ALK - Units, Customers, Employee Time Card, LTD Meter Values, Meter Readings, Orders - Fuel Tickets, PM Due, Parts Catalog, Parts Requisition List, Trip Ticket Segments, Trip Segments, Unit Master, and Vendor Master.

What is XML?

XML (Extensible Markup Language) was developed by the World Wide Web Consortium as a standard for describing languages which describe the structure of data. Unlike HTML, which has a fixed set of elements, XML allows individuals to create tags to describe their own content. An XML document is made up of storage units called entities, which contain tagged data.

Tags are represented much the same way as HTML tags: for example, <name> or <address>.

Because XML is flexible, two authors can use different tags to describe the same data.

<name>John Doe</name>
<first_name>John</first_name><last_name>Doe</last_name>

While both tags contain the same data, they must be parsed (processed to extract data) and the program receiving the incoming data must be aware that two different tags were used.

For the TravelCenters interface program, the tags have already been developed by TravelCenters of America and are mapped into TMT Fleet Maintenance/SQL by the interface program. When using the interface, although it is helpful to understand how XML works, you do not need to have an in-depth understanding of it.

How Data is Exported

The format of an XML file is very generic. When the export program generates the XML, it simply creates a <METADATA> section with a list of <FIELDS> that match the grid columns of the Tables tab of the Data Export form. The program then
generates a list of <ROW> tags that correspond to the rows of the grid on the Tables tab of the form.

Sample

A sample export for a single unit looks like this:

```xml
<?XML VERSION="1.0" STANDALONE="YES" ?>
<DATAPACKET Version="2.0">
  <METADATA>
    <FIELDS>
      <FIELD attrname="DESCRIP" fieldtype="string" WIDTH="12" /> 
      <FIELD attrname="FLEETID" fieldtype="4" /> 
      (all other fields are listed here)
    </FIELDS>
    <PARAMS/>
  </METADATA>
  <ROWDATA>
    <ROW UNITID="1001" DESCRIP="GG Cargo Trailer" FLEETID="3"
DOMICILE="01" COSTCDCODE="1-2-01-1" DEPTCODE="DISTRIBUTION"
    (all other fields with values are listed here) />
  </ROWDATA>
</DATAPACKET>
```

Exporting Using a Schema System

Some data exports use a schema system that defines how the data is exported these export types include: Customer Invoices, Repair Orders, and Units.

Using a schema system allows:

- Multiple exports can be created for the same export type. For example, you can create an export for each customer in the Customer Invoice export, or you can create an export for each Shop ID in the Repair Order export.

- You can export to an FTP address and schedule the export. On the FTP tab, if Use FTP is checked, you must enter the FTP information and assign a scheduled task on the Scheduling tab.

**NOTE:** A schema must be created before these exports can be used.
Index

Numerics
9-digit VMRS code 53
A
about command 15
about this book 1
Account Type 48
account type 98, 143
accounting 90
determine accounting year 284
export
creating disbursement details 294
creating sub-accounts 292
creating transaction subrule 295
exporting data 297
how to set up 292
exporting data from TMT Fleet Maintenance 283 integration 286
method
AVGCOST 43
FIFO 43
LIFO 43
setup 282
accounts command 13
accounts payable 283
accounts receivable 283
Acct (Accounting) Method 43
Activities menu
commands
bar code labels 11
meter readings 11
reports 11
activities reports 265
add
additional units to TMT Fleet Maintenance 54 item to TMT Fleet Maintenance menu 26
NATC Locator vendor to TMT Fleet Maintenance/SQL 134
new section to repair order 188
parts to local inventory 149
RO template section 188
Add Current Part to Local Inventory 150
adding images to forms 21
Adding User-Defined Fields 168
adding vendor parts 221
additive type 74
adjust single inventory item count 209
advanced features 277
aftermarket parts warranty tracking function 70
aftermarket potential warranty claim report 266
ALERTS. See E-management reporting
All Labor Lines via TINA Only 105
Allow Charging of Parts from Mechanic Workstation 115
Allow closing of Repair Orders 105
Allow Employee Assignment without a Job Code 39
Allow for adding items to Requisition List 36, 93
Allow Future Dates 53, 329
Allow Items to be moved to Pending orders 106
Allow Job Pause 105
Allow Local Parts 44
Allow Mechanic to go Remote 114
Allow Override of system generated Number 52
Allow Overriding of Estimated Times 105
Allow Parts Requests 105
Allow Parts Transfers from Part Requisition 44
Allow Parts Transfers from Parts Requisitions 213
Allow Paygrade selection 40, 96
Allow Paygrade Selection in TINA 104
Allow RO creation from within TINA 104
Allow Section creation within TINA 104
Allow Vendor LInes within TINA 105
AP (accounts payable) 283
Apply incoming order data to the open orders using 353
apply payment to invoice 319
AR (accounts receivable) 283
Archive Path 355
arrange all command 15
assembly level codes 67
assigning units to customers 160
assignments
  inspection ticket 279
  parts 170
asterisk, using 116
ATA codekey type 62
Auto Create Job Codes Based on Fleet ID 39, 95
Auto Create Shop Plans 103
Auto Cross VIN to Unit ID 51
Auto default Job Code (Component Complaint) 39, 95
auto fleet definitions 66
Auto selection of weekend paygrade 40, 96
Auto zero-fill numbers 52
auto-complete 19
Auto-Create Sections 182
AUTOCROSS 142, 147, 222
Automatic Exception Level Reporting. See E-management reporting
automatic requisitions 212
Available on Handheld 67
average cost 43
AVGCOST 43
B
Background 59
Backgroundtype 59
backorders 215, 226
Bar Code 50
Bar Code Printer 50 bar-code
  label 226
    command 11
    printing 307
  RO number 35
base transactionr rule
  create new 294
batch management command 10
batch mode 182
  for invoices 312
bid price 221
Billable Repair Order Sections 92
billable repair order sections 35
billable sections required for invoicing 309
bin
  ID 154
    inventory 153
blank comments 192
blank part
  ID 142
BLOB SIZE parameter 21
BMP image 22
Buffer Time 103
burdened labor rate 35, 81
button
  Edit 135
    Import 135
C
calendar 343
campaign 331
  add new 331
cancel 336
cancel section 337
edit 335
pending ROs 336
status 336
view history 337
view sections 336
work pending 183
Can Not Override Bid Price 42
cancel button 19
cancel campaign section 337
cancel changes command 8
cancelling campaigns 336
capacity field 67
cascade command 15
cause 67
cause codes 69
change vendor on repair order 179
changing driver name 108
charge category 205
charge date 205
chart of accounts 283
check box 19
Check for Open ROs when creating New RO 92
Check for open ROs when creating new RO 35
check lists for diagnostics 171
checklist box 18
Chronic Repair Interval (Days) 37
Chronic Repair Order Interval 93
chronic repairs 183
claims price table command 13
clear all 225
clone units 115
close
    inventory 208
    purchase order 226
    repair order 180
    repair order on post 182
    trip tickets 245
close all command 15
Close Order on Post 182
close repair order 180
closed
    invoice
        reopening 317
    repair orders 254
warranty claims 378
code
 inactive 49
code description 86
codekeys 86
 CASH 63
 CHECK 63
 company division 63
 CREDIT CARD 63
 designing 62
 Great Plains 63
 inter-company account 63
 license type 127
 reason for repair 63
 reports 267
 printing 63
 setup 62
 user-defined 63
 combo box 19
 COMCHECK 63
 ComCheck 186
 ComData 186, 357
 command button 19
 comment 192
 company
 address 65
 currency 65
 definition 65
 e-mail 65
 fax 65
 fuel purchase data export 377
 phone 65
 setup command 12
 complaint 67, 188
 complaint code 68
 default 38
 complaint, cause, and correction codes 67
 component 188
 code 72, 76, 143, 254
 component level codes 67
 search 120
 specifications 76, 255
 component code
 markup 309
 parts catalog 142
 roll-up 309
component codes
  system and assembly level markups 309
compute fuel tax 242
configure commands 8
confirm dialog cancel 51, 56
contents command 15
conversion factor 64
convert units of measurement 64
copy command 8
copyright information 1
cores, shop inventory 154
correction 67
correction codes 69
cost
  basis 310
costs
  shop inventory 157
count sheet sample 209
counts tab for inventory 207
create
  purchase orders 219
  vendor on the fly 41
Create Invoice from RO 162
create new base transaction rule 294
Create plans when plan w/o RO Exists for a Single Unit 104
Create Unit Cross Reference for Catalog Parts 36
credit
  invoice 319
  limit 163
    customer 164
    on invoice 164
  memo 188
currency 131, 156
  default 52
custom
  invoice 165, 275, 319
  purchase order 42
customer
  active 167
  assigning units to 160
  credit limit 164
deleting 159
  ID 115
  inactive 159
    active customer 167
invoice
data export 378
invoice limit 164
master 159
data export 378
options
invoicing 162
reports 250
tax 166
Customer Inquiry screen
images 316
Customer Options - Printing 164
customer support phone number 1
Customer Taxes 168
customize display for repair orders 180
cut command 8
D
data
importing and exporting 345
uploading from handheld device 349
data export 377
ALK batchpro 381
trip 377
ALK Batchpro company fuel purchase 377
closed repair orders 378
closed warranty claims 378
customer 381
customer invoice 378, 382
customer master 378
employee time card 377, 381
fuel tickets 381
how data is exported 381
LTD meter value 377, 381
meter reading 381
meter readings 377
orders 381
orders and fuel tickets 377
parts
requisition list 378
parts catalog 378, 381
parts requisition list 381
PM due 377, 381
print 380
repair order 382
road fuel purchase 377
sample XML 382
schema system 382
setup 379
shop planner estimates 378
time cards 377
tire audit meter values 378
trip segment 381
trip ticket 377
trip ticket segment 377, 381
unit 377, 382
unit master 377, 381
vendor 381
vendor master 377
XML 381
data import 345
exceptions 347
final order status 353
FleetNet 371
from Palm device
  fuel tickets 359
  meter readings 366
  parts inventory 360
  parts requests 363
  yard check 368
fuel data 355
  from Palm device 356
fuel inventory 347
meter
  considerations 347
  PeopleNet 366
  reading limitation 347
parts requisition considerations 347
repair invoice import considerations 351
repair order type 353
setup 347, 348
unit
  FTP Configuration tab 355
  General tab 354
  Task Scheduler tab 355
  Unit Defaults tab 355
unit considerations 347
uploading from Palm device 349
using the wizard 349
Database Login 2
date and search edit 19
days meter 73
default
  complaint code 38
currency 52
reason for repair code 38
repair class 36
repair site 37
shop 52, 57
Default Repair Class 36
Default Repair Site 37
Default Shop 57
define
  jobcodes 81
  task assignments 81
  tasks 81
definition, parts catalog 142
delete
  section 187, 188
  trip tickets 246
  vendor parts 221
delete record command 8
dependent PM 121
  detection percent 38
designing codekeys 62
destination shop ID 230
detail report 180
detailed print 200
diagnostics
  definitions 171
  report 267
  setup 67
direct sale invoice 318
Disable Ignore for Meter Readings 36
disable period close 297
Disallow Purchase Order Access 106
display
  toolbar panels 25
  trip tickets 242
Do Not allow Duplicate Invoice Number by Vendor 41
Do not allow meters that exceed the Daily Max 36, 347
Do not create exceptions for invalid meters 53
Don’t Allow Vendor Parts on POs 41
DOT stickers 126
Download Data Files for Palm 58
Download Folder 354
driver
  DOT audit restrictions 108
  name fields disabled 108
Driver ID 114
E
E-Commerce/E-Mail Adapter 136
edit
  pay grade 80
  section 188
  trip tickets 244
edit box 18
Edit button 135
Edit menu 8
Edit menu commands
  cancel changes 8
  configure 8
  copy 8
  cut 8
  delete records 8
  edit records 8
  insert records 8
  paste 8
  post changes 8
  search 8
  show status bar 8
  show toolbar 8
edit record command 8
effective date 86
e-mail
  client (MAPI) 51, 56
  interface 56
    type 51
  user name (MAPI) 52, 56
E-management reporting 340
employee
  command 9
  master 109
  reports 250
  time cards
    data export 377
    tools 278
Employee and Jobcode Assignments 39, 95
Enable Accounting Features 48
Enable AutoComplete 56
Enable Inter-company Account Assignments 48
Enable Warranty Processing 92
Enable warranty processing 36
ending date 88
Enforce Credit Limits 163
Enforce Invoice Estimate 45
Enforce Shift Times 103
engine field 67
Enter key as Tab key 56
entering a fuel ticket 233
entering items into inventory 206
EPurchChkFld 136
error messages, sound 56
errors on fuel tickets 233
estimated time 45
Exclude sales tax in orders/inventory 43
existing system, period close 274
exit TMT Fleet Maintenance 7
Expendable Item 144
Expense supplies to indirect charges 41
expenses 88
export accounting data 283
   using AccountingExport 299
   using TMT Fleet Maintenance 297
exporting data 345, 377
Extended ASCII support for barcode printing 50
extended warranty 121, 122
F
fax
   purchase order 226
fees, miscellaneous 311
field
   ShopID 84
   user defined 60
   verification for non-company units 177
FIFO (first in first out) 43
File menu 7
File menu commands
   exit 7
   load saved report 7
   mail 7
   print 7
   print preview 7
   print setup 7
first in, first out (FIFO) 43
first physical inventory process 269
fixed cost 173
   history 175
flat markup 310
flat rate 45
FleetNet
   import data 371
fluid
  groups 75
  setup 74
form definition 16
forms 16
fuel
  data
    importing 355
  meters 73
  permits 126
  system 231
  tax computation 242
  type 232
fuel ticket 87, 118, 232
  command 10
  correcting errors 233
  data export 377
  entry 233
  order form 233
  status 232
  system 231
  with Palm device 359
Fuel tickets require trip tickets 52
G
general ledger 283
generate
  command 88
  invoice 313
  purchase order from requisition list 213
  warranty claims 327
GL (general ledger) 283
Great Plains
  codekeys 63
grid controls 16
grid definition 16
group assignments 86
grouping feature on menu 17
H
handheld device 349
help button 19
Help menu 15
Help menu commands
  about 15
  contents 15
  how to use help 15
  search for help on 15
TMT home page 15
HelpFile, LangFile, DLIFILE 59
history
  fixed cost 175
hourly rate 80
how to
  delete a section on a repair order 187
  fax purchase orders 226
  use help command 15

I
Ignore Inactive Disbursement Rules 48
Ignore Invalid Meter Readings 36, 347
images 316
  add 21
import
  part catalog information 142
  unit data 354
  VMRS codes 376
Import button 135
import data 345, 348
  FleetNet 371
  fuel 355
Import File Name 354
import FleetNet data 371
Import Source File 353
In Service 123
inactive
  customer 159, 167
  shop 84
  vendor 140
Inactive Codes 49
include
  no-charge parts on invoices 313
  sales tax in inventory cost 43
  sales tax in orders only 43
Include parts with zero quantity on hand 264
independent PM 121
  detection percent 38
indicator lights, warranty 193
indirect
  charge 87, 204
    code 205
    command 10
    order query 204
labor
  include or exclude on reports 251
order entry 205
order number 205
INI file 58
initial inventory count 210
insert
  new bin 154
  record command 8
  repair order after post 182
Insert Assignments After Post 182
Insert Assignments After Section Post 182
Insert Order After Post 182
inspection ticket 279
  assignments 279
integration of accounting features 286
interface options 56
invalid meter 347
Inven menu 11
Inven menu commands
  part fee/tax assignments 11
  physical inventory 11
  reports 11
  requisition lists 11
inventory 43, 98
  automatic requisitions 212
  bin 153
  closing 208
  first count process 210
  how to enter items 206
  how to relieve items 206
  manual requisitions 212
  method 143, 152
  parts request form 211
  prices 312
  report 262
  requisition list 211
  shop 277
  tool 277
  track 277
invoice 87
  batch mode 312
  billable sections only 309
  closed 317
  create from closed/complete RO 179
  credit 319
  credit limit 164
  custom 165, 275, 319
Index:

direct sale 318
generating 313
images 316
limit 163
customer 164
messages 312
parts with no charge 313
payments 319
price table 310
printing 322
printing job codes 45
reopen
closed invoice 317
repair 352
show purchase orders 314
status 314
update amount paid on RO 180
invoicing module
setup 309
using 309
item max column 153
J
jobcode
define 81
printing on invoice 45
reports 251
K
kits
contents 154
shop inventory 154
L
labor 45
charge 205
define cost basis 310
estimated time 45
flat rate 45
line 191
standard repair time (SRT) 45
Labor Entry via Start/End Times 92
Labor entry via start/end times 36
Labor Time Options 163, 164
Make Minimum Labor Line a Separate Line 46
Sum Labor by Paygrade Type 46
Sum Labor for Invoice by Job Code 45
LanguageDLL 114
Large Text 50
last in, first out (LIFO) 43
Leading/Trailing 50
License 54
license type 127
Life to Date 257
LIFO (last in first out) 43
line item, viewing 189
link NATC Locator vendor to TMT Fleet Maintenance vendor 134 list box 18
load saved report command 7
local parts 44
Locator button 132
Log Execution 355
Log File Name 355
lookup VMRS codes for new parts 44, 142
LTD meter value data export 377
M
mail command 7
main system menu
overview 22
Make Minimum Labor Line a Separate Line 46, 164
Make, verify 177
Manager ID 114
manual requisitions 212
manufacturer’s part information 152
MAPI e-mail Client 51, 56
MAPI e-mail user name 52, 56
mark all 225
marking up component code 309
master
employee 109
file setup 83
record data entry 33
Masters menu 9
Masters menu commands
employees 9
reports 9
shop inventory 9
shops 9
units 9
vendors 9
Masters reports 249
Max number of rows returned 51
Max RO Component Level 37, 93
Maximized Windows 51, 56
Maximum Allowable Shift Time 103
McLeod Interface 48, 63
Mechanic Workstation 53
Mechanic Workstation tasks 81
Medium Text 50
memo box 18
meter
greater meter value 72
LTD value data export 377
meter groups 72
meter readings 201
    command 11
meter setup 72
meter type 72, 117
older Down Date 72
on fuel ticket 72
on repair order 72
PeopleNet 366
reading
data export 377
data printing 187
    ignoring when importing 347
readings
decimal points 201
replacement meter 72
replacing meters 72
scheduling intervals 121
UnitID disabled 202
meter setup 117
meters, fluids, PMs
    setup 71
    setup command 12
Min Labor Line Description 46
Misc tab 52
miscellaneous fees 311
Model
    verify 177
Module License Code 55
Move Call History Log to RO Comments 53
multiple payment methods 322
N
NATC
    updating 135
new
    comment line 192
    labor line 191
    part line 190
pay grade 80
service line 192 non-company unit
verification 177
O
OEM warranty 122
OEM/extended potential warranty claim report 266
OK button 19
On-hand based Re-Order Formula 97
on-hand based re-order formula 41, 211
online mode 182
Only Allow Access to RO Assigned to Employee 105
open
date 188
new trip ticket 243
repair orders 254
options 34, 91
allow parts transfers from parts requisitions 213
command 13
inactive code 49
misc 52
print grid 380
record is exported 380
shop 91
warranty status 327
order inquiry
customize results display 261
reports 259
order number 205
orders 87
data export 377
reports 259
Orders menu 10
Orders menu commands
batch management 10
fuel tickets 10
indirect charges 10
purchase orders 10
repair orders 10
reports 10
trip tickets 10
out of balance parts 213
Override Taxes and Fees for this Invoice 319
P
Palm device 349
Palm programs
fuel tickets 359
meter readings 366
parts inventory 360
parts request 363
yard check 368
part
  line 190
  requisition
    automatic 213
    manual 213
part catalog
  importing parts 142
  shops 149
part catalog master
  shops 149
part fee/tax assignment command 11
part ID 142
part user-defined fields 283
partial shipment 225
parts
  add
    vendor parts 221
  charging shop inventory on repair order 191 cross-reference 147
  fee 172
  importing 142
  in kits 154
inventory
  insert new bin 154
  method 152
  reports 262, 263
invoice price field 316
link price to specific vendor 221
manufacturers part information 152
out of balance 44, 213
parts classification 152
pick list 170
  setup 67
price 315
prices 221
renumber 145
request form 211
stock level 152
substitute 148
superceded 145, 148
transfer 87, 213, 228
transfer from requisition list 230

type 147

updating vendor price 221

usage report 262, 263

vendor 221

vendor price update 221

warranties 144

parts catalog

advanced search 145

bid price 221

changing vendor bid information 221

classification 143, 152

component code 142

cross-reference 145

data export 378

definition 142

kit definition 147

master 141

  definition 142

  kit definition 147

  parts catalog vendors 148

  parts cross-reference 147

report 252

searching 145

evendors 148

Parts Catalog Vendor Sync Options - Update Price 44

Parts Catalog Vendor Sync Options - Update Primary Vendor 43

Parts Catalog Vendor Sync Options - Update Target Point 43

Parts Catalog Vendor Sync Options - Update Vendor 43

Parts on Pending Orders Report 265

parts requisition list data export 378

passwords 2

paste command 8

pay grade 79

  assign to shop 80

  command 13

  create new 80

  edit 80

  hourly rate 80

  shop rate 81

pay grades

  burdened labor rate 81

payment

  invoice 319

  methods

    multiple 322

Index:
printing 330
types 63
PDF image 22
PDT 349
pending repair order
  on campaigns 336
pending repair orders 254
PeopleNet 366
period close
  disabling 297
  first period close 269
  on existing system 274
  preparing for 269
  procedure 269
  process 285
  reports 268
physical inventory
  command 11
  process 206
  reports 262, 265
physical meters 72, 73, 118
pick order
  0 153
  column 153
PM
  due 255
    data export 377
    setup 75
PM Sections 94
PO required for vendor lines on ROs 36
position 143
  codes 67, 70
post changes command 8
prefix numbering 87
  using starting constants 87
preparing TMT Fleet Maintenance 29
preventative maintenance 255
  setup 71
price 156
  0.00 313
  fuel 315
  invoice 316
  table 310
    unit 310
primary
  bin location 153
fluid 118
vendor 148, 157
print
command 7
jobcode on invoice 45
preview 7
purchase order 227
setup 7
vendor RO 185
work card 183, 282
Print bar-coded receiving labels 40
Print bar-coded RO number 92
Print Custom Direct Sale Invoice 46
Print Custom Invoice Report 46
Print Custom Purchase Order Report 42
Print Grid option 380
Print pending tags upon item request 106
Print PO 157
Print Purchase Receipt 216
Print Receipt 216
Print Receiving Document on Closed or Received Status 185
Print RO Detail Report on Close 183
print section detail 188
print section work card 188
Print Shop Name in place of Company Name on POs and Invoices 46, 50
Print TimeCards at logout 104
print warranty claim payment 330
Print warranty part tags 103
Print Work Card 183
printing 57
bar-coded labels 50, 307
codekeys reports 63
invoices 322
meter reading data 187
multiple repair orders 322
RO detail report 183
work card 183
procedure for period close 269
processing warranty claims 324
Prompt for batch... 53
Prompt for Creating of Vendor Parts Records 36, 93
Prompt for GL Accounts on PO Lines 49
Prompt for PO Close at time of PO Receipt 41
Publish to Customer Inquiry Screen 66, 170
purchase order 87, 214
adding services 223
backorder 226
backorders 215
change vendor 224
closing 226
command 10
creating 219
custom 42
dollar limits for users 219
from invoices 314
from repair order 180
print 227
receiving 224
saving 223
section 0 315
sticky note 220
updating 219
purchasing 40, 97
purchasing and inventory management 206
Purge non-repair orders 353
Q
quantity unit of measure 156
R
radio button 19
radio group 19
reason for repair code, default 38
reassign part
  part
    reassign 213
Receivables Account 162
receiving purchase orders 224
Record Is Exported 380
Record segments by distance 52
relieve inventory items 206
Remit payment to 46
renewable licenses 126
renumber
  driver 108
  employee 111
Renumber Part ID 145
renumbering parts 145
reopen
  closed indirect command 13
  closed invoice 317
  closed repair order 200
  closed RO command 13
reorder formula 97
Repair - Default Repair Class 93
Repair - Default Repair Site 93
repair invoice 352
  defaults tab 351
  general tab 352
repair order 87, 91, 177
  add new section 188
  auto-create section 182
  change vendor 179
  charging parts from shop inventory 191
  chronic repairs 183
  close 180
  create invoice from closed/complete RO 179
customize grid display 180
data entry 183
detailed print 200
dollar limits for users 219
entry options 181
exporting closed ROs 378
images 316
invoicing 309
modes 182
new comment line 179, 192
new fee line 179
new labor line 179, 191
new part line 179, 190
new service line 179, 192
new tax line 179
open 179
open template 179
order number generation 185
print detail report 180
print purchase order 180
print work card 179
print work card checkoff list 180
printing multiple ROs 322
reopen closed RO 200
repair orders command 10
section
  customize display 188
  edit 188
  print detail 188
  print work card 188
  view items on order 188
section detail report 180
sections must be billable to create invoice 309
sections tab 187
setup 68
setup command 12
status 181
sticky note 180, 186
system setup 67
template
  create 195
template for single or multiple units 179
templates 194
update invoice amount paid 180
vendor 185, 189
  printing 185
view items 180
work card 179, 198
work card section 179
work pending 183
repair reason 188
repair shop 185
repairs 35
reports 249
  activities 265
aftermarket potential warranty claim 266
codekeys 267
customer 250
diagnostics 267
employee 250
indirect
  labor 251
inventory 262
jobcode 251
Masters 249
OEM/extended potential warranty claim 266
order inquiry 259
orders 259
parts catalog 252
parts inventory 262, 263
parts on pending orders 265
parts usage 262, 263
period close 268
physical inventory 262, 265
shop 252
SysMgr 267
TINA 253
tools 268
unit 257

Index:
unit components warranty status 266
unit inquiries 256
unit repair inquiry 254
unit warranty status 266
units with aftermarket part warranties 266
vendor 258
warranty 265
reports command 9, 10, 11, 13, 15
reports vs inquiries 249
Require Cause and Correction Codes 105
Require Cause and Correction if under warranty 92
Require cause and correction if under warranty 36
Require Comment Lines to Complete RO 105
Require Driver Number on Road Calls 53
Require invoice amount to match PO receipt total 41
Require Meter on Opening of RO 36, 93
Require passwords at login 104
Require Payment Method 42
Require PO 162
Require Signoff on Checkoff Lists 105
Require Vendor for Vendor Lines on RO 92
Require vendor for vendor lines on ROs 35
requisition list 211, 230
command 11
using to generate purchase order 213
requisitions 212
automatic 212
manual 212
resolving price discrepancies on invoices 225
RO Enabled 114
RO requirements
component code 143
position 143
serialized parts 144
RO Template Multi Unit 194
RO Template Single Unit 194
Road Call Mapping Type 53, 58
road fuel purchase data export 377
RTF image 22
s
sales tax 43
sample count sheet 209
saving purchase orders 223
schema system
data export 382
search

Index:
command 8
for help on command 15
for trip tickets 242
purchase orders 214
vendors 132
searching parts catalog 145
SecAdmin program 219
section
delete 188
delete lines 187
section 0 315
Section Comments Read Only 105
Section Component Code for PM Parts 38, 94
Section Total 254
Sections tab, repair order 187
security 1, 219
settings 91
Select PMs Due to Create Sections 38, 94
Serial Number Lookup 338
serial part numbers 191
serialized parts 144
  on warranty claim 330
service
  purchase order 223
service line 192
Service Lines on PO Require an Order 223
Service Lines on PO requires an Order 42
Service Locator 133
service locator
  updating NATC information 135
services tab 310
setup
  accounting 282
data import 347
  invoicing module 309
meter 117
meters 72
to import data 348 TMT
Fleet Maintenance 29
  warranty claims module 325
shop
  assign pay grade 80
command 9
currency 84
default 52
definition 84
description 84
ID 84, 232
inactive 84
inventory 152
  bin 153
  cost 157
  kits and cores 154
  part definition 152
  prices 312
  vendors 156
  warranty information 155
inventory command 9
rate 81
reports 252
rights 91
shop
  type 84
  ShopID 84
sticky note 83
tools 277
shop master
  accounting 90
  expenses 88
  file 83
  group assignments 86
  inventory 98
  options 91
  orders 87
  purchasing 97
  repair order 91
  shop definition 84
  taxes 89
Shop Planner 53
ShopID field 84
shortcut icons on toolbar 23
Show Inactive Rules 294
Show line item monetary amounts 104
Show Pick List Prompt 183
Show Running Invoice Prices on Repair Order 164
Show Running Invoice Prices on Repair Orders 45
show status bar command 8
show toolbar command 8
side-by-side tax 89
Small Text 50
SMTP 52, 57
Sound With Error Messages 51
sound with error messages 56
source shop ID 230
specifications
    component 76, 255
spin edit box 18
SRT (standard repair time) 45
standard
    messages 312
    messages command 13
tax 89
standard repair time 45
starting constant 87
starting date 88
status 188
    campaign 336
    fuel tickets 232
    invoice 314
    repair order 181
    warranty 330
    warranty
        status 327
sticky note
    on repair order 180
    parts catalog 141
    purchase orders 220
    repair order 186
    shop inventory 152
    shops 83
    units 115
stock level 152
Sum Labor by Paygrade Type 46, 164
Sum Labor for Invoice by Job Code 45, 163
superceded part 145
Suspend Service 162
SysMgr
    calendar 343
    menu 12
menu commands
    company setup 12
    meters, fluids, PM setup 12
    options 13
    pay grades 13
    reopen closed indirect 13
    reopen closed RO 13
    repair order setup 12
    reports 14

Index:
system setup 13
  tax rates and fees 13
  work shifts 13
  reports 267
system level codes 67
system setup 34
  command 13
T
tab control 19
taking a physical inventory 206, 269
target point 156
tasks
  define 81
  defining task assignments 81
  Mechanic Workstation 81
tax 89
  assignment 172
  customer 166
  override tax or fee on direct invoice 319
  rates & fees command 12
  rates and fees 77
  type 78
Tax Exempt 162
template
  add section
  section
    template 188
  repair order
    new 195
templates
  repair order 194
Terms 162
tile command 15
time cards data export 377
TINA reports 253
tire audit meter values data export 378
TMT codekey type 62
TMT home page command 15
TO factor 64
tool bar button 19
toolbar 23
  panels 25
  shortcuts 23
tools
  catalog 277
  setup 66
command 15
employee 278
reports 268
shop 277
Total 255

track
  employee tool inventory 277
  shop inventory 277
Track fuel in inventory 44
trademarks 1
transaction rule
  base 294
transfer parts from requisition list 230
TMT Fleet Maintenance
  menus 7
    add item 26
  reports 249 TMT
Fleet Maintenance INI
file 58
TRANSMAN.INI file
  updating 60
Treat Enter key as Tab 51, 56
Treat incoming non-company units as company units 354
tree view 19
trip tickets 242
  closing 245
  command 10
  data export 377
  deleting 246
  display list 242
  edit 244
  open new 243
  searching 242
  segments
    data export 377
    setting options 244
TX T image 22
U
unit
  aftermarket part warranties report 266
  assigning to customers 160
  clone 115
  command 9
  components warranty status report 266
  cost 123
  cost depreciation 123
  data export 377
definition 115
fluids 118
groups 126
importing 354
inspection definitions 67
license 126
master data export 377
meters 116
non-company  verify field 177
open template 179
PMs 121
price tables 310
reports 257
repair inquiry 254
unit inquiries 256
warranty status 266
shifts 125
specification 119
unit ID  date range field 232
UnitID disabled 202
warranty 122
Unit / Misc / User License Code 54
Unit Cost Summary Report 258
Unit Information First on Non-Company Units 53, 162
Unit Limit 54
unit master 115
  component search option 120
  unit cost 123
  unit definition 115
  unit fluids 118
  unit groups 126
  unit license 126
  unit meters 116
  unit PMs 121
  unit shifts 125
  unit specification 119
  unit warranty 122
unit of measurement
  area 64
currency 64
distance 64
length 64
quantity 64
temperature 64
time 64
volume 64
weight 64
unit user-defined fields 283
unread estimate 202
until date 86
Update Price 44
Update Primary Vendor 43
update purchase orders 219
Update Target Point 43
Update Vendor 43
updating NATC information 135
upload data from handheld device 349
Use Bid Price for Vendor Price on PO 42
Use external PO system 41
Use FTP 354
Use last cost for consignment parts 44
Use last cost for new vendor purchases 41
Use PARADOX Tables for Custom Invoice 46
Use Parts Workstation for Parts Requests 103
Use shop tax (instead of vendor tax) 41
Use TMT Part Number for Manufacture Number 44
Use Unit Domicile 338
Use VMRS Descriptions as Part Description 44, 144
User
   menu 15
   menu commands
       reports 15
       tools 15
user
   interface 51
   options 55
       interface options 56
USER codekey type 62 user-defined field 60
   command 13
user-entered estimated time 45
using
   Palm devices to enter fuel tickets 234
Palm programs
       for meter readings 366
       for parts inventory 360
       for parts requests 363
       for yard check 368
prefix numbering 87
the keyboard with TMT Fleet Maintenance 7
the mouse with TMT Fleet
Maintenance 7 TMT Fleet
Maintenance program 177
using custom invoices 165
V
Validate Comp Code against PMs for that Unit 38
vehicle registration 126
vendor
   accounts 138
   add parts 221
   change on purchase order 224
   change on repair order 179
   charge tab 310
   command 9
   contacts 137
   definition 131
   delete parts 221
   e-commerce 136
   ID 131, 232
   inactive 140
   name 131
   purchase order
      purchase order
         vendor 185
   remit to 139
   repair order 185
      printing 185
   reports 258
   search 132
   services 139
   shop inventory 156
   taxes 137
   type 131
Vendor AP Remit Code 283
vendor master
   data export 377
   vendor accounts 138
   vendor contacts 137
   vendor definition 131
   vendor services 139
vendor repair order 189
Vendor RO - Default Repair Class 93
Vendor RO - Default repair class 37
Vendor RO - Default Repair Site 93
Vendor RO - Default repair site 37
verify non-company unit information 177
View Associated ROs 216
view items on order 188
view items on repair order 180
View Order 157
View Transaction Tables 298
viewing line items 189
Viewing NATC Vendor Information 134
VMRS
   code 70
   (9-digit) 53
code imports 376
import code 376
lookup 142
part import command 13
W
warranty
   claim
      status 330
indicator lights 193
markup 132
parts 144
potential claim
      potential warranty claim 327
printing payments 330
processing 36
report 265
serialized parts 330
status 330
tracking 193
types 122
warranty claims
   claim numbers 87
exporting closed claims 378
generating 327
module (setup) 325
print 329
processing 324
   specify close date and print 329
Warranty Cost 254
Warranty Status 327
website URL 1
wheel base field 67
Windows
   menu 15
   menu commands
      arrange all 15
cascade 15

Index: